Your Garage botysf16 Amazon Fashion Learn more Discover it Maxwell Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro

Anyone else have problems playing Cowboys & Aliens BD?


Sort: Oldest first | Newest first
Showing 1-16 of 16 posts in this discussion
Initial post: Dec 7, 2011 6:58:01 PM PST
Brian McLean says:
Got BD tuesday and it played OK through the previews but then hung and never got to disc menu. Player is Sony BDPN460 with up-to-date firmware and it plays other recent BD OK. Arranged Amazon exchange and was pleasantly surprised that it arrived overnight, however the replacement BD has the same problem....anyone else have issues? Did I just get unlucky with bad batch of discs or is there an issue with this movies BD format that Sony has not patched yet?

Posted on Dec 17, 2011 12:29:33 AM PST
I had a problem with mine also and didn't get it from Amazon. My player is a Sony BDP 350. I have a samsung Bluray that I will test it on tomorrow

In reply to an earlier post on Dec 18, 2011 10:48:37 AM PST
I have samsung BD-D6500 brand new out of the box. It is doing the exact samething for Cowboys and Aliens, Cars 2, and Fright Night. What these seem to have in common is that in the beginning of each disc there is a pop up (asking you to select language) or some other interruption to play....any suggestions? Changed out Blu-ray player because of this problem and brand new one out of box does exact same thing.....?

Posted on Dec 19, 2011 8:51:42 PM PST
M. Rumbolz says:
I am also having this same problem. I have an LG player and have had no problems with any other movies. Cowboys & Aliens will play thru the previews and then a screen comes up saying to download a remote app on my phone. After that it won't play at all. I have exchanged it twice already.

Posted on Dec 26, 2011 9:44:36 AM PST
Chill Will says:
This plays alright in my samsung but, what's up with the annoying BONUSVIEW box in the upper right of the picture ? How do you get rid of it ?

In reply to an earlier post on Dec 30, 2011 12:15:34 PM PST
AKmaro1 says:
You can shut off the preview ticker by turning off the option at the bottom lower left menu. It should say the "what's new" option powered by BD-Live

In reply to an earlier post on Dec 30, 2011 12:17:38 PM PST
AKmaro1 says:
Same problem here on my new Samsung BD-D6500. Seemed to help by upgrading the firmware, but still gitches at 1 or 2 scenes in the movie. And it's only on this Title. Probably an authoring issue....

Posted on Jan 25, 2012 5:38:56 PM PST
Dave447 says:
Same problem with my Oppo BD-83. Hangs at Top Menu.

Posted on Feb 4, 2012 7:14:35 PM PST
StarSpots says:
Same problem with my Panasonic DMP-BD60. It played OK through the previews but then hung and never got to disc menu.

Posted on Feb 22, 2012 2:00:39 PM PST
Last edited by the author on Jul 8, 2012 4:54:55 PM PDT
Ed Seith says:
I bought this Blu the week it came out. During playback, occasionally the video speeds up momentarily, throwing the audio out of sync. It will stay that way until I pause and unpause, and then it will take a few seconds (3-8) to sync up again before resuming playback. This is on a Samsung 1590 player, that has now had several firmware upgrades. I need to try the disc in my Sony and see if it does the same. Anyone else have this problem?

UPDATE 7/7/12: Samsung relaeased the first new firmware for this machine this year, and the problem is now fixed, for me at least.

In reply to an earlier post on Mar 16, 2012 9:33:26 AM PDT
Try clearing your bd live data if you have it. Thats how I got mine to work.

Posted on Jul 1, 2012 9:38:17 AM PDT
Dog Lover says:
I have tried two different BR DVD's of Cowboys and Aliens via a rental service and neither worked on my Panasonic Blu-ray player. I am glad I found this thread as I thought I might have to replace my player.

Posted on Jul 7, 2012 2:43:34 AM PDT
Aaron Cains says:
I have a Sony BDP-S360 blu-ray player with current firmware (ver. 011). Playback issues occur for me at 1:02:00 to 1:04:00. And also at 01:54:00 to 01:55:30. Hopefully, a future firmware update will correct this? :/

Posted on Aug 5, 2012 5:49:24 PM PDT
C. Waters says:
I'm experiencing the same problem with two Blu-ray discs of Cowboys and Aliens, from a rental service. I have a Sony BDP-S350. Very frustrating!

In reply to an earlier post on Oct 5, 2012 6:40:17 PM PDT
Jerome Bush says:
Ed, I have bought 2 copies, and both do the same thing as yours. I also have the Samsung 1590. I did the firmware update, and nothing changed. Reminds me of a Cream song, "What a Bringdown."

Posted on Oct 24, 2012 2:36:27 PM PDT
Last edited by the author on Oct 24, 2012 2:40:01 PM PDT
A. A. says:
This Bluray disc is a faulty master from the factory; both the Netflix and Blockbuster mail-order discs are flaky as all hell. I've confirmed it on multiple copies on multiple machines.
You know you have a "rental" disc when the enhanced, extended version on the disc won't play because it is java blocked. Audio sync, chapter freezes, you name it - this disc is borked all over the place for the theatrical version.
Haven't tried the full-Monty purchased version and I won't.
Not worth it...
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Participants:  15
Total posts:  16
Initial post:  Dec 7, 2011
Latest post:  Oct 24, 2012

New! Receive e-mail when new posts are made.
Tracked by 10 customers

Search Customer Discussions