Compatible with Mac OS 10.4? I have a fairly old laptop (macbook) that is OS X 10.4 - is this scanner compatible with it or does it only accept newer versions of OS X?
asked by Ruby Red on August 5, 2012

See all questions about this product