Customer Discussions > Free Kindle Books and Tips forum

Dowloading books from blog


Sort: Oldest first | Newest first
Showing 1-24 of 24 posts in this discussion
Initial post: Dec 3, 2010 6:47:35 AM PST
This is a great blog and since signing up have gotten lots of books. However, the first two weeks I had no problems downloading the books from the blog, now I can't seem to download them. Why is that?

Posted on Dec 9, 2010 6:16:47 AM PST
Pamela-

I just saw your question- - could you please be a little more specific in how you're going about it? Are you trying to download them directly from your Kindle or are you clicking on the link on the website and having issues?

Regards,

Michael Gallagher
Amazon Author Page: http://www.amazon.com/-/e/B002MSG20A
Publisher of the Free Kindle Books Plus a Few Other Tips blog

In reply to an earlier post on Dec 9, 2010 6:27:17 AM PST
When I first signed up for this blog I had no issues downloading straight from my Kindle, now I cannot do that. I use to be able to go to "Click here" in the blog and download straight from the kindle, I can no longer do that.

Posted on Dec 15, 2010 7:31:43 PM PST
Pamela-

I just tried it on my Kindle 3 with one of the offerings from today and it worked; it did not work on my Kindle 2. Have you tried it again lately?

Regards,

Michael

In reply to an earlier post on Dec 16, 2010 3:24:38 AM PST
I did try it again yesterday and it took me to Amazon and it worked that way. It has not been working for several weeks now. Now Icannot get it to delete a sample Jumble puzzle. I am so frustrated.

Posted on Jan 4, 2011 9:40:39 AM PST
IS there a way to delete items/games/books from the Kindle 3G w/WiFi???
If so, how?

In reply to an earlier post on Jan 4, 2011 11:12:13 AM PST
yes, go to the home page, scroll down to the item you want to delete. go the arrow square and hit the left button, delete will pop up, just hit the center button to delete

Posted on Jan 4, 2011 7:52:43 PM PST
T. G. WARNER says:
Some of the books that show as Free today, have a price listed when I get to the Amazon site. Does that mean I missed the "timeframe" of the book being free? Example was the "Crave Book" today. It didn't show free but I downloaded it thinking it would change the price, but I was still charged the $9.99.

thanks,

Posted on Jan 11, 2011 7:25:11 AM PST
Sabrina Kidd says:
When I read the blog on my kindle for PC I can't get to the book on Amazon by clicking on the "click here"! All I get is an error message. I just downloaded the Kindle for PC on my new PC! Is there something I need to do so I can get to a book by simply clicking on the "click here" that is provided in the blog?

In reply to an earlier post on Jan 17, 2011 3:53:19 PM PST
M. Kleven says:
I am having the same problem for the last few weeks - I click on the link in the blog to download a book and my kindle does nothing (there was no problem before that.) Any suggestions??
Thanks, Marilyn

Posted on Jan 19, 2011 7:08:16 AM PST
@srkidd: blogs (for some reason) are not available on the Kindle for PC application.

Posted on Jan 19, 2011 7:08:47 AM PST
@Marilyn: what version of the Kindle do you have?

In reply to an earlier post on Mar 4, 2011 9:57:33 AM PST
marsha ford says:
I have some items that would not delete no matter what I did. So, I made a "Collection," put them there so they wouldn't be in my way.

In reply to an earlier post on Apr 9, 2011 10:28:40 PM PDT
Last edited by the author on Apr 9, 2011 10:40:00 PM PDT
I am having the same problem with my Kindle 3 (3G wireless). The problem started about 2 weeks ago. I click on "click here" in the blog and go to a blank web screen page. So I've been clicking on "shop kindle store" and entering the title and author on the shop screen to make the purchase. Can you solve the problem or point me in the right direction?

In reply to an earlier post on Apr 10, 2011 1:56:48 PM PDT
Katherine_

I don't have any explanation for you, which is why over the past two weeks I have been putting th e"or type n " with a short URL to tye into your web browser. It sounds like an Amazon software issue.

Regards,

Michael

Posted on Jan 1, 2012 10:21:18 PM PST
Last edited by the author on Jan 7, 2012 6:45:22 PM PST
Cyclist says:
I can't download your books to a Kindle Touch unless I am connected to a wireless connection. 3G will not work. Amazon is remiss for not letting you know what links to their store are supposed to look like. Or maybe they're even putting the faulty links in themselves! Your blog is linking to a web page Amazon doesn't like apparently, and 3G won't download from a web page. Does Amazon have any blog author support?

In reply to an earlier post on Jan 6, 2012 6:48:23 AM PST
If the link in the blog doesn't work, just go to menus and click "shop in kindle store", then type in the name of the book. The link in the blog has never worked for me and I've never considered it a problem. I prefer to do it the way I just told you. Then I can read the books' description and some of the customer reviews before deciding if I want to buy the book.

In reply to an earlier post on Jan 7, 2012 8:53:30 AM PST
Cyclist says:
What error message?

In reply to an earlier post on Jan 7, 2012 8:54:12 AM PST
Cyclist says:
Do you get an error message? What is the error message? What Kindle model do you have?

In reply to an earlier post on Jan 7, 2012 8:56:23 AM PST
Cyclist says:
The reason is that the link in the blog is formulated with an address that make Kindle think you want to browse the web in 3G instead of just going to their store.

In reply to an earlier post on Jan 7, 2012 8:58:18 AM PST
Last edited by the author on Jan 7, 2012 6:49:07 PM PST
Cyclist says:
Thanks for the hint, I knew and tried that before, and for me that doesn't work, I have a bad memory. The blog makes it easy with links to the store. If it was a blog with no links, I doubt it would be as popular. I don't like browsing the Amazon store more than I have to because it's hard to type and click there on the Touch. I want to keep navigating to a minimum.

Posted on Feb 4, 2012 8:48:38 PM PST
P. Ledesma says:
I don't get the free book minks in the bloc on my Kindle Fire. Why is that?

Posted on May 1, 2012 5:30:26 AM PDT
J. CHEAK says:
I just got the Kindle DX. I changed my subscription to go to it instead of my Kindle Keyboard 3G. that works fine I am getting the daily blog, however when I click on the link in the DX it takes me to a different looking site 'almost a mobile looking site) the Kindle keyboard took me directly to amazon. and while everything is there book, price it has a statement 'This mobile site does not currently support the purchase of this item. Add it to your Wish List and you can view and purchase it from your computer. I don't want to use my computer that's why I have the kindle. Is there some setting I need to change on the DX? Please help
John

In reply to an earlier post on Jul 1, 2012 11:50:18 PM PDT
Last edited by the author on Jul 2, 2012 7:16:42 AM PDT
S. VALE says:
I have a Kindle Touch and have the same problem. But like some of the early posts on this, mine did work with the links in the blog for months before it just started exhibiting this behavior.

I can place the books on my "wish list", but cannot seem to purchase them that way.

It thinks I'm on a smart phone or regular tablet.

It worked for awhile. I did have this problem before and it did get fixed, but I don't remember how I did it. I have done a reset, but I don't want to do a restore to factory defaults. At least not yet.

I am going to try a few more things, and then contact the Kindle Support team. Perhaps there is something they can suggest.

I will post it if I find a solution
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Participants:  13
Total posts:  24
Initial post:  Dec 3, 2010
Latest post:  Jul 1, 2012

New! Receive e-mail when new posts are made.
Tracked by 7 customers

Search Customer Discussions
This discussion is about
Free Kindle Books and Tips
Free Kindle Books and Tips by Michael Gallagher
4.4 out of 5 stars   (161)