Your Garage botysf16 Amazon Fashion Learn more nav_sap_plcc_ascpsc PME Fire TV Stick Sun Care Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro
Customer Discussions > SCRABBLE forum

Games not uploading


Sort: Oldest first | Newest first
Showing 1-21 of 21 posts in this discussion
Initial post: Jul 10, 2012 7:11:26 AM PDT
Clompky says:
I have about 25 ongoing games which I cannot access. It would be nice to have it fixed before my opponents push the forces forfeit button.

Posted on Jul 10, 2012 10:28:51 AM PDT
plumst says:
Mine hasn't updated in 24 hours+. Seems yo do this a lot. Makes me wonder why I paid for the game.

Posted on Jul 10, 2012 11:46:06 AM PDT
mattieben says:
My game is completely frozen...won't do anything but tell me, "Something went wrong. Please try again." If EA can't fix this application then they should stop selling it. Also, Amazon should take it off the market until it works correctly.

Posted on Jul 10, 2012 1:40:34 PM PDT
Clompky says:
I agree!! I've been playing online for a few months and have a group of steady opponents. Now my scrabble game is totally frozen. I was told by customer service this has been an ongoing problem and it might take weeks it might take months to fix it. So let's hope it's soon.

In reply to an earlier post on Jul 10, 2012 1:45:25 PM PDT
[Deleted by the author on Jul 10, 2012 1:46:23 PM PDT]

Posted on Jul 10, 2012 2:22:08 PM PDT
My Scramble game on Kindle Fire will not load. It keeps saying "something went wrong". I've done all the suggested fixes and still cannot get into the game. This has been ongoing since yesterday.

In reply to an earlier post on Jul 10, 2012 6:23:30 PM PDT
ZetaTauri says:
Same exact problem here! I can no longer access my games in progress and when I try to load my stats I keep getting "something went wrong". Ironic since I rated this app at 5* back when I got it. I wouldn't give it more than a 1 now. I uninstalled it (which deleted all my single player stats), reloaded it, and what do you know? "Something went wrong." The Origin website states that there will soon be a fix for this. I hope its not too little too late.

Posted on Jul 11, 2012 12:38:10 AM PDT
Marna says:
Same here for past several days. Come on Scrabble or Kindle Fire people - what's up?

Posted on Jul 11, 2012 10:02:43 AM PDT
I thought it was just my game--what's up. Especially since its a game that I paid for.

In reply to an earlier post on Aug 8, 2012 12:30:50 PM PDT
Deidre Sapp says:
I have been having this problem for a while. Soooo annoying! Try hitting Play random opponent and it should load a game anyway then you hit next game and it will work normally or it does for me. Play friends will let you in too. But if you leave scrabble that's it. I have to start some unwanted games sometimes so I really hope they fix this soon. I just wanna play :) pinkribbon0903

Posted on Aug 8, 2012 12:36:09 PM PDT
Deidre Sapp says:
Try hitting random opponent or play with friends it will let you in and the game should work normally. It works for me, but if you leave the same thing will happen again. I hope they fix this soon. Good luck.

Posted on Aug 31, 2012 2:58:17 PM PDT
Force forfeit no longer works. Incomplete games by opponent just stay open.

Posted on Oct 15, 2012 7:28:42 AM PDT
S. Cloutier says:
Force forfeit is broken for me too. I forced forfeit on an opponent over ten days ago and it still has not removed them from my games!

In reply to an earlier post on Oct 18, 2012 7:46:48 PM PDT
Why Not says:
I have 16 games that I have forced forfeit over 14 days old now....where is the solution Amazon? Writing in the issue has yielded zero support from easupport.com over 12 days now...not even a response that they know the issues are going on and that they are working on it...a small lie and a large mocha coffee might help with the addiction and keep me from throwing this KF in the lake!

In reply to an earlier post on Oct 19, 2012 5:14:27 AM PDT
Clompky says:
It's been months for me and still no reply. I guess they don't care about their PR.

Posted on Nov 7, 2012 11:17:32 AM PST
Thom Tellez says:
I have these workarounds --
1. full reset. hold the power button for 20 seconds. I end up with this full recycle every fortnight.
2. when the search is circling hte drain, select "play random opponent" then decline the game. The next game featuer will select fomr your open games.
Not tidy solutions, but they work.

In reply to an earlier post on Nov 11, 2012 7:12:23 PM PST
Wild Ideas says:
Mine will rarely even load a random game, so no workaround. I think we should start asking for our money back. This game increasingly won' load properly.

In reply to an earlier post on Nov 12, 2012 4:07:57 AM PST
I think the programmer(s) of Scrabble should be fired. An amateur could do a better job.

Posted on Jan 6, 2013 4:36:32 PM PST
E Stuart says:
have been having the same problem since around Thanksgiving and still no luck getting back into previous games. I can play games with *Norm* (the computer) but NO ONE else? very frustrating considering this is a app that was paid for!

Posted on Feb 8, 2013 7:56:37 PM PST
lp says:
I'm having the same problem. And there is no tech support. This app sucks!

Posted on Jan 15, 2015 3:14:09 PM PST
Jennie. says:
I pay for my scrabble, but I can not download it on my E-Pad.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  SCRABBLE forum
Participants:  15
Total posts:  21
Initial post:  Jul 10, 2012
Latest post:  Jan 15, 2015

New! Receive e-mail when new posts are made.
Tracked by 7 customers

Search Customer Discussions
This discussion is about
SCRABBLE
SCRABBLE by Electronic Arts Inc.
3.7 out of 5 stars (6,327)