Industrial-Sized Deals Books Gift Guide Books Gift Guide Shop Men's Athletic Shoes Learn more nav_sap_SWP_6M_fly_beacon Ty Dolla Sign egg_2015 All-New Amazon Fire TV Beauty Deals Gifts Under $50 Amazon Gift Card Offer minions minions minions  Amazon Echo Starting at $84.99 Kindle Black Friday Deals TheGoodDinosaur Outdoor Deals on HTL

Onkyo TX- NR 5007 - no sound after months of turning it on twice every time

Sort: Oldest first | Newest first
Showing 1-2 of 2 posts in this discussion
Initial post: Jan 11, 2012 5:50:01 PM PST
M. Russell says:
I made the bad decision to research the features on this unit and never thought the quality control problems would far outweigh the state of the art features and sound quality. Constant inability to "handshake" the first time with the HD Cable box has given way to virtually no sound with a crystal clear picture. After hours of pursuing a process of elimination I narrowed the problem to the cable box and a bad hdmi connection or the Onkyo Receiver HDMI input. After taking the Samsung 55" 8500 tv through it's diagnostics, and getting the tv speakers to work no problem when connected directly via HDMI cables to the box, it was clear the Receiver is the problem. The Receiver plays DVD's sound and video signal but cannot put any sound out when reconnected to the HD Cable box. Let me say the setup worked for nearly two years with great sound after always needing to turn the tv on and then the Receiver twice ( never once) for the sound and video signal to turn on. I have reveresed the power up order to no avail - still no sound the first and when receiver is turned off then on again it gets sound. Now the receiver is bombing out after 2-3 seconds of playing sound and going blank screen. I have had it with this SO-CALLED TOP OF THE LINE RECEIVER. It's constant clicking noises as it establishes the resolution between commercials, movies and tv shows is ridiculous. I am sending it in under ( hopefully) a two year warranty deadline just 2 weeks away. If the unit cannot be fixed properly I will move on and never buy another ONKYO product.

Posted on May 4, 2012 1:21:41 AM PDT
Last edited by the author on Aug 14, 2012 3:59:50 PM PDT
J. Adkins says:
After two and half years of flawless performance I spent 2 months turning mine off and on to get sound before it refused to issue any sound. At the last, the front panel lights worked just fine and I could go through all the setup menus. Performing a reset didn't resolve the problem. Finally, I sent it to a repair center. They said I needed a new HDMI board. $580 including shipping. I choked a little but still, I paid. I love this receiver.

After the repair of the unit it the worked fine for a little more than 3 months. Then the HDMI board went out again.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in


This discussion

Participants:  2
Total posts:  2
Initial post:  Jan 11, 2012
Latest post:  May 4, 2012

Search Customer Discussions