Customer Discussions > Amazon Instant Video forum

low connection speed, poor quality


Sort: Oldest first | Newest first
Showing 1-25 of 119 posts in this discussion
Initial post: Mar 31, 2012 8:14:59 PM PDT
Last edited by the author on Mar 31, 2012 8:15:59 PM PDT
Every time I use VOD, the quality is horrible - pixelated and very choppy. I even upgraded my internet thinking this was the problem - didn't make any difference. I ran the download test as suggested on the help page. I should be more than okay to watch a movie from what the tests are saying. When I start the movie, it says I have a high connection speed. Within 30 seconds, it goes down to very low. Any ideas what's going on?

Posted on Apr 1, 2012 1:51:22 AM PDT
Emi says:
Your internet might be set up with a "turboboost" system, in which the initial part of a download goes rapidly, and after a short period of time it is throttled down.

That being said, I use a poor internet connection that is slower than recommended, and besides the occasional re-buffer have had no problems streaming... Though I don't attempt to stream in HD, as I am well aware that is beyond my connection's capacity.

Posted on May 20, 2012 4:43:46 PM PDT
Cube says:
I have a high data speed but my amazon prime video looks terrible and reports a low connection speed? Netflix works fine but not Amazon Prime. Whats Happening?

Posted on May 31, 2012 8:34:04 PM PDT
Rjupiter says:
have the same problem. i have a 40 Mbps connection and it will throttle down the lowest and crappiest after a bit. the only solution i found, which is odd, is to pop-out the video. if i do that it will play at full speed/connection the entire time.

Posted on May 31, 2012 8:39:41 PM PDT
Last edited by the author on May 31, 2012 8:40:36 PM PDT
Cube says:
I found a simple solution. All it took for me was to reopen the browser and when the page reloaded it returned to high speed. Some times I have to do this several times during a movie when I notice the speed decreases but it dose work. Netflix dose not hang up as Amazon prime dose but at least it's working for me again.

Posted on Jun 28, 2012 12:49:07 PM PDT
Yeah, I'm having the same issue. I've got a 50Mb up and down fiber optic connection. I'm actually getting a little more than that if I run a speed test. Netflix always defaults to the highest quality and never has an issue. I have to hit reload a couple of times on Amazon for it go highest quality. It never has an issue once it starts, just takes a few tries at first.

Posted on Jun 28, 2012 1:17:25 PM PDT
Cube says:
netlix dose not hang up near as often or bad as amazon. I just restart amazon to get better a better signal. THe FF command in amazon is also primitive compared to Netflix. Amazon dose a few titles that netflix lacks. I wish amazon would list all their tv shows under same page as netflix dose. It makes looking for something to watch cumbersome when using amazon.

Posted on Jul 13, 2012 12:44:56 AM PDT
JMM says:
I am having a connection problem as well problem. I tried on multiple devices, on of them being my mac - on which the video is very low quality. I tried resetting the internet connection and restarting my mac, but nothing works.

I even ran the speed test that Amazon recommends, and I was in the 87th percentile (meaning only 13% of people have a faster connection).

In reply to an earlier post on Jul 13, 2012 6:29:58 AM PDT
Gdaddy says:
A few other people have recommended closing the player after the movie starts and then re-opening it. I tried it and the streaming speed immediately increased so that the player was able to stream HD content. I suspect that either there is a bug in the player for a PC or the problem is actually intended to limit the bandwidth that Amazon uses to stream movies so that they save money. However, my Kindle Fire doesn't experience this issue at all, only my PC.

Posted on Jul 23, 2012 8:14:53 PM PDT
Kevin T. says:
I found a different fix for this issue -- the Amazon streaming player cannot autodetect speed properly if you have flash storage disabled.

I have a 50/25 FIOS connection, but every browser I tried autodetected "very low speed / very low quality". The fix was to right click on the player area and configure 100k storage for the Amazon ECX site (the one that shows up under "Settings".) I left flash storage disabled globally, with only the one exception for ECX, and my speed was autodetected correctly as soon as I tried to play the next video.

In reply to an earlier post on Aug 12, 2012 10:20:33 PM PDT
Kevin! Thank you! Good answer!

In reply to an earlier post on Aug 15, 2012 10:30:47 PM PDT
Overpanic says:
Excellent solution, Kevin. Seems to have solved my problem. Prior to this, I could only get my videos to play at lowest quality.
Now I'm having a problem with video hang, though... but I probably just need to restart my computer.

Posted on Aug 16, 2012 4:22:36 PM PDT
Heh. Looks like I'm not so all alone. I'm a Netflix subscriber, and thought I'd come over here to give Amazon's 1-month free trial offer a go. Well, strike one was when I found a dearth of titles in areas of my specific interests. Strike two I've just experienced, when even though it claims a high connection speed, the video quality is very poor with prominent pixelation. This is awful. Why would anybody want to pay $79/yr for this trash? I'll mess around with things some more and see if I can't improve things. Honestly, why should anybody have to jump through all the hoops that Kevin T outlines above just for a decent picture? I just want to click on the show I want to watch and be able to watch in HD quality, same as I do with NF. Anything less is needless aggravation and a waste of my time.

Posted on Sep 5, 2012 10:05:00 PM PDT
M. Person says:
I am having same speed issues. I have FIOS (fiber to the house). 35/35 Mbit on speedtest.net/speedtest.comcast.net. GBIT ethernet (wired entired lenght from router to PC). But videos are run at 384kbit on Amazon. On youtube I can watch 1080p seamlessly. I replied to Amazon from the play - will see if they respond.

I did try changing cache size - from 0, 100K to 10MB and unlimited. Also popping up viewer, restart/reload page and no luck.

Might have to try something else (NF) to see what the heck is wrong, if anything (although youtube proves my connection is not an issue)

Posted on Sep 6, 2012 9:03:26 PM PDT
PETER says:
I have experienced the same issue, but I just ignore it and then later like 2-3 minutes it will adjust to max connection.

I have to say this because it always first start at low connection for at least 2-3 mins to change to High connection

Posted on Sep 7, 2012 9:46:07 AM PDT
Remember Amazon Prime uses crappy Adobe Flash. I was never really ever able to stream anything reliable using Adobe Flash. YouTube, HBO Go etc it is all a hit or miss. Sometimes it will play good and other times it will just keep pixelating and buffering. Netflix however uses the much improved Microsoft Silverlight and playing videos on the computer the quaility is great never buffers or anything.

In reply to an earlier post on Sep 22, 2012 6:36:23 PM PDT
pthig says:
Thanks Kevin!

Posted on Oct 2, 2012 11:46:51 PM PDT
M. Person says:
After more testing and reading around I found below workarounds that should be useful to many of you. I also talked to Amazon support and their answer was "well your internet connection speed is slow at 380 kbit". Well that is what crappy Amazon streaming software thinks - that is NOT what speedtest shows and NOT what Netlflix/YouTube/Vevo see - I stream 1080p in its fully glory no problem w/ my 35Mbit FIOS. I could not explain this to support person - they keep on going back to "our software shows slow connection so we stream slow". But when I use forceBR method below then Amazon can stream 720p (TV shows) or 480p (movies) no problem :-) ....

Adjusting buffer size and adding ECX to peer assisted networking does not seem to work for me.

1) On one PC (Lenovo laptop) the speed will start low and then improve after 2-3 minutes. Alternatively, if you pop up viewer it will improve immediately. Then you can go back to the browser (close popup) and it stays fast. Go figure.

2) This workaround does NOT work on another PC. Solution is to modify HTML link by adding forceBR and this fixes it every time. Same can be used for laptop.

/?forceBR=3
/?forceBR=4
/?forceBR=5

Put them after the B00 number, same as with the diag option.
forceBR=3 is for 996 kbps
forceBR=4 is for 1328 kbps
forceBR=5 is for 2500 kbps

From

http://www.amazon.com/gp/help/customer/forums?ie=UTF8&cdForum=Fx2NFGOONPZEXIP&cdThread=Tx37ELYZ5POE0CI

In reply to an earlier post on Oct 8, 2012 6:19:41 PM PDT
K. Erskine says:
You do not even need to reopen the browser - just click on the episode link again and hit resume. Annoying, but quicker than restarting your browser.

In reply to an earlier post on Oct 20, 2012 9:15:26 AM PDT
L. Hartown says:
Kevin, This worked on my logitech revue, google tv. the poor amazon video on demand had bugged me for a while. thank you. it was still low the first time but I skipped forward and it went to 4 bars.
thanks again

Posted on Dec 1, 2012 4:07:24 PM PST
Joe Terry says:
I signed up for a trial today and selected a movie. It would stop everyy3-5 minutes andhaveto buffer. After 45 minutes orsoI was somewhat annoyed and thought I had Internet issues. Ran speed tests and all was well. Have a competitors service - used the same device (SonyBluRay) to watch the same movie with not a single "buffering" interruption. Seems to be the Amazon Service.

In reply to an earlier post on Dec 2, 2012 7:04:49 PM PST
Last edited by the author on Dec 2, 2012 7:05:27 PM PST
Joey Saylor says:
Thanks a lot Kevin T, fixed the issue!

Posted on Dec 3, 2012 2:58:42 AM PST
Tee Box says:
To everyone posting on this subject, you might also look at the discussion labeled "constant buffering" in the discussion threads. More info there, but the bottom line seems to be a problem with the server that Amazon uses to stream video. I went though calling my internet provider, my router, and Sony (BluRay player I use to stream), only to eventually figure out the problem is apparently with Amazon. The final straw was when I joined Netflix just to see if I could stream with them. I can, no problems. If your joining Amazon Prime just to stream video, I would advise against it until they get these problems ironed out.

In reply to an earlier post on Dec 5, 2012 8:28:08 PM PST
Joey Saylor says:
Yeah unfortunately I'm still having the problem. The solution offered above only works temporarily and I have a 6Mbps connection. I'm getting a lot of buffering.

Posted on Dec 5, 2012 10:01:00 PM PST
M. Person says:
If forceBR is not working they you probably do have connection problem or amazon server has issue. What does speedtest.net say about it? 6Mbps is pretty low given movie is at least 2.5Mbps ... in my connection it would fill butter in no time (35Mbps) and never buffer. Same experience with YouTube/Netflix. Can you stream 1080p from YouTube?
‹ Previous 1 2 3 4 5 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Amazon Instant Video forum (1016 discussions)

 

This discussion

Participants:  83
Total posts:  119
Initial post:  Mar 31, 2012
Latest post:  2 days ago

New! Receive e-mail when new posts are made.
Tracked by 29 customers

Search Customer Discussions