Customer Discussions > Amazon Instant Video forum

PS3 App Taking Forever to Start

Sort: Oldest first | Newest first
Showing 1-25 of 25 posts in this discussion
Initial post: Sep 25, 2012 6:34:29 PM PDT
A. Rand says:
For the past week or so, we've been having a bit of an issue with the Amazon Instant Video app on our PS3. It's been taking an unusually long time to finish loading up--it will sit on the initial splash page, showing the picture for something like The Artist, or Lost, or, today, Hunger Games or the Avengers, while the little white loading circle spins. This will take anywhere from a 2-10 minutes, before it will finally go the rest of the way into the program, at which point it works fine from there. Tonight, we were unable to get it to load up at all, after a full 10 minutes, quitting, restarting, and waiting another 15 before finally giving up.

I have no idea what's wrong here. We get no error messages. Our internet connection is working perfectly fine--other video apps operate properly on the console, and I can get Amazon Instant Video to run perfectly all right through the website on one of our computers. And even AIV itself works without trouble once it finally finishes that initial start up.

Is there anything we can do to fix this?

In reply to an earlier post on Sep 25, 2012 8:12:35 PM PDT
I wish I had a solution for you but all I can say at this point is that I'm having the exact same issues as you. I would be wary of deleting the app and trying to reinstall like I did. It downloads the original version of the instant video app and tells you it needs to install an update to get to ver. 1.03 but for me it shows something like 300+ minutes to install! I've successfully completed this process once and re-registered my PS3 with my Amazon account but it still gave me the same long load times you're experiencing. I hope there's a fix for this issue soon.

In reply to an earlier post on Sep 25, 2012 8:24:34 PM PDT
A. Rand says:
Well, I'm relieved(?) that I'm not the only one, at least! And thanks for the warning about the uninstall/reinstall. That was going to be what I tried next. I might still do it--I can set it to start downloading in the morning if it's crazy lengthy, and leave it while we're at work--but now I won't be too optimistic that it'll help.

Posted on Sep 25, 2012 9:10:46 PM PDT
I've been experiencing the same exact issue since Sunday which was also the last day I was able to get in. Now it will just stay at the loading screen no matter how long I leave it. Hope this can be fixed soon!

Posted on Sep 27, 2012 6:24:42 AM PDT
A. Rand says:
In the interests of additional data points, yesterday evening I loaded the app when I first got home, around 6pm EST. I was thinking I might try uninstalling and reinstalling to see if that would help, but first wanted to see if the problem had magically gone away. It loaded promptly, as it had not done in several days, taking only about 30 seconds, possibly less. Pleased, I shut it down until later in the evening when we were actually going to use it.

Unfortunately, around 10pm when we were trying to start it up to actually watch something, it sat there loading for about 8 minutes without success. We quit the app and restarted it, and it finally finished logging in after another 4 or 5 minutes.

Posted on Dec 19, 2012 7:29:51 PM PST
Tallone1969 says:
I can't get the update version 1.3 of Amazon Video to install on my ps3. Playstation 3 starts the download of update data then stops and gives me error message. Also, I can't believe that a 20MB update is at 5% with 190 minutes left? This seems absurd to me. Very frustrated with PS3 update.

Posted on Dec 26, 2012 3:27:46 PM PST
B. Beringer says:
I get a black screen, not even showing the loading screen when trying to start the app. It shows me two white bars, one at the top of the screen one at the bottom, those like when you push the PS button on your controller..
app would NOT start at all

In reply to an earlier post on Dec 26, 2012 5:50:22 PM PST
Tallone1969 says:
I finally got application to install on ps3. I needed to turn off all devices that were running on my home network. Once I turned off desktop, laptop and program installation was easy...went very fast and works fine now.

Posted on Dec 27, 2012 5:18:45 PM PST
Schofield12 says:
Cannot update either.

Posted on Dec 28, 2012 9:45:40 PM PST
Pickles says:
I cannot access the Amazon app on my PS3 either. For the last week or so I've been having the same problems described here. I deleted the app and it reinstalls, tells me it needs to update to the latest version, and then the update doesn't download. So I'm stuck. Also I'm using Verizon FIOS as my ISP.

Posted on Jan 18, 2013 9:27:17 AM PST
The same thing has happened to me. Last week it was fine. In fact it was great. Thus week I try it and all that pulls up is a black screen..... no lines no nothing. I've tried to delete and reinstall and update. I didn't have any problems doin those things but once I did I still have the same problem. Black screen. I also tried updating the ps3 itself......still nothing. I fear this app is broken.

Posted on Jan 25, 2013 9:00:24 PM PST
Last edited by the author on Jan 25, 2013 9:01:01 PM PST
Same thing here I have been experiencing long intro load times on the ps3 app. It used to work just fine and take about 30 or less but now it just hangs on the loading screen. Its loading right now, over 10 min so far, come on amazon give us a fix already.

Posted on Jan 27, 2013 3:03:57 PM PST
I've been using amazon instant video in my ps3 for about 2 weeks now, accessing the majority of content through my trial 'amazon prime' membership. I was very impressed with the great variety of selection of content. (Even the stuff I had to pay to watch). I was going to pay the $70+ annual fee to renew my membership once my trial membership expired.
But then I ran into the problem of not being able to get past the load screen advertising new releases (as described in previous posts in this topic). I deleted and re-installed 4 times (twice without bring able to download version 1.04 at all, and twice taking more than an hour to download and install the update), but I STILL can't access any content, as it STILL won't go past the initial load screen.
Using a search engine to try and find a way to fix this problem, I came across this discussion board and found that this problem has existed since September 2012 with version 1.03 in the ps3, and had yet to be fixed with the more recent 1.04 ps3 update for the software.
So congrats, amazon, for not resolving this issue. I'm canceling my prime membership promptly and reverting to Netflix to view reliable streaming tv/movie content.

P.s. I understand there are many im difficulties and obstacles to overcome such complex operations of streaming a plethora of content via multiple media devices, but all I ask is for acknoledgement of knowing the problem exists and assurance that the issue had been identified and is bring worked on. 3+ months is well outside the acceptable parameters of customer courtesey (IMO)

Posted on Jan 30, 2013 7:11:34 AM PST
ZH says:
There is another discussion entitled Amazon instand video and ps3. I was having the EXACT same issues as all of you here. A very helpful poster posted the following. I tried these steps and it worked for me. I also switched from the Verizon DNS server to the Google DNS server. (you can find the steps to do this by googling it) I have FiOS and am in NY. Good Luck.

Edward Martin says:
I got it working for me, in your router ( ) go to Advanced -> DNS Server, add a new entry

IP Address:

Your DNS Server on the PS3 under internet settings has to be set to (should be the default, unless you've been messing with it), now your PS3 will download updates from a server in Arizona where this issue isn't a problem, you should probably remove the DNS entry eventually, one day it might break things and you don't want to forget that's the reason things are broken, also, when they do get around to fixing this issue, this DNS entry in your router will keep the PS3 downloading updates from Arizona instead of the NY server, which is obviously somewhat slower.

Posted on Apr 19, 2013 8:04:37 AM PDT
I don't think I would want to try that. I know how much issues changing stuff inside of the server can cause. I believe that Amazon should come up with a solution, not us. We aren't the tech support. Well, I am...but not for Amazon. XD So I don't think I should have to work when I'm off the clock. Just saying. :P

In reply to an earlier post on Aug 9, 2013 11:16:47 AM PDT
A. Rand, did you ever reach a solution? I am having this same problem.

In reply to an earlier post on Aug 17, 2013 3:01:59 PM PDT
Having the same problem...

Posted on Oct 30, 2013 7:20:24 PM PDT
Erc Price says:
I tried watching a paid program for the first time on the instant video and found the circle just going around and around for over 10 minutes. I deactivated my phone and laptop from the network (the only two devices on it) and tried to reload the show. It worked fine this time. Don't know if this was the cause of the bad load, but give it a shot and see what happens.

In reply to an earlier post on Dec 14, 2013 10:12:34 AM PST
HD_Dude says:
Same here, 6 weeks after your post.

Down in DC.

Posted on Dec 21, 2014 1:21:45 AM PST
PS3 restarting as Amazon Prime Instant app getting stuck all the time. Called the rep and she suggested to re-install the app. I can't do that everytime the app fail to load videos. Any suggestions ?

Posted on Dec 23, 2014 5:24:26 PM PST
Last edited by the author on Dec 23, 2014 5:27:18 PM PST
I have this issue too. I never had this issue before it just started recently. I tried deleting and reinstalling the app and it did not work. I recently switched from Frontier FIOS to Comcast, wonder if this is the issue?

Posted on Jan 1, 2015 3:15:07 PM PST
Same problem

In reply to an earlier post on Jan 2, 2015 7:43:01 AM PST
Try turning off the Closed Captions. My Amazon Instant Video app stopped freezing up after I did so. For more info, check out this thread:

Posted on Jan 24, 2015 3:27:15 PM PST
Clear Blue says:
I have the same issue. My ISP is Suddenlink. I too have uninstalled and reinstalled amazon app in PS3. I have reset my modem reset PS3 to new and reset my router to new and completely redid the internet structure, still didn't help. I have just purchased powerline network adapters to extend the wireless. I hope that helps.

Posted on Jan 24, 2015 5:51:15 PM PST
Chris says:
At least you can use the prime app on your PS3. When I try to open mine up it just goes straight to VUDU for some reason.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Amazon Instant Video forum


This discussion

Participants:  22
Total posts:  25
Initial post:  Sep 25, 2012
Latest post:  6 days ago

New! Receive e-mail when new posts are made.
Tracked by 9 customers

Search Customer Discussions