Your Garage Summer Reading Amazon Fashion Learn more nav_sap_plcc_ascpsc Lacuna Coil Father's Day Gift Guide 2016 Fire TV Stick Get Ready for Summer and Save 15% Father's Day Gifts Amazon Cash Back Offer DrThorne DrThorne DrThorne  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis UniOrlando Outdoor Recreation
Customer Discussions > Amazon Instant Video forum

Instant Video Player update breaks rights


Sort: Oldest first | Newest first
Showing 201-225 of 364 posts in this discussion
In reply to an earlier post on Aug 16, 2012 11:29:24 AM PDT
udev is hal's replacement and running hal on a system which uses udev without the appropriate udev rules will result in hardware misbehaving. For example, flash drives losing data because of incorrect disk cache settings or your MP3 player not being recognized as such or your printer not supporting the resolutions the manufacturer claims it should support.

Additionally, unless you are using an enterprise supported distributions such as RHEL or SUSE (others I am sure), because hal has not been maintained for some years, no security fixes have been introduced and therefore user roles/permissions may not be correctly assigned to devices that are attached to the system.

Posted on Aug 16, 2012 12:08:33 PM PDT
cactus says:
thanks for the info. much appreciated.
so, if i'm using mint13, and hal has been installed and activated by default, i am assuming that i don't have any of these issues ( i haven't experienced any issues).
i'm assuming that by role/permissions issues brought on by the lack of security fixes, you are referring to the possible denial of my system not reading files that are on a device (haven't had an issue) or my printer not working (no issues), or just plain not reading a device because of a permissions conflict (no issues so far)? i was just wondering what to look out for.
once again, thank you for shedding light on possible issues we should be watching for. at least this might point me in the right direction if an issue occurs.

In reply to an earlier post on Aug 16, 2012 2:09:32 PM PDT
I am not familiar with Mint but I am sure you are okay. Basically, if your distribution uses hal by default then hopefully your distribution has taken care of those conflicts. The potential issues will only affect distributions that by default do not enable hal as they are utilizing udev. Distributions that ship with hal enabled by default most likely have special rules that handle the hal/udev conflicts allowing the two libraries to function and coexist in harmony.

Also, I am not stating that there are any security fixes. Only that because the project is not maintained, those normal permissions/rule issues that are found from time to time are not being found and therefore might reveal vulnerabilities that have not been accounted for. But if such security vulnerabilities exist, they would pertain to the permissions used to mount certain device types. For example, a web cam device might be read/write by all meaning that another application or user on a system could gain access to the device and eavesdrop on you.

The most common conflict is as you suggest. Plain and simply a device isn't being recognized correctly or being seen at all (as if it isn't connected).

Posted on Aug 17, 2012 10:47:34 PM PDT
Allison says:
This is really a shit deal Amazon/Flash has given Linux. I'm not even that "fluent" in Linux usage but I was finally able to install HAL (KDE/ArchLinux; Chromium) and all it took was "sudo /etc/rc.d/hal start" to get the videos going again. Funny thing, the error occurred MID SEASON of the series I'm watching... Luckily I can watch on my TV, but for the money I pay, I should be able to watch wherever the hell I want.

Frankly I'm scared what will happen once Flash 11.2/Linux becomes decrepit and useless... I'll never understand why Adobe hates Linux.

Posted on Aug 18, 2012 9:16:07 AM PDT
cactus says:
i.m.h.o.
it might have something to do with the free software....
the transition to html5 seems to be going smooth. most youtube videos play it smoothly.
it should get nice and screwed up once they get eleventy billion layers of drm protection mucking it up.
i, for one, am sick of seeing my cpu gage jumping into the red when i watch a video.
even win8 is limiting flash support.
there is no reason to need a 10ghz cpu with 20 cores to surf the web. right?
the only thing i'm worried about is that now i'll have to find something else to heat my lap in the winter....where's the cat?

Posted on Aug 19, 2012 10:28:27 PM PDT
John Dunlap says:
I'm using Ubuntu 10.10 x64. My latest inquiry to Amazon support yielded the following link: http://kb2.adobe.com/cps/929/cpsid_92948.html

From that page, I ran the following commands,
sudo apt-get install hal
rm .adobe/ -rf

And everything works fine now. Amazon support was actually helpful, for once. Hooray! :)

Posted on Sep 5, 2012 11:15:56 AM PDT
Last edited by the author on Sep 5, 2012 11:24:09 AM PDT
Steven Starr says:
They updated there player again today and once again it breaks linux support!!!!!! I am getting fed up with this I am about to cancel all my amazon accounts. None of the normal fixes work now.

Posted on Sep 5, 2012 12:00:17 PM PDT
cactus says:
my playback is fine with mint 13.
it won't allow hd playback with the newly added vids (i.e. ironman2 ect.) but it's good quality.
sorry if i'm missing something.
please keep us posted and feel free to post a link to a prime vid that you can't play (in the past there has been a problem with certain vids. only).

Posted on Sep 5, 2012 1:35:24 PM PDT
B. Beck says:
Confirmed... Broke for Linux again... running Ubuntu 12.04 64bit.

In reply to an earlier post on Sep 5, 2012 2:07:17 PM PDT
Doug Roberts says:
Still works for me:

Linux Mint 13 32-bit
Firefox 15.0 with Adobe Shockwave Flash Player 11.0r1
It does not work with Google Chrome Browser with the latest Shockwave Flash 11.3 r31, but it will work in Chrome with the older 11.0r1 Shockwave Flash

Posted on Sep 5, 2012 3:12:07 PM PDT
cactus says:
yep. confirmed.
i tried it on ff, chromium, and chrome. on chrome i just get a black screen.
the only difference that i can see is the use of chrome's 11.3 version of flash.
they just can't leave well enough alone, i guess.

In reply to an earlier post on Sep 5, 2012 3:37:42 PM PDT
Last edited by the author on Sep 5, 2012 3:41:16 PM PDT
Doug Roberts says:
Well, you should probably be careful before you go blaming Amazon for this one. The last known Linux version of Flash Player that Amazon's instant video content is known work with was 11.0r1. Google Chrome has updated the Flash Player that they supply with Chrome twice since then. The two latest versions do not work with Amazon's content, probably because Amazon cannot (or doesn't want to) "upgrade" it with their own DRM version of the player.

To find out what version of the Flash Player plugin your Google Chrome is using enter about:plugins in the url window.

Posted on Sep 5, 2012 3:40:45 PM PDT
M. Schrody says:
Ubuntu 12.04, Firefox 15.0, Shockwave Flash 11.02r (8/17/20120)

Tried to play Super8 in HD - received message that I couldn't play HD in browser, must use Xbox, Roku, etc... offered link to SD version. Clicking "Play" in SD version triggered "Updating Player" - update went quickly (about a minute) and then movie started and is playing perfectly in another tab as I type this.

Posted on Sep 9, 2012 8:43:50 PM PDT
Virginia says:
I'm running Fedora Core 64 bit and Amazon Instant Video stopped working for me a few days ago. It used to run in Firefox using Flash 11.2, but it looks like Amazon released an update that broke Linux support again. Does anyone know if Amazon is working on this issue? I hope Amazon will start putting some more thought into testing Amazon Instant Video on more platforms before releasing an update.

Posted on Sep 9, 2012 9:05:29 PM PDT
I opened bug 1048446 against the flashplugin-nonfree player at Ubuntu's Launchpad. Ubuntu users, be sure to log in to launchpad and click the green button that says "This bug affects me too" at the top. (You don't need to comment on the bug unless you have technical details that would be helpful, like contact info for a linux developer at Adobe.)

https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/1048446

In reply to an earlier post on Sep 9, 2012 9:25:32 PM PDT
Virginia says:
Does Captain America work for you? The only video that seems to work for me is Iron Man 2. Captain America and all the other videos I have tried play for about 24 seconds and then stop.

In reply to an earlier post on Sep 11, 2012 6:40:00 PM PDT
irisch says:
I was having this same problem and looking at the bug report in launchpad by installing hal
sudo apt-get install hal
Fixed the problem with Amazon videos for me.

Posted on Sep 11, 2012 9:41:27 PM PDT
Virginia says:
Fedora Core 17 is now working with Amazon Instant Video on Google Chrome. Unfortunately Firefox is a no go even though it's using the same version of Flash as Chrome. These are the things I had to do to fix Amazon Instant video in my situation.

1) Make sure haldaemon is running. If it's not then start it up with the command service haldaemon start.
2) Go to chrome://plugins/ and find Adobe Flash Player. Disable Flash 11.3 and enable Flash 11.2. Unfortunately Flash 11.3 shows a blank screen on Amazon Instant Video. Now close Chrome.
3) cd $HOME/.adobe; rm -rf *
4) Now load Chrome and try to watch a Video.

In reply to an earlier post on Sep 12, 2012 3:11:23 AM PDT
Thanks for that!

sudo apt-get install hal

Worked on Ubuntu/Kubuntu 12.04.1 LTS and now I can see my Amazon Instant Video shows again.

In reply to an earlier post on Sep 17, 2012 4:10:35 PM PDT
Fantastic! Worked great!

Posted on Sep 17, 2012 5:32:28 PM PDT
I'm having the same problem of receiving an error message when I try and watch videos from my library "Sorry. Your player requires an update to play this video..." I've installed the latest version of flashed, restarted, and no luck. Everyone else on this thread seems a lot more tech savvy, I have a basic Samsung laptop, windows opertating system...how can I get this to work?

In reply to an earlier post on Sep 17, 2012 7:23:54 PM PDT
cactus says:
did you run windows update?
also google flash version check and make sure you have the latest version.

In reply to an earlier post on Sep 25, 2012 11:18:34 PM PDT
Worked perfectly! Thanks Cameron!

Posted on Oct 27, 2012 2:37:36 AM PDT
Gary J says:
I am running ubuntu 12.10 64bit and chrome browser. After a bit of research I found the problem to be that Chrome is using flash 11.3 in their browser, but amazon only works on 11.2 So I went into about:plugins and disabled 11.3 then sudo apt-get install hal and sudo apt-get install hal
in terminal, then used Ubuntu Software Center to install flash plug-in then went back to about:plugins and enabled 11.2 now it works. Probably could have used a shorter method, but thought I'd share my experience.

Posted on Oct 27, 2012 9:52:33 PM PDT
http://kb2.adobe.com/cps/929/cpsid_92948.html

Worked perfectly!
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Amazon Instant Video forum

 

This discussion

Participants:  187
Total posts:  364
Initial post:  Dec 17, 2011
Latest post:  22 days ago

New! Receive e-mail when new posts are made.
Tracked by 54 customers

Search Customer Discussions