Your Garage botysf16 Amazon Fashion Learn more nav_sap_plcc_ascpsc CaseLangVeirs Explore Premium Audio Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer AnnedroidsS3 AnnedroidsS3 AnnedroidsS3  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Best Camping & Hiking Gear in Outdoors STEM
Customer Discussions > Amazon Instant Video forum

Amazon Instant Video not working on my PS3

Sort: Oldest first | Newest first
Showing 1-25 of 412 posts in this discussion
Initial post: Apr 4, 2012 7:49:04 AM PDT
Megan says:
We have it downloaded and registered but when we go to hit the "Watch Now" button to play a video that we already own we just get a grey screen and a spinning orange wheel then it goes back to the menu with an added green bar that says "Video already owned"

So far none of our videos work, has anyone had this problem or know of any way to fix it?

Posted on Apr 4, 2012 10:30:56 AM PDT
Cindy says:
I have a similar problem but mine doesn't even load up, like I click the app from xmb menu and it takes me to the first screen with loading circle

Posted on Apr 4, 2012 7:44:31 PM PDT
Have the same issue as Cindy... what's going on?

Posted on Apr 4, 2012 9:30:51 PM PDT
Brad Davis says:
I'm seeing something similar. I just get the audio track, while the screen stays on the orange spinning wheel

Posted on Apr 7, 2012 7:29:58 AM PDT
Last edited by the author on Apr 7, 2012 7:30:26 AM PDT
GrandMasterJ says:
I have the same exact issue as Megan while trying to view the Prime free videos. Oddly enough, any episode I've watched before or any future episodes in the same series won't play while some random videos will play. I am going to try uninstalling the VoD App from the PS3 and reinstalling and registering it. There aren't too many options to troubleshoot a 3rd party app on a Ps3.

Posted on Apr 7, 2012 7:35:44 AM PDT
GrandMasterJ says:
For anybody interested, this has fixed the problem for me. I hope this is not a recurring issue. Maybe it becomes corrupted if you shut the PS3 off while the app is open and playing video? Does anybody else do this?

Posted on Apr 8, 2012 9:56:21 PM PDT
I watched a show and everything was working fine. I then hit next to watch the next episode in a series and encountered this issue. I went back and tried to watch the episode I just watched, and had the same problem. This is BS... it has been happening for several hours now. Tried restarting my system several times and it does not resolve the issue someone please help? I cannot watch any videos!

Posted on Apr 8, 2012 10:02:13 PM PDT
I was able to get this to work by deleting the application off my PS3, re-installing, and re-synching my PS3 with my Amazon account. After doing this my videos are working again.


Posted on Apr 9, 2012 9:35:04 AM PDT
StaticFox says:
I'm having the same problem. Glad I'm not the only one scratching my head here.

In reply to an earlier post on Apr 10, 2012 5:39:14 PM PDT
PDV says:
I'm having the same problem,would you please write us how to delete the Amazon app and re-install it?
I really appreciate your help.

In reply to an earlier post on Apr 10, 2012 5:41:14 PM PDT
PDV says:
Hello Nathan E. Mitchell,

I'm having the same problem,would you please write us how to delete the Amazon app and re-install it?
I really appreciate your help.

Posted on Apr 11, 2012 12:04:36 PM PDT
dwfoth says:
I am having the same problem as Cindy and Benjamin. When clicking on the Amazon app it loads a random "splash screen" with a loading circle that never goes away. I've never made it to the register account screen. If you've seen this discussed elsewhere please let us know. Amazon has been no help to this point. This is the first place I have found others with the same problem.

PDV... You can uninstall the app by navigating to it, and clicking the triangle button which should pull up a small menu. After you delete the app it should be replaced by a new app which will download the Amazon app again.

Posted on Apr 11, 2012 12:08:37 PM PDT
For the people that are having the same issue as described by 'dwfoth', Cindy and myself... are you by any chance at a college dorm, or someplace were your internet goes through a switch in your floor before getting to you? The reason I ask, is because I have a similar setup, and the only way I got this to work was by tethering my phone and the app loaded right away! Hope this helps some of you...

In reply to an earlier post on Apr 11, 2012 12:33:03 PM PDT
dwfoth says:
Benjamin... very interesting! I am not in that situation BUT I do access the internet through a Proxy Server on another of my home computers because Cox Cable seems to severely throttle downloads when it senses a PS3 is attempting to download. When I get home I will try to access directly instead of through the Proxy Server. Thanks for the tip!!! I am curious if Cindy has a situation similar to either of us.

Posted on Apr 11, 2012 7:00:44 PM PDT
dwfoth says:
Update: I removed the proxy server from my ps3 settings and I was able to register my device and watch videos. Cindy, do you have some kind of non-traditional internet connection?

In reply to an earlier post on Apr 12, 2012 4:52:48 AM PDT
PDV says:
Thanks for your tip, I deleted & re-installed the Amazon app and my videos are working again. Thanks

Posted on Apr 12, 2012 9:37:43 AM PDT
Todd Erwin says:
I would recommend CALLING Amazon of these issues, as I just got off the phone with them and they are "unaware of any bandwidth or buffering issues on the PS3" and blamed my isp for the low bandwidth (they were saying I was connecting at 2.3 Mbps even though my ISP says I'm getting way beyond what I'm actually paying for (15 Mbps).

Posted on Apr 14, 2012 5:45:34 AM PDT
We were having the same issue with never-ending spinning circle. We deleted and reinstalled the Amazon app on the PS3 and got a new code. Then we entered the code on the Amazon website using the computer, NOT using the Amazon website through the PS3. Worked like a charm.

Posted on Apr 18, 2012 12:12:21 PM PDT
Mike Prior says:
Is there a way to de-register your PS3 from your Amazon account? Has anyone else needed to do that?

Posted on Apr 19, 2012 10:09:24 AM PDT
[Deleted by the author on Apr 19, 2012 10:10:55 AM PDT]

Posted on Apr 19, 2012 10:10:39 AM PDT
Same issue!! Just a spinning orange circle....

Posted on Apr 19, 2012 9:44:40 PM PDT
I experienced the same issue. Deleted the app, unregistered my PS3 then re-installed and registered again. All issues fixed!

Posted on Apr 23, 2012 5:37:07 PM PDT
Been having this issue as well. We deleted the amazon instant video app, then when reinstalling it was told that a 'newer' version needed to be downloaded. That is probably why it wasn't working.

Posted on Apr 26, 2012 11:52:14 PM PDT
Last edited by the author on Apr 26, 2012 11:52:46 PM PDT
StaticFox says:
I got the same issue a second time...I was okay with the reinstall being a simple one time fix, but I'm not really looking forward to having to do this every week.

I was hoping the previous update/patch would have fixed it, but I'm back to the spinning orange circle. Also, I'm not in a college dorm, or have any other kind of switch access. Simply wifi to my airport extreme router (in case that helps anyone).

Posted on May 5, 2012 10:31:23 PM PDT
We purchased a whole season of a show, and were able to watch the sneak peek, the first tiny episode offered, then after that just a spinning circle, nonstop. We waited half an hour and eventually watched it on a laptop. I am not amused, seeing as I had intended to watch good ole' Archer on my nice big bedroom Tv.

Amazon needs to get on this, asap.
‹ Previous 1 2 3 4 5 6 7 8 9 10 ... 17 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Amazon Instant Video forum


This discussion

Participants:  302
Total posts:  412
Initial post:  Apr 4, 2012
Latest post:  2 days ago

New! Receive e-mail when new posts are made.
Tracked by 66 customers

Search Customer Discussions