Your Garage Best Books of the Month Amazon Fashion Learn more nav_sap_plcc_ascpsc $5 Albums Fire TV Stick Sun Care Patriotic Picks Shop-by-Room Amazon Cash Back Offer roadies roadies roadies  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis UniOrlando Segway miniPro
Customer Discussions > Amazon Instant Video forum

Instant Video Player update breaks rights


Sort: Oldest first | Newest first
Showing 151-175 of 364 posts in this discussion
In reply to an earlier post on Apr 7, 2012 6:26:27 PM PDT
Thank you, this fixed my problem.

In reply to an earlier post on Apr 8, 2012 6:33:31 PM PDT
David says:
OK, I did get it going. I had to install hal to get it to work.

What I don't understand is I played Episode 1 of a video last night, and then Episode 2 ran into the error.

Now, both run.

But, just removing the cache did not do the trick.
# Remove cached junk from Adobe and Macromedia.
# Back these up if you're not sure what you're doing.
rm -r ~/.adobe ~/.macromedia
firefox
# Firefox did not play video
chromium-browser
# Chromium did not play video

But I installed hal, and it worked (without rebooting).
# Install the required packages.
sudo apt-get install hal
# Remove cached junk from Adobe and Macromedia.
# Back these up if you're not sure what you're doing.
rm -r ~/.adobe ~/.macromedia

firefox
# SUCCESS - Firefox plays video
chromium-browser
# SUCCESS - Chromium plays video

In reply to an earlier post on Apr 8, 2012 9:45:21 PM PDT
T. Walters says:
I have hal already installed; Firefox - yes...Chromium - no. So there's more going on then just hal.

Posted on Apr 9, 2012 7:42:27 PM PDT
It worked for me after I followed Andy's instructions to install hal and hallib1.

I must say I'm displeased with Amazon. The person who initially fielded my email had no explanation for this issue, nor did the second fellow who replied to my follow-up email. I only found the link to this discussion by following a link from an Ubuntu discussion forum.

The root of the problem is Amazon's failure to communicate. Their error message said nothing about hal. Instead it suggested my flashplayer was probably out of date, which is nonsensical. The technical support people who answered my emails had no awareness of this issue and were therefore inclined to believe the error message from the video player was correct and useful in guiding me towards a solution, even though they should have been able to glean from a careful reading of my emails that an out of date flashplayer couldn't possibly explain the issue.

It's hard to put my frustration in words, but I can say that I have lost confidence in Amazon's ability to handle technical problems with competence and efficiency. This shouldn't have been a problem. It shouldn't have been my problem. Once it became my problem, they should have been able to help me resolve it quickly. In all that they failed.

Posted on Apr 9, 2012 9:21:45 PM PDT
Peter Ohaver says:
I've been looking through here and I haven't seen anyone mention this, but I can still watch HD videos, but not SD. Not all shows are available in HD, so that's disappointing.

Posted on Apr 10, 2012 12:55:59 AM PDT
cactus says:
i agree. they look pretty bad after this.

In reply to an earlier post on Apr 12, 2012 5:05:08 PM PDT
Heather says:
This solution worked perfectly! Thank you A.D.!

In reply to an earlier post on Apr 13, 2012 7:27:23 PM PDT
thank you, David. I just opened my terminal, typed sudo apt-get install hal, entered my password, and then followed through with the removal, update, and installation. thanks for clear instructions!!

Posted on Apr 14, 2012 12:14:15 PM PDT
Last edited by the author on Apr 14, 2012 12:14:43 PM PDT
HAL is deprecated and not an acceptable solution https://en.wikipedia.org/wiki/HAL_%28software%29. Trust me - Amazon has no interest in making this work for Linux users.

Posted on Apr 14, 2012 12:18:41 PM PDT
T. Walters says:
Thanks Scott - important info and I think you're right...

Posted on Apr 14, 2012 2:06:02 PM PDT
Hi all, installing "hal" and rebooting fixed my problem. Why that should fix things makes no sense to me, but I'm glad it did. AMZN will get my instant video business for a little while longer.

In case this data is useful I'm running Ubuntu 11.10, 64b, flash 11.2.202.228 (which according to Adobe's flash version web page is actually *newer* than the latest), and Google Chrome. And if anyone cares, the video in question is Doctor Who, Season 6, non-HD. My replica Sonic Screwdriver was not used in the process of fixing this issue.

Posted on Apr 18, 2012 6:48:24 AM PDT
Last edited by the author on Apr 18, 2012 6:59:22 AM PDT
B. Jones says:
I too am having this issue. (and the update to flash player that just came out did not fix it). I am running Fedora 16 x64 with Firefox (chrome is NOT an option) and unfortunately the "hal" workaround is not an easy option since hal has been deprecated. I am going to try and compile it for f16x64 and see if that works (just so I can watch videos I paid for), but add me to the list of people who will not be renewing my prime subscription and not buying any more videos until they get this fixed.

Edit: I know it is not the correct answer but for those of you with Fedora 16 (and no HAL) see this post over on Fedora Forums:
http://forums.fedoraforum.org/showthread.php?p=1553395#post1553395
It has instructions for grabbing the Fedora 15 HAL packages and installing them and it seems to fix the problem... for now.
Your reply to B. Jones's post:
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
 

Posted on Apr 28, 2012 8:08:40 PM PDT
[Deleted by the author on Apr 28, 2012 8:09:22 PM PDT]

Posted on Apr 28, 2012 9:19:14 PM PDT
T. Walters says:
As noted by others above - this doesn't seem to work for everyone

In reply to an earlier post on May 27, 2012 11:50:26 PM PDT
ruach says:
Thanks for posting the update - I'm having the same problem on a Win7 64 bit machine with Opera, Firefox, and Chrome. All browsers and plugins are the most current versions. My backup machine (WinXP, Firefox) updates the player just fine, so I know it's not my network as the error/status message claims. Unfortunately, a new administrator account hasn't solved my problem, and neither has calling Amazon's Customer/Technical Support.

In reply to an earlier post on May 28, 2012 2:28:28 PM PDT
Thank you A. D. Lim! Based on your advice, I installed hal (Hardware Abstraction Layer) from the Ubuntu Software center and did nothing else and my problem was instantly fixed! I understand that hal is deprecated, but that is a problem for the udev developers to work out while I'm streaming videos.

I know, I should be a better citizen and discover what is missing from udev that hal still provides, but really, I just don't know enough about udev or hal to be any help. I'm eternally thankful to the people who understand udev and hal and are working to make a better world for the rest of us.

I'm using Ubuntu 64-bit 12.04 with Chromium.

In reply to an earlier post on May 28, 2012 2:51:54 PM PDT
The issue is not in udev or hal. It is that Adobe Flash is using deprecated libraries to interact with the hardware layer and Amazon has updated the DRM protection to rely on Adobe's broken code.

Posted on Jun 1, 2012 10:30:21 PM PDT
Last edited by the author on Jun 5, 2012 4:32:45 PM PDT
nautilus says:
On openSUSE 11.4 x64, installing hal, rebooting, and removing ~/.adobe and ~/.macromedia directories (all in that order) fixed playback in Chrome and Firefox.

In reply to an earlier post on Jun 4, 2012 8:44:36 AM PDT
J. Garcia says:
Installing the hal package also fixed the Amazon player for my Firefox on Ubuntu 64-bit 12.04...Thanks!

Posted on Jun 6, 2012 10:25:51 AM PDT
justme says:
I just wanted to confirm that installing the HAL package fixes the problem. Adobe has documented this is an issue with Flash Player 11. See here. http://helpx.adobe.com/x-productkb/multi/flash-player-11-problems-playing.html

"Ubuntu 10.x and 11.x Linux OS users sometimes see a blank or black screen with Flash Player 11 when playing protected video content. (For example, this issue occurs on services such as Amazon Instant Video.) A missing Ubuntu HAL (Hardware Abstraction Layer) module, which is not installed by default, causes this behavior. If the vendor exposes errors message, users see a DRM error 3323 or 3322."

In reply to an earlier post on Jun 6, 2012 10:34:51 AM PDT
solved my problem with archlinux also. The hal package is in aur (for arch users), and can be started by (as root) /etc/rc.d/hal start. It can also be put in the daemons array in rc.conf. This fix got me viewing with 64-bit also.

Posted on Jun 7, 2012 8:59:46 AM PDT
After using this process to fix my ubuntu back in Feb, I had since reinstalled ubuntu (to version 12.04) and the amazon player worked without installing the HAL packages so I didn't bother--until a few days ago when I got the same error as before about the player updating. Once again, I followed the same process (see below) and it was fixed without any need for a reboot. I'm curious if anyone knows why it worked for a while on a fresh install and then stopped working.

sudo apt-get install libhal1
sudo apt-get install hal

In reply to an earlier post on Jun 8, 2012 7:18:40 PM PDT
FarylBabe says:
I can verify that this works for me also. I'm running Ubuntu 12.04, kernel 3.2.0-25, and flash was broken for *some* vidoes on Amazon (broken for Star Trek TNG; working for Doctor Who, for example). It was broken for all browsers, where it tries to update my already updated version of the plugin (most of them are using the same flash, but Chrome has it's own plugin). After running:

sudo apt-get install libhal1 hal

appears to be fixed. Star Trek plays. No reboot required either.
This issue was fixed on my system for a while, and never broken on one of my other computers, and was a mystery I had yet to pin down. Thanks to whomever figured this out!

Posted on Jun 25, 2012 3:51:43 AM PDT
Just wanted to add that installing hal worked for me as well. I'm currently using Mageia 2, and installing "hal" from the Mageia Control Center worked for me (libhal or lib64hal install automatically has dependencies). Just install, then reboot, and you're golden. If you try to install, then simply close and re-open the browser you'll get a flash has crashed error message, so you need to reboot

Or, if you're skilled enough, you could probably just do a manual start of HAL from the terminal, but rebooting is the easy option.

Posted on Jul 7, 2012 9:31:58 PM PDT
M. Schrody says:
Thank you for this. Not sure why, but I just encountered this on one of my several Ubuntu boxes. The hal fix worked for me. Interesting that the problem and fix have been around for some time, but many of us are still just running into trouble now.
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Amazon Instant Video forum

 

This discussion

Participants:  187
Total posts:  364
Initial post:  Dec 17, 2011
Latest post:  May 8, 2016

New! Receive e-mail when new posts are made.
Tracked by 54 customers

Search Customer Discussions