Automotive Holiday Deals Up to 50% Off Select Books Shop Men's Athletic Shoes Learn more nav_sap_SWP_6M_fly_beacon Train egg_2015 All-New Amazon Fire TV Grocery Gifts for Her Amazon Gift Card Offer cm15 cm15 cm15 $30 Off Amazon Echo $30 Off Fire HD 6 Kindle Cyber Monday Deals Cyber Monday Video Game Deals Shop Now Tikes
Customer Discussions > Amazon Instant Video forum

Instant Video Player update breaks rights

Sort: Oldest first | Newest first
Showing 1-25 of 360 posts in this discussion
Initial post: Dec 17, 2011 1:52:19 PM PST
I'm running Ubuntu. As of yesterday, when I ordered a movie and "Watch Now" I first get a message "Updating Player", then, once that's done, and the movie starts to stream, I get another message saying "Sorry you do not have rights to stream this video."

This happens with Firefox, Chrome, and Opera. If I uninstall and reinstall the flashplugin, I get the same "Updating player" message and the "no rights message", so it seems to have something to do with the update Amazon is doing. Older movies in my library work fine.

Customer service has done nothing except to suggest updating my Windows software, in spite of the fact that I have told them I'm running Linux. Has this happened to anyone else?

Posted on Jan 10, 2012 1:23:07 PM PST
I recently started having a similar issue; the installation fails when updating:

"an error occurred and your player could not be updated"

No solution yet, same error on firefox and chrome.

Posted on Jan 10, 2012 2:19:01 PM PST
Yeah, I'm having the same problem as you, J. Rodger. If anyone knows how to fix and/or get around this, please share.

In reply to an earlier post on Jan 10, 2012 2:25:24 PM PST
Good to know I am not the only one.

I am running Ubuntu 11.10, with the ubuntu-restricted-extras package providing the flash player. It is currently the newest version, according to Ubuntu.

I don't want to go to the trouble of installing a separate flash package, but I'm wondering if that might be helpful.

Posted on Jan 10, 2012 2:41:10 PM PST
My system works fine; Ubuntu 11.10. I tried it in FireFox but I bet it works in Chrome, too. I just opened a terminal and typed

apt-cache showpkg adobe-flashplugin

and it said I am running version

In reply to an earlier post on Jan 10, 2012 4:11:34 PM PST
That looks like it could be the issue. It seems the package you mention is not the standard ubuntu package, which is listed as: - flashplugin-nonfree

What source are you using for that package? I would like to give that a try.

In reply to an earlier post on Jan 10, 2012 4:36:15 PM PST
OK, I found that package and installed it, and the same error pops up.

I cleared the flash content cache, no luck.

I also tried running firefox as root in case it was a permissions thing, I got the same error.

Has anyone seen that 'updating player' message, and watched it complete successfully?

Posted on Jan 10, 2012 4:42:01 PM PST
My netbook gets the same error as well.

In reply to an earlier post on Jan 10, 2012 5:52:50 PM PST
I'm using the standard Ubuntu "multiverse" repository. (Activated using the Software Sources preference panel.) I keep this machine "standard" except for installing the non-free media packages. No root or other tricks necessary. And this little netbook only has 1GB ram so it wouldn't be that, either.

Now that I think of it, the only non-standard fix I probably applied was the "fix full screen flash in Ubuntu" (do a Google search on that; there are a couple of valid ways to apply the workaround). This solves a crash that happens when Flash tries to go full screen. Maybe the latest version of the Amazon player chokes it too.

In reply to an earlier post on Jan 10, 2012 6:02:29 PM PST
Thanks, I will give that a shot.

I was wrong about the Ubuntu package you are using; listed in the software update is 'Adobe Flash Plugin 10', but installs v11, the packages you listed. 'Adobe Flash Plugin' installs the ones I mentioned. Go figure.

Posted on Jan 10, 2012 6:06:37 PM PST
Yeah, I saw that, too. Probably a volunteer missed that when Flash got updated. I believe the package doesn't actually have flash in it -- it's just a downloader to grab the correct file from the Adobe site, because that's what Adobe insisted upon to meet their licensing requirements.

Posted on Jan 10, 2012 6:16:19 PM PST
Your full screen fix did not work either. I do not know why Amazon IV needs to update Flash, this is where the problem is. I should mention that this was working fine a few days ago on the same machines.

I am going to follow up with their support desk, maybe they can shed some light. If I find a solution I will post it here.

Thanks for the help!

Posted on Jan 10, 2012 6:34:50 PM PST
Last edited by the author on Jan 10, 2012 6:36:38 PM PST
OH I forgot to point out -- the approved way to check which version of Flash you are running is to run the test(s) at the Adobe site. is one link that tells you the version you are running AND lists the latest versions for each platform. Right now mine says "You have version 11,1,102,55 installed."

In reply to an earlier post on Jan 10, 2012 7:45:52 PM PST
Well, situation resolved. I did not even close the previous browser window, it just started playing correctly. Very strange.

In reply to an earlier post on Jan 10, 2012 7:56:45 PM PST
Since you added the config file in /etc/adobe (like I did) maybe it ultimately took care of it for you. My understanding is that workaround avoids a nasty bug in Flash regarding graphics memory.

I hope others seeing this will update to let us know if it helps them too.

Posted on Jan 12, 2012 9:24:55 PM PST
I too am having this issue. Worked fine a little over 24 hours ago but now I get the "Updating Player..." message followed by "An error occurred and your player could not be updated. This update is required to play back this video. Please try again."

Just for completeness I tried T. W. Trussell suggestion of setting OverrideGPUValidation to 1 but this had no affect.

Posted on Jan 13, 2012 8:37:17 AM PST
Ester Lubman says:
Mine isn't updating either. I am running Linux. Hope this gets resolved.

Posted on Jan 13, 2012 11:34:21 AM PST
I'm not sure what to suggest. It's still working here. I just ran apt-get upgrade so I'm running the latest FireFox now and it still works. Chrome works. Another possibility is we are each seeing different "versions" of the web site, however you would think that after a few days they would have all their servers updated. I'm sure y'all have probably tried logging out and back in to your Ubuntu sessions. Another thing to try is to try FireFox with a totally clean account (in case it's a plugin conflict or something). I have more plugins installed than I remember, but when I clicked the "Check to see if your plugins are up-to-date" and the Add-ons Manager only shows one definitely outdated -- Mozplugger. I have several media plugins (gstreamer, vlc, others) installed, so maybe that is a difference, too.

This little netbook is barely able to handle a flash stream so frankly *I* am surprised it still works...

Posted on Jan 14, 2012 9:23:07 PM PST
Last edited by the author on Jan 15, 2012 1:48:28 PM PST
EDIT: Although I fixed my problem on one machine, it appears that the fix didn't take care of the issue on another machine. :( I have tried uninstalling the flash-plugin and also clearing various levels of the Flash Plug-in cache and Firefox cache in the hopes that the issue would resolve itself. I am at a loss.

Original fix which worked on one machine:
Okay. I fixed my problem. I tried a few different things so can't be certain if the fix works for others but I will start with the actions that resulted with a fix.

I am on a 64-bit machine and therefore use a 64-bit OS. However, seeing that Adobe had a major audio bug in their 64-bit version of Flash Player and didn't think the Linux community mattered to them, I had no choice but to downgrade Flash to the 32-bit version. A few months ago, Adobe got things worked out and put up the 64-bit repository allowing me to get updates from them faster and to use the 64-bit version. However, on the machine that started giving me this "Update Failed" when attempting to watch Amazon Instant Video, I was still running the 32-bit version. Even though the 32-bit version had the same version number of the latest Adobe Flash Player plug-in, it seemed to be the cause of my problems.

I remove the 32-bit version and installed the 64-bit version and things work now.

Perhaps my issue wasn't with the 32-bit version and a re-install of the 32-bit version would have been enough.

I had also tried the following things without any success:

- Log out of Amazon
- Restart Firefox
- Restart machine
- Empty Flash Plug-in cache and licenses
- Empty Firefox cache and cookies

Hope this info may help others.

Posted on Jan 15, 2012 5:13:12 PM PST
Last edited by the author on Jan 15, 2012 5:22:16 PM PST
B. Beck says:
I am having this very problem as well. Worked fine until today. I'm on Ubuntu Linux 11.10 64bit. I don't own a TV so any set top box wouldn't do me any good. I've tried the latest Firefox and Chromium. I have the latest Adobe Flash installed.

I am a huge Open Source Advocate. I don't mind running closed source software most of the time. I just want it to run on the Operating System of MY choice! I wonder when the big companies are going to get this point? My only advice to all of us using Linux and Open Source Software is to keep raising awareness, teach others about Open Source and keep pushing for our freedom to us our OS of choice!

So I'm guessing the problems lies within the why Adobe Flash is installed and/or how Amazon is trying to update it?

Posted on Jan 15, 2012 5:27:17 PM PST
B. Beck says:
***UPDATE*** I was able to watch an older random video I had purchased (by accident). It seems though it is one of the new video on demand rentals that isn't allowing us to watch? The one I had rented was: Colombiana.

Posted on Jan 15, 2012 10:15:00 PM PST
Nanofuture says:
I am also having this issue... I'm running the latest version of flash available. Everything worked fine until 1/15/2011 when the "could not update player" error started popping up. Some videos still work fine while others are unplayable. This is very irksome and hopefully is resolved soon.

Posted on Jan 16, 2012 6:09:57 AM PST
B. Beck says:
The response I just received from Amazon Tech Support....Doesn't work with "Linux"


From the content of you e-mail, I understand that you are able to watch Amazon Instant Videos you have purchased previously, now you are unable to watch the videos purchased recently.

I've checked with our technical team and they have confirmed that at this time Amazon Instant Videos are not compatible with "Linux." I apologize for any inconvenience this may cause.

I've forwarded your comments to our Amazon Instant Video team, they will carefully review your comments and will regularly work on improvements. Customer feedback like yours is very important in helping us continue to improve the experience of watching our digital videos.....


My question is... if it isn't "compatible with "Linux." then why has it worked so well for the past year!? I had netflix for 2-3 years, but finally dropped them when I went all Open Source. I gladly pay for Amazon Prime and Hulu Plus, as these are my only form of TV/Movies watching that I do. I watch all on laptops/netbooks running Linux. I do not have a TV.

Posted on Jan 16, 2012 2:07:06 PM PST
Doug Roberts says:
Same problem here. I called Amazon support last night and got a support representative who did not know what Linux was. Not a good sign.

Posted on Jan 16, 2012 2:16:31 PM PST
Doug Roberts says:
I emailed a problem report to Amazon and received the following reply just a few minutes later. It seems that they are aware of the problem, which I'm guessing involves browser-sniffing at their end and refusing to accept Linux-based browsers. Here's the response:


Thank you for writing to us at

I'm so sorry you had trouble watching the videos.

I have reviewed your account, as well as the notes regarding your phone call to our Customer Service department on January 15, 2012. I know this may be frustrating; however, please understand that one of my colleagues has already forwarded your concern to technical department to get the problem resolved for you at the earliest.

It usually takes 1-2 business days for this sort of research, but in this case it's taking a little longer. I'm very sorry about this delay. I've also sent a note to my colleague following up with your issue.

You will soon receive an update on this. If you need to contact us in the future, here's a link to our e-mail and phone form by which you can reach our Amazon Instant Video specialists 24 hours a day, seven days a week:

Amazon Instant Video specialists can be reached by phone or email 24 hours a day, seven days a week using the following link:

I appreciate your understanding. We look forward to seeing you again soon.

Did I solve your problem?

If yes, please click here:

If no, please click here:

Please note: this e-mail was sent from an address that cannot accept incoming e-mail.

To contact us about an unrelated issue, please visit the Help section of our web site.

Best regards,

Ramesh U
Your feedback is helping us build Earth's Most Customer-Centric Company.
‹ Previous 1 2 3 4 5 6 7 8 9 10 ... 15 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Amazon Instant Video forum


This discussion

Participants:  184
Total posts:  360
Initial post:  Dec 17, 2011
Latest post:  6 days ago

New! Receive e-mail when new posts are made.
Tracked by 55 customers

Search Customer Discussions