Customer Discussions > Kindle forum

Can't connect kindle fire hd to desktop because of MTP driver!


Sort: Oldest first | Newest first
Showing 1-25 of 36 posts in this discussion
Initial post: Jul 16, 2013 4:41:20 PM PDT
Here is the error message:
The drivers for this device are not installed. (Code 28)

There is no driver selected for the device information set or element.

To find a driver for this device, click Update Driver.

I do not know what to do! I've tried updating the driver but it cannot find the software.

I've also tried changing ports, uninstalling the drivers under the universal serial bus controller tab in device manager but still to no avail. I need help I've been at this for over a week...

Posted on Jul 16, 2013 4:45:14 PM PDT
SeaLevel274 says:
What OS?

Posted on Jul 16, 2013 5:06:36 PM PDT
Windows 7 64 bit

In reply to an earlier post on Jul 16, 2013 5:08:58 PM PDT
I would guess at a corrupted Win 7. I have no problems with Win 7 64 bit (home edition) installing the necessary drivers. Can you just click through?

Posted on Jul 16, 2013 5:10:08 PM PDT
What do you mean just click through?

In reply to an earlier post on Jul 16, 2013 5:11:35 PM PDT
Artist says:
I don't have a Fire, but on all other Kindles, you just hit escape to get out of that screen because no drivers are needed.

Posted on Jul 16, 2013 5:16:39 PM PDT
Last edited by the author on Jul 16, 2013 5:18:50 PM PDT
My issue is that I want calibre to recognize my device but it doesn't because my desktop doesn't.

My device is also giving me the usb compatibility message and telling me to go to kindle.com/support/downloads But I'm not finding anything useful there

In reply to an earlier post on Jul 16, 2013 5:18:59 PM PDT
Artist says:
I know nothing about Calibre, sorry.

Posted on Jul 16, 2013 5:21:00 PM PDT
Last edited by the author on Jul 16, 2013 5:21:19 PM PDT
The issue doesn't directly involve calibre. I just want to know why I have no MTP drivers and why my computer cannot find them online!?!? This is so frustrating...Is there a place I can go online to download this software or what :(

In reply to an earlier post on Jul 16, 2013 5:22:01 PM PDT
Last edited by the author on Jul 16, 2013 5:22:17 PM PDT
Artist says:
Have you contacted Kindle customer support? That's what I'd do next.

edited: typo

In reply to an earlier post on Jul 16, 2013 5:23:14 PM PDT
You have no drivers because no drivers are needed. That is also why you can't find any drivers on line. They just do not exist. Win 7 probably has a corrupt file which is causing it to think you need drivers. Win XP and Vista will give you the same error when files are corrupt.

Posted on Jul 16, 2013 5:28:39 PM PDT
MTP is media transfer protocol. Windows Media Player or some other obnoxious application has claimed the Kindle for its use. That's not what you want. You need to delete the association your computer has made with your Kindle's drive letter and tell it to open for file transfer only.

In reply to an earlier post on Jul 16, 2013 5:40:23 PM PDT
How do I do this? Every time I plug in my kindle it tells me MTP doesn't have a driver. Because of this my kindle is not recognized by my desktop which in turn causes calibre to not recognize it either.

Posted on Aug 10, 2013 6:58:47 PM PDT
martymc says:
I am having the same or similar problem using Windows xp and the latest version of WMP.

Posted on Aug 11, 2013 9:04:50 AM PDT
Try this: http://www.driverupdateutility.com/usb-drivers/mtp-usb-device-driver-download/

In reply to an earlier post on Aug 12, 2013 12:07:30 PM PDT
Zekeuyasha says:
That didn't work. All it does is tell me it has no driver and no driver can be found. Then it wants my credit card to register it to fix the other "problems" it found on my PC. Garbage payware.

Posted on Oct 18, 2013 8:59:30 AM PDT
Make sure your Kindle isn't "locked". If it's locked it won't show up as a valid device on your computer. Once you unlock it you should see a new drive under 'Devices with removable storage' and it should be called "KINDLE".

Posted on Oct 23, 2013 6:37:24 AM PDT
G. McWhorter says:
I was having the same problem connecting my kindle fire hd 7" to my winxp machine via USB. Here's what ended up working for me (some of the steps may not be necessary but this is everything I did):

- Update your PC to latest version of Windows Media Player 11 (you may have to update to service pack 2 or 3 first if you haven't already)
- Plug in Kindle via USB. If Windows tries to install drivers (probably for MTP) just go ahead and let it try to install (it won't find drivers but that is okay). Now go to device manager (control panel -> system -> hardware -> device manager) and uninstall anything related to Kindle (like Android composite device) and MTP (if you've tried installing drivers before, MTP probably shows with an exclamation point because it didn't install correctly). Just right-click on each one and select uninstall.
- Now, you want to uninstall any Amazon drivers that have been installed to your computer. If you've rooted your Kindle, you probably downloaded a package of ADB drivers from a forum or somewhere else that installed to c:/program files/amazon.com. I used Revo Uninstaller Pro (free trial available) to locate and uninstall those drivers and all related registry entries. You may or may not be able to uninstall them using the Windows uninstaller (control panel -> add/remove programs).
- Unplug Kindle from PC and reboot your computer.
- On your Kindle, go to Settings -> Security and disable "EnableADB"
- Do a hard reboot on Kindle (hold power button for approx 30 seconds).
- Now that PC and Kindle have both rebooted, unlock Kindle and plug in USB cable. Windows should automatically install MTP and MTP device (it shouldn't need to ask you for any drivers) and you should see Kindle in "My Computer" and be able to explore it just like any other removable drive.

Like I said, you may not have to do all of those steps, but I have been trying to get this to work for days and those were all of the steps I finally had to take to get it to work after Googling and reading countless posts about this issue. Hope that helps!

Posted on Jan 31, 2014 8:32:47 AM PST
C. Nail says:
this worked. Thanks...

Posted on Feb 6, 2014 10:11:04 PM PST
Dell Laptop Kindle Fire HD MTP Driver doesn't work
Hi everyone,

This isn't really a question but rather a solution to what I had to look for, for a long time.

I have a Dell Laptop and for some reason I couldn't connect my Kindle Fire HD. So after Looking around (for a very long time) I found a way of fixing it.

In my case it would install all drivers except the MTP driver. It would just show me MTP with a yellow triangle and an exclamation mark inside.

Like so:

I did the following to fix it:

1. Open Device Manager

2. Right click "MTP" and press on "Properties"

The "MTP Properties" window should open.

3. Go to the driver tab and press "Update Driver".

4. Select "Browse my computer for driver software"

5. Press "Let me pick from a list of device drivers on my computer"

6. Scroll down to "Portable Devices", select it and press "Next".

7. Select "(Standard MTP Device)" for "Manufacturer" and "MTP USB Device" for "Model".

Press "Next" when done.

8. A warning will show up, just press "Yes".

9. It should give you the "Successful" message.

Close all windows and go to "Computer".

10. Your Kindle should now show up on "Computer".

I hope this will help out some of you since this has been a big problem for me for a long time.

Thank you for reading.

In reply to an earlier post on Feb 27, 2014 10:44:42 PM PST
Jason H says:
THANK YOU! I've been trying to solve this problem for hours.

In reply to an earlier post on Mar 18, 2014 3:16:10 AM PDT
Ethan says:
Omg, Give this guy a medal!!!!!!!!!!!!!!!!!!!
I have been all over the internet trying to find a solution to this problem. I called amazon support and after speaking to a few dim whits that didn't know jack about anything, they said they where going to escalate it and have someone contact me with in 48 hours. Its been more that 48 hours.

Thank you so much sir!!

In reply to an earlier post on Mar 23, 2014 6:39:56 PM PDT
I have the very same problem but have 64 bit running Windows 8.1. I also use Calibre and want it to recognize my device. My computer does not even recognize that my Kindle is connected.

Posted on Mar 26, 2014 12:18:28 PM PDT
fobman says:
great game love it -

If I could buy you a beer, I would! You are a demigod of the Internet! I had problems with my Kindle Fire HD 8.9 and Galaxy S3 phone and this solution solved both problems. You da man (or woman)!

Posted on Apr 7, 2014 5:41:28 PM PDT
***********************************************
1. plug kindle into pc
2. ignore unpleasant driver message
3. enter device manager and click the following:
* update driver software
* browse my computer for driver software
* let me pick from a list of device drivers on my computer
4. select 'portable device' from the list
5. select 'standard mtp device' from the list
6. select 'mtp usb device' from the list
7. click next
***********************************************
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  27
Total posts:  36
Initial post:  Jul 16, 2013
Latest post:  1 day ago

New! Receive e-mail when new posts are made.
Tracked by 10 customers

Search Customer Discussions