Your Garage Best Books of the Month Amazon Fashion Learn more nav_sap_plcc_ascpsc $5 Albums Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer roadies roadies roadies  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro STEM
Customer Discussions > Kindle forum

Cannot open any books on one of my Kindle for PC installations


Sort: Oldest first | Newest first
Showing 1-25 of 44 posts in this discussion
Initial post: Nov 19, 2009 12:13:09 PM PST
I recently downloaded Kindle for PC onto two of my computers. One one of them, it works fine. But on the other one, the books download (to the "My Kindle Content" folder in "My Documents") but will not open.

Every time I double-click on a book, I see a message: "The book could not be opened. Please remove the book from your device and redownload it."

Has anyone else had this problem?

I have already tried removing and reinstalling the application, the data files, the cache files, and the content files. I contacted Amazon, and they suggested I do the same (which I had already done).

Right now, I am chalking this up to a bug which will hopefully be resolved in the next release of the application. Any ideas?

Posted on Nov 19, 2009 12:30:31 PM PST
Jodi1360 says:
You might want to contact Amazon kindle cs, they may be able to help you. Good luck I hope it all work out for you

jodi

Posted on Nov 19, 2009 12:33:47 PM PST
Jodi -

Thank you for the suggestion.

The issue is not critical, and as far as I can tell, it is a bug in the application. I am going to avoid spending the time on a support phone call unless I get to the point where I stop thinking it is a bug (i.e., where I think a support call might be able to resolve). Probably, I will just wait until the issue is resolved in a future automatic update of the software.

I mainly started this discussion to try to see if any other users out there are experiencing this issue..

Posted on Nov 19, 2009 12:41:19 PM PST
A customer says:
Did you download it from within the program or did you try to transfer the folder from one computer to another?

In reply to an earlier post on Nov 19, 2009 12:42:38 PM PST
I have tried both - download from within the program, and copying a book file from another PC.

Posted on Nov 19, 2009 12:50:33 PM PST
TiffanyS says:
I experienced this same problem on two PCs, the one having the problem being the one on which I was not the Administrator of that PC. Could that be the issue? The application downloaded just fine, but when trying to then download a book, I did not have authorization to download anything to that PC because I did not have administrative rights.

Posted on Nov 19, 2009 12:55:59 PM PST
Last edited by the author on Nov 19, 2009 12:58:21 PM PST
Howright says:
I had the same problem - I ended up un-installing Kindle for PC from my netbook and unregistering it from Amazon and then reinstalling & registering it. I tried once and didn't unregister it and I kept getting the same error, once I degistered and re-registered it was fine.

Posted on Nov 19, 2009 1:44:32 PM PST
John says:
***I had the same problem - I ended up un-installing Kindle for PC from my netbook and unregistering it from Amazon and then reinstalling & registering it. I tried once and didn't unregister it and I kept getting the same error, once I degistered and re-registered it was fine.***

Deregistering from the app itself or from the Manage Your Kindle page is very important. If you don't then when you reregister it (even on the same computer) it will rename it as ***'s Kindle for PC 2 etc.

In reply to an earlier post on Nov 19, 2009 1:51:19 PM PST
H. Wright - Thank you for the suggestion. I did try these steps, but it did not work. I will try the same steps again, just to be certain.

Posted on Nov 19, 2009 2:25:29 PM PST
I took the following steps, but still cannot open books on this PC.

- Uninstall application

- Confirm that the following folder has been removed:
C:\Program Files\Amazon\Kindle For PC

- Remove the following folder:
%userprofile%\Local Settings\Application Data\Amazon\Kindle For PC

- Remove the following folder (Note: For me, the "My Documents" folder is redirected to a file server. Maybe this is causing a problem?):
\\FILESERVER\My Documents\My Kindle Content

- Confirm that the following registry keys have been removed:
HKLM\Software\Amazon
HKCU\Software\Amazon.com

- Deregister the PC from the "Manage your Kindle" section of Amazon.com

- Reinstall the software, sync, and try to open a book

Registration of the device works okay. Sync and download of books also works okay. It is only opening the downloaded book that fails. This makes me think that there is not any network issue.

If I have time tomorrow, I will try running Filemon and Regmon on the PC while attempting to open a book, to see if this gives any useful information.

Thanks all, for your suggestions..

Posted on Nov 19, 2009 2:29:48 PM PST
John says:
hmmmm, it seemeth to me that if you are savy enough to use filemon and regmon that you are probably above and beyond the help you could probably find here. My guy impression would be the redirect to a file server. If you are using ntfs you could try changing the redirect to point to C:\Example and create a symbolic link from C:\Example to \\FILESERVER\MY Documents\My Kindle Content

Of course this would probably require a complete redesign of your folder structures. It really pisses me off that there are no options to select the install nor storage directory for Kindle for PC.

In reply to an earlier post on Nov 19, 2009 2:35:56 PM PST
Yes, I am savvy enough to use Filemon and Regmon, and I will try to figure out the issue if I can.

My apologies - I had originally posted here in order to see if others were experiencing the same issue, not necessarily to get an answer. I had already tried all the standard stuff before posting, and in my opinion the software has a bug which will be resolved in some future deployment.

That said, I am hoping that someone in the development team may read this thread and use the info to help identify the bug.

But if I can find a workaround, then all the better, and some of the suggestions helped me to think along some new lines of thought!

In reply to an earlier post on Dec 2, 2009 2:43:27 PM PST
I am having the same problem, did amazon refund you money for your purchase?

Posted on Dec 2, 2009 2:52:11 PM PST
Bufo Calvin says:
I know you are doing fine on your own...just fun to suggest some things:

1. The files were either moved from your archives to Home on that computer, or downloaded for that computer, right? I'm a bit suspicious that what you are getting is caused by the DRM (Digital Rights Management) coding for the book. If the file had been downloaded for the other PC, that would cause an error

2. I'm also thinking about security the second computer might have: firewall, virus protection, that sort of thing. When you look at the files in Windows Explorer, do they have the icon for Kindle Content?

3. You might want to try getting a free book from FeedBooks...if K4PC is properly installed, it should ask you if you want to open it with Kindle for PC. Knowing if that works could be an important diagnostic

Good luck with it! I'm curious...let us (the forum members) know what happens. :)

Bufo Calvin
Amazon Author Central page:
http://www.amazon.com/-/e/B002E0NBIW

In reply to an earlier post on Dec 3, 2009 3:43:04 AM PST
No - I did not request a refund. The books open fine on my Kindle and on my other PC's running Kindle for PC. Occasionally, a few of them even open fine on the "problem" PC.

In reply to an earlier post on Dec 3, 2009 3:46:35 AM PST
Bufo Calvin -

1 - I have tried every combination of steps to get the content on the PC, and have also cleared all the content manually several times.

2 - Every PC I use has several fairly standard security tools running on it. I've tried fiddling with these. In any event, an application that fails silently on a PC that is able to run every other application without problem is still a buggy application that should be fixed, in my opinion. :-)

3 - Occasionally some of the books open on the "problem" PC, including books I have purchased (sometimes).

In reply to an earlier post on Dec 15, 2009 4:58:45 PM PST
Mandy Omrani says:
thanks I had same issue and your solution worked for me.

Posted on Dec 15, 2009 5:22:40 PM PST
It seems like the kindle book is not recognizing the PC.

Can you see the tab "Archived Items" when you're on the Home Page? If you can see the "Archived Items", then the PC is registered properly and Amazon recognizes that this group of books can go to this Kindle Device.

Can you move an Archived Item to the Home Page? An error at that level may be due to a firewall.

If you can move the Archived Item to the Home Page but you can't open it, then that's much trickier. Amazon recognizes your PC and sends the book but the book doesn't think it's on the right PC. I have no clue how to get around that.

Posted on Dec 16, 2009 3:05:57 AM PST
I have the same problem. Archived items are on the home page, but I can't open them. I sent an e-mail to Customer's Service and they are studying the problem .

Posted on Dec 19, 2009 5:40:00 AM PST
Same problem here. I can no longer open any books on my PC.

Posted on Jan 21, 2010 5:07:40 AM PST
I'm having the same problem here with one of 2 PCs (the one with Windows 7 works fine, and the one - an old IBM Thinkpad T60 with Windows XP can open only 1 of 4 books).
I have tried every possible solutions (de/re-installation, de/re-registration, one PC registered at a time, etc....).
Contacted support by m-mail, but no real solution at the time. Probably would call the support.

Do you have any progress with this issue ?

In reply to an earlier post on Jan 21, 2010 8:49:11 AM PST
I'm still having the issue. I feel like it is a bug in the application - I've just given up on using the app on this particular PC.

Posted on Jan 21, 2010 11:52:18 AM PST
Having the same problem as Shannon and others. Books won't open, but no problem with opening blogs. Have tried all of your suggestions. Kindle 2 with 2 PC's. I am the administrator. Too soon for a response from CS>

Posted on Jan 21, 2010 12:50:20 PM PST
I tried downloading additional books from my archives and they open. Could it be a corrupt file?

In reply to an earlier post on Aug 16, 2010 2:25:14 PM PDT
Has Amazon given any fix or work around for redirect "My Documents" users? There are several professional programming books I would like to by and read at home and work but I don't want to lug them back and forth. Unfortunately I run a serer at home and am obviously on one at work, each of which have "My Documents" redirect. Home I could fix but don't want to and work is not of my choosing. Would love to use the product but need that fix.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
My Kindle Fire won't charge 392 4 minutes ago
85° and Sunny - A Perfect Day to RAOK! 9829 5 minutes ago
Elephants Three at The Ģrandest Hotel - Part IV 4741 5 minutes ago
Where are the KF blogs as we read a book? 7 6 minutes ago
Deal of the Day 9 14 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 1773 23 minutes ago
KINDLE KITCHEN #5: Home of Family, Friends and Good Food 8733 24 minutes ago
It's After Midnight and I Just Opened a Bottle of Wine 5625 24 minutes ago
Kindle FireHDX Frozen 58 35 minutes ago
"Summarize" for students 10 38 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  32
Total posts:  44
Initial post:  Nov 19, 2009
Latest post:  Feb 20, 2014

New! Receive e-mail when new posts are made.
Tracked by 10 customers

Search Customer Discussions