Customer Discussions > Kindle forum

kindle fire web browsing


Sort: Oldest first | Newest first
Showing 1-25 of 45 posts in this discussion
Initial post: Oct 9, 2011 8:29:08 AM PDT
glenn brown says:
can u browse the web with kindle fire

In reply to an earlier post on Oct 9, 2011 8:30:27 AM PDT
Yes, that's one of the Fire's primary purposes. :)

Posted on Oct 9, 2011 8:30:31 AM PDT
Read this: Kindle Fire, Full Color 7" Multi-touch Display, Wi-Fi

In reply to an earlier post on Dec 23, 2011 9:46:58 AM PST
i bought a kindle fire recently and trust me, trying to web browse SUCKS. it's very difficult to get it to respond to your clicks and when it does, it responds to the WRONG click! Very frustrating. Basically, I paid $200 for a color reader. That's what it's good for and that's all.

In reply to an earlier post on Dec 25, 2011 7:54:56 AM PST
L. Smith says:
yes, having trouble with the web browser - hopefully firefox arrives soon

In reply to an earlier post on Dec 25, 2011 7:58:48 AM PST
Keep playing around with it and you'll get used to the touch screen or buy a stylus.

Posted on Dec 25, 2011 8:06:10 AM PST
dawnsong says:
It took me a couple of weeks to adapt to touch input... now I love it.

Be sure latest update is installed - improves touch responsiveness.

Posted on Dec 25, 2011 8:14:53 AM PST
Been browsing with mine all day. Seems quite responsive to me. I am even posting here with it. I did turn off the acceleration setting in the Silk settings screen. I also sideloaded firefox. It works ok but I am still using Silk.

Posted on Dec 26, 2011 10:14:36 AM PST
J. S. Wright says:
I just got a Kindle fire and I cannot get on the internet. Yes, yes, I have a router, Roku;however, when I type the URL in, it just sits there and does not access it. Wonder if there is something wrong with this one.

Posted on Dec 26, 2011 11:02:21 AM PST
dawnsong says:
Have you tried a hard reset?
Hold the power button down for 30 seconds and let it reboot.
Might also want to reset your router.

Posted on Dec 29, 2011 1:17:13 PM PST
Alyson says:
The problem is with the web Browser itself, as the book and app downloads are nimble and speedy, but surfing the web is painfully, terribly slow- to the point of being unusable. If this continues, I will be returning the Kindle Fire.

In reply to an earlier post on Dec 30, 2011 11:14:20 PM PST
K. Koenig says:
Totally agree with you Jessie...Amazon would have a hit product if they could fix that...I have a smart phone that surfs the web faster on 3G than the Fire can on the fastest speed internet you can find....

Posted on Jan 1, 2012 8:26:26 AM PST
Jsmart says:
I hate my fire for browsing the web. Amazon really messed it up. My phone browses the web much faster. Avoid the fire and get a samsung tablet. I'll be returning my fire. What a POS.

Posted on Jan 1, 2012 8:40:45 AM PST
Eric135 says:
I read an article on How To Geek dot com suggesting the web browser settings be changed to DISABLE Accelerated Page Loading, turn off Enable Plug Ins and have web pages rendered in Mobile rather than desktop view and, having done these steps, browsing is noticeably faster. But I didn't have any issues before. I've grown to really love my Kindle Fire but I'm very fast and accurate with tap-typing. I even love the 7 inch form factor. So far it's been everything I expected and more.

Posted on Jan 1, 2012 8:42:20 AM PST
KMB says:
How to you get to silk setting's screen?

In reply to an earlier post on Jan 1, 2012 11:45:52 AM PST
Silky says:
Download the maxthron web browser from the app store. It works a lot better

Posted on Jan 1, 2012 12:01:25 PM PST
roger says:
After having stumbled onto this thread researching ways to speed up my Kindle Fire I looked up the article from How to Geek mentioned about. I followed the directions and wow, what a difference. Thanks for that reccomendation. My pictures on FB display now, they did not before. I did not choose the mobile loading option, I may try that to see what it is like. Here is the link if anyone wants to give it a try.
http://www.howtogeek.com/98241/how-to-make-the-kindle-fire-silk-browser-actually-fast/

Posted on Jan 1, 2012 12:19:16 PM PST
Sandy H. says:
As suggested, I just modified the browser settings to disable plug-ins and acceleration, and use mobile instead of desktop browsing. The browser is dramatically more responsive than it was before. It makes a huge difference and can easily be changed back if, for some reason, you don't like it. So far, it seems to be a very simple fix for the Silk browser's sluggishness.

In reply to an earlier post on Jan 1, 2012 4:39:48 PM PST
Eric135 says:
@KMB, from the Kindle Fire home page, start up the web browser. If the touch keyboard comes up, turn it off. Then tap the lower part of the screen to pull up the browser options, then go to "Settings". The option to turn of page acceleration, turn off plug ins and set viewing preference to Mobile are lower on the list of options.

I personally switched from Mobile to Automatic. I actually like using pinch-to-zoom.

@roger, thanks for posting the link to howtogeek...

Posted on Jan 1, 2012 5:02:38 PM PST
I am new to e reading and all that. Just got a kindle fire. I have a charge card number on it, but I only want to purchase books, etc. with my amazon account where I keep downloading gift cards. How do I do that?

Posted on Jan 1, 2012 5:04:13 PM PST
I am new to e reading and all that. Just got a kindle fire. I have a charge card number on it, but I only want to purchase books, etc. with my amazon account where I keep downloading gift cards. How do I do that?

In reply to an earlier post on Jan 2, 2012 12:20:20 PM PST
MamaReindeer says:
How do you "sideload" firefox?

Posted on Jan 5, 2012 8:33:02 PM PST
asl chica says:
Thanks for the suggestions... I was really frustrated with the web browsing because it seemed non-existent - until I made the changes... it really helped! Thanks again!

In reply to an earlier post on Jan 9, 2012 2:26:15 PM PST
Thanks soooo much!!, That totally fixed the problem, before I reset my Kindle Fire (as featured in "How to Geek") I was ready to throw it across the room!!

Posted on Jan 16, 2012 4:22:07 PM PST
I am having trouble...if I log off the web...the next time I open it several tabs are open. I don't want 20 tabs open. What can I do to stop this?
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
Software Update for Kindle Paperwhite, Kindle Voyage and $79 Kindle
0 9 days ago
Announcement
Simon & Schuster Agreement
0 Oct 20, 2014
Announcement
Have a Kindle Question?
0 Sep 12, 2012
Australian/Kiwi kindle users thread #4 - "the BBQ" 1092 2 minutes ago
non delivered ebooks lost in space 0 10 minutes ago
Free Books and Chat - FB&C- Saturday/Sunday/Monday November 22, 23, 24, 2014 110 11 minutes ago
False advertising, Amazon Instant Video on Android 874 18 minutes ago
November 2014 Informal Poll--What are you reading now? 571 27 minutes ago
Dragi's Croatian Crab Shack and Wine Bar - The times they are a changin' 4621 28 minutes ago
Can the Paperwhite 3G browse the web using its 3G connection? 292 38 minutes ago
Al's Place 35mm 4707 49 minutes ago
kindle won't power down or turn off 0 1 hour ago
 

This discussion

Discussion in:  Kindle forum
Participants:  34
Total posts:  45
Initial post:  Oct 9, 2011
Latest post:  Mar 2, 2013

New! Receive e-mail when new posts are made.
Tracked by 6 customers

Search Customer Discussions