Customer Discussions > Kindle forum

Download Error for three graphic novels on Kindle App for iOS (iPad 2)


Sort: Oldest first | Newest first
Showing 1-25 of 49 posts in this discussion
Initial post: Jul 12, 2012 1:53:19 PM PDT
I purchased 3 graphic novels and received "Download Error" when trying to view them on my iPad. I am connected to the internet and a regular novel that I purchased at the same time downloaded fine. Thoughts/Ideas to help?
Just in case, the G.N.'s were Batman: Year 1, Batman: The Dark Knight Returns, and Batman: The Long Halloween.

Posted on Jul 12, 2012 4:02:00 PM PDT
many have reported the same problem with the new update; what worked for me was de-register, delete, re-download, re-register. Now Watchmen and V/Vendetta work fine. However, all my other books were wiped out and had to be re-downloaded. I haven't seen any better suggestion tho.

Posted on Jul 14, 2012 1:01:18 PM PDT
Jason Reedy says:
Batman: The Dark Knight Returns

Thanks for the suggestion, although you are correct that this is not the ideal solution, this was the only option which would work for me and allow me to download my copy of the graphic novel.

Posted on Aug 6, 2012 11:37:08 PM PDT
Richard says:
I have just encountered the same problem. I have followed the solution advised above and still have the same problem. It is very frustrating! Does anyone else have a solution?

Posted on Aug 7, 2012 2:32:07 AM PDT
also here... same problem

Posted on Aug 7, 2012 2:52:41 AM PDT
James Self says:
The same thing is happening to me and the method above doesn't work for me.

Posted on Aug 7, 2012 3:01:15 AM PDT
same problem- tried deleting and re-registering - can't download anything

Posted on Aug 7, 2012 3:33:17 AM PDT
N Weller says:
Same here. I cannot download onto my iPad, iPhone or Windows Phone. Is something wrong?

Posted on Aug 7, 2012 5:04:29 AM PDT
Carole says:
Same problem here. I tried the above and it is still not working.

Posted on Aug 7, 2012 5:25:59 AM PDT
Download the new version of the app. Apparently no need now to delete the previous one or to deregister

Posted on Aug 7, 2012 5:37:15 AM PDT
C. Smith says:
Just been in contact with them as I'm having the same issue and tried all the suggested routes to resolve the issue with no luck. Apparently there is a problem with the ipad and iphone app and they're working on it and should be sorted in the next 24-48 hours.......we'll see!

Posted on Aug 7, 2012 5:53:29 AM PDT
Richard says:
I am thinking that this will cost amazon kindle as I will not be buying anymore books until it is sorted. Good to hear that someone is working on it though, fingers crossed eh!

Posted on Aug 7, 2012 9:19:32 AM PDT
Emma Ashton says:
I too contacted them this morning when my purchased book wouldn't download from the cloud. After speaking to two different people they confirmed in an email there is am problem with the cloud at the moment but didn't say when would be fixed. Frustrating

Posted on Aug 7, 2012 10:45:02 AM PDT
Emma Ashton says:
Just as a quick update - I have just deregistered my iPad and registered again and they all now downloading no problem. Hope this helps

Posted on Aug 7, 2012 12:46:52 PM PDT
Richard says:
Ok, I just tried the deregstration from iPad again, then I deleted the icon from my iPad and registered again and I can now download too (Thanks Emma). Don't know what has happened but am just happy to be working again.

In reply to an earlier post on Aug 7, 2012 9:17:23 PM PDT
Did.you lose your previous books?

In reply to an earlier post on Aug 7, 2012 11:14:14 PM PDT
Richard says:
No my previous books re loaded automatically

Posted on Aug 8, 2012 12:30:37 AM PDT
RAB says:
There is clearly a problem and I am surprised they have not made an announcement. Until it is fixed there is no point buying new books if you intend to read them on an iPad

Posted on Aug 8, 2012 2:41:15 PM PDT
N Weller says:
Working for me now as well. Phew...

Posted on Aug 12, 2012 6:58:36 PM PDT
R. O'Bday says:
I had to de register and re register, then book downloaded to device. What a pain.

Posted on Aug 17, 2012 8:36:04 AM PDT
Mike says:
Unregister, delete, install, register worked for me.

Posted on Aug 31, 2012 1:37:28 AM PDT
I tried the de-register, delete, download, and register option. But I still cannot open the book. Is this also an issue with the Kindle for Andriod app?

Posted on Sep 22, 2012 8:01:47 AM PDT
Heloooo? How do you de-register?

Posted on Sep 22, 2012 8:20:17 AM PDT
Woody says:
You deregister by going to Amazon's website, logging into your account then going to Manage my Kindle, then choosing Manage my Devices.

Posted on Nov 13, 2012 7:55:14 AM PST
kkcheong says:
I just need to deregister and download it with no problem.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
Software Update for the Original Kindle Paperwhite
0 29 days ago
Announcement
News: Kindle for Android app Update 4.13 Now Available
0 Jun 25, 2015
Announcement
Amazon Introduces New Kindle Paperwhite: The Most Popular Kindle, Now Even Better
0 Jun 18, 2015
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Welcome To The Quirky Zoo! Home To Many Exotic and Everyday Creatures Including a Platypus! 4639 2 seconds ago
Australian/Kiwi kindle users thread #4 - "the BBQ" 5201 5 seconds ago
Free Books and Chat... July 2015 1015 1 minute ago
Freebie Books - Links Only - No Self Promotion IV 3032 9 minutes ago
parental control 1 44 minutes ago
question on kindle fire carousel & kindle paperwhite on same account 72 56 minutes ago
Purchase not showing in Cloud Reader 1 57 minutes ago
RAOK 82 has a spring in its step! 6734 1 hour ago
 

This discussion

Discussion in:  Kindle forum
Participants:  38
Total posts:  49
Initial post:  Jul 12, 2012
Latest post:  Jun 7, 2015

New! Receive e-mail when new posts are made.
Tracked by 8 customers

Search Customer Discussions