Your Garage botysf16 Amazon Fashion Learn more nav_sap_plcc_ascpsc Maxwell Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro
Customer Discussions > Kindle forum

Fire HD not recognized on computer

Sort: Oldest first | Newest first
Showing 1-15 of 15 posts in this discussion
Initial post: Sep 21, 2012 9:46:09 AM PDT
Roxanne says:
When I plug my new Kindle Fire HD into my computer via the USB cable it does not recognize the Kindle. I am using the cable from my Kindle KK. Could that be the reason why?

In reply to an earlier post on Sep 21, 2012 9:59:59 AM PDT
rickh57 says:
What kind of computer are you using? The HD uses a different USB format (MTP) than earlier Kindles.

In reply to an earlier post on Sep 21, 2012 10:05:43 AM PDT
Roxanne says:
I have a Macbook pro. I am using my cord from my Kindle Keyboard and wonder if that is a different cord than my Kindle Fire?

In reply to an earlier post on Sep 21, 2012 10:10:23 AM PDT
rickh57 says:
Your cord should work fine. You need to follow the instructions on this page (, specifically:

Macintosh: Mac OS X 10.2 or later. Note: Mac users need to install a free app, Android File Transfer, to complete a USB transfer. Visit and follow the onscreen instructions.

In reply to an earlier post on Dec 25, 2012 12:22:39 PM PST
Last edited by the author on Dec 25, 2012 12:28:37 PM PST
SigurSuger says:
I got the app, but am not sure how it works. Also, I'm trying to work with calibre, but my kindle fire hd isn't recognized there, either. What can you recommend I do about that? Sorry, I'm pretty new to all of this...

Edit: I'm using a macbook pro, latest OS update, etc.

In reply to an earlier post on Dec 25, 2012 1:15:39 PM PST
L. Hawes says:
i am having the exact same issue...

Posted on Dec 25, 2012 1:40:55 PM PST
I cannot get my MacBook Pro or my Mac (desktop) to recognize my Kindle Fire. I have tried using different cords, restarting both computers and the device, and nothing. I'm getting frustrated. Someone help?!?

In reply to an earlier post on Dec 25, 2012 5:30:16 PM PST
PJinCali says:
I have a brand new Windows 7 machine and i can't get it to recognize my Kindle Fire HD, either. I like my Kindle but I will take it back and get something else if there's no fix.

Posted on Mar 4, 2013 12:12:49 PM PST
this sucks windows need to recognize i have logged off and on and nothing enough is enough!

Posted on Mar 5, 2013 7:12:37 AM PST
Alan says:
The following link gives instructions with some additional links to get connectivity with your computer:

I can't speak for Mac or Windows, but Linux is working fine here following the instructions on the link page.

For those using Ubuntu Linux, here is what I did to get it working:

Follow the instructions for the following link:

It requires you to download the source for the MTP library and then to compile it and to also install the gMTP client (this program that will display a file explorer type window). You can follow the directions to get the gMTP client or simply get it from the Ubuntu Software Center. If any of this is confusing just ask for help and I will be happy to answer any questions if I can. The procedure may seem complicated, but really is quite easy.

One caveat, after starting gMTP, be prepared to wait awhile (a long while - a minute or two) for the program to display the Fire file system. I spent the better part of a day chasing down a problem that didn't exist (I thought the Fire was not recognized) - I just didn't know to wait for the Fire to be fully recognized.

In reply to an earlier post on Mar 5, 2013 10:10:01 AM PST
Last edited by the author on Mar 5, 2013 10:10:17 AM PST
ThePrince says:
1) What rickh57 said: Mac users need to install a free app, Android File Transfer, to complete a USB transfer. Visit and follow the onscreen instructions.

2) What Alan said: You'll have to wait.

My Kindle Fire HD sometimes takes 2-3 minutes until it shows up. Kindle Fire 2 and Kindle Fire HD 8.9" show up instantly.

3) Sometimes your folders won't show up. Just wait and if they don't show up then go in and out of the 'Internal Storage' folder. If that doesn't work plug in and out.


MTP Support is included in the latest version of Media Player for Windows. So update Media Player if you don't see it working.

Between my Windows 7 PC and my Windows 8 PC I have almost 25% of the time some folders not show up. It was just a bad choice to use MTP file protocol.

- switch11 @

Posted on Mar 12, 2013 5:07:54 AM PDT
I own a PC, so I don't know how the two relate, but I had to do this. My Kindle would charge, but would not allow anything to be DLed into it or show on a computer. doing this does not harm anything, it just makes Kindle say hello again.

Delete the ADB driver to allow it to reinstall.

Plug in your kindle.
Hold down the windows key on your keyboard, then, with the windows key held, tap the "R" key.
This will bring up a Run dialog.
Type in devmgmt.msc then press <enter>

This will open the Device Manager
Locate something titled Android Phone.
Windows XP, click the [+] sign preceding Android Phone.
Windows Vista/7, click the [>] sign preceding Android Phone.
Right-Click the device listed below it, choose Properties.
Click on the Drivers tab at the top.
Click Uninstall Driver.

Now, unplug your Kindle Fire and plug it back in.

---I'm sure, even if different, the elements of what to do are there

Posted on Apr 13, 2014 7:30:50 AM PDT
Veronica says:
I have tried every solutions as suggested and still my computer will not recognize my kindle fire hd. I am using the brand new cable that came with my replacement kindle since my original was not charging or holding a charge!!!!! None of the steps described work to get my Windows XP Computer to recognize the Kindle. I need suggestions to resolve this issue!!!! Kindle does my no good at all if i cannot get my pc to recognize it!!!!!

Posted on Apr 13, 2014 2:22:23 PM PDT
Alan says:
You may need to upgrade your version of Windows Media Player. Check out the following link:

In reply to an earlier post on Aug 18, 2015 3:48:30 PM PDT
Ladybird says:
Using Windows 10 and Fire First Generation. NOTHING will get my compouter to recognize the Fire. N.O.T.H.I.N.G. From net-surfing, I gather that this has been a terrible, serious, ongoing, infuriating problem completely unaddressed by Amazon. Holy Toledo! What is this - Apple? Very, very disgusted.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum


This discussion

Discussion in:  Kindle forum
Participants:  12
Total posts:  15
Initial post:  Sep 21, 2012
Latest post:  Aug 18, 2015

New! Receive e-mail when new posts are made.
Tracked by 6 customers

Search Customer Discussions