Your Garage botysf16 Amazon Fashion Learn more nav_sap_plcc_ascpsc Adele Fire TV Stick Sun Care Patriotic Picks Shop-by-Room Amazon Cash Back Offer AnnedroidsS3 AnnedroidsS3 AnnedroidsS3  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis Segway miniPro
Customer Discussions > Kindle forum

Cannot connect to Appstore on Kindle fire?

Sort: Oldest first | Newest first
Showing 1-25 of 100 posts in this discussion
Initial post: Mar 31, 2012 11:03:59 PM PDT
Mrs. B says:
I have tried repeatedly to go to the appstore on my kindle fire and all i get is the orange circle that goes round and round. I have internet so no problem there. All my applications have been cleared from data and in the cache. Anyone else having this problem?

In reply to an earlier post on Mar 31, 2012 11:07:57 PM PDT
v. vincent - I saw some posts earlier that people were having trouble buying apps from their Fires and on the website. Amazon may be having server problems. I do know they are doing some updates to their website so that could be it.

In reply to an earlier post on Mar 31, 2012 11:10:25 PM PDT
Q says:
No, sorry. My Fire opens the app store easily. Not sure why yours is doing that.

I would have thought it meant you have an internet issue, but if I turn off the wireless card and go to the app store, it does the orange circle and then tells me it has "No Internet Connection".

I would try two quick things:
* Reboot your router by unplugging it, wait one minute and then plug it in again. It may take a few minutes to fully reboot)

* Reboot your Fire. Do this by pressing and HOLDING IN the power switch for a full 30 sec. Then release it and press the power switch again to restart it.

Once both are fully rebooted, turn on your Fire's wireless, connect to your network and try to access the app store again.

Posted on Mar 31, 2012 11:11:40 PM PDT
Mrs. B says:
Their problem was authenticating though. Mine has been happening for over a week, I just didnt think anything of it till now. I cant even see the apps to try to buy them. I just have the loading orange circle that goes round and round forever.

In reply to an earlier post on Mar 31, 2012 11:14:07 PM PDT
Q says:
Can you try my two quick suggestions any way? It wouldn't take over 10 min and will satisfy my curiosity... and maybe help you.

Posted on Mar 31, 2012 11:14:50 PM PDT
Mrs. B says:
Q- How could my laptop, which runs on my wireless, work and not the kindle? I rebooted the kindle and still nada.

Posted on Mar 31, 2012 11:32:57 PM PDT
Mrs. B says:
Ive also just realize that I downloaded 4 new books back on march 13 and they never made it to my kindle.

In reply to an earlier post on Mar 31, 2012 11:36:24 PM PDT
v. vincent -Many times everything will connect with your router perfectly except the Kindle. Rebooting the router by unplugging it for a minute often times helps. I've had it work for many people.

In reply to an earlier post on Mar 31, 2012 11:41:57 PM PDT
Q says:
I echo Pineapple's thoughts.

Posted on Apr 3, 2012 6:22:43 AM PDT
M. Hohe says:
I have been having the same problem and I have tried to connect to two different wifi sources. One is my University's internet so I do not think that the internet is the problem.

Posted on Apr 3, 2012 12:47:08 PM PDT
Mrs. B says:
I somehow got mine to work. I basically cleared out everything I wasnt using, almost back to factory settings and hit the sync button a lot and it worked. Weird :)

In reply to an earlier post on Jun 15, 2012 11:31:49 AM PDT
ray says:
i have tried both rebooting my router and my fire and still unable to open the app store

Posted on Jun 16, 2012 5:13:06 PM PDT
Tom Lucas says:
I had exactly the same problem as v. vincent stated earlier. I could access websites, such as google, yahoo (that means my wifi worked), but the kindle could not connect to the app store. I tried everything, but to no vail, only solved the problem by restoring to factory default. It happened after I upgraded to the newer version of kindle software early this year. I suspect there are some issue with the root certificates out of date for secure connections, as there were pop-up warning messages when I accessed some websites

In reply to an earlier post on Jun 18, 2012 11:57:23 PM PDT
elle d says:
How did you restore to the factory default? My kindle fire started doing this two days ago were the websites work but the apps and amazon app store does not work.

In reply to an earlier post on Jun 22, 2012 4:28:43 PM PDT
dd says:
I am too with my kindle fire

In reply to an earlier post on Jun 22, 2012 5:27:15 PM PDT
jsh1120 says:
elle d and dd,

Before restoring to the factory default (which will require you to reload and reconfigure a number of things), try clearing the cache and data from the Amazon Shop app.

Touch the grear icon (Settings) > More > Applications> All Applications > Amazon Shop

Then clear the cache and the data from the app. If it doesn't work, you won't be any worse off.

In reply to an earlier post on Jun 23, 2012 7:06:34 AM PDT
yes same problem

Posted on Jun 30, 2012 1:23:43 PM PDT
oooooooooooo says:
My son is having same problem. Two kindles in the house can access app store but his can't. We tried resetting kindle and clearing cache. Actually it said there was nothing to clear. Any other suggestions?

In reply to an earlier post on Jul 2, 2012 6:46:20 AM PDT
check the date and time on your fire. if it is off too much it won't connect to app store. set it to automatic time synch in the date and time settings

Posted on Jul 9, 2012 6:10:32 AM PDT
Changing the date and setting it to sync automatically cured it for us.

In reply to an earlier post on Jul 29, 2012 9:40:24 PM PDT
R.steptoe says:
Mine does the the the sames but a pop up comes and say CANNOT CONNECT TO APPSTORE.

In reply to an earlier post on Aug 3, 2012 6:11:42 AM PDT
G. A. Lust says:
Thanks RRVaughan and Sherri Berman. in my case, I had this problem for months ... and I have change date to sync automatically, and now it works!!!!!!

In reply to an earlier post on Aug 27, 2012 9:50:56 AM PDT
Tom Kuczwara says:
Force close amazon app store and clear the app data. This should reset the app store. You will have to put in your login information in order to reset the app store connections.

Posted on Sep 30, 2012 7:56:45 PM PDT
Jaime Haight says:
Setting the dat/time to auto sync and making sure the time zone was correct did the trick for me! Thank You RR Vaughan

In reply to an earlier post on Oct 13, 2012 10:03:50 AM PDT
C. Matheson says:
I was having the same issue resetting the date and time worked like a charm THANK U... and my daughter thank u too she was positively distraught!
‹ Previous 1 2 3 4 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
my kindle won't connect via USB from my PC 27 47 minutes ago
Discounted / Price Dropped Kindle eBooks III 9558 1 hour ago
June Informal Poll -- What are you reading? 199 1 hour ago
Australian/Kiwi kindle users thread #4 - "the BBQ" 6646 1 hour ago
Kindle Fire Battery Overheating 26 1 hour ago
Which Kindle Voyage font shows the most text per page 2 1 hour ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 1698 2 hours ago
Kindle Unlimited 15 2 hours ago
Kindle Fire charging port getting loose 1350 2 hours ago
how do i find the total number of books on my kindle fire 1 2 hours ago

This discussion

Discussion in:  Kindle forum
Participants:  80
Total posts:  100
Initial post:  Mar 31, 2012
Latest post:  Apr 30, 2016

New! Receive e-mail when new posts are made.
Tracked by 18 customers

Search Customer Discussions