Customer Discussions > Kindle forum

Kindle Fire: Web browser will not open.


Sort: Oldest first | Newest first
Showing 1-25 of 154 posts in this discussion
Posted on Jul 28, 2014 5:29:23 PM PDT
K. Cole says:
I'm not sure that I am having the same problem as the others but I'm hoping you can help. I have a Kindle Fire HD and when I go to Shop or to Apps and then Store, it just goes back to the carousel. If we follow the steps above, will we lose all of our progress in our games?

Posted on May 24, 2014 1:38:35 AM PDT
Cau Ju says:
I own a Kindle HD 8.9 which now i bring to Indonesia. I have to stay in Indonesia for the next one year before return to USA. Is there anyway I can buy apps from Amazon? Please help, I am bore!

In reply to an earlier post on Oct 21, 2013 11:13:10 AM PDT
Dara Burns says:
I just got my kindle fire and the browser does not work. I tried to do the above instructions and my device did not allow me to open my browser options inside the application options inside more. It just sent me back to more settings page.

Posted on Oct 13, 2013 1:07:15 AM PDT
otessa63 says:
The above instructions are not working for me. I have the Kindle Fire HD 8.9. I am still not able to access the web to search for anything. The web browser has not worked since I had my Kindle encrypted at work to receive m work emails. Is this why the browser will not work? Is there a way to fix this AND keep the encryption so I can receive my work emails? Many thanks; not being able to do web searches is highly disappointing for such an otherwise great piece of equipment.

In reply to an earlier post on Sep 5, 2013 7:26:30 PM PDT
KC says:
Thank you so much, my kindle is up and running.

Posted on Aug 27, 2013 6:42:58 PM PDT
[Deleted by the author on Aug 27, 2013 8:01:10 PM PDT]

Posted on Aug 17, 2013 8:51:35 PM PDT
This worked for me! Thank you!

Posted on Aug 16, 2013 11:18:46 PM PDT
i have a problem when i went on silk and loaded up google nothing happened i mean it said google in the website address but there was just a white screen and thats with all the websites please help

In reply to an earlier post on Aug 1, 2013 1:31:43 PM PDT
The reason it did not work is because you go to Gear wheel>Applications>Installed Applications>Silk then force stop. Hope this helps others like me that had issues getting this to work. Other than that this fix worked great!!

In reply to an earlier post on Jul 23, 2013 6:01:43 PM PDT
s. vaught says:
It worked! YAY.. Thank you very much!

In reply to an earlier post on Jul 23, 2013 6:01:19 PM PDT
s. vaught says:
It worked. Thank you!!!

Posted on Jul 20, 2013 2:26:34 PM PDT
Ok so this happened to me only with my app store but it didn't work, anyone got any ideas? My kindles only new so i don't have any apps at all. Please help

In reply to an earlier post on Jul 13, 2013 9:13:38 AM PDT
E. Muhlhause says:
This finally worked for me thanks

Posted on Jul 11, 2013 8:40:55 AM PDT
Nigel Brown says:
Thank you so much......I couldn't find the browser initially then realised the browser was actually 'Silk" so once I'd done that it worked perfectly...

In reply to an earlier post on Jul 7, 2013 10:58:07 AM PDT
Wasabi323 says:
Try shutting it down, after you do that hold the power button down for 30 seconds then let it turn on.

In reply to an earlier post on Jul 6, 2013 7:51:50 AM PDT
Renate says:
thanks so much, my husband just bought a kindle fire. 3 Years after I bought mine and his works a little different. I was able to correct the problem with the first step. Thanks Again !!!!

Posted on Jun 22, 2013 9:08:30 PM PDT
Last edited by the author on Jun 22, 2013 9:13:25 PM PDT
Mab says:
I have a kindle fire 8.9" HD and when I open the web tab, all I get is a black screen. All other web access such as shop and apps work fine from the internet but I cannot pull a browser page through the web tab. Interestingly though, when I exit the black screen, I can get a glimpse of the page I tried to pull up. Sometimes it even leaves a link on my carousel to the last web page I tried to access when the screen went black. I have tried to follow the instructions in the forum, but I cannot find a "gear wheel" anywhere on this kindle. Can anyone help?

In reply to an earlier post on Jun 19, 2013 2:05:24 PM PDT
belle says:
Yay! It works. You're a legend. Thank you :-)

Posted on Jun 17, 2013 4:13:25 PM PDT
Wasabi323 says:
I would suggest getting an apple product if you continue to have issues with kindles...that's what I did

In reply to an earlier post on Jun 4, 2013 9:11:19 PM PDT
Shante Banks says:
Thanx a million....Worked great!!!!

Posted on Apr 11, 2013 4:28:39 PM PDT
Wasabi323 says:
I dropped my kindle fire and it won't let me swipe the screen to get to the carousel or the home screen is it broken forever?

Posted on Mar 21, 2013 4:33:07 PM PDT
I have the new Kindle HD and my Silk browser hasn't worked for weeks. Frustrating to purchase the $500 version and only be able to use apps. I have gone through *all* of the steps listed above (cleared data under apps --> silk, cleared cache, stopped Silk from running, re-started 10+ times), but my Silk screen remains grey for some time before I receive the message "Silk is not responding. Would you like to close it?". What other option do I have? Waiting doesn't work. I would like to install a different browser, but I am unable to access the web to install a new browser. Can anyone help? Everything was fine until I had to encrypt my device in order to access corporate email. Is it the encryption + Silk combination? Thanks!

In reply to an earlier post on Feb 22, 2013 2:40:28 PM PST
Rustybird says:
you rock

In reply to an earlier post on Feb 22, 2013 1:55:16 PM PST
Rustybird says:
you rock

Posted on Feb 1, 2013 4:09:11 PM PST
Last edited by the author on Feb 1, 2013 4:18:00 PM PST
I have photos in my Kindle fire. I click on photo and it will not open. I just get the home setting. everything work but I receive a Kindle update and photo stop working. Should I do a reset and put pic. back in.
‹ Previous 1 2 3 4 5 6 7 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  124
Total posts:  154
Initial post:  Jan 1, 2012
Latest post:  3 days ago

New! Receive e-mail when new posts are made.
Tracked by 20 customers

Search Customer Discussions