Customer Discussions > Kindle forum

Unexpected failure with Silk


Sort: Oldest first | Newest first
Showing 1-13 of 13 posts in this discussion
In reply to an earlier post on Jul 8, 2013 5:59:58 AM PDT
I had the same problem, followed the given advice and...OK again. Thanks.

In reply to an earlier post on Feb 27, 2013 7:02:57 AM PST
Last edited by the author on Feb 27, 2013 7:04:37 AM PST
RLW says:
Pineapple, this fixed my problem!! Thank you!

Posted on Feb 26, 2013 6:45:33 AM PST
Just got my fire hd yesterday and had the same issue. Tried all the suggestions above with no success. Did a full factory reset and all is working now.

Posted on Feb 20, 2013 9:39:12 PM PST
None of the above worked for me. I ended up wiping my device.

One thing I noticed, I had accently setup my Kindle as English (UK) instead of English (USA). Might want to check your region settings, this is the only thing I changed after wiping my device.

Posted on Feb 10, 2013 6:24:15 AM PST
Kimber says:
I found one of the troubleshooting pages that said to hold down the power button for 20 seconds, then plug it in, then turn it back on.....and this fixed the issue for me!!!

Posted on Feb 7, 2013 9:04:50 PM PST
Last edited by the author on Feb 7, 2013 9:18:44 PM PST
Nietzsche says:
I just got my Kindle Fire HD today and opened silk for all of 1 minute, then closed it down. Got back home a few hours later and tried to use it and this unexpected restart thing started happening over and over again. I followed the directions but the issue is still there, and I can't access the internet through Silk... Any other suggestions before I throw my hands up in the air and give up on this silly little device?

Update:
Just was playing around with it, and the unexpected error message seems to pop up only when I open a new tab. I also figured out that none of the buttons on the bottom work except the home button AND the search button, which seems to override the error and allow you to browse however you want, but it is still EXTREMELY annoying to put up with the popup every time I want to open a new tab. Hopefully somebody will figure out how to fix it for the rest of us soon.

Posted on Jan 29, 2013 6:22:03 PM PST
Last edited by the author on Jan 29, 2013 8:05:17 PM PST
I'm having same issue with Silk. I cannot use it. Already cleared the data of Silk, re-started the device. No luck.
I also don't want to unregister the kindle. Will wait for some idea to fix it.

UPDATE:
Just fixed it. Looks like the key was to disable the option for "Page load Acceleration" (As *~*Pineapple*~* said)

In reply to an earlier post on Jan 29, 2013 2:12:55 PM PST
foxcry18 says:
I have done every step you have suggested and repeated 4 times, and yet it still doesn't work. Even tried restarting the kindle to insure setting took, but they didn't. Do you have any other suggestions without having to unregister the kindle and redoing it all over again?

In reply to an earlier post on Jan 28, 2013 3:48:49 PM PST
I downloaded a different browser - Dolphin which works fine.

Do a search on the forum for Dolphin.

In reply to an earlier post on Jan 28, 2013 3:18:46 PM PST
Nikola Tesla says:
I am having the same problem as Kevin.
There is no "storage" option on the HD 7"
the only options that exist are "general" "saved Data" and "advanced"
as I attempted to clear all data under the "saved Data" category, the message of "Unexpected Failure: Silk has unexpectedly stopped working and must be restarted" (this is the original message that occurs when trying to start up Silk) pops up, and no progress can be made. I have rebooted the Fire several times, and every time the same message pops up. Any help towards this problem would be greatly appreciated

In reply to an earlier post on Nov 7, 2012 4:26:44 AM PST
Hi I just bought the Kidle Fire HD did everything you mentioned but cant find the "Storage" "Clear data" option.. I cant basically use the device. It's showing the Unexpected failure message with every option I tried, downloading an app or opening an internet browser... HELP!

In reply to an earlier post on Sep 27, 2012 5:30:20 PM PDT
Kevin - I'm not sure what your problem is since you didn't tell us anything or ask a question, but you may benefit from resetting your browser:

* Go to your HOME page
* Swipe down from the top > More... > Applications > Installed Applications
* All Applications
* Scroll down to "Silk"
* Under "Storage", "Clear Data"

Nothing will be lost or harmed by doing this, though you will lose your browser bookmarks and passwords.

You will need to reset some things in your Web Settings after doing this.

* Open the Web browser
* Click on the Menu icon (garage door icon) on the bottom bar
* Settings
* Be sure JavaScript is still enabled
* Acceleration OFF

Initial post: Sep 27, 2012 5:27:51 PM PDT
Kindle Fire HD 7", Dolby Audio, Dual-Band Wi-Fi, 16 GB
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Announcement
Meet other story lovers at Write On by Kindle
60 6 days ago
Announcement
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 Feb 2, 2015
Wish List won't stay removed from favorites area 28 27 seconds ago
Fire stick drops network connection 790 55 seconds ago
forgot password for parent controls 146 1 minute ago
Kindle Paperwhite w/ larger screen? 56 3 minutes ago
Help! I bought a book but I can only access the sample! 10 5 minutes ago
Why do i need wifi and 3g 12 6 minutes ago
Australian/Kiwi kindle users thread #4 - "the BBQ" 3716 9 minutes ago
asphalt 8 update problem on Kindle Fire HDX 18 9 minutes ago
Kindle text to speech 99 13 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  13
Total posts:  13
Initial post:  Sep 27, 2012
Latest post:  Jul 8, 2013

New! Receive e-mail when new posts are made.
Tracked by 5 customers

Search Customer Discussions