Customer Discussions > Kindle forum

Fire Problem with Apps Stuck on "Installing"


Sort: Oldest first | Newest first
Showing 1-15 of 15 posts in this discussion
Initial post: Dec 7, 2011 5:24:34 PM PST
Amazon Support has been unable to solve this problem over the phone. It's been sent up the line and "hopefully I will hear from them soon by email." (their words).

I have successfully installed about 30 apps on my Fire, but since 3 days ago, I have been unable to install any apps. They download okay, but never fully install. In the notification area, I currently have 9 notices that the various apps are "Installing." No progress shows on the progress bar icons. I have done umpty-dozen hard restarts to no avail.

Presumably, I need to somehow "unstick" the installer process but can't figure out a way. Any ideas, please?

Other than this, the Fire works beautifully. All installed apps are working fine.

Thanks!

Lynda

Posted on Dec 7, 2011 5:31:23 PM PST
Last edited by the author on Dec 7, 2011 5:45:36 PM PST
J. Spotts says:
I'm guessing they had you try:
- A hard reset by holding the power button down for 20 seconds.

Maybe you could try reinstalling the same app that the installer got stuck on. Try to run it over the top. I'm guessing at this point, but I'm thinking in my head back to an issue I had uploading content when my computer internet connection would drop out. It stalled the uploader, until I tried reuploading the same file. Just a thought ... I've no where near the technical experience to explain how or why this worked for that situation. Maybe it will work in reverse for downloading and installing.

In reply to an earlier post on Dec 7, 2011 5:41:08 PM PST
Downloading works fine. I have complete downloading and web surfing success.

I did try reinstalling the first app where it got stuck, and now there are two instances (notifications) that it too is "Installing."

I'm really at a loss. I'm technically savvy and usually can figure most things out for myself.

Lynda

Posted on Dec 7, 2011 5:47:43 PM PST
I'm thinking that the problem is with your method of payment. My credit card associated with my Amazon account was stolen so I deactivated it, but I forgot to update the Amazon account. When I tried to purchase an app on the Kindle Fire, it seemed to purchase but crash on install. I validated with an email to technical support. A quick update on the Amazon account page and I was back in business.

In reply to an earlier post on Dec 7, 2011 5:50:44 PM PST
I've not made any changes to my credit card. The purchases go through (I get a $0.00 receipt by email) and the apps appear in my cloud. They download successfully and then get stuck on "Installing."

But thanks for the suggestion. It's worth keeping in mind for other issues.

Lynda

Posted on Dec 7, 2011 8:13:58 PM PST
Update:

Oddly enough, I find I can use my GetJar app to download and successfully install the EXACT SAME APPS that are stuck while "Installing." Anything I get from the Amazon Appstore will download but not install, but GetJar works. Go figure.

Lynda

Posted on Dec 7, 2011 8:47:09 PM PST
BookLover says:
I had this problem. This is what worked- select the settings gear, then more, then applications, then all. There are three Amazon apps with the phrase "app" in the name. I don't know which did the trick, but I cleared the cache and the data for each of the three. I may have also restarted the Fire. Anyhow, it did the trick. Good luck!

In reply to an earlier post on Dec 7, 2011 9:45:59 PM PST
deannah says:
Lynda, I had the exact same problem a couple of days ago. I cleared the data from the app store by clicking on the gear, then more, then applications and chose ALL applications. Found the app store application, cleared the DATA and the CACHE. Had a warning message but ignored. All worked properly after that.

Not sure if it was a faulty app install or what, but that was the cure. Good luck.

In reply to an earlier post on Dec 7, 2011 10:26:09 PM PST
Last edited by the author on Dec 7, 2011 10:57:17 PM PST
Q says:
Lynda,
I had this problem yesterday. I think it was because I tried to download and install too many apps at once (like 15).

In the end, I plugged the Fire into my PC and copied over all of the Fire's contents. Then I reset the Fire back to factory settings: upper right Cog Wheel>More... (Settings)>Device>Reset to Factory Defaults.

This wipes the Fire and makes it as it was out of the box (except the updates stay installed). Then I reregistered it online. Then I plugged it back into the PC and copied back my /Books, /Documents & /Downloads folders.

I think it is running even faster now. I redownloaded my apps (though one at a time now.) All is well. The reset, reregistering & recopying back the book & doc folder all went very quickly. Glad I did it.

In reply to an earlier post on Dec 7, 2011 10:41:40 PM PST
Booklover and Deannah,

It worked! I cleared the data and cache for the Amazon App and Amazon Appstore, and suddenly--boom, boom, boom--15 apps installed right after one another!

THANKS SO MUCH!

Lynda

Posted on Dec 7, 2011 11:04:21 PM PST
great.

Just as an explanation for other people who run into this problem.

This is probably because there is a fixed amount of space for apps and you run out of it. So when you clear the data and cache for those two apps - you free up space.

Also, if that step doesn't work for you - you could just delete the data for other apps or even delete some of the big apps and it would work.

In reply to an earlier post on Dec 8, 2011 6:58:07 AM PST
Last edited by the author on Dec 8, 2011 6:59:11 AM PST
Worked perfect!!!

Posted on Dec 8, 2011 8:24:11 AM PST
Ernie says:
There is no fixed amount of space for apps. beyond the 8gb of flash drive.
Cached data can do this - prevents installation of apps.

Posted on Dec 8, 2011 8:53:58 AM PST
Midnight763 says:
Wow thanks - I was unable to install Angry birds seasons due to a problem with an old version - and these tips clearing the cash allowed it to install .... so happy now.

In reply to an earlier post on Dec 9, 2011 1:43:40 PM PST
Sweet! Thanks! My problem started at the same time and this definitely fixed it, yay!
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  11
Total posts:  15
Initial post:  Dec 7, 2011
Latest post:  Dec 9, 2011

New! Receive e-mail when new posts are made.
Tracked by 4 customers

Search Customer Discussions