Customer Discussions > Kindle forum

Can' t get selections to open in Kindle store on Fire HD since yesterday

Sort: Oldest first | Newest first
Showing 1-5 of 5 posts in this discussion
Initial post: Dec 22, 2012 9:51:59 AM PST
Jenny Wren says:
When I click on selections in the Kindle Shop, they only open sometimes. I've tried a variety, free and paid, books and apps. I can' t see a pattern and have tried turning it off and on again. I' ve had the Fire for a couple of weeks. Do I need to try resetting it to factory settings? Any and all advice is welcome. Thanks.

Posted on Dec 22, 2012 11:03:19 AM PST
Fud53 says:
My advice to all owners is to contact amazon when they have an issue...seems a bit obvious...

Posted on Dec 22, 2012 11:32:07 AM PST
Last edited by the author on Dec 22, 2012 11:33:54 AM PST
Arual says:
Jenny, resetting it to factory settings should be a last resort, because then you'd have to reload everything. Try doing a reboot first: Fully charge your Fire, then unplug it. Press and hold the on/off switch for a full thirty seconds. (Time it! And ignore what the screen says.) Then turn it on again and wait for it to come back to life.

I've heard the advice of de-registering it and then re-registering it, but I don't know if that applies to e-ink Kindles only. But it wouldn't hurt, I suppose...

If these don't work, get in contact with Kindle Support. Click "Help" on the top of this page, then "Contact Us" on the right.

In reply to an earlier post on Dec 22, 2012 12:06:37 PM PST
Jenny Wren says:
Thanks, Arual. I will try that when I recharge it again. I wasn't sure if I could get a good Kindle rep over the weekend so I thought I would ask here first. I used to hang out on these forums a lot in the past so I know how helpful you all are in a pinch.
I did try a hard reset a little while ago. It did not take a full 30 seconds for it to shut down. Barely half that. Should I wait a full 30 anyway when I try it later? I'll post back tomorrow if it works and trying calling customer service later if it doesn't. Anyway, I was able to get to a book I was trying to download and it worked fine but then it stopped letting me choose books and the page-back arrow wouldn't respond either. I'm wondering if it's the app, as everything else seems to be working fine.
Again. Thank you. :)

Posted on Dec 22, 2012 12:15:30 PM PST
Last edited by the author on Dec 22, 2012 12:17:08 PM PST
Arual says:
Glitches are irritating, aren't they?

Regarding the thirty second thing, yes, do wait that long. It's the difference between just shutting the Fire down versus rebooting it.

I hope that fixes things. Otherwise, Kindle Support is wonderful. They'll take care of everything.

Merry Christmas to ya.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in


This discussion

Discussion in:  Kindle forum
Participants:  3
Total posts:  5
Initial post:  Dec 22, 2012
Latest post:  Dec 22, 2012

New! Receive e-mail when new posts are made.
Tracked by 1 customer

Search Customer Discussions