Your Garage botysf16 Amazon Fashion Learn more nav_sap_plcc_ascpsc Maxwell Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro
Customer Discussions > Kindle forum

netflix not working kindle fire

Sort: Oldest first | Newest first
Showing 51-75 of 189 posts in this discussion
Posted on Sep 18, 2012 5:23:38 AM PDT
Mary says:
Well you could contact amazon directly and met them know instead of waiting for them to see this thread. Mary

In reply to an earlier post on Sep 18, 2012 1:45:50 PM PDT
Chris B. says:
That's exactly what it's doing to me as well...

Posted on Sep 18, 2012 1:54:11 PM PDT
Last edited by the author on Sep 18, 2012 1:55:10 PM PDT
Mary says:
Wow I wonder what's going on. Was gloomy and rainy all day here so I sepnt most of the day watching netflix on my fire and it was flawless. I wonder if the netflix update goofed up some people. Mary

Posted on Sep 18, 2012 2:04:29 PM PDT
J blodgett says:
Believe me, I have. I get the same generic response every time. Even though I've reported directly to amazon month-old problems, month-old problems are still plaguing my experience. I just get the feeling fixing the problems aren't a priority for them.

Posted on Sep 18, 2012 2:14:24 PM PDT
Mary says:
Maybe try contacting netflix, could be on there end. I have used netflix on my fire from day one and no issues unless of course I use hotel wifi and they have a cruddy connection but even away from home most times it good and perfect at home with my high speed connection. Have you tried clearing out the cache for the app? Mary

Posted on Sep 18, 2012 2:49:40 PM PDT
Google "Netflix streaming problems" and you'll see that the problems aren't limited to the Fire.

I use Netflix nearly every day on my Fire. I've only had an issue once. I was outside on the patio. I rebooted the Fire and everything has been fine since.

In reply to an earlier post on Sep 18, 2012 4:34:11 PM PDT
JustMe says:
I too use Netflix nearly every day. Occasionally it is a bit 'rough' so I reboot my Fire and it is fine again. I suspect some apps may not 'play nice' w/ the Fire's memory (especially now that 'everyone' is jumping on the make an app bandwagon) and if you never shut it off (I don't) things may get gunked up. I suspect if they surveyed everyone with issues about what apps they have as well as how full their Fire's are etc. there would be some commonalities between the people w/ issues.

Posted on Oct 1, 2012 8:05:07 PM PDT
Mikah says:
I've been having this issue for months...haven't been able to use Netflix.
I have done everything(but dance naked in front of it) and it still won't work.
I opened the APP and it immediately froze after I tried to search for something to watch.

Maybe it's trying to tell us we watch too much TV & need to get outside more??
Who knows.

Posted on Oct 2, 2012 6:48:20 AM PDT
[Deleted by the author on Oct 2, 2012 6:48:37 AM PDT]

Posted on Oct 24, 2012 11:22:43 PM PDT
Joe says:
I've been watching netflix via the netflix app since the beginning of the year on my Kindle. All of a sudden, as of Tuesday, I'm not able to watch movies. The app allows me to browse and select a movie, but it just displays "loading" and times out with the following error message - Sorry we could not reach the Netlix service. Please try again later. If problem persist.... (0041). Error code 0041 on the netflix website = Netflix is not supported on this device. Please check the Netflix website for a list of supported devices (0041). I tried uninstalling the app, verifying that the kindle has the current software updates, etc. Netflix streams to my two windows laptops, my android tablet and my blu ray player. I am left to conclude that this issue has something to do with tablet and application wars. Amazon has a streaming movie business, Amazon Prime, so maybe they've decided to stop allowing it's streaming competitor (Netflix) access to it's device and customers.

In reply to an earlier post on Oct 25, 2012 5:00:40 AM PDT
jsh1120 says:

No problem here. Netflix works fine on both my first gen KF and my KFHD.

Posted on Oct 29, 2012 8:12:01 PM PDT
I have very fast wifi and my netflix app on the fire doesn't work. It was working okay for awhile, not great, but okay. It was slow as heck to get going but it at least did get going. Now it loads the selection screen but encounters problems when I actually try to watch something. I've removed it from the Kindle Fire and re-installed it, but to no avail. So far, it's turning out to be a horrible app, just for it's slow loading alone, not to mention the fact that it doesn't even want to play the movies. HBO Go works fine, why can't they get this app right? Must be extremely difficult.

Posted on Oct 29, 2012 8:20:32 PM PDT
Mary says:
Still no problem here and I use netflix every night on my fire. Have been using it since I got my fire last January. Mary

In reply to an earlier post on Oct 29, 2012 8:36:04 PM PDT
Same here, except for the one time I mentioned above, and I've had my Fire since last November.

Posted on Nov 3, 2012 6:16:47 PM PDT
S. Solloway says:
Both of my Fire's have the same problem as Joe describes, error 0041. They were both purchased last Christmas (2011) and Netflix was working fine then stopped. I wonder what is going on.

In reply to an earlier post on Nov 3, 2012 6:24:50 PM PDT
Reboot your router

Posted on Nov 3, 2012 7:29:21 PM PDT
Mary says:
That's what I would try is a router reboot. Every one I know that got a fire after Christmas like me and uses netflix is not having this problem so I don't know what to make of this. Mary

Posted on Nov 4, 2012 8:25:13 AM PST
S. Solloway says:
OK. I rebooted the router and it still doesn't work. I uninstalled and reinstalled the app, no go. I can wirelessly stream Netflix to my TV, my Wii, my laptop with no issues. There are no other connectivity issues with the Fire - even Netflix quickly updates my recently watched shows, it just will not play them. I then grabbed another open wireless connection that was available and am getting the same error. It does not seem to be network related. Off to customer service to see if the issue can be resolved.

Posted on Nov 4, 2012 10:01:03 AM PST
Mary says:
Post back if you figure it out. Mary

In reply to an earlier post on Nov 4, 2012 10:13:28 AM PST
JustMe says:
If it's not a router issue, I still wonder if it's either an issue with the Fire being nearly 'full' or an app it doesn't play nice with. For those for whom it 'used to work' but now it doesn't, you might want to see what app's you've added in between and maybe try deleting them (they're still in the Cloud, so you can always put them back) and of course try shutting down and restarting the Fire. I use Netflix on my Fire nearly daily without issue, there has to be some commonality between those who can't get it to work.

Posted on Nov 4, 2012 4:58:49 PM PST
Lena B. Ross says:
I am having the same issue with my kindle fire. Has anyone had any luck solving the problem?

Posted on Nov 4, 2012 5:42:13 PM PST
Reboot your router.

If you know how, set your Fire to a static IP address

In reply to an earlier post on Nov 5, 2012 6:40:50 AM PST
S. Solloway says:
I have static IP addresses setup for my Fires and have since I got them. The router reboot changed nothing. I'm curious, is it possible for the router to be restricting Netflix streaming through the Fire while allowing it through the Wii, TV, laptop (all wirelessly)? I haven't changed any router or Fire settings. I do need to find some time to call Netflix and/or Amazon to get it worked out.

In reply to an earlier post on Nov 5, 2012 6:54:27 AM PST
jsh1120 says:
S. Solloway,

As you can see, many of us have no problems with Netflix (me included) so we're troubleshooting in the dark here. I'm wondering if it's somehow related to the number of or specific other Netflix-enabled devices one has, one is actively using, or has used recently. I know nothing about Netflix' internals either on the client or server side but I can imagine that multiple connections (even if not active) may trigger the bug.

In reply to an earlier post on Nov 5, 2012 6:58:56 AM PST
S. Solloway says:
I was wondering the same thing and why I plan on talking to Netflix first. I will update after I talk to them.
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum


This discussion

Discussion in:  Kindle forum
Participants:  78
Total posts:  189
Initial post:  May 17, 2012
Latest post:  Mar 9, 2016

New! Receive e-mail when new posts are made.
Tracked by 30 customers

Search Customer Discussions