Customer Discussions > Kindle forum

Problems w/ WiFi connection on Kindle Fire?


Sort: Oldest first | Newest first
Showing 726-750 of 886 posts in this discussion
Posted on Dec 24, 2012 1:45:51 AM PST
[Deleted by the author on Dec 24, 2012 1:57:15 AM PST]

Posted on Dec 24, 2012 1:57:36 AM PST
T.B.S. says:
We got two Fires for the kids for Christmas. One connected to the wifi and registered immediately, the other one shows the x and won't connect at all.
After playing with the one that did connect and reading all the posts here I'm getting them Nexus tablets instead. My Nexus runs an Amazon app for when I want it but overall is much more robust and much less restricted. Also - why does Amazon charge for apps that I've gotten for free on Google Play?

Posted on Dec 24, 2012 8:09:49 AM PST
From what I understand about WIFI connection.
There has been an update on the communications signal and yes I had to update my Router as well.
The other is depending on what type of Router you have you may not be able to handle more than one device on the Router?? Not too sure about that, but it si true with my Router.
Also I agree....get a Nexus I'm thinking about doing that next year 2014 Christmas either that or a laptop hybrid with a tablet screen like the HP Envoy by then they should have more models like that out in the market place.

In reply to an earlier post on Dec 24, 2012 6:14:45 PM PST
I have the exact same problem. Please help. Just got this for my husband for Christmas, would like him to be able to use it.

Posted on Dec 25, 2012 1:49:19 PM PST
Me and my mom both got kindle fires for Christmas. The WiFi kept nit letting it connect. I've come to realize only ONE will connect if nothing else is connected to the WiFi, including my laptop. So how do I fix this? My router is definitely able to handle multiple connections (we`'ve had at least 3 laptops connected at once). So any ideas??

Posted on Dec 26, 2012 8:05:59 AM PST
Mrsaurora says:
I have had my KF for a year, I bought it just before Christmas '11. It has always worked fine on my home WiFi. Something happened and all of a sudden, I'm not able to access my home WiFi. I would get the little x next to the signal strength. I messed with settings for several days. After getting on here and trying several of the "fixes" I turned the static IP address off. It connected immediately. To do this I went to the list of available WiFi networks, scrolled down to "Advanced Settings", turned off the "Use static IP". Hope this helps someone.

Posted on Dec 26, 2012 8:16:27 AM PST
[Deleted by the author on Dec 27, 2012 4:32:57 AM PST]

Posted on Dec 26, 2012 10:41:14 AM PST
I have had nothing but problems with my Kindle Fire since the day I got it. In fact, Amazon has replaced it once, and it still has the same problems. I've called Amazon support at least five times, and get nothing except they walk me through powering everything down and then back up, and about half the time, that makes the Fire work for about an evening, but then the next day, it won't connect again. This has been a whole year, and it's very frustrating. Amazon support is helpful, but they can't do anything to really fix the problem.

Posted on Dec 26, 2012 2:00:21 PM PST
i had similar problems when i first got my fire about year ago. I bought a new router cisco valet plus. setup guest capabilities and use my kindle fire as a guest. i have not had problem since. i don't what the problem is but i'm sure the protocol the KF uses has some kind of flaw? Next time i upgrade i will switch to something like the nexus or ....>>>?????

Fred

In reply to an earlier post on Dec 26, 2012 3:13:47 PM PST
Deborah, I read your post and I found very little sympathy for the people having problems. You can't really expect people to like being characterized as conspiracy theorists. I found this thread because a year later, the Kindle Fire I got last Christmas is now doing exactly what others are describing. I have three other wireless devices in my house that are working fine, but the WiFi on my KF has gone crazy. Bear in mind the number of people actually posting complaints and questions is only PART of the population that is affected. Many others are simply reading to find a solution.

It seems obvious at this point that this KF does indeed have WiFi issues. The customers do not have bad routers or psychiatric problems. They should not have to return one Kindle after another, do Google searches or read your lengthy, unkind, and unhelpful comments.

And please: do not get snippy with people who are understandably frustrated, then wish them "peace and joy."

In reply to an earlier post on Dec 26, 2012 3:17:02 PM PST
Mine worked fine for a while. Then the battery began to drain because the device kept turning on the WiFi after I had turned it off and put the device to sleep. Now the WiFi is very hard to get connected, and it's even harder to keep it connected. Every other wireless device in the house works. You're a bit of a know-it-all.

Posted on Dec 27, 2012 4:56:35 PM PST
D Mohr says:
I had not been able to connect my new Kindle Fire HD 8.9 to our wireless system since we received it for Christmas. So frustrating! But, after researching how to add some of the workarounds suggested here (MAC filtering, Static IP, etc.), I realized that our DLink Router 624 received years ago when we installed Verizon FIOS Internet was last updated in 2005 and was obsolete. Verizon calls us "First Generation" and we were early adopters when they first initiated service in our area. A quick trip to the Verizon store with our old router and modem and a quick install of the brand new one has my Kindle and my internet humming along. So glad I did not return it and worked through the real problem - the old router.

Posted on Dec 28, 2012 5:45:11 PM PST
Last edited by the author on Dec 28, 2012 5:46:28 PM PST
Shar E. says:
So here is the bottomline... And someone needs to tell Amazon Kindle this... A TON of these will get returned for a Droid Tablet or something else because there are waaaaaaay too many threads/issues related to simply connecting to wi-fi. Its 2012 -- not 1913 -- there should not be ALL these explanations (stand on your head... jump up and down 20 times, etc...) just to connect to Wi-Fi in 2012. Amazon, you have one time to help me fix this and if I cannt get it t work -- its getting returned and we will get a Droid tablet! Day 5 and I STILL cannot even register this stupid device -- let alone use it! I am not a fan at all!!!!! PISSED off new Kindle owner!

Posted on Dec 28, 2012 9:19:46 PM PST
We are having the same problem with a new Kindle Fire we got for Christmas. However, we also have the same problem on a new Windows 8 laptop. If we turn on the Wi-Fi on the Kindle Fire, it immediately shuts down the connection that our router has with all other devices and it also does not allow a connection to the Kindle Fire. Ditto for the Windows 8 laptop; if we turn on the Wi-Fi adapter on the Windows 8 laptop, it immediately shuts down the connection that our router has with all other devices and it also does not allow a connection. I know that our router is "older"; TRENDnet TEW-432BPR w/ latest firmware. I've tried messing with WEP, WPA, PSK, EAP, TKIP, AES, Auto, MAC addresses, etc.

So, we are getting the same behavior on a Windows 8 laptop that we are getting with a new Kindle Fire.

In reply to an earlier post on Dec 29, 2012 7:40:56 AM PST
When I first got my KF last year, I had very poor and a spotty connection. I went by an electronics place in a flea market, so decided to "pick the brain" of an employee. When he asked, I told him I had a Linsky's router. He asked what model it was, and I said I did not know, but it was about 5 years old. He said I needed the latest model, and that being the "N" mode. I went home and found I had a "G" model. I then bought an "N" model, and found I now had a much better connection to my KF, with few, if any, "drops". I have no problem with my Windows 7 connection, either, on my laptop. Get the newest, most upgraded wireless router. You can always sell the old one to a newbie geek.

In reply to an earlier post on Dec 29, 2012 7:45:56 AM PST
email Amazon. They have a great support person. They might even ask you to call them back on the phone. Also, make sure you hold your KF with the antenna end up, not buried or resting on your stomach.(I figured out that myself...the antenna end being the end opposite the plug end). Also, I found it does not have much of a range, unless you are in an area with a big wi-fi setup. I use mine only in my home. The closer I am to my Linskys, the better the coneection.

Posted on Dec 29, 2012 9:58:29 AM PST
s glidewe says:
I have a Linksys E1200 router. What is a router with a greater range; does anyone have a suggestion. Also I now have an Ipad and have had no problem at all with losing my wi fi connection. It is defintely something to do with the Kindle Fire. I still have my Kindle but am using the Ipad more and more because of the connection problems. Would never have bought an Ipad if I werent having all connection problems with the KFire. Fire did everything I wanted it to do but what good is that if you keep losing your wi fi connections. Amazon needs to come up with a fix or they will start losing customers for the Fire.

Posted on Dec 29, 2012 12:50:11 PM PST
Hi says:
I don't get it... I've completely unlocked my home wifi ( NOT RECOMMENDED ), and I still can't get the fire to connect!

In reply to an earlier post on Dec 29, 2012 12:51:54 PM PST
The higher the letter in the router number, the stronget it, supposedly. I learned that from a flea market electronic store. I had a G router. Now, I have an N router, with better results.

In reply to an earlier post on Dec 29, 2012 12:53:41 PM PST
email amazon. Maybe they can help. They had mine all set up when it came in the mail to me. Maybe it is the fire that is locked, not the wifi. I see that can be done...to keep snoopers out.

Posted on Dec 30, 2012 5:42:36 PM PST
fishy says:
am i to believe that my ipod touch 4th gen has better wifi connectivity then a kindle fire hd? because ive never dropped wifi with the ipod, but i just dropped 5 times in 30 min with my kindle fire hd

In reply to an earlier post on Dec 30, 2012 8:18:24 PM PST
I've had an issue in a rental home where I can't change (or even power cycle) the router. I have a Kindle Fire (2011 model) & have never run into any connectivity issues until just now a year later, only at this rental house which has some kind of Comcast access point and wireless router.

Here's how I was able to solve it:

Selected in WiFi Adavnced settings which allows you to enter a static IP address, along with subnet mask, etc.

Using my Ipod Touch, gen 4, I could see the IP address and settings to enter into the Kindle.

Kindle connected to wirelesss AND internet fine.

I may need to undo this when I take it back to other places where it auto-connected without issue, but I think you can easily switch Static IP setting on and off.

Hope this helps-not sure if it's applicable to newer Kindle HD's, we didn't yet try our new one out.

Posted on Dec 30, 2012 8:35:31 PM PST
MajorYoshi says:
After reading through pages of discussions I think I may have resolved it for us, for now at least.

I was using an older WRT54G wireless access point with mixed mode on (B/G) and WPA2 security. Kindle has been used for nearly a year now streaming netflix without issue.

Picked up a new WAP today (Netgear EA4500 N900) and after installing, the Kindle would barely connect, wouldn't hold a connection, and if it did the speeds were horrible (Netlfix wouldn't work at all).

The KF is currently at 6.3.1, but since the problems happened immediately upon me installing the new WAP, that *had* to be the issue.

With each change below, I tested via opening a movie never watched on netflix (different movie after each change to ensure no buffering or anything else that could cause mixed results):

I tried a few different config changes. All of which were no good.
I then set everything to open (no security) and while I could connect, the picture was nearly unwatchable due to massive compression just to get the stream to work. No good.
I changed from Mixed mode to use only G on the 2.4 ghz band and N on the 5 ghz band (the N900 router has dual bands). Now the picture was actually pretty. Good start.
I turned security back on but set it specifically to WPA2 Personal instead of the WEP/WPA/WPA2 that was the default setting. Things are good after reconnecting.

So, it looks like it may have issues with some routers that are transmitting in mixed mode. None of the wireless devices I'm using are old enough to need the B band, so there's really no point in using it for me (and I'm betting for many of you too).

Good luck, hope this helps someone. At least it seems to help us so far.

In reply to an earlier post on Dec 31, 2012 10:25:06 AM PST
Thanks for your contribution, Major, but to be honest, I didn't understand much of it. I had to have a friend install my router for me and I have no idea how to change its configuration and would not want to try, for fear of making a real mess of things. I'm having no trouble with my router, except possibly for my KF, and that only started happening a few months ago (I've had it a year). Three other wireless devices all work fine, so as far as I'm concerned this is an Amazon/KF issue and they need to solve it. Complaints have been coming in for over a year, yet there has been no software update or official troubleshooting fix. Frustrating.

In reply to an earlier post on Dec 31, 2012 12:27:53 PM PST
Also having issues connecting with the wifi. As soon as kindle connects to router it "knocks out " the connection. This is the replacement product that amazon sent us. Will call support desk one last time in the morning before returning and getting money back! Not a happy customer of the company trying to be the best customer service company in the world!!!
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  510
Total posts:  886
Initial post:  Nov 15, 2011
Latest post:  Nov 17, 2014

New! Receive e-mail when new posts are made.
Tracked by 78 customers

Search Customer Discussions