Your Garage Best Books of the Month Amazon Fashion Learn more Discover it blink-182 Fire TV Stick Sun Care Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro
Customer Discussions > Kindle forum

Kindle Fire cannot connect to internet


Sort: Oldest first | Newest first
Showing 151-175 of 788 posts in this discussion
In reply to an earlier post on Nov 26, 2011 3:09:00 PM PST
Carbonbased says:
If I understand correctly, you will need to disable static IP address when out and about at a hotspot.

In reply to an earlier post on Nov 26, 2011 4:32:42 PM PST
A. Blanco says:
yes. i use a static ip at home for my secured network. when i go out to free networks i disable static ip on the kindle (located under advanced settings undr wi-fi) and all works fine.
it may not help if you want to access another secured network.

i think amazon went cheap on the wifi hardware, or flubbed the android os when modifying it to their hardware. they'll never admit it, but that has to be it.

In reply to an earlier post on Nov 26, 2011 10:35:12 PM PST
You are correct. My static IP address WAS disabled when it came to me. I could not connect to all hotspots. However, I went and disabled it again and was able to connect to a hotspot where I had not been able to get a wi fi connection. As everything else I had tried failed, I think this is the answer.

Posted on Nov 27, 2011 10:20:33 AM PST
Another suggestion is to see if your router manufacturer offers a firmware upgrade for your model. This is particularly important if you have an early, "pre-N" access point. See
http://www.zdnet.com/blog/networking/four-ways-to-get-the-most-from-your-80211n-wi-fi/122

In reply to an earlier post on Nov 27, 2011 10:55:40 AM PST
Last edited by the author on Nov 27, 2011 10:59:26 AM PST
Blue Lady says:
I have an att router and it was the same thing, I couldn't connect, I kept getting the message that the password was wrong. After finally listening to my daughter, and calling att, they showed me how to fix it. On the back of the router, the last 3 digits of the serial number is your wifi number and the number in parentheses, is the password. (without the parentheses) I spent a frustrating week trying to connect to the internet, once I found out how, it took 2 minutes!

Posted on Nov 27, 2011 11:48:46 AM PST
T. Anderson says:
My KF worked great for almost a week. No problems with wifi connections at all until last night , when all of the sudden, I started having the same issues as many here. very frustrating, because when it works it it pretty cool, but if it wont, Its pretty useless.

Posted on Nov 28, 2011 7:45:54 AM PST
Alison H says:
I'm able to connect to my home router with no issues whatsoever, HOWEVER, when I go to work to try to log into their wifi, it shows connected, but with the little 'x' by the signal strength. I've read through all the postings here, though I skimmed them, so I might have missed something, I've disabled the Static IP, and restared my KF many times. Still not truly connecting here at work. Suggestions?

Posted on Nov 28, 2011 8:07:12 AM PST
Alison H says:
I was able to turn off Wifi, and then turn it back on, then re-entered the password here at work, and it connected just fine. It seems I'm good to go now.

Posted on Nov 28, 2011 5:06:43 PM PST
R. Vlahos says:
Just got my Fire today - belated birthday present. I have 3 computers here on a strong wireless connection. This device simply does not connect. I am not ready to reconfigure my router and risk losing the other (essential) devices for one plaything. Amazon clearly did little homework in this area, and I am about ready to cut my losses.

In reply to an earlier post on Nov 28, 2011 5:35:51 PM PST
Keep trying. I couldn't connect my KF at first, but I kept trying. Try turning it off and then turn it on again. Also, someone else posted about the length of the network name having an effect on the connection. After I turned it off then on it connected fine to my network. I tried a billion times before then and kept having to put in my password. Finally it just connects. There is also an update to the firmware I believe.
Good luck. Mine works perfectly now. I just hate the home page where it shows everything that you were looking at to anyone who's interested.

In reply to an earlier post on Nov 29, 2011 4:36:06 AM PST
Sooz says:
Mine connected just fine and now that I'm enjoying it so much I'm glad it did. If it hadn't worked I would have sent it back. Try a few of the suggestions that have been posted or send it back for another. My daughter bought 2 and they connected without problems too. I had been reading all these posts expecting that when mine got here it wouldn't connect. I worry too much.

In reply to an earlier post on Nov 29, 2011 5:28:07 AM PST
Annemarie I have the same problem as you. I'm aol user to get on the internet. my kindlefire device connects to my wifi but not the internet from my home. I took it back to best buy and let the geek squad look at it but it worked fine there. I brought it home and still no internet. I still have that x on wifi to at my home. I also talked to kindle slupport and no help there either. René

Posted on Nov 29, 2011 4:00:35 PM PST
R. Vlahos says:
My last post was pretty negative: frustrated, unable to connect to my wireless network, after trying for about a half hour. I turned the darn thing off and went back to my pc. A couple hours later I turned the pc off and retired. Then, in bed I decided to give the fire one more shot. If not connect maybe play some kind of preloaded game. I turned it on and to my amazement it announced "connected." No problems since, even next to the connected pc. Might just keep it after all! :-)

Posted on Nov 29, 2011 4:14:47 PM PST
Richard.H says:
reset to factory default might solve this problem. I did it on my friend's fire and browser back to work.

In reply to an earlier post on Nov 29, 2011 4:30:30 PM PST
At some point in the last week I did the same. Turned it off, forgot it for a few hours, turned it on, and was connected. Has stayed that way since. Though I have not left the home connection to take it anywhere else lately.
Somehow this frustrates me more. It's like when your car won't run, then it starts again. You want to know why it didn't start so you can avoid it happening again! With a short time frame to return the Fire, I am hoping that it won't decide not to connect again after the fact. By the way, I am on a home access point in an apartment community where I can't mess with the router. So I did not reset, or change anything with the router.

Posted on Nov 29, 2011 5:18:43 PM PST
K. Powers says:
I was having the same issue of successfully connecting to my router but not being able to connect to the internet. the only place that I was not able to connect to the internet was from my home. So I went to a family member's where I could connect and instantly received the 6.1 upgrade. Upon coming home the Kindle fire connected to the router and the internet without issue. I didn't have to do anything. For those that can not connect to their routers call support to make sure your Kindle fire's serial number is in their database, that was the 1st issue i encountered.

Posted on Nov 29, 2011 7:06:36 PM PST
Amanda says:
My wifes KF had the same wifi connection issue. I went to the update page that has been mentioned on here and seen that they now have 6.2 out. I sideloaded it into the KF through my laptop computer. Update the KF with 6.2 and so far wifi is working great. I even downloaded and installed the Netflix app and played a movie through it. So far so good. Hopefully 6.2 will be the major fix for these issues. Time will tell.

In reply to an earlier post on Nov 30, 2011 5:10:42 AM PST
Jill says:
Check to see if your router has a password printer on the the device and try using that instead of your password.

Posted on Nov 30, 2011 3:46:49 PM PST
B. Rickard says:
I received my new Kindle Fire yesterday, and was able to connect to my office router and even a Boingo hotspot on a ferry, but in neither case would it connect to the Internet. Resetting the Kindle and the office router did not improve the results. When I tried to download the v6.2 system software from Amazon using my Windows 7 computer, the transfer never budged from 0% and eventually would time out.

Once at home, I was not even able to get an IP address on my home router until I supplied the full 26-character hexadecimal WEP key instead of the password/passphrase (I've only had to do this with Apple products previously; this is my first Android-based product). Although I was unaware of it, the Kindle then automatically downloaded the new system software, which it indicated it was installing when I plugged it in to charge overnight. Today when I turned it on at the office, it immediately connected to the Internet, which I attribute to having the new v6.2 software.

Hopefully some of this will help others.

In reply to an earlier post on Nov 30, 2011 5:50:52 PM PST
Did you ever resolve this? They have just opened a ticket for me because I drop my wireless signal when trying to watch video, and they could not get my log files either. Of course they had me try ;dm instead of your :dm so that might be the log problem there.

Posted on Dec 1, 2011 12:35:38 PM PST
Madden says:
Received my KF on Monday and like many others, was disappointed to find I couldn't get it connected to the internet. It got stuck on the whole 'acquiring IP address' thing and never connected even after hours of trying. After reading all the posts here about the router issue I decided to see if there was still a problem with the new router/internet service I was having installed the following day before I decided whether to send it back or not. Cable guy installed my new internet/router and had NO problems connecting the KF! I've had no issues with it since and have streamed video, music and played games with no connectivity problems. I haven't tested it in other localities outside of home yet though to see if I will have the same problem with a different router. I know this isn't a solution, but seems to re-enforce the thought that this is a router issue more than anything else and hopefully Amazon will come up with the solution here soon, because other than the connectivity problem this is a GREAT device.

In reply to an earlier post on Dec 2, 2011 7:28:52 PM PST
D. Woita says:
Thank you so much--this fixed my problem and a week's worth of frustration in less than 15 minutes!

Posted on Dec 3, 2011 7:17:20 AM PST
Vicki L says:
I tried one last thing I hadn't tried before that Arunangshu Sharma suggests on page 4 of this forum thread. I reset our router back to the default factory settings. From there, I reset the router's password to the one it had before and reset the security keyword to the one it had before. The only thing that appear to have permanently changed are the DNS settings. And now the KF works. It's worked for 9 hours with repeated checking during that time frame. Solid connection. So that may be the answer for some, I sure am glad Arunangshu Sharma posted the solution that worked for them.

Posted on Dec 3, 2011 11:44:47 AM PST
Last edited by the author on Dec 3, 2011 11:47:20 AM PST
CP Review says:
I had this problem: Kindle Fire connects to Wi-Fi, but cannot go to the Internet. Resetting (power cycling) of the router and the cable modem did not help. Update to the 6.2 firmware did not help either. Spent an hour on the phone with tech support - no result.

I suspected that something is wrong with DHCP. It's the protocol that tells new devices on the net where to go for Internet (gateway) and assigns them an IP address on the network so they can communicate. If something goes wrong with this process no Internet connection will be available. DHCP server (the router) keeps the records typically for a few days. So if something goes wrong between Kindle and the router chances are that there will be no connection on Kindle for a few days. On Windows you can fix this by "repairing" the connection. No such thing on Kindle. Many routers allow to delete the DHCP records of their clients. If this is the case - turn off Wi-Fi on Kindle, delete all DHCP records on the router and power cycle the router (just in case). When the router is up and running (few minutes after power-on to be sure). Turn on Wi-Fi on Kindle and cross your fingers. Worked for me.

Posted on Dec 5, 2011 10:30:35 AM PST
LarryB says:
REALLY glad I found this discussion. I've been having the problem where I can connect to wifi (Broadband router; Virgin Mobile 3G hotspot; and brand new 4G Verizon Droid Razr), but can't get Internet pages to load. Same with all 3 wifi connections. And all 3 wifis work with a notebook computer. I just checked and I already have 6.2 installed, so I guess I'll try calling customer support.
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Announcement
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
FREE Books and Chat - July 2016 20 6 minutes ago
Kindle on Windows 10: highlight problem in secondary display 4 8 minutes ago
Discounted / Price Dropped Kindle eBooks III 9583 15 minutes ago
Kindle Fire won't accept my wi fi password 106 20 minutes ago
SwagBucks Thread 2016 424 21 minutes ago
Australian/Kiwi kindle users thread #4 - "the BBQ" 6656 28 minutes ago
Volume control page turning for iOS 6 32 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 1914 42 minutes ago
Dragi's Croatian Crab Shack and Wine Bar - The Answers Are Blowing In The Wind 1376 43 minutes ago
A amount of 105.93 7 44 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  467
Total posts:  788
Initial post:  Nov 15, 2011
Latest post:  4 days ago

New! Receive e-mail when new posts are made.
Tracked by 85 customers

Search Customer Discussions