Your Garage Summer Reading Amazon Fashion Learn more nav_sap_plcc_ascpsc Melvins Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer WienerDog WienerDog WienerDog  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis Segway miniPro
Customer Discussions > Kindle forum

Can't find books on Kindle Fire after USB transfer?


Sort: Oldest first | Newest first
Showing 1-25 of 26 posts in this discussion
Initial post: Jan 17, 2012 10:08:59 AM PST
B.Smith says:
I followed Amazon's directions to a "T" on transferring a purchased Kindle book from my computer (I have Vista) to my Fire. However, it doesn't show up in my Kindle. I can find it on there in the E.S. File Explorer app, but it won't open as a book through there, and it doesn't show up in my library or anywhere else. Am I missing something? Surely it must be simple since Amazon gives no further instructions on how to find it on the Kindle, or troubleshooting on this aspect. Any help would be appreciated!

Thank you!

(we don't have wireless at home anymore so this is why I'm trying to figure out the USB thing)

In reply to an earlier post on Jan 17, 2012 10:11:29 AM PST
 nospin  says:
Did you look under documents?

Posted on Jan 17, 2012 10:13:04 AM PST
B.Smith says:
Yes, it doesn't show up there either.

Posted on Jan 17, 2012 10:15:28 AM PST
B.Smith says:
Maybe a stupid question, but does it have anything to do with the file type? On my computer, it shows the rest of my kindle books to be "PRC" files? But the one that I chose to "transfer via USB" shows as a "TPZ" file. Maybe that has nothing to do with it but since I don't understand that stuff, and that's the only difference I can see, I figured I'd ask!

Thanks again!

In reply to an earlier post on Jan 17, 2012 10:16:58 AM PST
 nospin  says:
I think you have hit the nail on the head, B. Smith.

People have posted instructions on removing tags using Calibre. I do not use it so cannot help.

Posted on Jan 17, 2012 10:19:02 AM PST
Which folder did you put it in?

Posted on Jan 17, 2012 10:20:32 AM PST
B.Smith says:
Nospin- Thank you! So if it doesn't work without modification, why does Amazon have it download that way and not instruct you on how to change it? Seems kind of silly to offer that option if it doesn't even work.

toasty- I've tried several different things. First I tried it in the books, then in the documents, then I just sent it there in general (not to any folder). Each time it showed up on the Kindle in the E.S. app, but never anywhere else where I could actually access it (books, documents, etc).

Posted on Jan 17, 2012 10:22:37 AM PST
art says:
Try rebooting the Fire. I have found that necessary to get sideloaded books to show up under the 'books' or 'documents' tabs. I also use the calibre 'remove [pdoc] tag' trick but that may not be necessary if you are downloading it from Amazon and all it means is the books show up under 'documents' instead of 'books'.

Also, in another thread someone reported that they were able to get all their previous Kindle books working on their Fire except for one .tpz format. I wonder if there is an issue with tpz files on the Fire.

In reply to an earlier post on Jan 17, 2012 10:23:14 AM PST
 nospin  says:
B. Smith-
I did not understand that you got it from Amazon. You have to specify the device in MYK for the book to work. They are specific to each device and app and you can't download a book to a PC and then move it to another device.

Posted on Jan 17, 2012 10:24:05 AM PST
B.Smith says:
art- Thanks, I will try that right now. So not all the purchased Kindle books are tpz files then? (this is the first one I've used this way, the rest were synced wirelessly)

Posted on Jan 17, 2012 10:26:50 AM PST
B.Smith says:
Nospin- I didn't download it to my PC for that reason, I purchased it with the "transfer to Kindle via USB" option, and in doing so it required me to download it to the computer and transfer the file manually. These are the instructions I followed:
http://www.amazon.com/gp/help/customer/display.html/ref=hp_navbox_usb_200375630?nodeId=200375630&#usb

In reply to an earlier post on Jan 17, 2012 10:27:43 AM PST
 nospin  says:
Sorry, I misunderstood that you had in fact told them which device it was going to.

Posted on Jan 17, 2012 10:29:37 AM PST
B.Smith says:
Hmm, tried the reboot with no success. Guess I'll just have to go get some wireless access somewhere until I can get this figured out!

Nospin- no worries, I appreciate your help!

Posted on Jan 17, 2012 11:08:43 AM PST
Last edited by the author on Jan 17, 2012 11:11:21 AM PST
art says:
Interesting!

I wish I had my Fire here to verify, but I think all the books I've bought from Amazon have been .azw format. If you look at the page you quote with the directions on how to download to your computer, down near the bottom is the supported formats list, and .azw is listed but .tpz is not! Maybe .tpz files won't work when transferred by USB. (that page does say it's for 2nd generation Kindles so it may not be accurate for the Fire and may pre-date the tpz format). I did read that the topaz format was designed by Amazon to be more secure than azw.

Edit: ok, I found the corresponding page for the Fire and it also doesn't say that tpz files can be transferred via usb. Maybe there is some extra security that has to go on over the network for you to open them.

Posted on Jan 17, 2012 11:25:00 AM PST
B.Smith says:
Hmm...sounds like they have some bugs to work out. :) Thanks for your research, I appreciate it!! So it sounds like I should try it with a "regular" formatted book and it should work? Is there any way to know the format of the books before I purchase them then?

Posted on Feb 29, 2012 9:06:36 AM PST
Sandy says:
Just copied documents (.doc, .docx, .xls, .jpg, .pdf) to my Kindle Fire from my PC (Vista). These documents are in 2 folders, and one document is not in a folder (as a test). None are visible in my 'Docs' folder. Any suggestions?

Posted on Feb 29, 2012 10:09:52 AM PST
art says:
Only the pdf file should show up under Docs, and then probably only if you put it into the Books or Documents directory (not in a subfolder). You may need to reboot your Fire to get it to show up.

The jpg should be found if you run the gallery app, regardless of what folder you put it in.

The microsoft file formats are not natively understood by the Fire and you'd need to open them in an app that supports them. Possibly quickoffice which comes preinstalled.

In reply to an earlier post on Feb 29, 2012 10:48:46 AM PST
Sandy says:
Thank you so much for this advice. The pdfs are visible under Docs (after rebooting). The MS Office documents (doc, docx) are visible under QuickOffice. And the jpgs are visible under Gallery.

In reply to an earlier post on Feb 29, 2012 11:05:01 AM PST
Mary Ellen says:
.mobi files show up uder documents as well as PDF files. I've got half a dozen on my Fire.

In reply to an earlier post on Feb 29, 2012 11:29:43 AM PST
Sandy says:
Thanks for replying, Mary Ellen. I don't have any .mobi files. What are they?

In reply to an earlier post on Feb 29, 2012 11:55:36 AM PST
Hi. It's a type of e-book file, short for "Mobipocket" file. It's based on an open-source format. The Kindle Fire can read these files. For a comparison of the different e-book formats follow the link below:

http://en.wikipedia.org/wiki/Comparison_of_e-book_formats

In reply to an earlier post on Feb 29, 2012 12:00:53 PM PST
Sandy says:
Thanks, Kieran.

Posted on Sep 11, 2012 7:41:31 PM PDT
[Deleted by the author on Sep 11, 2012 7:42:15 PM PDT]

Posted on Sep 11, 2012 7:43:23 PM PDT
[Deleted by the author on Sep 11, 2012 7:43:54 PM PDT]

Posted on Oct 13, 2012 8:46:45 PM PDT
J. Swift says:
Make sure you have "Device" view selected and not "Cloud" view. They are two tabs on the top of the screen right under the clock. This nailed me once and it took a while to find that I was viewing cloud files in the Documents folder.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  10
Total posts:  26
Initial post:  Jan 17, 2012
Latest post:  Oct 7, 2013

New! Receive e-mail when new posts are made.
Tracked by 4 customers

Search Customer Discussions