Customer Discussions > Kindle forum

kindle for pc - this book could not be opened. please remove the book from the device and redownload it


Sort: Oldest first | Newest first
Showing 1-25 of 30 posts in this discussion
Initial post: Jan 31, 2010 7:37:18 AM PST
N. Callaghan says:
I love my Kindle, but because of poor vision I find it even easier to read Kindle books on my laptop. While reading on my laptop several weeks ago the page faded and a box appeared that said THIS BOOK COULD NOT BE OPENED. PLEASE REMOVE THE BOOK FROM THE DEVICE AND REDOWNLOAD IT. I have done this several times, with no luck. I can open public domain books but not books I have purchased. I have uninstalled from my laptop and reinstalled several times. I have rebooted several times. I've tried disabling the firewall. Nothing works. I have no problem reading content on my desktop and Kindle, but can't read on my laptop. I have contacted Amazon customer service several times during the past month, waiting days for a Kindle specialist to call me which didn't happen. After talking to someone last week and six days later received a response from Kindle Support that the technical staff had not gotten back with him, I should contact them again at a later date. I can't believe I'm the only one who has had this problem and wish Amazon provided better support in these situations.

Posted on Jan 31, 2010 7:43:37 AM PST
The message you are getting is because the instance of Kindle you are running isn't matching the DRM on the book you are trying to open.

Make sure you are loading the book to Kindle for PC using either the archives or "Send to ..." with that installation's name. Do not use the "Transfer via computer" option, as this add DRM for a particular hardware Kindle. Delete the book from Kindle for PC, then download it again using one of these options.

As a last resort, uninstall Kindle for PC and then reinstall it again. Then redownload the book, so that the DRM matches.

As for Kindle support, make sure you start on the help page for kindle, not the general help page. Kindle support is completely separate from general Amazon support and you need them specifically. Using the Call Me option should result in a call in about a half a second.

Karen
Books on the Knob - a blog about free and bargain books
http://booksontheknob.blogspot.com
Twitter - @BooksOnTheKnob

In reply to an earlier post on Jan 31, 2010 7:59:09 AM PST
N. Callaghan says:
I've done all of this. I read on my laptop for weeks before the screen faded as I was reading, and I got the message, haven't been able to open a book since.

Posted on Jan 31, 2010 9:15:17 AM PST
" I read on my laptop for weeks before the screen faded as I was reading..."

What did you do after this happened? Send it for repairs? Replace it?

The message is annoying and has been reported by others (I've even had it once or twice; always resolved by removing the book, then sending it again to get the new DRM set -- Kindle for PC uses a combination of a fixed PID and a non-fixed session number for the DRM and if a "new session" starts, then the book won't work. Many have also reported problems with trying to read on Kindle for PC when there is no internet connection (or the connection changes).

Karen
Books on the Knob - a blog about free and bargain books
http://booksontheknob.blogspot.com
Twitter - @BooksOnTheKnob

In reply to an earlier post on Jan 31, 2010 1:39:01 PM PST
N. Callaghan says:
Did you read my original e-mail? Kindle (not my laptop) crashed while I was reading. There is nothing wrong with the laptop or internet connection--I'm using it now. I have about 50 purchased books on my Kindle. None of them will ope on this laptop. Removing and re-downloading doesn't help. I know how to do it, it just doesn't work. The public domain books will open. I've disconnected the firewall and uninstalled and reinstalled Kindle for PC several times. My son says the public domain books and purchased books must use different links. I've gotten no help from a Kindle specialist. Thank you for your effort, anyway--much appreciated.

In reply to an earlier post on Jan 31, 2010 6:07:40 PM PST
I am having the same problem, and have done everything including uninstalling K4PC and reinstalling. books in my home say they need to be deleted and reinstalled, but then books in archives say they also need to be deleted and reinstalled. I have tried Manage my Kindle and when it says send to PC or to Kindle I check send to PC and it says the book has been sent, but i get the same message again.Right now I can't open anything on K4PC but everything's fine in kindle. I guess I'll have to call, but I was hoping this could be resolved by one of the experts on here...I always find that everyone is so helpful.

Posted on Jan 31, 2010 6:22:57 PM PST
It works! The only thing I did differently this time was that I deregistered after I uninstalled. When i reregistered everything came back to normal. This is after 3 days of messing with this, and uninstalling the app at least 3 times previously. Why didn't I deregister before, you ask? I was afraid that all of my books would be gone into cyberspace heaven, but they weren't.

In reply to an earlier post on Feb 1, 2010 5:03:36 AM PST
N. Callaghan says:
I'm so happy to hear someone else has the same problem--and you solved it! I have been afraid to deregister because Amazon says do that only if you sell the computer, that you can no longer buy books for it. But I will try it anyway. I certainly have nothing to lose. Thanks. I've spent more than a month dealing with this with no help from Amazon.

Posted on Feb 1, 2010 5:19:42 AM PST
N. Callaghan says:
Thank you, Donna. It did indeed work! Amazon should say that if you de-register you can then re-register. I can't begin to say how much time and frustration this has caused me, and probably others. You've been a huge help. Thanks again.

In reply to an earlier post on Feb 1, 2010 5:28:35 AM PST
Yay! That is great news I am so pleased.

Posted on Jun 15, 2010 6:54:06 PM PDT
Cathy says:
I also got this message with Kindle for PC, for a different reason. Just in case anyone else runs into it ... the cause was my "My Documents" folder was on a network server drive that is synchronized for offline use. As soon as I reconfigured "My Documents" to use the default location on my C: drive it worked fine. I believe this is a bug in the Kindle for PC software. If it won't support standard network configurations then it should allow you to specify the storage location it will use during installation.

Posted on Nov 8, 2010 2:33:40 PM PST
I am having the same problem. I have uninstalled, reinstalled, removed the files manually... nothing i do is working.

Posted on Nov 21, 2010 1:30:12 AM PST
N. Callaghan says:
I had this problem with my laptop (see above posts) and solved it by de-registering and then re-registering it. Worked like a charm!

Posted on Jan 14, 2011 4:58:16 PM PST
Some additional information...I didn't uninstall the program, but rather just Deregistered and Removed all licensed content from device. After clicking Deregister, the Deregister dialog opened and I checked "Remove all licensed content from this device" (tell me that doesn't make you take a step back before you click "Deregister"). After you click the Deregister button everything vanishes (and I think your heart stops for a moment also). I closed and re-opened the program (not sure if that was needed). Upon reopen, the program required me to re-register, which I did and then the Sync started. After the sync completed all my books returned and my paid for book worked. The first time deregistering I didn't check the "Remove all licensed content from this device" and it didn't fix the problem. I'm thankful for Donna for uncovering the fix for this!
Jon

Posted on Feb 23, 2011 7:18:32 AM PST
If using Kindle for PC, steps I followed are below:
1) open Kindle program
2) Goto Menu-->Tools-->Options...
3) Select "Registration"
4) Click "Deregister"
5) Make sure "Remove all licensed content from this device" is checked
6) Click "Deregister" button
7) On the "Options" window, click "Register" button.
8) Enter the email and password and click "Register" button
9) you should see your items in the Home or Archived Items tab.

In reply to an earlier post on Apr 1, 2011 11:06:48 AM PDT
Deregistering & reregistering worked like a charm for me! Thank you so much. Great post!!

In reply to an earlier post on Apr 6, 2011 12:30:11 PM PDT
Perrita says:
I had the same problem with my PC and did the Remove and re-download thingy without any change. But I followed the advice below to de-register and re-register and it worked. Thank you all who suggested it! I'm waiting to decide/afford an e-reader so I can read in bed, and meantime I've been browsing free books. At first I wondered if I was deliberately being shut out because I could read those books I had paid for, or first chapters free. But it wasn't that at all.

Posted on Sep 24, 2011 5:42:22 PM PDT
Just leaving a message of another Kindle deregistering and re-registering WIN! that's all i needed to do. :) thanks for the discussions. I was having the same problems as most, if not all, but i figured to go to amazon, found this discussion group and my problem was solved in less than an hour (still an hour wasted >:/)

Posted on Oct 30, 2011 7:17:34 PM PDT
Joey L. Noll says:
I agree this all you need to do but wow to have to do this everytime is quite a pain. Enough of a pain to make this not even a viable option to work with.

Posted on Oct 30, 2011 8:15:58 PM PDT
In honor of Halloween, another zombie thread that won't die!

Posted on Mar 4, 2012 9:20:51 AM PST
fiery says:
When I started Kindle for PC I received the same error "This book could not be opened...". I found that somehow after an update I have two versions of Kindle for PC installed. One in the "Program Files" (v1.3.0) and one in "AppData/Local" (v1.8.3). The error appears only if I start v1.3.0. Books work fine with v1.8.3.
I found that I have two versions because I searched in Windows 7 for application called "Kindle" and as a result two apps appeared: "Kindle" and "Kindle for PC". The second is v1.3.0 which gives that error.

Posted on Mar 20, 2012 8:05:29 AM PDT
I also just recently experienced this problem. I also removed and re-downloaded the book I was trying to read. I re-downloaded the reading app. None of this worked. Based on these postings, I then de-registered and then re-register the PC reading app (checked the remove the licensing box) and that worked perfectly!! Thank you!

In reply to an earlier post on Mar 15, 2013 10:03:53 AM PDT
Patty Mcgee says:
I was having problems and found this post and tried it and it worked perfect! Thank you for taking the time to post this on here!

Posted on Aug 3, 2013 7:43:42 AM PDT
HRH Spider says:
thank you ..de-& re-register worked beautiflly

Posted on Nov 25, 2013 5:49:01 AM PST
I keep getting this problem at when using PC Kindle at work. Deregistering, re-registering and downloading books works but is a pain since the books stop being abled to be opened after a day or so. I tried downloading several books but after a while some got corrupted and wouldn't open. Any one know what can be done about this?
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 26 days ago
Announcement
Have a Kindle Question?
0 Sep 12, 2012
New Kindle is lock or frozen 4 51 seconds ago
Fire Tv has no sound on HDMI 2 71 2 minutes ago
saving newspapers 4 7 minutes ago
Elephants Three at The Ģrandest Hotel - Part IV 2842 15 minutes ago
Amazon Echo (no invite questions) 2808 16 minutes ago
Leonard Nimoy dead at 83 27 18 minutes ago
Voyage cover 8 18 minutes ago
Amazon Echo 3409 24 minutes ago
Download Failed 3 25 minutes ago
Discounted / Price Dropped Kindle eBooks III 5321 26 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  22
Total posts:  30
Initial post:  Jan 31, 2010
Latest post:  16 days ago

New! Receive e-mail when new posts are made.
Tracked by 4 customers

Search Customer Discussions