Your Garage Best Books of the Month Amazon Fashion Learn more nav_sap_plcc_ascpsc PME Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer AllOrNothingS1 AllOrNothingS1 AllOrNothingS1  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Starting at $49.99 All-New Kindle Oasis AutoRip in CDs & Vinyl Segway miniPro
Customer Discussions > Kindle forum

Kindle Fire cannot connect to internet

Sort: Oldest first | Newest first
Showing 1-25 of 788 posts in this discussion
Initial post: Nov 15, 2011 4:28:38 PM PST
Have just opened Kindle Fire. Can connect to wifi but no internet. All other wireless devices in home are working fine connecting to internet. Signal is strong. Have turned "Wireless Networking" on and off several times. Still showing X on wifi icon after obtaining IP address and no internet connection. Open dynamic ip unsecured wifi network.

Posted on Nov 15, 2011 4:32:18 PM PST
Last edited by the author on Nov 15, 2011 4:37:38 PM PST
Conscript says:
I seem to be having an issue where my Fire can connect to my router, but my internet's speed immediately plummets down to where it can only download at 1.0 kb/s. As soon as I make my Kindle forget my network the speed jumps right back up. Downloading 6.1 update now to see if that fixes the issue.

Updating to 6.1 fixed my problem. Props to Snoopy for the information. 6.1 download link:

Posted on Nov 15, 2011 9:59:49 PM PST
Anonymoose says:
6.1 did not affect the problems with my fire's connection/speed issues.

Posted on Nov 16, 2011 5:54:07 AM PST
Last edited by the author on Nov 16, 2011 5:54:28 AM PST
I am having the exact same issue. Connected to wireless, have an IP, etc. No connectivity. I spoke with an Amazon CS last night and was told my particular kindle fire was not provisioned correctly to my account in their system. I gave him my serial and mac and he said it would be resolved in a few hours. As of this morning I still don't have internet. I am not buying that reason. I have a 2nd Fire on order that should be here today or tomorrow, so I can really troubleshoot the issue. I think its something wrong with the wifi hardware in my Fire. I have a ton of other wireless devices working with no issues.

btw manually installed 6.1 last night - did not help.

In reply to an earlier post on Nov 16, 2011 8:53:13 AM PST
Michael B says:
Same as your problem, except when I spoke to CS this morning I was told it was a "known issue" and would be resolved within three to four hours. He also stated he made a note in my account for follow up with me via phone or e-mail in approximately the same amount of time. That was 6am EST, it is now 11:45am, still no internet connectivity or return call.

I have not applied the update yet, did not know about it until seeing this post. Although I am doubtful, it will make any difference.

This is not a minor issue; we all currently have nothing more than expensive paperweights. How do they ship product with its major functionality not functioning? Honestly, I am very close to returning my item.

Posted on Nov 16, 2011 12:01:18 PM PST
CC says:
My Kindle Fire is not connecting to my network either. It recognizes my router but once I enter the security key it attempts to connect and fails.

Posted on Nov 16, 2011 12:04:03 PM PST
Last edited by the author on Nov 16, 2011 12:05:01 PM PST
Jazzy_Jeff says:
Try rebooting your WiFi routers and see if it starts working. Just unplug the router for about 30 seconds. Also try rebooting your cable modem at the same time. This usually fixes connection problems.

Posted on Nov 16, 2011 1:51:43 PM PST
I have a 2nd Fire at home waiting for me to get home from work. I will see for 100% sure if its the Kindle Fire or my home network. I am already 99% sure its a problem with the Fire or Amazon. I am a sysadmin for a gov sub contractor and I deal with stuff far beyond wireless networks everyday and I also have no issues with any other device on my home network. I agree, at this point my 1 Fire is a paperweight, and I hope Amazon can resolve. These two are going to be Xmas presents for the kids if I can get them working, otherwise they are going back.

In reply to an earlier post on Nov 16, 2011 3:32:57 PM PST
Michael B says:
I also wasn't sure if it was my network on the device so I took mine in to work, still wouldn't function on the WiFi there. However, when I got home applying the 6.1 update fixed my issue and mine is functioning correctly now.

Of course still no promised follow up call from CS and (until seeing this post) they didn't even mention updating the device, or that there was an update availible. So, still not impressed with that aspect but we'll see what comes in the long run.

Hope you are able to get your device(s) working, good luck.

Posted on Nov 16, 2011 4:04:47 PM PST
V. Leontiev says:
So how do you update without being able to connect to wifi?

Posted on Nov 16, 2011 4:30:09 PM PST
Last edited by the author on Nov 16, 2011 4:37:41 PM PST
CigarDaze says:
Same here. My KF booted up grabbed wifi downloaded the update 6.1_user_2017120, but when I try to play any music on the cloud I get " No internet connection", yet wifi shows connected although it is at 1mbps. On phone support now. Of course they said they need to speak with engineers and will get back to me. It really sounds like they have no idea what is going on and are basically asking the customer to standby with a useless device without wifi.

In reply to an earlier post on Nov 16, 2011 4:34:21 PM PST
Snoopy says:

To update manually.

Posted on Nov 16, 2011 4:38:37 PM PST
Last edited by the author on Nov 16, 2011 4:40:01 PM PST
CigarDaze says:
I have the update (6.1_user_2017120) and it still does not work.

In reply to an earlier post on Nov 16, 2011 4:45:14 PM PST
Marilyn says:
Jazzy Jeff-That totally fixed my connecting problem. Once the router was rebooted, my Kindle Fire was good to go.

Posted on Nov 16, 2011 4:45:28 PM PST
Last edited by the author on Nov 16, 2011 4:46:55 PM PST
CigarDaze says:
Ok. no idea if this will work for others. But I rebooted the device and now it appears to have wifi. So download the update if you can't connect initially, then reboot.

Initially, I noticed a small "x" under the wifi signal at the top status bar after the update but after rebooting its no longer there. I no others said to reboot the router but I think just rebooting the kindle solves the problem.

Posted on Nov 16, 2011 4:50:19 PM PST
J. Mcgregor says:
I just got a Kindle fire. I have connected to the internet with my wifi. Signal strength is "good" to "excellent."

I can't stream video. Stops every 3 minutes. I can connect to internet, but it's slow, and frequently fails. It's like trying to use a 10 year old computer on the modern internet. So much of it seems inaccessible.

Three computers and a Roku box can ready my wifi fine. Kindle is struggling.

Posted on Nov 16, 2011 5:05:00 PM PST
J. Mcgregor says:
Just went into the room where my wifi router is. Stood next to it. Signal strength, "Excellent." Tried to read the (quite unenthusiastic) reviews for the marware cover that I have purchased for $45.

"Network Error."

If my network had a problem, you would not be reading this email message.

Posted on Nov 16, 2011 5:27:27 PM PST
I seem to be connected (after several attempts) to my wireless router (WiFi) network (54Mbps) but Fire just says "Obtaining IP address..." and freezes. Anyone else experiencing this problem, or am I mssing something?

Posted on Nov 16, 2011 6:34:15 PM PST
Jeff Flinn says:
On my KF the wireless sees the router but got stuck obtaining address. Did everything others in this forum suggested. Did a manual upgrade to 6.1 and now the wireless says "attempting" to connect but still doesn't. Found an "advanced" selection in the wifi area and was able to add a static IP address and then everything worked. Could surf, download books, everything. However, it still won't connect if I turn the static IP off and attempt a DHCP connection again. Verified my router is using WPA2-PSK with AEP encryption. Checking the Belkin router I can see what devices are getting a DHCP address and there is a new android device connected with a very strange host name and the Kindle's MAC address. Even though the router thinks it gave out an address to the Kindle it still continues to "attempt" to connect so I must presume it does not think it has an address. May have to return the KF if I have issues with other routers. Will test other routers tomorrow.

In reply to an earlier post on Nov 16, 2011 7:37:05 PM PST
Gio C says:
I have the same issue. I tried solutions mentioned for similar problems on the board and it still will not work.

In reply to an earlier post on Nov 16, 2011 7:45:19 PM PST
TL Oveca 34 says:
I am having the same issue. I did the manual update, still no luck.

In reply to an earlier post on Nov 16, 2011 7:57:03 PM PST
Mark says:
I am anxious to see if you have the same issues with your 2nd one. I was considering requesting a replacement but it may not be worth the trouble and will just opt to return it.

Posted on Nov 16, 2011 9:48:19 PM PST
same here...updated to 6.1, rebooted, no luck...

In reply to an earlier post on Nov 17, 2011 5:14:43 AM PST
G says:
Same problem. Manually updated to 6.1 via usb cable, still no joy. Took it to starbucks instead of my home network.

Still no connect.

Posted on Nov 17, 2011 5:28:45 AM PST
Adding on to the list. The Fire refuses to connect to my wireless network. It was connected for few hours, then around 8 PM EST it stopped working. I tried other wireless and some unprotected wirless and the problem is still happening. I also did a factory reset just to make sure. I'm on 6.1 Already. Glad I'm not the only one. This thing was about to get shipped back.
‹ Previous 1 2 3 4 5 6 7 8 9 10 ... 32 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum


This discussion

Discussion in:  Kindle forum
Participants:  467
Total posts:  788
Initial post:  Nov 15, 2011
Latest post:  4 days ago

New! Receive e-mail when new posts are made.
Tracked by 85 customers

Search Customer Discussions