Customer Discussions > Kindle forum

netflix on kindle fire hd


Sort: Oldest first | Newest first
Showing 1-25 of 209 posts in this discussion
Initial post: Oct 1, 2012 5:13:50 PM PDT
i just got a kindle fire hd for my son. we have a netflix account, and i can get the netflix page up, but how do we actually get the ap, or get the videos to play? maybe a dumb question, but were just starting out....

In reply to an earlier post on Oct 1, 2012 5:17:36 PM PDT
Shelly, type Netflix Android app in the search box at the top of the screen. Or, even better, go to the app store from the Fire and search for it.

Posted on Oct 1, 2012 5:19:13 PM PDT
Last edited by the author on Oct 1, 2012 5:19:28 PM PDT
Here's a link to the Netflix app:

Netflix

You will need to use the app to connect to Netflix, it will not work through the web browser.

Posted on Oct 1, 2012 5:21:38 PM PDT
thanks a bunch, i knew it had to be pretty easy!

Posted on Oct 1, 2012 5:25:44 PM PDT
You're welcome Shelley!

Posted on Oct 3, 2012 8:54:34 PM PDT
Raghavan says:
I purchased a kindle fire HD just yesterday and I downloaded and installed the netflix app. I am able to launch the app and view my movie lists but when I try to play a movie, I just get the "Loading..." page indefinitely until it times out. However, I am able to play videos from amazon without issues with excellent quality. I even tried resetting the kindle to factory defaults and reinstalling the app and still the same. What could be the problem? Appreciate your responses...

Posted on Nov 1, 2012 2:32:53 PM PDT
I am having the same issue as Raghavan. It says loading.... forever and never loads the movie. I just got this Kindle HD today and watching netflix on it was one of the reasons why i got the thing. Any ideas anyone? I reinstalled the app and a bunch of stuff trying to get it work but FAIL. If this doesnt get fixed i might just return this thing and get a diff tablet.

In reply to an earlier post on Nov 1, 2012 2:43:55 PM PDT
Try it at a different wifi location if you can, but remember that public wifi will be very slow.

In reply to an earlier post on Nov 1, 2012 3:13:05 PM PDT
jsh1120 says:
Raghaven and D. McAllister,

Raghaven, you say you're able to view Amazon videos without difficulty. D. McA doesn't say but assuming that's also true, the problem has to be with the Netflix server or (less likely) with corrupted data in the Netflix app. (Obviously, if you also have trouble viewing Amazon videos, the problem is likely your internet connection or router). Try the following:

1) Reboot the KFHD by pressing and holding the power button for 30 seconds and allowing it to shut down on its own. Then press the power button again. (This is unlikely to solve the problem but it's always the best first step in troubleshooting.)

2) Access settings by swiping down from the top of the device. Then More>Applications>Installed Applications. Find the Netflix App and "Clear Data."

3) Still no luck? Contact Netflix and see what they have to say. Try to get past a first tier CS person and find someone who might know whether your router settings are problematic (doubtful) or whether Netflix servers are having problems (more likely but unlikely to be divulged to you.)

Posted on Nov 1, 2012 3:17:50 PM PDT
Netflix is rather notorious for problems with its mobile service - no matter the device.

Sometimes the problem is the DNS cache on the router.

In reply to an earlier post on Nov 1, 2012 3:24:05 PM PDT
jsh1120 says:
OR,

Thanks. Now that you mention it, I recall that the DNS cache is a known issue.

Posted on Nov 1, 2012 6:17:04 PM PDT
so far i deleted the data for netflix and did a restart on the kindle. no luck. currently trying netflix on my phone with wifi but looks like another fail. next im going to try my phone using 3g network then teather my kindle to my phone

In reply to an earlier post on Nov 1, 2012 6:19:36 PM PDT
Thanks for the update. Let us know how it turns out so other's can benefit from your experiences.

Posted on Nov 1, 2012 6:27:07 PM PDT
Last edited by the author on Nov 1, 2012 6:27:49 PM PDT
so my phone wouldnt allow me to load the video either on my home network wifi... it loadedthe app and load my movies and selections but not the movie itself. I turned off my wifi on my phone and found that my phone on 3g network would load the movie fine. I turned on my mobile hotspot on my phone and connected my kindle hd to my phone via wifi. I loaded the netflix app and after a minute or two the movie did start to play on the kindle. I believe it was long delay to load only cause i am using my phone as my internet source. So there must be something within my network thats not allowing my netflix on my kindle to load the movie properly. Any suggestions on that one?

BTW amazon movies load and work perfect. nice and clear on this thing

In reply to an earlier post on Nov 1, 2012 6:38:52 PM PDT
Have you tried rebooting your router? If it is a DNS cache issue, personally I'd be hesitant to try to give you a suggestion that might lead to you being worse off than you were to begin with.

Posted on Nov 1, 2012 6:43:52 PM PDT
lol was in process of rebooting router when you responded back. That seemed to work to get it working on my home network. Steaming netflix via wifi on home network now where as it wouldnt prior to rebooting router.

In reply to an earlier post on Nov 1, 2012 6:57:13 PM PDT
cool!

Posted on Nov 17, 2012 5:30:42 PM PST
Jana Kimball says:
how can i get to my instant queue to see the movies i've chosen?

In reply to an earlier post on Nov 17, 2012 5:50:59 PM PST
On my Fire... I have it right here by my laptop, the first row is continue watching, the second row is Top 10 for me, and the third row is instant queue.

Posted on Nov 26, 2012 5:57:01 PM PST
[Deleted by the author on Nov 26, 2012 5:59:56 PM PST]

Posted on Nov 26, 2012 6:00:09 PM PST
hmmmm there are lots of tech comments here but that doesn't fix the issue. netflix work on android, windows and mac... why not on amazon tablet hd? i was wondering if it has anything to do with amazon movies?....

In reply to an earlier post on Nov 26, 2012 6:11:43 PM PST
The Kindle Fire *is* and Android device. NetFlix issues are usually Netflix problems, or the wi fi connection of the user. I use NetFlix on my Fire HD almost daily with no issues.

Posted on Nov 29, 2012 10:39:22 AM PST
C. Close says:
I've got another question. I now have the Netflix app loaded, tapped on, Netflix wants my e-mail and password, but I don't see a keyboard. How do I do that?

Posted on Nov 29, 2012 10:39:33 AM PST
[Deleted by the author on Nov 29, 2012 10:43:49 AM PST]

In reply to an earlier post on Nov 29, 2012 10:54:26 AM PST
❤ Ann says:
I've used the Netflix app on a 1st-generation Fire, a Fire HD 7" and a Fire HD 8.9", and haven't encountered any problems. What issue are you having?
‹ Previous 1 2 3 4 5 6 7 8 9 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  98
Total posts:  209
Initial post:  Oct 1, 2012
Latest post:  13 hours ago

New! Receive e-mail when new posts are made.
Tracked by 32 customers

Search Customer Discussions