Customer Discussions > Kindle forum

Open Guest Wifi cannot get to login page


Sort: Oldest first | Newest first
Showing 1-25 of 34 posts in this discussion
Initial post: Nov 16, 2011 8:23:25 AM PST
Scott Beegun says:
I am connecting to an open guest wifi. Its telling me i need to login to access it like you would do for a hotel wifi. It tries to bring up a login page but its just blank. So there is no way for me to connect. Any suggestions?

Posted on Nov 16, 2011 10:45:48 AM PST
Last edited by the author on Nov 16, 2011 10:46:26 AM PST
Hello Scott Beegun,

Kindle Fire supports public and private Wi-Fi networks or hotspots that use 802.11b, 802.11g, 802.11n, or enterprise networks with support for WEP, WPA and WPA2 security using password authentication. Kindle does not support connecting to ad-hoc (or peer-to-peer) Wi-Fi networks.

I am providing you a link with that will provide you further information regarding Connecting Your Kindle Fire Wirelessly:

http://www.amazon.com/gp/help/customer/display.html?nodeId=200729310

If you are still experiencing difficulty connecting to the WiFi network at your current location after reviewing the information I have provided, please contact us here at Amazon Kindle Customer Support!

http://www.amazon.com/contact-us

You can also give us a call at:

U.S. and Canada: 1-866-216-1072
Kindle Support: 1-866-321-8851
International: 1-206-266-2992

Best Regards,

Shannon A.
Amazon Kindle Customer Service

In reply to an earlier post on Nov 16, 2011 10:50:58 AM PST
WendyT says:
I also had that happen -- the blank page just sitting there (there was a "Close" button on it). What I did was close that page and then I clicked on the web tab on the Fire -- that then brought up the login page...every time I get on this wi-fi network, it works this way. Maybe it will help you, maybe not. Good luck:-)

In reply to an earlier post on Nov 19, 2011 9:33:48 AM PST
Thank you WendyT! I had this exact problem this morning at my favorite breakfast location, where I was really looking forward to spending some time on my Fire. It appears to have no trouble finding the network, but while I was given the username and password, the login page that popped up through the Wireless Networking screens in the Kindle Fire was simply blank, so I couldn't enter it. I'll try your tip tomorrow to see if the browser will bring it up. Fingers crossed :)

In reply to an earlier post on Dec 27, 2011 2:10:01 PM PST
[Deleted by the author on Dec 27, 2011 2:10:11 PM PST]

Posted on Apr 11, 2012 8:47:44 AM PDT
Joe R. says:
I have this exact problem but unfortunately WendyT's solution didn't work for me. I just can't get my Kindle to find the login page. What's worse is that I found the link to the login page using my laptop but it doesn't work when I put it in manually on the Fire.

Posted on Aug 21, 2012 10:00:33 AM PDT
J. Mitchell says:
I have this exact problem. Once in a blue moon, the amazon browser will show the guest wireless internet login page on it's own, but most days it just doesn't and there is no way to login or surf the web on a guest network.

In reply to an earlier post on Aug 21, 2012 10:09:04 AM PDT
This is all to do with how the web page (wireless login page) has been programmed. Ensure that you have java enabled or try a different browser is all I can suggest.

Posted on Nov 12, 2012 6:44:15 PM PST
M. Dougherty says:
Same issue here on new Kindle Fire HD. The connection will say you have to log in to get access and then it brings up an Amazon page. I log into my Amazon account, but can't do anything else other than view Amazon's web site. I found another thread in this forum that said to disable popups in the WEB - MENU - SETTINGS and to uncheck ACCELERATE PAGE LOADING. I have done that, but won't be able to test until I can get back to the public wifi sites.

Posted on Jan 14, 2014 10:30:35 AM PST
Trey says:
So, I just got a Paperwhite first generation and I'm trying it on a few guest networks and it doesn't work.
For you folks at Amazon, is there a solution or do I need to return this? Because otherwise, what's the point?

In reply to an earlier post on Jan 14, 2014 10:52:39 AM PST
Last edited by the author on Jan 14, 2014 11:16:54 AM PST
When you pull up a thread that was started 3 years ago, it has a lot of inaccurate info as things have changed.

This is not Kindle support. This is a customer forum that Amazon does not monitor. The paperwhite first gen has been out for about a year and there haven't been a lot of posts from people about connecting so it's not an issue.

Why don't you start by telling us what you are doing and seeing so we can help you? The guest network that you are trying to connect to - is it your router? Have you power cycled the router? Have you power cycled the PW? When the PW does a scan for networks, is that network showing? Is it asking for a password? What happens when you enter the password?

If you don't want to give us info to help you, I suggest you contact Kindle support by clicking on help at the top or bottom of any Amazon page. Click on the contact us button on the next page. Answer the questions and the correct contact info is shown. I suggest using the phone for quickest response.

Posted on Jan 14, 2014 11:06:08 AM PST
T. Cook says:
" is there a solution or do I need to return this? Because otherwise, what's the point? "

You do realize Amazon doesn't control how someone chooses to offer their Free WIFI service, right?

Saying "it doesn't work" tells us nothing about what you tried to do and what you saw and what you were able to try...

In reply to an earlier post on Jan 14, 2014 11:23:20 AM PST
CBRetriever says:
I've been unable to get it to work at several hotels I've stayed at simply because the hotel website had videos, pop-ups that covered up where I needed to type, etc and it wasn't the kindle's fault, just the website designer trying to be too fancy

and it's why I've always bought kindles with 3G if possible, so i can at least download books while travelling

In reply to an earlier post on Jan 14, 2014 11:45:07 AM PST
T. Cook says:
At one hotel, it brought the sign in screen then immediately forwarded it to a blank screen, it did this repeatedly, so I tried it on my netbook, it worked, so I manually typed the URL for the login screen on my Kindle and it took me to the sign in screen and did not foward to a blank screen, so I was able to connect successfully, so even if "it doesn't work", there can be ways of making it work, depending on what "it doesn't work" means...
Plus, having worked at an internet help desk for a company that sells internet service to hotels, there should be a tech support help number in the hotel room you can call if you're having help accessing their wifi. (Ours was on a folded double sided card on the desk).

In reply to an earlier post on Jan 14, 2014 2:05:20 PM PST
Trey says:
Well, it is the first one on the topic.
Kindle Help sure doesn't address the topic.
And it looks like I may have some helpers here. So, thank you.

OK, brand new paper white and at a hospital and trying to get it to connect to the guest wireless network.
It asks me if I want to open the browser and go to the page. When I go to the page it cycles for a minute or more and then errors out and asks if I want to try again. Repeated attempts net nothing.
Reading further into the thread, it looks like the log in page may have too many graphics or a video that prevents it from working. So, time to go bug the hospital help desk and see if they live up to the rest of the service here.

In reply to an earlier post on Jan 14, 2014 2:23:34 PM PST
Good luck on that. A lot of the "free" networks that I've run into require you to agree to something before you are allowed access. I wish you luck and understand your frustration.

In reply to an earlier post on Mar 27, 2014 12:37:27 PM PDT
Julie Joe says:
Oh my goodness!!! Thank you SO much for your post! I've had this problem on and off for quite sometime and you fixed it for me in just a few seconds! Super easy! I don't know why I didn't think to try this! Thanks again!!! ~ Julie

Posted on May 20, 2014 7:46:09 AM PDT
Last edited by the author on May 20, 2014 7:48:08 AM PDT
Same trouble here. I have the new Paperwhite and am staying at a hotel that requires a login and agreement with terms. For a time, the hotel login page would display, but even then it was exceedingly difficult to check the "agreement" box, as it was unresponsive to my tapping it on the screen. Now, all of a sudden, all I get is a blank page--even though it shows that I am connected to the wi-fi itself. Thinking that the trouble may originate with the hotel website, I walked next door to a McDonalds and tried connecting. Same result: blank screen. At this point, I've tried all I know to do and nothing has worked. Very aggravating as I have several books queued to be loaded onto the device.

And as a sort of P.S., I might add that the Kindle User's Guide has been singularly unhelpful with the various issues I've encountered since purchasing the Paperwhite.

In reply to an earlier post on May 20, 2014 7:58:18 AM PDT
Reboot the Kindle.

In reply to an earlier post on May 21, 2014 8:06:29 AM PDT
Thanks. If "reboot" is synonymous with "reset"--an option available within the settings menu (an additional drop-down menu)--this is precisely what I did and it worked. The result was that all of my books and docs were dumped from the device, but they are easily retrieved from the cloud.

In reply to an earlier post on May 21, 2014 8:37:36 AM PDT
The factory defaults option is the only one that deletes content and, I believe, it would also deregister the device.

The other reset option on the menu wouldn't be possible on a device that's frozen so pressing and holding the power button/switch for 30 seconds is the alternative.

Posted on May 21, 2014 10:42:37 AM PDT
Whoops! Looks like my solution was overkill. It did deregister the device, though that was quickly fixed. Next time I'll know to use your solution. I had no idea.

In reply to an earlier post on May 21, 2014 11:36:18 AM PDT
Rebooting cures all sorts of problems without deleting content, so the factory reset is a last resort as far as I'm concerned. I would never recommend that before having Kindle CS go through some other troubleshooting steps.

Posted on May 21, 2014 11:51:17 AM PDT
I'm afraid I panicked. :-)

In reply to an earlier post on May 21, 2014 11:52:54 AM PDT
I know what that's like.

You know how to get help from Amazon, right?
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  18
Total posts:  34
Initial post:  Nov 16, 2011
Latest post:  2 days ago

New! Receive e-mail when new posts are made.
Tracked by 5 customers

Search Customer Discussions