Your Garage Best Books of the Month Amazon Fashion Learn more nav_sap_plcc_ascpsc Recess Monkey Explore Premium Audio Fire TV Stick Sun Care Patriotic Picks Shop-by-Room Amazon Cash Back Offer AnnedroidsS3 AnnedroidsS3 AnnedroidsS3  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis AutoRip in CDs & Vinyl Best Camping & Hiking Gear in Outdoors STEM
Customer Discussions > Kindle forum

Problems with kindle app on new Samsung Galaxy S3


Sort: Oldest first | Newest first
Showing 1-11 of 11 posts in this discussion
Initial post: Apr 8, 2013 8:06:52 PM PDT
Just changed my cell to a Galaxy S3. When I downloaded the kindle app all my books appeared in archives, you can download and read a book, but on the home page of the app no recommendations appear. On the bottom half of the screen just says loading and that circle keeps spinning. It did that for several hours before I finally decided to uninstall the app to conserve my battery. I have tried rebooting and a factory reset on my phone but with each attempt to reinstall the app the same thing happens. Anyone else having this issue or any suggestions. I spoke with kindle customer service and they were unable to resolve the problem.

In reply to an earlier post on Apr 8, 2013 8:12:12 PM PDT
Loz says:
Could it be something to do with your service provider? I have the same phone and my app has the recommended section (which I've never really noticed or looked at!).

In reply to an earlier post on Apr 8, 2013 8:24:13 PM PDT
I had the same provider for my previous phone and the app worked fine. I took my phone back to the store tonight and was going to exchange it but they tried my SIM in another brand of phone and the same thing happened. They think it is probably a problem with this version of the app. Kindle support has sent my problem up the chain to an engineer so hopefully it gets resolved soon. I really don't care about the recommended section just want it to stop loading and draining my battery.

In reply to an earlier post on Apr 8, 2013 8:38:27 PM PDT
Loz says:
Hmm, that is a weird one. I don't think I've been prompted to update the app on my phone for a while so perhaps that's why mine still works ok. I would say it's definitely an issue within the app itself rather than your phone, especially if it happened in another phone.

In reply to an earlier post on Apr 8, 2013 11:25:45 PM PDT
How did you download the Kindle app? Was it from Google Play or the Amazon App Store? I downloaded mine from Amazon. This may have nothing to do with it, but I have that same phone and my app works great. You may want to try downloading it from another store. I have version 3.8.2.4 running on Jelly Bean.

Posted on Apr 9, 2013 3:51:48 AM PDT
Charlie Fox says:
I have the same phone, I'm running 3.7.0.108 and it works fine.

Posted on May 20, 2013 9:12:22 AM PDT
babsonpe says:
I can't sign into the Kindle app on my Galaxy S3. All I get is a message saying Error - there was an error processing your request.

In reply to an earlier post on May 20, 2013 9:21:54 AM PDT
babsonpe - Try uninstalling an reinstalling the app. Also, I find mine works best when I'm connected to wi-fi instead of just 3G/4G.

In reply to an earlier post on May 20, 2013 9:46:54 AM PDT
babsonpe says:
That did the trick! Thanks!

In reply to an earlier post on May 20, 2013 9:48:00 AM PDT
babsonpe - Great! You're welcome.

Posted on Jun 17, 2013 7:12:13 PM PDT
Last edited by the author on Jun 17, 2013 7:13:34 PM PDT
Pineapple, outstanding. I had the same issue and a Google search brought me here. I then went and did a search on you tube for visual instructions on how to remove the app off the phone. Simple to reinstall the same app. Worked the first time. Tks.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  6
Total posts:  11
Initial post:  Apr 8, 2013
Latest post:  Jun 17, 2013

New! Receive e-mail when new posts are made.
Tracked by 1 customer

Search Customer Discussions