Customer Discussions > Kindle forum

KIndle FIre and Verizon email

Sort: Oldest first | Newest first
Showing 1-25 of 79 posts in this discussion
Initial post: Dec 21, 2011 5:13:48 AM PST
I've been trying to piece together info from various threads. Am I right that I must use the KF email app to read my email? I don't see Verizon in the list of choices (gmail, yahoo, etc). How can I access Verizon email? If I go exernally to the webmail site, I cannot view emails nor compose them. Thanks in advance.

Posted on Dec 21, 2011 7:06:15 AM PST
Webmail is generally bad enough on a full-size computer, so you need to use the app. Every reputable service provider has a help page somewhere on their website showing the settings required for email service. Verizon's is thoroughly buried, but here is a link:

This assumes you have Verizon home broadband service.

It may not work if you connect to the Internet while traveling, at the library, etc.

I won't use my Internet provider's service for that and other reasons. I use Gmail, which does support apps as well as its own Web interface, works everywhere, and supports IMAP, which is superior to POP. POP basically just downloads your mail. IMAP lets your mail app more properly manage the remote mail, including moving things to remote folders, deletion, etc.

In reply to an earlier post on Dec 21, 2011 7:09:46 AM PST
Mary Jane says:
I believe that one of the choices is "Other". That's what I used to set up my comcast account.

Posted on Dec 21, 2011 5:38:06 PM PST
tazman says:
I have verizon DSL and i didn't have any problems connecting. i just went to other and no ploblems

Posted on Dec 22, 2011 4:21:02 PM PST
I think verizon's webmail is pretty good, but it doesn't work at all with the kindle browser. I'll see if I can work around it and report back.

Posted on Dec 22, 2011 4:44:46 PM PST
Thanks to all who commented. Part of my problem was "user error" which was cleared up once I called Amazon directly. I have Verizon email set up and working properly. What I should have done was learned how to use the Kindle before attempting anything as drastic (HA HA) as setting up email.

In reply to an earlier post on Dec 25, 2011 2:42:44 PM PST
M. F. Key says:
Please post the settings for Verizon e-mail. Thank you. Merry Xmas!

In reply to an earlier post on Dec 25, 2011 2:45:44 PM PST
C. Scilley says:
I agree. Gmail works so much better.

In reply to an earlier post on Dec 25, 2011 3:02:58 PM PST
POP3 server =
port = 110

SMTP server =
port = 587

These are the same as you would use if you were setting up Outlook on your computer to read/send Verizon email.

In reply to an earlier post on Dec 25, 2011 7:41:54 PM PST
Marie says:
I am also a Verizon user. But if you are getting your email through yahoo you must include yahoo in the settings.

POP3 server =
port = 110

SMTP server =
port = 587

Posted on Dec 26, 2011 7:01:24 AM PST
John says:
FYI...the original Verizon webmail works on Kindle Fire. The new Message Center format does not. Be warned - the conversion to Message Center is permanent - there is no going back! The best that can happen is all of us complaining to Verizon so that they fix the webmail to work on all browsers (especially since they won't offer us IMAP support).

Posted on Dec 26, 2011 9:55:08 AM PST
M. F. Key says:
What about the security settings for verizon e-mail? Thanks for the help already.

Posted on Dec 26, 2011 6:54:28 PM PST
I am confused and trying to set up my Verizon email, too. I keep getting a message-username or password incorrect when I get to the incoming server settings and hit next. I am using my username and password that I use for Verizon.

Posted on Dec 26, 2011 7:00:29 PM PST
Just saw the above post about Yahoo mail and Verizon. That is my situation and just followed that advice and it worked! Thanks!

In reply to an earlier post on Dec 26, 2011 7:14:31 PM PST
Last edited by the author on Dec 26, 2011 7:15:31 PM PST
M.F. Key ie security type settings
None incoming or outgoing
Incoming server
Authentication type = PLAIN
Port 110
Outgoing Server
Port = 587
Require sign-in. Checked
Authentication type = AUTOMATIC

Posted on Dec 27, 2011 8:55:07 AM PST
I have set my e-mail up according to the above instructions and it is working II can view my inbox and open individual e-mails but I am having touble figuring out how to reply to them...there seems to be no reply button

In reply to an earlier post on Dec 27, 2011 9:35:03 AM PST
There is an arrow Icon at the bottom. When you touch that it gives you reply and reply all. My next question is how to delete text going forward. The arrow with the X deletes backwards. Can you delete forward?
Also how do I turn off the auto word corrector? Sometimes I mean a certain word. I hate that it won't let me type what I want!

Posted on Dec 29, 2011 10:46:07 AM PST
Here are the settings I got to work for my niece who kept getting "Username and Password incorrect":
First provide the Email address and password. Click Next.

The next screen sets up the Incoming Email Server settings. It makes some assumptions which are incorrect.
Use the following values, despite what comes up automatically:

Username : FULL Email Address (not just the part before the "@" symbol.)
POP Server : (by default, it will use You need the "yahoo" part.)
Security Type : SSL (always)
Server Port : 995
Authentication : Plain

For Outgoing Server:
Username : FULL Email Address (not just the part before the "@" symbol.)
Password : Same as before.
SMTP Server : (by default, it will use You need the "yahoo" part.)
Server Port : 465

Then finish up.

Hope this helps someone out there.


Posted on Dec 29, 2011 12:09:36 PM PST
VickiC says:
Kimberly Cidern's settings are perfectly correct for anyone who has a email that goes through Yahoo. Easy set up with those settings. Everything came through with no problems. Thanks Kimberly!

Posted on Dec 29, 2011 6:10:18 PM PST
Hi, I found sk@gmail to work pretty well, and it's easy to set up. Now my gmail and verizon mail can be managed separately. Problem solved!

In reply to an earlier post on Jan 5, 2012 4:57:54 PM PST
Peter Horne says:
Thanks Kimberly!! Your instructions worked perfectly!!

In reply to an earlier post on Jan 5, 2012 5:28:57 PM PST
karen says:
I have verizon fios i always use the web to check my email on verizon site it works 90% of the time

In reply to an earlier post on Jan 14, 2012 5:04:16 PM PST
Thank you so much for the clear step by step directions. Mine now works!!

Posted on Jan 15, 2012 5:58:43 AM PST
D. P. Wright says:
Kimberly has it right, exactly. I use almost the exact same setup, except I keep my yahoo and verizon accounts separate. That just means there is no yahoo in the outgoing server name. The 995 and 465 ports are the "new" ones verizon uses, at least in my area of the world. They sent out an email to tell us that it was changing and I didn't bother until my mail stopped working correctly. You guys who are able to use verizon webmail on a fire are far more patient than I am, I can barely tolerate it on a desktop. I does work for me, I tried it just for giggles, but it's too much for my tired eyes.

In reply to an earlier post on Jan 26, 2012 5:10:52 PM PST
Molly Chomas says:
THANK YOU!!!!!!!!!!!!!!!!!!!!!!! You saved me from hours of frustration!!!
‹ Previous 1 2 3 4 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum

Discussion Replies Latest Post
NEWS: Kindle for iOS 4.8
0 12 days ago
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Meet other story lovers at Write On by Kindle
36 Mar 20, 2015
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 Feb 2, 2015
new kindle 6 1 minute ago
When downloading a new purchase, a previous already downloaded book also downloads 0 1 minute ago
We're So Quirky, Our Chihuahuas Ride Bicycles! So Geese and Tally Ho! 4671 2 minutes ago
RAoK Room 81 is ready to serve you..... 9047 8 minutes ago
Dragi's Croatian Crab Shack and Wine Bar - The times they are a changin' 7165 9 minutes ago
Al's Place 35mm 7749 9 minutes ago
reset parental control password with deleting personal information 3 13 minutes ago
Kindle unlimited 10 14 minutes ago

This discussion

Discussion in:  Kindle forum
Participants:  49
Total posts:  79
Initial post:  Dec 21, 2011
Latest post:  May 18, 2014

New! Receive e-mail when new posts are made.
Tracked by 13 customers

Search Customer Discussions