Your Garage botysf16 Amazon Fashion Learn more Discover it Drowners Fire TV Stick Subscribe & Save Patriotic Picks Shop-by-Room Amazon Cash Back Offer WienerDog WienerDog WienerDog  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis Segway miniPro STEM
Customer Discussions > Kindle forum

Kindle Fire - "Internal Service Error"


Sort: Oldest first | Newest first
Showing 1-25 of 38 posts in this discussion
Initial post: May 25, 2012 8:31:13 AM PDT
I keep getting "Internal Sevice Failure" "There was and internal error" popping up on my screen when I open apps and they won't work. Anyone know how to fix thsi?

Posted on May 25, 2012 8:40:21 AM PDT
GnomeEd says:
Hard reset?

Hold the on button on for 30 seconds

In reply to an earlier post on May 25, 2012 8:58:38 AM PDT
Tried it again after your suggestion. Still no fix?
Any other ideas out there?
Is the a customer service number that I can call? Couldn't seem to find one.

In reply to an earlier post on Jul 11, 2012 12:37:43 PM PDT
My wife had the same problem.....somehow her Kindle Fire clock was reset to Aug 2012. After re-establishing the correct time and time zone. ALL THE PROBLEM WERE RESOLVED. CHECK YOU TIME.

In reply to an earlier post on Jul 11, 2012 12:39:53 PM PDT
J. Donahue says:
Up at the top of the screen, click on the "Help" menu option. Then, there's a "Contact Us" button on the right.

Posted on Oct 7, 2012 9:55:15 PM PDT
To fix the problem just de register ur device and then hold power button for 20 seconds. Turn back on and re register. Ur apps and books should still be there and any music u downloaded. In other words nothing should be missing. But u will lose ur progress in any of ur games.( I did this myself and it worked)

In reply to an earlier post on Dec 26, 2012 1:19:34 PM PST
jenna says:
Thank you for the post, my kindle was set for Aug of 2013, dont know how that happened. Put the right time and date on it and the internal error went away.

Posted on Dec 26, 2012 1:29:59 PM PST
Really would of been nice to have this connected to a wireless internet service, very disappointed.

Posted on Feb 24, 2013 8:31:07 AM PST
Had this same error. Just checked the date and somehow the kids got it to 2032...a little off! Reset date and all is good and well in our household again. Thanks.

In reply to an earlier post on Mar 30, 2013 5:41:43 PM PDT
YES! Thank you, changing the date and time resolved the problem.

Posted on Apr 10, 2013 5:10:53 PM PDT
getting the internal error message
when trying to play any already loaded games; can read my books without an issue. Tried the reset procedure; my date is correct....what is next?

Posted on Jun 1, 2013 7:32:10 PM PDT
Khristian says:
I had the same problem and my date and time were correct and a hard reset didn't fix it either. I deregistered, and registered again, and it started working right :)

Posted on Jun 1, 2013 11:30:42 PM PDT
Where do I find the date and time ?

In reply to an earlier post on Jun 2, 2013 12:44:05 PM PDT
Saju says:
On the settings option, select device. Inside Device option there is Date

In reply to an earlier post on Jun 2, 2013 6:22:08 PM PDT
terster says:
HI. What do you mean you deregistered and then reregistered it? You deregistered your kindle from amazon? Or did you do a factory reset? Can you guide through the steps you took? Thanks.

In reply to an earlier post on Jun 3, 2013 8:19:53 AM PDT
... says:
This is exactly what the issue was for mine. Thank you for sharing.

Posted on Jun 3, 2013 6:23:55 PM PDT
terster says:
Hi. I changed my timezone to the other side of the world, restarted the device and that did not work. I then deregistered the Kindle from my Kindle Account on Amazon. I then restarted the Kindle. I then went to my account settings on the kindle... registered it again. Fortunately the device remembered most of my settings. But, in the end, it did NOT work. I still get the error. So now, based on the other reading I think I have to do a Factory Reset on the Kindle and this... really, really, really does not make me happy!

This thing is brand new... I've had it 3 days... I just got most of it figured out, email set up, other apps working and then bang... this dumb error that now comes up randomly in applications and they want me to do a full factory reset. Unreal.

But, it is the next step.

In reply to an earlier post on Jun 5, 2013 6:04:16 AM PDT
That didn't work ...I bought games and now they won't even work....!!!!....what a rip off

Posted on Jun 5, 2013 8:09:15 AM PDT
Last edited by the author on Jun 5, 2013 8:13:15 AM PDT
terster says:
Well, I have an update...

I was so fed up after that other post that I was not going to do a factory restore any more that evening. The last thing i did before giving up that night was to go into my amazon account and remove the ePrint app from my list of purchased apps. I then made sure it was not on the Kindle itself. I then reset the date again to something on the other side of the world, restarted the device, set the date back, restarted again. I then deregistered the device from my amazon kindle account again... then registered the device itself one final time by turning on and going to My Account and then register. I set up my email on the Kindle and that was it. I was done for the night. Last night... I turned the unit on started hunting for more apps, like the TV channels and movie channels and stuff like that. I looked and got some apps like an alarm clock on (which i'm testing now, lol). Point is, I actually forgot about the "issue" I was having.

So, once I remembered I thought... oh yeah... I still need to be able to print.

So I went back, found the ePrint software, bought it again (its free) and this time, it d/l'ed to the Kindle and installed normally. I was able to set it up and within 3 minutes I was printing.

The long and short of it is... I don't know if it was fully removing the app from the kindle as well as my amazon account, changing the time zone a 2nd time, deregistering a 2nd time and then waiting over night to do anything more... or if it was something else. I wish I could tell ya as this seems to be a common issue people have.

My recommendation... if you're still at the point where you're reading this... I would go through the motions one more time before doing factory reset. Make that your very last option.

Go into the Kindle itself and make sure that ANY APP that throws the error is uninstalled/REMOVE FROM DEVICE. Then go out to your Amazon Kindle account and remove the same apps there. Once they are gone, gone... come back to your kindle and change your TIME ZONE to something obscure. Turn the unit off. Wait 2 min's. Turn the unit back on. Reset the time zone to the correct one. Turn Kindle off and wait 2 more min's. Turn on and then go to Settings | Account and DEREGISTER your Kindle. In 45 seconds, everything will disappear. Turn off, wait 2 min's. Turn on, go back to "Settings | Account" and now REGISTER. Now give this a full 5 minutes for things to start reappearing.

At this point, I went to bed, however... when I came back the next evening, I set up email, other web apps, played for at least an hour by finding and downloading apps, etc. I then went and found the ePrint app ON AMAZONS SITE and I bought it there (I did not buy on the kindle but on amazon). For you... buy each app, but one at a time, from AMAZON Site, not from Kindle. Ok, push to your kindle.

Go to your Kindle Settings and then push the SYNC button so that it comes down. Now go to Apps | Cloud on your Kindle and go ahead and download it/install it, set it up.

If all is good now... keep going. Go back to Amazon.com, find the next app that was throwing the error and is now gone... purchase, send to Kindle. Refresh/Sync Kindle... install, continue.

Ok... sorry this is so wordy... i'm just hoping that it's detailed enough that this may help others. I'm just glad it worked for me and now that it is working... I really like this thing. Its my first experience with a tablet. I've always been a PC/Laptop kind of guy... but this thing... when working right... rocks.

Now... anyone got any idea's for how to make wireless more stable on this thing? LOL Every other device I use (Roku, BRay Player, Laptop, even my wife and son's ipads) are incredibly stable with wireless... but the Kindle... signal is up and down and all over the place! So... i'll now go find a forum for that issue. :)

Thanks to all that posted... some or all of the idea's worked for me, at the end.

Posted on Jun 9, 2013 11:08:05 PM PDT
DollReviews says:
I'm tryinf to play an app called Road Warriors ok so I had internet when playing then it got turned off
But I could still play without it I've played for 2 months so far and now I tried playing it when I was out
Of town in Fairview Height MO. Then the INTERNEL SERIVE FAILURE popped up now it won't work so
What do I do?

Posted on Jun 19, 2013 4:22:03 PM PDT
La Chinche says:
If I deregister and then register again will Istill have allmy playlists?

Posted on Jun 19, 2013 5:06:40 PM PDT
terster says:
DollReviews... unfortunately I don't have the full answer. My recommendation... remove the app from your kindle... restart it. Change the time on your kindle to some other timezone on the other side of the world... restart the kindle. DEREGISTER it, restart again. Then REGISTER the device again, confirm the time and then download the app and install.

La Chinche... I can't answer your question about your playlists. I did not have any so I don't know. I DO KNOW... that I did have to set up my printing again, I had to set up my emails again, my wireless again. But... I found that my apps remained installed, my favorites remained on the device, etc.

So for me, it seems that just about anything that required you to INPUT INFORMATION (like setting up email) did require me to do it again...

I don't know if this helps. Hopefully. IF you email Amazon Kindle Support, they may be able to tell ya.

Thanks.

In reply to an earlier post on Jul 21, 2013 6:34:57 PM PDT
Mine hd is

In reply to an earlier post on Sep 4, 2013 8:32:39 PM PDT
Abigail says:
well for me its all the apps are not working with the INTERNAL SERVICE FAILURE on every app

Posted on Sep 7, 2013 6:44:09 PM PDT
sclotus says:
i just deregistered and re-registered and it was all better :) i checked my time zone prior to this and my time was already correct so I didn't mess with it
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  33
Total posts:  38
Initial post:  May 25, 2012
Latest post:  Mar 14, 2016

New! Receive e-mail when new posts are made.
Tracked by 11 customers

Search Customer Discussions