Customer Discussions > Kindle forum

Is this weird Kindle mounting/charging/downloading glitch worth worrying about?


Sort: Oldest first | Newest first
Showing 1-9 of 9 posts in this discussion
Initial post: Sep 5, 2011 3:12:54 PM PDT
André Jute says:
Here's one I never saw mentioned anywhere.

Plug my Kindle in to the computer via USB, intending to drag and drop the manuscript of a novel that I'm editing to check the formatting on the Kindle.

The orange charging light on the Kindle comes on, so there's a connection, and current flowing. But the Kindle doesn't mount on the computer, nor at the Kindle end go into the "battery mode".

Thinking that the rather thin, vulnerable USB cable Amazon supplies has been damaged, I try a few other USB cables with appropriate plugs. No change.

Next likelihood, the multiple chained USB stacks behind my computer are at fault; some devices demand to be close to the computer in the chain, some demand to be right next to the computer, a few demand to be directly on a computer USB port. But the Kindle never gave that sort of trouble before. Even plugged directly into the computer, the Kindle still won't mount.

I start wondering if there's maybe a wire damaged where the Kindle's USB socket meets its PCB because there's a bit of wiggle there. I really, really don't want the bother of sending my Kindle back to be fixed or replaced.

One more thing to try: it's maybe not be a hardware error at all, but an OS glitch.

Perform the initial level of reset by holding the on-off switch for twenty seconds. The Kindle restarts. Plug it in again. The Kindle mounts onto my Mac's Desktop. Problem solved.

Problem not explained, of course. Probably too rare to bust my brains about. What do you reckon?

In reply to an earlier post on Sep 5, 2011 3:25:36 PM PDT
i know that some cords were disintegrating so amazon replaced them, as for the rest im not sure, have you loaded a lot of books lately? if so see if one is stuck indexing thats all i can think of sorry

Posted on Sep 5, 2011 3:26:44 PM PDT
Sometimes a good old fashion reboot is all that's needed to get devices like this to act normally. USB connections aren't always reliable when it comes to your pc detecting the device, or the device "realizing" that it's even connected to a computer. I wouldn't fret over it much. I know I've experienced similar issues with my Kindle from time to time, as well as with a whole host of other USB to pc connectable devices. ;)

Posted on May 25, 2012 11:05:41 AM PDT
P. Cudmore says:
I'm having the same issue. I can mount the kindle once fine. then go back to the computer and try to re-mount by plugging it back in. Nope. I will not mount. Restart computer. still no. Restart Kindle. Now it mounts. I've got this problem on my home and my work computer. Both are iMACs. I have not tried to replicate on a PC yet.

In reply to an earlier post on May 25, 2012 11:19:13 AM PDT
Denis Powell says:
Are you following the instructions in the user guide when you eject the Kindle. I had a similar problem on one occasion when I inadvertently used the wrong method. I was told that doing that could have resulted in a file becoming corrupted. A reboot solved the problem and it hasn't happened since.

Posted on May 25, 2012 3:13:10 PM PDT
Fud53 says:
Almost all devices that utilize a computer for it's brain require the occasional "reboot" to get them working like new. All of our computers require it, iPad, digital tv cable box, kindles, etc. It's the nature of the beast. I wouldn't worry about it unless it starts occurring more often.

Posted on Nov 28, 2012 5:55:22 PM PST
this product is plain and simple garbage. it will not mount on my imac, nor my mac mini. amazon is telling me i need special software. this is plain nonsense. if i go into system profiler it shows up as a USB connected device. should have stuck with buying an ipad mini. not happy with this purchase.

In reply to an earlier post on Nov 28, 2012 6:15:19 PM PST
dfn.ninja says:
So get the software dude. You're the one who bought two Mac devices and then stepped outside the fence right?

Posted on Jan 4, 2013 5:48:20 PM PST
C. Kennedy says:
I'm having the same problem with at least 2 different Kindle Fire's. I tried one because I'm working with Amazon support to diagnose another problem. They sent me directions to download an error log, transfer it to my computer via usb, then email it to them. Problem is that the device isn't connecting via usb. Just to confirm it's the problem Kindle, I try another Kindle fire, but it wont mount either. Ugh.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  9
Total posts:  9
Initial post:  Sep 5, 2011
Latest post:  Jan 4, 2013

New! Receive e-mail when new posts are made.

Search Customer Discussions