Customer Discussions > Kindle forum

Kindle fire hdx - How to change wifi frequency?


Sort: Oldest first | Newest first
Showing 1-6 of 6 posts in this discussion
Initial post: Jan 2, 2014 1:12:17 PM PST
I'm getting some interference that's causing my internet connection to cut out any time Bluetooth is on. Wifi signal from my router remains strong, but any app that uses internet tells me there is no internet connection. The problem remedies itself as soon as Bluetooth is turned off.

I assume this is an issue stemming from the frequency band the wifi is set to connect through, but with the Kindle's OS I can't find any option to change it. Can anyone help me out?

Posted on Jan 2, 2014 7:41:18 PM PST
Retired EE says:
The Wi-Fi band is set by your Wi-Fi source not the Kindle which in your case is your wireless router. If your router can be set to the N or B band that might help. You can also change channels on the router which is less likely to help because the frequency change is very small unless there is another Wi-Fi source on the same channel. Otherwise the Wi-Fi signal strength may be too weak.

In reply to an earlier post on Jan 2, 2014 7:54:33 PM PST
Old Rocker says:
As you can probably guess, that shouldn't happen. Sounds like a perfect chance to use the Mayday option.

I suppose there is a chance the HDX is drawing on the battery too hard and the WiFi radio isn't getting enough power. Try it while it's plugged in with the wall charger. It's a long shot. Sorry, best I can come up with.

In reply to an earlier post on Jan 2, 2014 7:58:27 PM PST
Thanks for the reply. My Android phone, an HTC One, has an option under Advanced Wireless Settings to specify Wi-Fi frequency band. I was hoping the Kindle had something similar. My router is currently set to b, g, and n. Would changing it to just B or just N help? I've already tried tweaking the channels to no avail. Also the router signal is plenty strong. It broadcasts far outside our house, and to be safe I've tested it from several different rooms.

Never had any issue with Bluetooth on any other devices connected to the router. Stumped as to why it's a problem with this.

In reply to an earlier post on Jan 2, 2014 8:07:33 PM PST
Old Rocker says:
Try turning off n on the router as an experiment.

Posted on Jan 2, 2014 9:27:48 PM PST
Last edited by the author on Jan 2, 2014 9:31:16 PM PST
PS56k says:
BTW - Bluetooth, WiFi, some cordless devices,
and all microwave ovens ALL use the exact same ISM 2.4Ghz freq band.
with the "other" WiFi freq band being 5.0 Ghz
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  4
Total posts:  6
Initial post:  Jan 2, 2014
Latest post:  Jan 2, 2014

New! Receive e-mail when new posts are made.
Tracked by 2 customers

Search Customer Discussions