Winter Driving Best Books of the Month Valentine's Day Shop Learn more nav_sap_SWP_6M_fly_beacon St Lucia easycohice_2016 All-New Amazon Fire TV Beauty V-Day Valentine's Day Cards Create an Amazon Wedding Registry Amazon Gift Card Offer chiraq chiraq chiraq  Amazon Echo All-New Fire Kindle Paperwhite Prime Exclusive Savings in Video Games Shop Now SnS
Customer Discussions > Kindle forum

Kindle app for Android - invalid item problem

Sort: Oldest first | Newest first
Showing 1-25 of 344 posts in this discussion
Initial post: Mar 24, 2011 7:06:55 AM PDT
Last edited by the author on Mar 24, 2011 7:13:23 AM PDT
There appears to be a problem with the Kindle app for Android.

The problem manifests itself as a messge 'Invalid item - please remove from your device and download again' when the user tries to open a book.

I'd appreciate if anybody has a solution or a potential solution to this if they could append details here.

There are quite a few discussions about it outside the Amazon forums - but surprisingly few mentions of it here.

I have this problem on my own android tablet - which I bought as an addition to my kindle (3g) - to give me a 'read in the dark' mechanism that was a bit less klunky than the couple of lights I have tried. There are other options but a cheap, entry level, 7" android pad looked like a good option - but clearly not if the app is flakey.

Some specifics of the problem :

It definitely still occurs on the latest version of the app

It is not by any means universal - only some users/devices are affected - but inconsistently as far as I can determine.

It may occurr only on Android 2.1 or below - or even only on 2.1 - it does appear not occur on most 2.2 devices. (2.1 and 2.2 form such a large percentage of the android device population that it is not clear if the lack of reports on 1.6 are not just a result of the small number of these devices and their generall unsuitability for use as a book). Most android users are stuck with the version they start with, upgrading android is only practical for a few as it requires considerable specialised knowledge unless the device vendor releases an upgrade.

It only occurs on some books on the affected device - and it appears to affect books which were purchased and not the free classics - interestingly it does affect free books which were offered free for a limited time and were at one time, or are now, chargeable.

The requested action - 'delete and redownload' - does not resolve the problem.

There are reports of the problem being resolved by repeated removal and reinstallation of the Kindle app with the clearing of some log data between the removal and reinstallation - dalvic logs are particularly indicated in this regard. But most reports are followed up with confirmation that the problem reoccurs later on any subsequently downloaded books. And this has not worked for some people (including me :-< ) despite repeated attempts.

There seems to be some confimration that the problem can be resolved by rebuilding the device image without a JIT component (also dalvic) - but this is beyond the skills of most users and not practical on some devices where not all componets are available to rebuild the image.

However the problem definitely occurs on some builds which don't include the JIT component so this is not the whole problem - and may even be misleading.

I'd appreciate if anybody can add any further information - or advise me if I anything I have provided above is incorrect or incomplete.

Thanks, John.

Posted on Mar 24, 2011 8:12:56 AM PDT
Karen C says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Mar 24, 2011 9:17:15 AM PDT
Last edited by the author on Mar 24, 2011 9:18:03 AM PDT
Thank you Karen,

You and many others are quite happily using Kindle for Android with no problems - but there is an unfortunate subset who are having problems - and the problem has been reported for at least 6 months and has not been resolved or even fully defined. It seems that most of these folks have just walked away and moved to a different device or to a different book store - personally I'm invested in Amazon (in the sense of owing books here) and I'd like to get it working on my android - I already have a kindle and I use the kindle app on my PC.

Perhaps you can add to the resolution by telling us which device and android build and version you are using successfully.


Posted on Mar 24, 2011 10:37:11 AM PDT
Moe Zilla says:
Ironically, I've been having problems using the Amazon App Store for Android. If I believed in conspiracy theories, I'd wonder if the Android operating system had declared war on Amazon and was hobbling all of Amazon's apps! :)

Hopefully somebody in this discussion can point you to some good information.
David Cassel, Editor
"Me and My Kindle" blog

Posted on Mar 24, 2011 12:57:34 PM PDT
M. Smith says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

Posted on Mar 24, 2011 3:08:49 PM PDT
Last edited by the author on Mar 24, 2011 3:09:06 PM PDT
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Mar 24, 2011 3:16:55 PM PDT
Last edited by the author on Apr 8, 2011 1:24:15 AM PDT
Thanks Mike,

I probably should have bought a galaxy. 20/20 hindsight!

But it would still be good to solve he current problem - I haven't been impressed with android which I have had to learn more than necessary about to try and address this issue. I have a tech background so it's managable, but rooting a device and exploring it with debug tools are not part of the 'consumer experience' these devices are aimed at. And I haven't resolved it, I've just eliminated some suggested possibilities.


Posted on Mar 24, 2011 3:23:23 PM PDT
Last edited by the author on Mar 24, 2011 3:26:03 PM PDT
John Newton says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Mar 24, 2011 4:48:42 PM PDT
M. Smith says:
I can only imagine the file is corrupt, maybe incomplete or partially downloaded. Does downloading using 3G differ from using WiFi? There can be long periods between data packets using 3G that the device might think the download is complete but the app realizes the file is actually incomplete.

In reply to an earlier post on Mar 25, 2011 7:25:33 AM PDT
Thanks M,

My tab is wifi only so cellular download is a 'red herring' here.

Data corruption can also be eliminated as I downloaded my entire set of archived items to the android and checked each one - there was a direct correlation between the books which failed and the paid books - and all the fully free books such as the classics opened with no difficulty. The suggestion on another forum is that there is some difference in the DRM on the paid (or sometimes paid) books and the DRM on the free classics and that this may be the key to the issue. I also checked the files sizes with my PC and Kindle and the sizes of the failing books were comparable so there didn't appear to be any chance of corruption affecting just the 'bad' books though the correlation with the paid books already makes this pretty impossible.

However nobody has added to this discussion who also has the problem - so maybe there are only a very few of us - there are several discussions on this subject which I have found on various Android forums and I will watch those as well to see if anything pops up.

Thanks for your help.

Posted on Apr 7, 2011 12:34:00 PM PDT
Jane T. Lee says:
I am or rather was reading paid books on a zenthink z-180 using the android for kindle app. I have uninstalled and reinstalled the app and still get a invalid message for my books..I hope there is help coming as I want to finish the book ...I started on Vacation .

In reply to an earlier post on Apr 7, 2011 12:40:52 PM PDT
Mary Jane says:
If you uninstalled the ap and then reinstalled it, Amazon may not recognize it as a registered device anymore. When you originally downloaded the books, they are coded to read on certain devices that are registered to your account. You probably just need to re-register your zenthink to your Amazon account and possibly re-download your books.

In reply to an earlier post on Apr 7, 2011 12:44:54 PM PDT
If I understand you correctly, you must be downloading your books from Amazon to your computer and then copying them to your Android? If so, are you downloading copies specifically for your Android, rather than for your computer? Each copy of each DRMed book from Amazon will work on precisely one device. The device must be registered to your Amazon account and must be specified at the time you do the download. Putting a file that contains the DRM for another device, even one on the same Amazon account, onto a device and trying to read it there will result in precisely the message you are getting.

In reply to an earlier post on Apr 7, 2011 12:57:55 PM PDT
Mary Jane says:
You may be onto something. However, an ebook purchased from Amazon may work on as many as 6 simultaneous devices but they have to be registered to them. If you downloaded a book to your computer, you cannot just transfer it to the tablet. But, you can download it directly to the tablet from the archives as long as the tablet is registered to the same account as the computer. Or you can go to Manage My Kindle and send the book to the tablet.

Posted on Apr 7, 2011 2:39:31 PM PDT
Last edited by the author on Apr 8, 2011 1:21:13 AM PDT
Mary, Melinda,

I appreciate you contributions - but these issues have been excluded.

Jane - sorry to hear you're having this problem. You can, of course, finish you book on the Kindle for PC (or Mac) application if you don't have a 'real' kindle. From the sound of things you seem to have introduced the problem to your device - which suggests something you installed or changed has caused it. You should be able to fix it by resetting your device back to its original state - which is a fairly major undertaking if you have a lot of data on it - and if you are careful about what you do subsequently you may even be able to to tell what event 'broke' the kindle app. In which case I'd be interested to hear what it was.

The devices are correctly registered and the books are being downloaded directly to the devices - I have explored many discussion about this on different locations on the web - a simple google search for 'android kindle invalid' will find a lot of discussions about this topic on a lot of different sites - some discussions are fairly simple and come to no useful conclusion or rework over old ground - but some are quite extensive and contributors have tested many scenarios.

In my case I reset my device right back to factory state - installed only the latest kindle app having deleted the previous registration through the Amazon site. I then methodically downloaded each book on my account - which comprises a number of free classics, an number of more recent books which were on special free offer and a number of books I had purchased. Every item was downloaded directly to the Android using the kindle app. But each of the purchased books and the recent free ones failed to open and all the classics opened with no problems.

I then purchased a couple of new books (they were on my wish list anyway) and acquired several new 'free offer' books and also added a couple more classics to my account - and retried the process with the new ones - and confirmed the results.

I then re-imaged my device with a more recent Android image from the manufacturer CnM (also Android 2.1) and began the process with an older version of the Kindle app - with identical results.

With the exception of one report from one forum where a developer was able to rebuild the contents of his android image and seemed to conclude that a component called JIT was a factor in the kindle problem I have seen no resolution - but I have seen reports of people who have fixed it once-off only to have it recur on the next downloaded item. I have not been able to reproduce this because rebuilding the Android image is not really possible unless you have one of the more popular devices like the galaxy pads or the google nexus phones which have very widespread developer support. But I have been able to confirm with debug tools that my build does not appear to include the suspect JIT component so this suggests that the cause is a related component rather than this specific component.

Poking around inside an Android device (in software terms) is not particularly easy - it is an embedded environment and designed to prevent users inadvertently destroying their phone/pad so once an app doesn't work there is not a lot to do until either the app developer produces a fix or the device manufacturer releases a new image which doesn't cause the problem.

But there is not much hope of Amazon fixing this as it is not a common problem - but very frustrating for the few that have it, most of whom do have other means of reading their Amazon e-books.

I only got into this trying to find a backlit device as even the reading lights which attach to the Kindle are too bright for my partner - the resolution is that I read on my phone (win mobile 6.5) at night and usually free books from Gutenberg etc or items I have purchased from Baen (no Kindle app for WM 6.5, unfortunately [thanks Amazon] - and no WM 7 upgrade for my phone [thanks HTC]) and then use my kindle where there is light.

(hint to Amazon - I'd buy more e-books if I could read on my CnM Android 2.1 pad - or if there were a backlit kindle with a good brightness control)

Posted on Apr 8, 2011 10:51:15 AM PDT
flipoid says:
I have a Pandigital Novel; yesterday I wanted to download the Kindle app for Android. I was able to download and install the AmazonAppstore, but when I try to download the Kindle app, I keep getting an error. Talking with Amazon/Kindle CS, I'm told that if your "tablet" device didn't come with the Android Marketplace pre-installed, you can't use the Kindle Android app. But there are lots of people here who have been able to download the App to their Nooks, and also people who have the same model of the Pandigital Novel that I have (with the new firmware), who have the Kindle app.

Can anyone help me?

In reply to an earlier post on Apr 8, 2011 10:55:19 AM PDT
Mary Jane says:
I see you are still having the problem. I saw another threat where the poster was also having problems with an Android tablet. I am out of suggestions. My Droid X works just fine. There must be some problem with the Kindle ap on Android tablets.

Posted on Apr 8, 2011 12:54:29 PM PDT

There is no link between having the android marketplace on your device and being able to run the kindle android app.

It can make it a bit more difficult to get it and install it - my device was supplied without the android marketplace but had the kindle app supplied as an APK file which could be direclty installed. The next update of my android did include the android marketplace and also included the kindle APK - and in this case I tried both installing the supplied APK and downloading from the market.

The amazon android application store can also be installed whether the android marketplace is installed or not and the kindle app can be installed from there.

Or you can just download the kindle app directly to a pc and transfer it to your device and install it that way.

In general you can easily get copies of the .apk file for any free android application including the kindle app and install them yourself.

The latest kindle app .apk file is called 'kindle204103870164.apk' - and is readily available on the web.

In reply to an earlier post on Apr 8, 2011 1:08:44 PM PDT
flipoid says:
Thanks for the information. I did find the .apk file for the Kindle app on other sites (the problem was that even though I can and have downloaded the AmazonAppStore, the Kindle app through the Amazon store gets stuck mid-download). On my Pandigital Novel, do you know *where* I would put that .apk file and how to install it once it's on my device?

When I go to the Android Marketplace on my Novel (using the browser), I log in with my Google email, and I get a message that says there is no device associated with that account--so I can't get anything from the Android Marketplace.

I have, as I just mentioned, installed Amazon's app store--but from *within* the Amazon store, I can't download the Kindle app--it gets stuck. After an hour-long conversation with Kindle CS last night, I got an email that gives what's apparently Amazon's "official" stance:


Kindle for Android is a free application that lets you read Kindle books on your Android--no Kindle required. Amazon's Whispersync functionality automatically synchronizes your last page read so you can easily switch between devices and pick up reading from where you last left off.

Kindle for Android can be used on Android OS 1.6 or greater. The app is not available on tablet Android devices that do not come with the Android Market pre-installed by the manufacturer.

It can be downloaded for free at

Thanks for your interest in Kindle.

Best regards,
(Kindle rep)"

Again, I did find the file--but I don't know where to put it on my Novel (what level--root or within a folder), and how to get it to install once it's on the Novel. Any help would be greatly appreciated.

In reply to an earlier post on Apr 12, 2011 3:35:39 AM PDT

I am not very familiar with Android devices in general - I only have one (a CnM 2.1 pad) which I bought specifically to use with the Kindle Application, which is why this situation is so frustrating.

On my device there is an application called APKInstaller which can be used to install APK files directly - it can also be called directly from the APPs section of the the main setting menu.

I have been trying to get the APK files for all my apps as it makes the whole cycle of resetting the device and starting from scratch much easier if the apps are installed from local .apk files.

There are older versions of the Kindle for android application available on the web - Some users have reported resolving other difficulties with the application by using older versions. Unfortunately having run through sever different versions that I have found, ans all of which installed successfully for me, I found that the problem with opening the DRM books was present with all versions of the application on my device.

Posted on Apr 12, 2011 11:06:44 AM PDT
John (Mr. J. Stafford Langan).

Thank you for your persistence.

My Craig 7-inch Touch Screen Tablet with Android 2.1 is having the same problems you describe in the first post. I removed & downloaded the items, and installed & reinstalled the Kindle App for Android .. multiple times, without success.

On the tablet, I can read 4 titles.. 2 paid and 2 free. However, the app displays "Invalid Item ... Please remove the item from your device and go to Archived Items to download it again." for 7 paid titles and the New Oxford American Dictionary, which is neither free nor paid.

After reinstalling the Kindle App for Android, I logged in to and followed links to Your Account > Manage Your Kindle. Under "Your Computer and Other Mobile Device(s)", I found multiple occurrences of "Android Device", removed all but the last one, and renamed it to something useful. I recommend you do the same, just to reduce confusion (yours and Amazon's).

Under "Your Orders", for each title, I chose "Deliver to" and selected each device in turn. Each title was refreshed in both the tablet and the PC, but opening each title on the tablet resulted in the "Invalid Item ... " message.

I am able to read all of the titles using Kindle for PC. I was able to read all of these titles on my Motorola Droid .. until an unfortunate incident with a sick infant and walking into a shower fully-clothed, but that's a story for another day. (;-)

Thank you,
- David

Posted on Apr 13, 2011 10:57:17 AM PDT
Thanks David,

Sorry to hear that you are having the same problem - or almost the same, as it seems that you could (can?) read 2 of your paid books.

Each time I reinstalled and reregistered my device I was careful to delete the old device on the 'manage your kindle' page - but this is good advice for folks to keep managing this device list if they do reset / reinstall Android on their device - typically just deleting and reinstalling Kindle (even a different version of the app) doesn't create another android device. But renaming it to something recognisable is good advice.

At this stage I have nowhere to go on this - I have rebuilt my device from the two manufacturer's images available several times - and I have set up just the android kindle app using all the versions I could find and nothing else, and each time I have hit the same problem.

I have asked the manufacturer (CnM) for as basic an android image as possible, as it is not possible to uninstall an application which is preinstalled on the original image - but I have only faint hope of their providing it - and not much expectation that it will resolve the problem if they do.

I have advised Kindle support of the problem and asked that they investigate, but it is not a widespread problem and it doesn't seem to be anywhere near the top of their list of priorities. I have not spent the hours on the phone to kindle support that others have as I don't believe that there is any chance that this issue is resolvable by first line support staff however well intentioned they are.

One issue that occurred to me a few days ago but I have not worked out how to test is whether there is some localisation setting affecting this. My Amazon account and my Google account (which the android knows) are based in Ireland. I have been wondering if there is some simple US-only (or NA only perhaps) rule for the kindle android app. However as well as a real kindle and kindle for PC I have also registered my daughter's ipod touch and this has the same localisation settings through i-tunes as the android has but does not have the invalid item issue (nor have I heard of it on any i-pod/i-phone/i-pad).

I'm slightly frustrated with this as my phone is a WM 6.5 device - and I had been waiting for Amazon to make kindle available on it - as I have been using it and its predecessors right back to my original palm as a reader with the e-reader software - but when kindle did arrive on windows mobile it was only on the recent WM7 platform. Of course e-reader also works perfectly well on my android so I have bought books on fictionwise and elsewhere which means I have little silos of paid e-books on quite a few different sites - and I'd really love to have my e-library all in one place, at least for future purchases, I had hoped on Amazon as have an expectation they will still be here in the future. But this looking increasingly unlikely as a single repository. Coupled with the minor annoyance that being in Ireland I have to buy physical books from and have to buy e-books from and ne'er the twain shall meet. So the UK site keeps trying to persuade me to buy a kindle (which it won't then sell to me) and the US site keeps trying to persuade me to buy books (which it won't then sell to me).

Of course I'll be first in the queue when a backlit kindle is available - at least first in the second class queue that I'll get put into for having the temerity to have not been 'born in the USA'.

Sorry for the rant !


In reply to an earlier post on Apr 13, 2011 2:19:27 PM PDT
flipoid says:
Mr. Langan, thanks again for your help. I was actually able to get the Kindle app installed on my Pandigital Novel, but now, even though my device is registered to my Amazon account and I can see my Archives, every time I try to download a book, I get a "download failed" message.

I called Kindle CS a second time, and the rep did NOT give me the same response I got from the first rep. He submitted a ticket to the techs, and he said they will try to solve the problem and get back to me.

So, there has been a little progress. (-:

Posted on Jun 6, 2011 3:24:06 AM PDT
There have been two new releases of Kindle for Android since I started this discussion - neither fixed this problem.

I have pretty much given up trying to get my android pad to run the Kindle app - which is a pity as it was the main reason I bought an android pad - so it has just become another dust gatherer.

From the other reports on the web it seems I was just unlucky - a small number of android releases have this problem, and there doesn't seen to be a fix for it, unless the vendor of the device releases a new image without the problem. But as it isn't clear what component of Android is causing the problem there is no guarantee that a new os release for the device will fix the problem.

In reply to an earlier post on Jun 6, 2011 10:11:32 AM PDT
Jane T Lee says:
I am in your boat as well sada to say Another useless toy... darn it Jane
‹ Previous 1 2 3 4 5 6 7 8 9 10 ... 14 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
RAOK, welcome to the wonderful world of RAOK 6728 2 minutes ago
Hear Ye! Hear Ye! We're Quirky And We're Not Going To Take It Anymore! 2016, You've Been Warned! So Geese And Tally Ho! 1417 2 minutes ago
4 Letter Word Language Filter for Text-to-Speech 10 17 minutes ago
Potentially Perky People - Part Deux 7123 37 minutes ago
Syncing Collections 18 37 minutes ago
Forgot what book I'm reading! 4 40 minutes ago
KINDLE KITCHEN #5: Home of Family, Friends and Good Food 5923 41 minutes ago
Al's Place 36 Degrees of Separation 1241 49 minutes ago
Usb host need or help with kb 7 1 hour ago
Sorting unread books 1 1 hour ago
I can't believe you can buy free book's!! How awesome! 6 2 hours ago

This discussion

Discussion in:  Kindle forum
Participants:  228
Total posts:  344
Initial post:  Mar 24, 2011
Latest post:  3 days ago

New! Receive e-mail when new posts are made.
Tracked by 62 customers

Search Customer Discussions