Customer Discussions > Kindle forum

Failure trying to download PDFS from web using Kindle Fire Silk


Sort: Oldest first | Newest first
Showing 1-25 of 30 posts in this discussion
Initial post: Dec 12, 2011 2:18:59 PM PST
Shelley P says:
Have tried several times to download a PDF using the Silk browser in Kindle Fire. Each time it tells me the download fails. I have no problems downloading the files using my computer and any browser.

Any suggestions?

Posted on Dec 12, 2011 2:20:14 PM PST
Shelley P says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

Posted on Dec 12, 2011 2:49:30 PM PST
[Deleted by Amazon on Jan 5, 2012 5:55:46 PM PST]

In reply to an earlier post on Dec 12, 2011 2:53:25 PM PST
Last edited by the author on Dec 12, 2011 3:06:32 PM PST
Shelley P says:
Your answer was not helpful. In fact, I'm not sure why you responded at all.

I was able to download Amazon's user guide in PDF format from my online bookmarks site, so this is doable. Now I have to figure out why I can from one site, but not another.

Posted on Dec 12, 2011 2:56:36 PM PST
[Deleted by Amazon on Jan 5, 2012 5:55:47 PM PST]

Posted on Dec 12, 2011 2:56:48 PM PST
Cotton Socks says:
Shelley, how strong is or wifi connection?

It's possible it is making too many retries on a weak connection?

Justathot. :)

In reply to an earlier post on Dec 12, 2011 3:08:05 PM PST
Shelley P says:
That's a good suggestion, but no, that's not it.

I was able to download a PDF from my bookmarks page online at my web site, but not another set.

There's either something about the PDF I'm trying to access, or the way I'm accessing it. But it does begin to see that it is something site specific.

Posted on Dec 12, 2011 5:40:02 PM PST
Cotton Socks says:
Yup, that's a point that is often overlooked when assessing Download/Upload speeds. No matter how fast the actual wifi connection is, it can only operate as fast as the server on the connected website can feed stuff. If that website server is very busy with a zillion surfers, then each connected user gets only a tiny fraction of a second for each segment of transmission.

Posted on Dec 12, 2011 6:29:04 PM PST
Shelley, "Roast Beef flaps" is a troll. Ignore it.

If you're not able to fetch a file it's an Internet problem, not a Kindle Fire problem. The Kindle Fire can display PDFs without any help, but if you prefer, you can go to the appstore and download Adobe Reader.

In reply to an earlier post on Dec 12, 2011 6:38:38 PM PST
[Deleted by Amazon on Jan 5, 2012 5:55:53 PM PST]

Posted on Dec 12, 2011 7:30:54 PM PST
Shelley P says:
It's my server, and it does seem to be something to do with the server.

I uploaded the Kindler User's Guide to the server. I had already successfully downloaded it from Amazon, but the download failed from my server.

It's not a time issue, because the failure happens immediately. And I have no problem downloading with my computer running off the same wireless.

I think it's probably something to do with my Apache web server setup. I'll have to check the logs.

Thanks much, folks, for the help. I wanted to be able to place my research on my server and access from both my computer and Kindle Fire, as a backup. I'll just have to transfer the files via the micro-USB connection, instead.

And S. Yelvington, I caught that early on ;-)

Posted on Dec 12, 2011 8:29:44 PM PST
Last edited by the author on Dec 12, 2011 8:31:00 PM PST
J. Spotts says:
You can help to stop the proliferation of forum trolls by:
(1) ignoring them ... do not respond to what they post.
(2) See where it says: Do you think this post adds to the discussion? under his posts. Click No when ever Roast beef flaps makes a post that bothers you. When enough people click it ... his post gets hidden. This helps so others don't read any lies or useless information the troll posts.

And remember ... starving a troll is the most humane thing you can do. I read Roast beef flaps post because sometimes they make me laugh or smile :)

Posted on Dec 13, 2011 5:42:21 AM PST
Shelley P says:
Well, just thought I would provide an update, in case others run into this.

When I checked my logs, I found that access to the files was returning a 401--unauthorized.

This web site is password protected. When I access the site using the Kindle Fire, I do get asked for username/password and can access the web pages. However, because of Silks remote caching, the security credentials aren't passed through, and my site is denying the remote access, and hence me, download access to the files.

Yes, I do consider this a bug and will report it. But at least now I know why the problem is happening.

J. Spotts, thanks for the useful advice.

In reply to an earlier post on Dec 13, 2011 11:37:43 AM PST
[Deleted by Amazon on Jan 5, 2012 5:55:54 PM PST]

Posted on Dec 26, 2011 8:09:36 PM PST
Lisa Rowe says:
Glad I wasn't the only one to discover this. The fire / silk also ignore both the pragma no-cache and the HTTP cache-control / expires headers. Definitely a bug.

Posted on Jan 24, 2012 9:00:01 PM PST
So does that mean there is nothing we can do in the meantime?

In reply to an earlier post on Jan 24, 2012 9:28:31 PM PST
You can sideload a different browser like Firefox Mobile, opera, or dolphin.

In reply to an earlier post on Feb 21, 2012 1:35:23 PM PST
I tried to get all 3 of these browsers on my Kindle Fire, with no luck. Any tips on how to make this happen?

In reply to an earlier post on Jan 24, 2013 8:13:08 AM PST
Cathy Conroy says:
I am having the exact same issue. It's been over a year. since you posted this. I guess amazon does not see it as a high priority bug to fix!!

Posted on Mar 20, 2013 2:02:25 PM PDT
sjbrit says:
I was having a problem downloading a pdf from a site. In other browsers on computers and loads the pdf just opened once downloaded. On Silk I finally discovered I had to go to the menu and pick downloads, from there I could open the pdf file. Not sure if this helps!

Posted on Mar 28, 2013 12:08:42 AM PDT
KV Trout says:
My Kindle Fire is very disappointing in terms of web browsing. For example, I go to the local City bus schedule page, click on the schedule which is pdf format and it doesn't open. Were it my laptop it would open, automatically, no need to download any app or program (Acrobat is included I think with any laptop)... Yet with my Fire (HD) this is what happens:
When I click the link to the pdf it says "Downloading". Then: Nothing happens.
I look in Documents. It's not there.
I go back and download the pdf again. It says "Downloading" but it then does not open NOR is it available anywhere I can find on the Drive.

What's up with this?

In reply to an earlier post on Mar 28, 2013 12:29:09 AM PDT
CBRetriever says:
it goes to a downloads directory if i'm remembering rightly (my Fire is at home) and I used ES File Explorer to locate and open it

aha:

To view downloads:

Tap the Menu icon (3 bars in a box) on the bottom or right side of the page and then tap Downloads.

In reply to an earlier post on Mar 28, 2013 2:20:22 AM PDT
Barbara says:
Yep. However, the password-protected PDFs issue is still unsolved. I can't access my magazine subscriptions or download stuff from my university website, for example.

In reply to an earlier post on Mar 28, 2013 3:11:55 AM PDT
KV Trout says:
Yes I tried that, and the pdf is not there!
I also tried a file explorer and there is no pdf anywhere to be found.
This is not a protected file, it is a bus schedule from a city bus web site!

I don't understand why Amazon doesn't make a browser that just automatically opens up pdf's like a lap top does! I click on VIEW pdf, it shows "Downloading" and then nothing happens, and the pdf is nowhere to be found. I'm very disappointed in how the Fire handles web surfing, it's kinda klunky if you ask me.

In reply to an earlier post on Mar 28, 2013 3:19:01 AM PDT
CBRetriever says:
I wonder if it's because the website would normally open a pop up with the pdf? The few times I've clicked on pdf maps (in my case train ones), they've downloaded and then were viewable.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
NEWS: Kindle for iOS 4.8
0 27 days ago
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Announcement
Meet other story lovers at Write On by Kindle
41 4 days ago
Announcement
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 Feb 2, 2015
May Informal Poll--What are you reading 47 6 minutes ago
SwagBucks Thread 5891 11 minutes ago
We're So Quirky, Our Chihuahuas Ride Bicycles! So Geese and Tally Ho! 6203 14 minutes ago
Freebie Books - Links Only - No Self Promotion IV 883 22 minutes ago
sirius xm app update 6 22 minutes ago
Dragi's Croatian Crab Shack and Wine Bar - The times they are a changin' 7341 24 minutes ago
sync table with kindle 0 26 minutes ago
Discounted / Price Dropped Kindle eBooks III 5987 46 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  16
Total posts:  30
Initial post:  Dec 12, 2011
Latest post:  Jan 30, 2014

New! Receive e-mail when new posts are made.
Tracked by 7 customers

Search Customer Discussions