Customer Discussions > Kindle forum

Unable to Eject Kindle (Windows 7)


Sort: Oldest first | Newest first
Showing 1-25 of 33 posts in this discussion
Initial post: Feb 19, 2011 9:05:12 PM PST
Last edited by the author on Feb 19, 2011 9:08:41 PM PST
I have properly attempted to eject my Kindle using the "eject" button in the lower right tray. The Q&A Forum Suggested posting a help request here. The screen retains the usb cable picture.

Is this a vista/win 7 bug or similar problem? The Kindle is brand new.

TIA,
Eric

Posted on Feb 19, 2011 9:21:31 PM PST
Last edited by the author on Feb 19, 2011 9:22:33 PM PST
Christie says:
Start--->Computer--->right click on Kindle drive--->select eject

This should work.

ETA: I've never been able to properly eject from the lower right tray.

In reply to an earlier post on Feb 19, 2011 9:21:49 PM PST
D. Payne says:
I also have this problem and have windows 7 as well... any help would be appreciated as I find I can't read my kindle when it is charging!

In reply to an earlier post on Feb 19, 2011 9:59:25 PM PST
Thx for the reply. I should have mentioned I tried this and it didn't work. Any other ideas?

Posted on Feb 19, 2011 10:25:27 PM PST
FAMILY LUV says:
I have XP and have the same problem. I don't have anything in rt. corner to eject from. Please help.

Posted on Feb 19, 2011 10:47:32 PM PST
krystalspin says:
Family Luv --

I have XP and have no trouble "safely removing" from the icon in the system tray that looks like a green arrow over a gray rectangle. You will have to click on the blue circle with the left pointing < (that says 'show hidden icons' when you hover over it) to see the icon you want. Left click and choose the Kindle's drive letter.

The directions on all of the Amazon pages say the icon is in the left corner and to use the right-click, but they are backwards.

Now, someone recently posted that it didn't work for them on XP -- and it appears that the Vista/W7 instructions also work for XP:
"Windows Vista and 7: Click on the Start button, select "Computer" from the options, right-click on the Kindle drive icon and select "Eject" from the pop-up menu. "

@ D.Payne
As above.

@ Eric
You should try Computer/Kindle-Drive-Letter/right-click/Eject again. Hold your mouth right. That is how it's done.

In reply to an earlier post on Feb 20, 2011 6:33:52 AM PST
Bjeans says:
I have XP too.

Click on the Start button
Click on My Computer
The drive your Kindle is on will be listed. (On mine it's "G" but yours will be different.)
Right click on the Kindle drive and select "Eject Kindle"

In reply to an earlier post on Feb 20, 2011 6:36:22 AM PST
Jazzy_Jeff says:
[Customers don't think this post adds to the discussion. Show post anyway. Show all unhelpful posts.]

In reply to an earlier post on Feb 20, 2011 6:48:29 AM PST
Tinker-bella says:
Professional Snark aka Jazzy_Jeff says:
"I would throw the Windows computer out the window. That would solve all your problems. :)"

Yes, but then the poor Kindle would be attached and go out the window as well! ;)

Posted on Feb 20, 2011 6:59:05 AM PST
CLS10 says:
I have windows 7 and I've never had problems ejecting anything, including the kindle--and I eject from the lower tray.

I'm not sure what's going on here.

Posted on Feb 20, 2011 7:01:47 AM PST
Jazzy_Jeff says:
If you can't get the Kindle to eject you could always shut down the computer and then you will be able to remove the Kindle safely. I know that is a hassle but safe.

Posted on Feb 20, 2011 7:11:10 AM PST
Is there a 'defenestrate' button?

Posted on Feb 20, 2011 9:28:56 AM PST
Eric135 says:
I have heard of this problem, and it sometimes happens when you try to eject a USB device while Windows Explorer is open and pointing to the device. So you might try shutting down Windows Explorer (or pointing it specifically to another drive) and then try the eject button in the lower right tray.

Hope this helps,
Eric

In reply to an earlier post on Feb 20, 2011 10:08:27 AM PST
FAMILY LUV says:
Thank you bjeans. It worked for me. I use to have an icon in my tray but I don't know where it went to, but it is gone. I went to my start-up's and it isn't there either. I think I will have to get me a new PC before long. This one is crazy. Has a mind of it's own.
Thank you again for your help. gen

In reply to an earlier post on Feb 20, 2011 10:53:30 AM PST
Bjeans says:
You're welcome. I think that method is pretty standard, and only takes a few seconds, once you know how to do it, that is. Someone had to tell me, too. : )

Posted on Feb 23, 2011 11:39:34 AM PST
I also can't eject Kindle. I have Windows 7 64bit and after usb eject command invocation, the operating system reports that Kindle is ejected, but Kindle device has still screen with USB storage mode displayed.... I have no Explorer opened.

Posted on Feb 23, 2011 11:43:11 AM PST
If for what ever reason your Kindle fails to eject and the device is not being written to or read (flash memory, that is) just unplug it and get along with life. No harm to puter or Kindle.

In reply to an earlier post on Feb 24, 2011 12:27:24 AM PST
D. Payne says:
Yes! My exact problem. It's a pain but I guess not the end of the world.

Posted on Feb 27, 2011 4:07:02 PM PST
solution for windows 7

if you try to eject the kindle from the notification area ( I use win 7 64 ) it does not work at all for the kindle.

INSTEAD, go to WINDOWS EXPLORER an you'll find a drive called KINDLE (x:).
clicking with the right mouse button on it, you'll get among several, the EJECT option.
works a 100%.

juabba

Posted on Feb 27, 2011 4:17:57 PM PST
Bjeans says:
Absolutely, though the drive may be different for different people, depending on what else is hooked up to the computer. But maybe that's just an XP thing? My Kindle drive is G, for example.

Anyway, that's how I eject my kindle too, though through My Computer instead of Windows Explorer.

In reply to an earlier post on Feb 27, 2011 4:32:59 PM PST
agree with you

from WINDOWS EXPLORER as well as from My Computer, it works

Posted on Feb 28, 2011 8:58:26 PM PST
Barbara says:
First make sure there are no applications accessing your Kindle. Close any windows explorer windows that show your Kindle directory, close Calibre or any other management software. Give it a few minutes. If it still won't eject, logging out and then logging back in will often close any programs that have failed to close properly. Failing that, you can either shut down the computer as someone else has suggested, or pull the plug anyway: most of the time, it doesn't really matter - there's just a small chance that something will be corrupted.

Posted on Mar 1, 2011 3:48:07 AM PST
L L. says:
I have to go in from my computer, If I do it from the tray , it shows it as being ejected, but it isn't. I just don't bother anymore, I read where it doesn't hurt anything, only causes you to lose some data if you're in the middle of sending books.

In reply to an earlier post on Jun 19, 2011 4:08:13 PM PDT
B. Smith says:
Yes, it worked for me. I used to be able to right click and eject from the task bar icon tray but since I loaded all these books, it no longer allows me to eject the Kindle from there. I believe it has something to do with Kindle indexing all the books with every USB charge. I kept getting the message " Device cannot be ejected right now. Try again later." This never happened when I only had about 40 or so books. Now I have way more than that but using windows explorer as you suggested didnt give me any problems ejecting the Kindle at all. Many thanks!!

In reply to an earlier post on Jun 19, 2011 4:16:10 PM PDT
Dragi Raos says:
Juan's procedure is correct - use "eject" from context (right click) menu of Kindle device icon, *not* the tray icon that is on Win7 confusingly also named "eject", instead of previous "Safely remove hardware".

Kindle should revert to its "normal" state. However, sometimes the icon does not disappear. You can use the tray "eject" function then, as a second step, to make it disappear.

BTW, if your Kindle stays with that "charging" screen with Vulcan fork (USB) icon, you can disconnect it without fear a minute or two after you finish any transfers. Device caches will flush by then.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
Software Update for the Original Kindle Paperwhite
0 3 days ago
Announcement
News: Kindle for Android app Update 4.13 Now Available
0 9 days ago
Announcement
Amazon Introduces New Kindle Paperwhite: The Most Popular Kindle, Now Even Better
0 17 days ago
Announcement
News: Kindle for iOS Update 4.9 Now Available
0 May 27, 2015
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Announcement
Meet other story lovers at Write On by Kindle
60 May 19, 2015
Announcement
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 Feb 2, 2015
SwagBucks Thread 6680 38 seconds ago
Kindle Paperwhite - sudden hairline crack in screen 91 46 seconds ago
Free Books and Chat... July 2015 105 53 seconds ago
Kindle won't sync on my Samsung tablet, it doesn't see wireless 19 8 minutes ago
Kindle Fire Tips: Getting Started 2 5752 12 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  26
Total posts:  33
Initial post:  Feb 19, 2011
Latest post:  Jan 24, 2015

New! Receive e-mail when new posts are made.
Tracked by 6 customers

Search Customer Discussions