Customer Discussions > Kindle forum

Kindle Store Language


Sort: Oldest first | Newest first
Showing 1-11 of 11 posts in this discussion
Initial post: Jan 23, 2013 2:42:51 AM PST
My kindle is set to English, but when I connect to the kindle store via wifi it is in Chinese (I am connecting from Hong Kong). How do i change the setting in the kindle store to english?

Posted on Jan 23, 2013 3:57:25 AM PST
Last edited by the author on Jan 23, 2013 3:57:46 AM PST
CBRetriever says:
I have a feeling that you may be registered to amazon.cn - it happened to the guy here

http://www.amazon.com/gp/help/customer/forums/kindleqna/ref=cm_cd_search_res_ti?ie=UTF8&cdForum=Fx1GLDPZMNR1X53&cdPage=1&cdSort=oldest&cdThread=Tx1AAIGQSXX2HD3#MxHA9DSJ72SWK3

and he was able to fix it by changing your country to Hong Kong and not China and/or registering it / deregistering it

Posted on Dec 13, 2013 12:15:05 AM PST
Jam65 says:
Not such a happy experience here. I just visited China with an English-language Kindle Paperwhite (registered in an English-language country) and had the language automatically change to Chinese. Changing language back to English was not possible for the Kindle Store - exceptionally frustrating as surely a sizeable advantage of Kindle over print is being able to find books to read whilst on the road on a foreign country.

On exiting China the Kindle Store language did not revert to English - I had to reset the Kindle over again.

My two cents? If you're going to have a mechanism to force an involuntary language-switch onto a Kindle Store user on entry to China then have a similar one set it back on exit. Or make the language setting of the Kindle apply to the Store also.

So Kindle is useless for English-language users in China. And passing through there with it stuffs it up. At least that is my direct experience

In reply to an earlier post on Dec 13, 2013 12:18:28 AM PST
CBRetriever says:
it was a glitch and has since been corrected:

Initial post: 13 Dec 2013 02:34:19 GMT
Jenn F. - Forum Moderator says:

Hi, Pro's! We've seen discussions where customers with the Kindle Paperwhite are being linked to the Kindle Store in China instead of the Amazon.com Kindle Store. I wanted to stop by and let you know that a fix has just been deployed for this issue. If you run into this, a quick deregister and re-register will resolve any issues.

In reply to an earlier post on Dec 13, 2013 2:31:41 AM PST
Jam65 says:
Thanks for the speedy response CBR,

A quick query re - "a fix has just been deployed"?

does this mean that, on my next visit to China, I will not encounter this phenomenon (my interpretation of a "fix") or that the fix is to "deregister and re-register" on my exit?

In reply to an earlier post on Dec 13, 2013 3:03:00 AM PST
CBRetriever says:
dunno, but I took the post to mean that the fix is permanent

Posted on Dec 27, 2013 3:33:29 AM PST
Last edited by the author on Dec 27, 2013 3:55:08 AM PST
Sandy Bear says:
This just happened to my wife as she just arrived in Thailand. Her Kindle is registred in US, and has always been in english but is now in chinese (in Thailand!?).... She wanted to purchase a few books on her well earned vacation but is unable to do so... This is a silly bug and Amazon is clearly losing purchases from vacationing/travelling kindle customers...

Posted on Jan 24, 2014 10:13:03 AM PST
Mel says:
I have also just started using my kindle in Thailand but the store is in chinese....I really want to be able to browse in english...Is there a fix for this? I live in Thailand so really need to be able to browse in English while I'm still in this region.

In reply to an earlier post on Jan 24, 2014 10:30:15 AM PST
CBRetriever says:
deregister it and then reregister it - it seems to work for most people

Posted on Feb 13, 2014 7:49:05 PM PST
Last edited by the author on Feb 13, 2014 7:51:01 PM PST
This happens most likely because your Kindle Store has no definite country setting. I registered my new Kindle this morning from Thailand and encountered the same problem as Mel. What I did was to sign in onto my Amazon account on my laptop and it now works fine for me.

Your Account > Manage Your Kindle > Country Settings

As I understand it, once you have set a country for your Kindle it should go to that store no matter where you are in the world.

In reply to an earlier post on Feb 13, 2014 8:41:50 PM PST
Paxton says:
Programmers should know to avoid making "silly" bugs.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
NEWS: New Update for Kindle Reading Apps on Android and iOS
75 6 hours ago
Announcement
Hachette/Amazon Business Interruption
0 May 27, 2014
Announcement
Have a Kindle Question?
0 Sep 12, 2012
FB&C--Free Books and Chat--Thursday July 10, 2014 12 55 seconds ago
Kindle / Audible Recommendations and Deals (KARD) 1534 2 minutes ago
keyboard sometimes blocks screen, how to hide??? OH! Kindle Fire HD 6 3 minutes ago
OT: Discussion - (Freebie Books Links Only) 1415 3 minutes ago
Quirky Children/Young Adult Book, called Monster Ballerina-Only 3 bucks! 2 5 minutes ago
Sudden issues with Facebook on Kindle Fire 14 8 minutes ago
Can Kindle grey screen ($59 and $69) read PDF Format in Chinese? and can they download apps? 9 13 minutes ago
FREE Books & Chat - Wed July 9, 2014 96 17 minutes ago
Can't charge my kindle 4 25 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  7
Total posts:  11
Initial post:  Jan 23, 2013
Latest post:  Feb 13, 2014

New! Receive e-mail when new posts are made.
Tracked by 2 customers

Search Customer Discussions