Customer Discussions > Kindle forum

Kindle 7in HD suddenly freezes; refuses input


Sort: Oldest first | Newest first
Showing 1-7 of 7 posts in this discussion
Initial post: Jun 27, 2014 11:57:07 AM PDT
BrowNServe says:
It's now 2:48 pm. At 12:00 finished playing android game Pacific Fleet, Kindle frooze at Home screen: 12:00PM wifi logo 66% battery charge, and has been that way sense refusing all input, including touch.

I'm waiting for the battery to die down hoping it will then accept input. Is there anything I can do other than wait, and is there any known cause of this behavior?

Posted on Jun 27, 2014 11:58:47 AM PDT
Last edited by the author on Jun 27, 2014 11:58:57 AM PDT
T. Cook says:
To Do: Hard Reboot.
Cause: Your game probably crashed your Kindle.

Posted on Jun 27, 2014 12:01:22 PM PDT
press and hold the power button and count slowly to 30. Release the button..... then press again to turn the device back on.

THat is a hard reset and might fix the issue.

Posted on Jun 27, 2014 12:01:57 PM PDT
BrowNServe says:
Great! Just checked forum, found solution. Held button for 30 sec., etc. Sorry. Anyway, T.Cook, thanks. Wasted two whole hours, couldda been playing the Fleet...:)

Posted on Jun 27, 2014 12:42:01 PM PDT
Red Car Lady says:
I have a Kindle Fire HD which turns on when I open the cover (i.e. no on button). I was reading a book, closed the cover and reopened it about 30 minutes later. The Kindle does not turn on. I had about 40% battery life left but recharged it overnight "just in case". It still doesn't turn on. Any suggestions?

In reply to an earlier post on Jun 27, 2014 12:50:10 PM PDT
there is an on button and the case also allows access to it. The case just eliminates your needing to push that button to "wake up" the device.

Posted on Jun 27, 2014 1:17:58 PM PDT
Red Car Lady says:
Monikat - Thanks for the response. At the risk of proving I'm a technical idiot (which I am), would you please describe where the button is. There is a volume button on the "top" edge as well as another button that I'm not certain what it does. If that is the "on" button, I tried holding it for a slow count to 30 but it didn't fix the problem. Would de-registering and re-registering the device do anything?
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

Discussion Replies Latest Post
Announcement
News: Kindle for iOS Update 4.9 Now Available
0 1 day ago
Announcement
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Announcement
Meet other story lovers at Write On by Kindle
60 9 days ago
Announcement
Enjoy your print books and personal documents on your Kindle with Kindle Convert.
0 Feb 2, 2015
We're So Quirky, Our Chihuahuas Ride Bicycles! So Geese and Tally Ho! 8857 1 second ago
DRM 0 7 minutes ago
FREE Books & Chat - May 2015 845 9 minutes ago
When will the rest of the Sebastian St Cyr be available on Kindle. 1 10 minutes ago
getting back to book being read 2 13 minutes ago
Kindle Fire & Facebook games 28 13 minutes ago
Amazon Echo (no invite questions) 3838 19 minutes ago
Concerning : Amazon MP3 0 26 minutes ago
 

This discussion

Discussion in:  Kindle forum
Participants:  4
Total posts:  7
Initial post:  Jun 27, 2014
Latest post:  Jun 27, 2014

New! Receive e-mail when new posts are made.
Tracked by 1 customer

Search Customer Discussions