Customer Discussions > Kindle forum

Send to Kindle email address "unavailable"


Sort: Oldest first | Newest first
Showing 1-19 of 19 posts in this discussion
Initial post: Oct 10, 2012 7:14:43 AM PDT
Any one seen this before? On my http://amazon.com/myk page AND on my Kindle settings, my Kindle Touch email address displays as unavailable -- no email listed. It was fine earlier this morning. Kindle chat support was unhelpful. Am I the only one seeing this?

In reply to an earlier post on Oct 10, 2012 7:21:33 AM PDT
Try contacting Kindle support via phone. I find that one on one conversation allows for better communication and gets the problem resolved fastest.

If you have the option on the contact us page for Kindle to call you, I would use it. They call immediately.

Posted on Oct 10, 2012 7:59:40 AM PDT
Yeah, I will probably call shortly (I know that's generally more effective). Just at work and not really having the time to make a call right now. I was wondering if this was a outage issue that others were experiencing too.

In reply to an earlier post on Oct 10, 2012 8:51:01 AM PDT
Craig says:
Just checked my page, and my Kindles show with their previously-registered email addresses... So it doesn't appear to be a global outage.

In reply to an earlier post on Oct 10, 2012 8:51:43 AM PDT
I appreciate you checking!

Posted on Oct 10, 2012 8:52:08 AM PDT
And I still have emails listed for my iOS devices...just Kindle Touch is MIA.

Posted on Oct 10, 2012 9:00:27 AM PDT
Craig says:
I probably should have elaborated - my Kindles are a Paperwhite 3G, a Touch wifi, and an iPad Kindle app. All seem to be working OK, but I can't verify that the test document was received on my Touch, since it's been demoted to back-up Kindle now that my Paperwhite is here.

In reply to an earlier post on Oct 10, 2012 9:04:52 AM PDT
No worries. Still waiting on my own PW ... I have a November delivery date. Can't wait!

In reply to an earlier post on Oct 10, 2012 9:07:49 AM PDT
❤ Ann says:
Yes. I recently reset my Touch to factory defaults and then re-registered it. After doing so, the send-to-Kindle email address disappeared. I haven't yet had a chance to contact support about it and figure out what's going on, though...

In reply to an earlier post on Oct 10, 2012 9:10:52 AM PDT
Hey, that is exactly what I did -- reset to factory defaults yesterday. But I've done that before and never seen this email issue before. Odd!!

In reply to an earlier post on Oct 10, 2012 9:21:30 AM PDT
❤ Ann says:
The send-to-Kindle email address is supposed to get assigned automatically during the registration process, so I'm guessing there's just something glitchy in the system.

It might be worth a try to de-register and then re-register again to see if that will trigger an email assignment. I don't have my Touch with me at the moment, so I'll give it a shot when I get home.

In reply to an earlier post on Oct 10, 2012 9:22:29 AM PDT
Let me know if you have any success. My Kindle Touch is currently stuck in the reboot cycle of death, so I can't try that right now.

In reply to an earlier post on Oct 10, 2012 9:30:53 AM PDT
Last edited by the author on Oct 10, 2012 9:32:04 AM PDT
Why can't you just add it back?

https://www.amazon.com/gp/digital/fiona/manage?ie=UTF8&*Version*=1&*entries*=0&#pdocSettings

Personal Document Settings under Manage My Kindle. It allows you to edit/change/remove your kindle email addresses. I removed mine and added my wife's when I gave her my kindle.

In reply to an earlier post on Oct 10, 2012 9:50:10 AM PDT
There is no edit button. No email is listed, and there is no option to edit it. I know what it should look like as I have edited send-to-kindle email addresses before.

In reply to an earlier post on Oct 10, 2012 9:54:44 AM PDT
❤ Ann says:
There's no option to add a kindle email address for the device in question. I do see addresses for my other devices, and can edit them, etc., but not for the Touch that is missing the address.

In reply to an earlier post on Oct 10, 2012 10:01:07 AM PDT
Guess I am not alone. Thanks for looking, Ann. I'm curious when this will get fixed. Haven't had time to call Amazon yet.

Posted on Oct 10, 2012 11:00:19 AM PDT
Very strange.

Posted on Nov 28, 2012 9:59:17 AM PST
mtflyfish says:
I have a Droid X2, and I too had a problem getting my Kindle app registered properly so I could access my personal documents. I found out that it was all because my phone came with a Kindle app from the Google Play store. Here's what I had to fix the problem. I hope it will help you all as well.

1. Go to the Amazon App Store and search "Kindle for Android" ( http://www.amazon.com/s/ref=nb_sb_noss?url=search-alias%3Daps&field-keywords=amazon+appstore+for+android )

2. Click on the link to the Android App and enter your phone number or email in the input box on the right-hand side.

3. Click on the link found in the text or email you receive to find and download the Amazon Kindle App for Android. This will install a new version of Kindle over your existing app. Note: you may need to go into your applications settings and allow non-market apps to be installed on your device. This may interrupt your installation, and you may need to try installing the app if that is the case.

4. Once the app is installed, Amazon should automatically register your Kindle for Android app and make it available to access your personal documents.

Like I said, this approach worked for me. I hope it helps you all as well.

Posted on Jun 5, 2013 5:02:43 PM PDT
Jamie says:
I had the same problem. I reset my Kindle again, and it fixed it.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  7
Total posts:  19
Initial post:  Oct 10, 2012
Latest post:  Jun 5, 2013

New! Receive e-mail when new posts are made.
Tracked by 2 customers

Search Customer Discussions