Truck Month Textbook Trade In Amazon Fashion Learn more nav_sap_cbcc_7_fly_beacon $5 Albums Fire TV with 4k Ultra HD Beauty Mother's Day Gifts Amazon Gift Card Offer ctstrph2 ctstrph2 ctstrph2  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Fire, Only $39.99 Kindle Paperwhite AutoRip in CDs & Vinyl Shop Now SnS
Customer Discussions > Kindle forum

Kindle Fire App Store unusably slow


Sort: Oldest first | Newest first
Showing 1-15 of 15 posts in this discussion
Initial post: May 16, 2012 11:05:58 AM PDT
Matt Welch says:
New Kindle Fire owner here. Was running on 6.1.something, and all seemed well. Pressed "Sync", which apparently upgraded me to 6.3.whatever. That was great, as the parental controls are just what I was looking for.

HOWEVER, the App Store is now completely, totally unusable. I go to the store, and it's like my Fire's CPU clock was dialed down by a factor 1000. I cannot scroll apps, or catogories. I can't select an app to view. Completely unusable.

I can't say for sure that it's related to the SW update, but that seems to be the case.

Any ideas?

Posted on May 16, 2012 11:09:29 AM PDT
Nope, mine worked just fine this morning.

Posted on May 16, 2012 11:10:52 AM PDT
T. Cook says:
Check to make sure you're connected to your own wireless network and not your neighbour's (but if your CPU seems slow rather than just the webpages loading slowly, that wouldn't help).
Reboot (clears RAM, stops running processes, etc).
Check if anything other than the App Store works fine, if it does, then it's not a CPU clock issue, it's a browsing issue.

In reply to an earlier post on May 16, 2012 11:15:45 AM PDT
Matt Welch says:
Sorry, should have been more clear. It's not actually a CPU speed issue, as everything else on the tablet is working great. It's only in the App Store that this happens. Book store, music store, video store: all work great.

It locked up my Fire at one point. Performing the necessary reboot there didn't help things when I tried again.

Posted on May 20, 2012 10:28:37 PM PDT
JennHawk says:
Matt Welch: I've been having the same problem with my Kindle Fire for about 3 weeks now. It is very frustrating.

Posted on May 21, 2012 12:28:40 AM PDT
dfn.ninja says:
Try clearing the data in the app store app. Gear icon/more/device/applications/show all/app store.

Posted on May 21, 2012 5:36:47 AM PDT
Matt Welch says:
I had tried clearing the data for the app store app, without any success. Finally reset my Fire to factory condition, and everything was OK after that.

Posted on Jul 3, 2012 10:45:14 AM PDT
If you reset it do u loose all personal stuff like music and pictures?

In reply to an earlier post on Jul 3, 2012 10:49:11 AM PDT
Yes.

Posted on Nov 24, 2012 1:30:37 PM PST
i have been experiencing the same app prob on my brand new 8" HD. Just spent three days loading docs and pics. I would hate to have to start over.

Posted on Dec 26, 2012 3:44:04 PM PST
lisalou says:
I' m also having this issue. Everything else works fine but not for searching for books.

Posted on Jan 2, 2013 2:08:15 PM PST
Last edited by the author on Jan 2, 2013 2:08:46 PM PST
HD Dem says:
I am having an issiue where I can not scroll and type on the kindle fire app store.
Any soulutions?

Posted on Jan 3, 2013 11:06:36 PM PST
[Deleted by the author on Jan 3, 2013 11:06:55 PM PST]

Posted on Feb 26, 2013 8:47:39 AM PST
Tylox says:
I'm having the same issue as above. I guess i can just wipe it clean, but that doesn't seem like the ultimate fix.

In reply to an earlier post on Jul 4, 2013 9:40:46 AM PDT
It will still be in ur cloud but not the device itself
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Kindle forum

 

This discussion

Discussion in:  Kindle forum
Participants:  13
Total posts:  15
Initial post:  May 16, 2012
Latest post:  Jul 4, 2013

New! Receive e-mail when new posts are made.
Tracked by 5 customers

Search Customer Discussions