Customer Discussions > Kindle forum

Help Needed


Sort: Oldest first | Newest first
Showing 1-12 of 12 posts in this discussion
Initial post: Mar 11, 2012 1:36:05 PM PDT
Lori Head says:
I am trying to get a book from our library. When I go to get book, it takes me to the Amazon "get your digital library loan" . but in the box where it should give me the choice to download to my computer it say "You currently have no devices registered that support transferring via USB." what am I doing wrong?

Posted on Mar 11, 2012 2:05:15 PM PDT
seedlady says:
do you have the kindle plugged into the computer?

In reply to an earlier post on Mar 11, 2012 2:15:21 PM PDT
Lori Head says:
No, I thought I had to download it to my computer then transfer to my Kindle. Will give it a try. Thanks!

In reply to an earlier post on Mar 11, 2012 2:18:11 PM PDT
seedlady says:
well, i spent one L O N G afternoon trying to move a book by usb, and tried 7 times, then gave up. the next morning i noticed the book on one kindle, so ONE of the things i tried worked. sigh. i have no idea which one.

Posted on Mar 11, 2012 2:24:54 PM PDT
Lori Head says:
I have spent all afternoon trying to figure this out. It will not give me the "Deliver to Option". I am about ready to give up.

In reply to an earlier post on Mar 11, 2012 2:29:58 PM PDT
Dittie says:
The Kindle is registered, right? Is it registered to the same account you're signed in to on your computer?

In reply to an earlier post on Mar 11, 2012 3:09:47 PM PDT
Lori Head says:
The Kindle is registered. Is there a way to find out if it is registerd to the same account I'm signed into on my computer? When you go to manage your kindle does it show it somewhere, because my books that i have gotten using my kindle wi-fi does not show up in my library on my computer. It has been awhile since I set this all up. I am at my wits end. This should not be this difficult.

In reply to an earlier post on Mar 11, 2012 3:13:35 PM PDT
Dittie says:
Content should show up on the Manage Your Kindle page and the device should be in the drop-down box where you choose the download device. This makes me think you mistakenly created a second account. Your best bet, especially where it concerns your account, is to contact Kindle customer service. US 1-866-321-8851

Posted on Mar 11, 2012 6:09:49 PM PDT
[Deleted by the author on Mar 11, 2012 6:10:15 PM PDT]

Posted on Mar 11, 2012 7:44:01 PM PDT
Lori,

Go to http://amazon.com/myk. After signing in, click on the link in the middle left called "Manage Your Devices".
It will list all of your Kindles registered to that account, including any apps like "Kindle for PC". Check to make sure it is registered properly.

You can also go to "All Items" at the top left, then at the top/middle of the page is a pulldown. Click on it and click on the last link "Loans".
You should be able to click on the 'Actions' button way to the right of the loan and select a Kindle on that account or select to transfer via USB.

Good luck!

Posted on May 30, 2012 1:28:04 PM PDT
Last edited by the author on May 30, 2012 1:30:00 PM PDT
D. Richards says:
I am having this same problem. This is a new phenomenon, since I downloaded library books to read over Easter vacation and can't even remember the process--it was that seamless.
Also, the "All Items" button suggested above is totally blank.
Has anyone got any other ideas?

In reply to an earlier post on May 30, 2012 1:47:25 PM PDT
M. Ratcheson says:
It sounds like you are not logged into the account to which your Kindle is registered.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Discussion in:  Kindle forum
Participants:  7
Total posts:  12
Initial post:  Mar 11, 2012
Latest post:  May 30, 2012

New! Receive e-mail when new posts are made.
Tracked by 1 customer

Search Customer Discussions