Customer Discussions > Tablet forum

Installing Amazon App Store on Asus TF300


Sort: Oldest first | Newest first
Showing 1-25 of 44 posts in this discussion
Initial post: May 27, 2012 4:35:33 PM PDT
Last edited by the author on May 27, 2012 4:36:51 PM PDT
I'm getting stuck trying to get the Amazon App Store to show up on my new tablet, Asus TF300 running ICS 4.

On the "Get Started" page for the App Store, Amazon gives two options: (1) enter your email address or (2) type the Amazon AppStore URL on the tablet and download the app that way.

I entered my email address and pressed "go," nothing happened. Tried this about 7-10 times, refreshing the page in between, but the "go" button doesn't work. Other links on that page work; when you press them, it takes you to the destination. But this link doesn't do anything at all, and of course, nothing is in the email inbox.

I entered the App Store URL on my tablet, pressed "Download," got a message that it is starting download now, then message disappears after a few seconds and nothing is downloaded. There is no warning or caution or anything that says the download is blocked. It just doesn't download. I tried this about 5 or 6 times.

I also have the tablet settings configured to allow Unknown Sources of non-Market Apps, so that is not the obstacle.

What am I doing wrong? How can I get Amazon App Store on my tablet?

Also, are there other forums on Amazon that are more focused for this kind of question? Is there a page that has a list of all the forums? The only one I could find was this one, when I was tablet-shopping. Thanks.

Posted on May 27, 2012 5:05:43 PM PDT
In your web browser navigate to the following address:
http://www.amazon.com/gp/mas/get-appstore/android

That's the download page to directly download the appstore app to your device. Just click the Download Now button and it'll download. Then use your device's file explorer to go to the downloads directory of your tablet, find the file called Amazon_Appstore-release.apk and tap it and it should install.

I'm not sure what the file explorer is called on your particular tablet. Probably simply File Explorer of File Manager but it might come with ES File Explorer or one of the others. Very likely it will have an icon that looks like a manila folder.

Barry

Posted on May 27, 2012 6:47:34 PM PDT
Thanks! You gave me the key to the mystery. The link itself worked on my Win 7 laptop, but on the tablet, it was immediately overriden and went to the Amazon homepage.

But you said I should find the file explorer on my tablet, and that unlocked the secret. On my tablet, it has the mysterious and unusual name of "File Manager." I opened it, found it has a folder named Download, and the Amazon app is waiting for me there. In multiple copies. I think it just downloaded so fast that it seemed nothing was happening at all, and I didn't know that afterwards I have to find the downloaded file and install the app.

Meantime as I type this, it's installed and ready to go.

Thanks so much.

Posted on May 27, 2012 11:57:12 PM PDT
C. Schmidt says:
For reference, the link directly to the download that I've found to work is http://amazon.com/app-email

In reply to an earlier post on Jun 2, 2012 4:21:14 AM PDT
So glad to find this link. I was. having this same problem with my tf300. All set now. Please make this info more available.

Posted on Jun 5, 2012 7:03:33 PM PDT
Okay, this helped me quite a lot! I at least got the app store and now trying to download Kindle.

How long should it take anyway on a very bad MID tablet? I am android 2.2 (or 3?) and it has been downloading for hours. I have a flash drive in there since I don't have a mini SD card yet. That might be the problem?

Or could it really be that s-l-o-w

The other apps have downloaded very quickly.

Posted on Jun 5, 2012 7:58:17 PM PDT
I don't really recall how long it took to download the Kindle app but if it was more then half a minute I'd probably remember that. Your download might have gotten stuck so you might want to cancel it if you can, restart the tablet and try the download again.

I got my new Samsung Player 4.2 a little over a week ago and I had something going on so I set it up real quickly, which included installing Amazon and the Kindle app, and the entire setup process was less than 15 minutes. Probably less than 10. and that included the installation of about 8 or 10 of the apps I use most. So my guess is that the Kindle app only took a few seconds to download. That's what most apps take.

Barry

In reply to an earlier post on Jun 5, 2012 8:08:47 PM PDT
C. Schmidt says:
It happens, Susan. You can try restarting the Appstore app and/or tablet to see if that helps you along any.

Posted on Jun 5, 2012 8:27:44 PM PDT
I have done, twice.

I thought I would get a mini SD card tomorrow and try again. This has been a piece of junk so far but if I can get the app to work, it will save the day for me.

Thanks for the replies. I don't seem to be able to cancel, it says downloading from the cloud and that is all.

In reply to an earlier post on Jun 5, 2012 9:30:20 PM PDT
C. Schmidt says:
Make sure you get the right kind for your tablet. I'm not sure which you have, but typically it's a micro SD or full SD. I usually buy the micro SD with the adapters to mini and full. A 4GB to 16GB will be good. You don't need a fast one like a Class 10. Class 2 or better will be fine.

Posted on Jun 5, 2012 9:32:03 PM PDT
C. Schmidt says:
Oh, forgot to mention, install it with the tablet powered off (not just sleeping), then go through your downloaded apps and move them to the SD card if they can be.

Posted on Jun 5, 2012 9:52:12 PM PDT
Thanks for the info, I would have known NONE of that!

In reply to an earlier post on Jun 5, 2012 10:14:28 PM PDT
C. Schmidt says:
Glad to help! If it gets confusing trying to move the apps, snag the app App2SD, which will help simplify the task for a new user.

Posted on Jun 6, 2012 11:58:23 AM PDT
:)

In reply to an earlier post on Jun 8, 2012 7:19:02 PM PDT
I have a card in there, the only one they had in 16g with adapter.

Now, apps is saying it has a parsing error and kindle won't reinstall. :(

Posted on Jun 8, 2012 7:49:01 PM PDT
it seems to be downloading now. dumb luck

In reply to an earlier post on Jun 8, 2012 7:56:14 PM PDT
C. Schmidt says:
Usually, parse errors are a result of a bad download, incompatible file, or trying to open with the wrong app. Normally, you will want to use you file manager/explorer to do the opening of the apk you download, not the browser.

In reply to an earlier post on Jun 8, 2012 8:02:51 PM PDT
I somehow uninstalled the old and redownloaded. I honestly don't remember where stuff is. I don't install with the browser. I have to download and then it installs itself.

I don't seem to be able to sync to get my books though. Geez, is it ever easy?

In reply to an earlier post on Jun 8, 2012 8:57:45 PM PDT
C. Schmidt says:
You did log into your account, yes? It took mine a little to sync.

Posted on Jun 9, 2012 3:34:17 PM PDT
Yes, thank you. It is under Archive for some reason. I am happy it worked. Thanks for your instructions and patience. Spot on!

In reply to an earlier post on Jun 9, 2012 10:20:50 PM PDT
C. Schmidt says:
Glad to help, Susan. :)

Posted on Jun 12, 2012 1:27:21 PM PDT
Last edited by the author on Jun 12, 2012 1:41:30 PM PDT
I am really giving you a workout on this tablet!!

NOW kindle won't open. I click the icon, it shows gray screen with kindle like it is loading then nada.

well, it loaded, then wouldn't show archives (not responding was the prompt) now nothing again. Funky tablet!

In reply to an earlier post on Jun 12, 2012 1:31:33 PM PDT
C. Schmidt says:
Have you rebooted the tablet, by chance? Also, did you move the app to the SD card just prior to this happening?

Posted on Jun 12, 2012 4:14:15 PM PDT
No, I haven't moved it and yes, it was a restart. I don't know how to move it actually, but the app you mentioned is checked. It kept saying that the Amazon kindle was not responding but it showed me a couple of books I recently got.

So, if I need to move it, that will be my next lesson? :))

In reply to an earlier post on Jun 12, 2012 5:02:06 PM PDT
C. Schmidt says:
LOL let's get it working first. Go into Settings, then Apps, and finally select the Kindle app. Click the button to clear cache, then try to open it. If no, go back and clear cache and data, then try to open again (will need to login again). Finally, if it wants to sit there, let it, for an hour.
‹ Previous 1 2 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Tablet forum

 

This discussion

Discussion in:  Tablet forum
Participants:  12
Total posts:  44
Initial post:  May 27, 2012
Latest post:  Jan 4, 2014

New! Receive e-mail when new posts are made.
Tracked by 7 customers

Search Customer Discussions