Customer Review

54 of 80 people found the following review helpful
5.0 out of 5 stars Great amp for the price, February 20, 2012
By 
This review is from: Boss Audio R1100M - 1100 Watt, Monoblock, Class A/B, MOSFET Amplifier With Remote Subwoofer Level Control (Electronics)
Installed this amp to power a single JBL GT5 12". So far the amp has provided a flawless performance. You should spend some time fine tuning the low pass filter settings to minimize distortion. The bass boost switch isn't needed for a single sub, and the remote control does not need to be turned all the way up for satisfactory results.

I would recommend you use an 8 ga. power cord and ground for your installation. Ground the amp with 24" or less of 8 ga. ground cord. The "Boss" emblem lights up when the power is on, so you might want to install the amp where it will not reflect onto your rear windshield.

I have not felt any excess heat coming from this amp yet. The compact size is great for concealing in small spaces. I was able to install it in the back of an F-150 cab and still have enough room for cooling. This is my first experience with a Boss amplifier, and I definitely pleased with the results.
Help other customers find the most helpful reviews 
Was this review helpful to you? Yes No

[Add comment]
Post a comment
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Amazon will display this name with all your submissions, including reviews and discussion posts. (Learn more)
Name:
Badge:
This badge will be assigned to you and will appear along with your name.
There was an error. Please try again.
Please see the full guidelines here.

Official Comment

As a representative of this product you can post one Official Comment on this review. It will appear immediately below the review wherever it is displayed.   Learn more
The following name and badge will be shown with this comment:
 (edit name)
After clicking the Post button you will be asked to create your public name, which will be shown with all your contributions.

Is this your product?

If you are the author, artist, manufacturer or an official representative of this product, you can post an Official Comment on this review. It will appear immediately below the review wherever it is displayed.  Learn more
Otherwise, you can still post a regular comment on this review.

Is this your product?

If you are the author, artist, manufacturer or an official representative of this product, you can post an Official Comment on this review. It will appear immediately below the review wherever it is displayed.   Learn more
 
System timed out

We were unable to verify whether you represent the product. Please try again later, or retry now. Otherwise you can post a regular comment.

Since you previously posted an Official Comment, this comment will appear in the comment section below. You also have the option to edit your Official Comment.   Learn more
The maximum number of Official Comments have been posted. This comment will appear in the comment section below.   Learn more
Prompts for sign-in
 

Comments

Tracked by 1 customer

Sort: Oldest first | Newest first
Showing 1-1 of 1 posts in this discussion
Initial post: Nov 21, 2013 2:41:23 PM PST
Dave says:
I have an F150 as well, going behind the seat. I had a previous installed amp that was old and finally died and so replaced with this boss. I hooked all the same wire to the appropriate spots and the red "protection" light is lit. The power light is not. The amp/sub is not working/firing. What am I doing wrong?
‹ Previous 1 Next ›

Review Details

Item

Reviewer


Top Reviewer Ranking: 2,677,513