is this lightroom 4 compatible with the new mark3
asked by Katherine M. Slattery on November 5, 2012
Sort: Most Helpful first | Newest first | Oldest first
Showing 1-5 of 5 answers
A
0
votes
If you are referring to Canon EOS 5D Mark III, then yes, including tethering (from v4.2 up)
N. Savoiu answered on November 5, 2012

A
0
votes
A friend of mine has a canon mk3 and uses lr4, he shoots raw. Make sure you update to the newest version.
larry answered on November 5, 2012

A
0
votes
Do you mean the Canon EOS 5D Mark III? If so, yes, and it works great with lens corrections for this model.
As stated by larry, just make sure you are completely updated.
Acontius answered on November 5, 2012

A
0
votes
Yes and Lightroom 4 is really quick with updates when new cameras and/or lenses are introduced to the public.
Michael S. Moncrief answered on November 5, 2012

A
0
votes
It works with any uploaded pictures, so all cameras would be compatible, once the photos are loaded into your computer, you move them into Lightroom.... According to my son, who is a pro photographer. Hope that helps
Kathy Olson answered on November 5, 2012
‹ Previous   1   Next ›