When i turn on the camera the lens will not open. Come up as lens error.Any idea how to fix?
asked by Patricia on February 6, 2013
Sort: Most Helpful first | Newest first | Oldest first
Showing 1-6 of 6 answers
A
I had the same issue with a different model. I forced it open slightly manually once and it was ok. I know it sounds crude. But it worked in the past.
Mrlobsterbob answered on February 6, 2013
Comment | 1 of 1 found this helpful. Do you?  Yes No | Report abuse

A
Has the camera been dropped? If so, it's pretty much dead.
Todd Slusar answered on February 6, 2013
Comments (2) | Do you find this helpful?  Yes No | Report abuse

A
If the camera is still under warranty you should have it fixed. My old camera had the same problem when I dropped it. I just pressed down on the ring surrounding the lens until it snapped into place and it started working again. Make sure you use a fully recharged battery before turning the camera back on because the gears may need to snap back in place.
David Tanaka answered on February 6, 2013
Comments (3) | Do you find this helpful?  Yes No | Report abuse

A
sometimes
Yeni answered on February 6, 2013
Comment | Do you find this helpful?  Yes No | Report abuse

A
Sorry I do not. As much as I dislike this camera, that is one problem I've not had - even after dropping it in the snow twice.
K. SMITH answered on February 7, 2013
Comment | Do you find this helpful?  Yes No | Report abuse

A
I had the same problem with another model (Powershot A620). Tried to fix it myself but couldn´t. Send it better to a repair shop. Openning will only damage it more. Sorry.
J. L. Sanchez answered on February 7, 2013
Comment | Do you find this helpful?  Yes No | Report abuse
‹ Previous   1   Next ›