Hill Climb Racing 2 Industrial Deals Beauty Best Books of the Month STEM nav_sap_plcc_ascpsc New Album by Josh Ritter PCB for Musical Instruments Starting at $39.99 Grocery Handmade Tote Bags Home Gift Guide Off to College Home Gift Guide Book a house cleaner for 2 or more hours on Amazon Transparent Transparent Transparent  Introducing Echo Show Introducing All-New Fire HD 10 with Alexa hands-free $149.99 Kindle Oasis, unlike any Kindle you've ever held Trade in. Get paid. Go shopping. Shop Now FFII_gno

Sort: Oldest first | Newest first
Showing 1-9 of 9 posts in this discussion
Initial post: Dec 10, 2008, 10:19:37 AM PST
Ann Ducommun says:
won't play - tried twice - starts then shuts power off - is anyone else having this problem?

In reply to an earlier post on Dec 14, 2008, 6:48:38 AM PST
A. Turner says:
Yes, Upgrade your firmware

In reply to an earlier post on Dec 17, 2008, 5:11:25 AM PST
G. Smith says:
I have already taken back this movie THREE TIMES. I also brought it in Blu Ray and have had the same problem. I have also purchased the 3 set of The Mummy-it does not play either. Both are made by Universal - seems their movies will not play in the Blu Ray format.

In reply to an earlier post on Dec 24, 2008, 12:34:11 PM PST
T. Suharik says:
I upgraded the firmware to 4.40 which is most recent (sony 301) and still doesn't work with Wanted, Death Race and concerned about others with same "BD-LIVE 2.0" listed on the back. The new Blue rays have newer stuff? After what seems like a long wait, error message comes up saying "can't read disc" and your stuck. Sony simply behind on the firmware to be compatible? Called Sony support- guy was clueless. Classic blamed it on the software stuff. I knew where that was going as the software will blame the hardware circle. He said if it works on some Blue Rays, the hardware is fine. It does, just not the new ones Amazon has just sent me. And if only one disk I would agree, however, so far two not working and Hulk has the same formats listed also (other posts suggest problems with this movie also) so suspecting that will fail also. Any suggestions other than wait for Sony to get its act together?

In reply to an earlier post on Jan 12, 2009, 1:24:41 PM PST
PS3's are the best BR players

Posted on Feb 5, 2009, 7:18:38 AM PST
Upgraded firmware to 4.5 (sony 300) last night and now every thing works just fine.

In reply to an earlier post on Feb 5, 2009, 11:58:30 AM PST
T. Suharik says:
Good to know Sony caught up- for now. Took over 2 months between updates? After more research simply found that we had wasted our money on Blu Ray too soon. Turned the Sony into a boat anchor like an obsolete computer after less than a year. Bought a new Samsung that is awsome with internet direct auto downloads and compatible with Netflix instant feed, etc. Live and learn. Actually gave it away to someone who didn't have a DVD player to use for that as it will be fine.

Posted on Mar 1, 2009, 9:48:39 PM PST
aHTown says:
Wow. I thought it was just my copy. I bought a copy back in Nov. It played with no issues the first time. I have tried to watch it 3 times since and have issues out of it each time. It freezes, I have to restart the movie, etc. Each time it froze at a different spot. I have the Sony PS3 with code 5.2. I like the movie so much I'm about to buy another copy. I sure hope it works!!

Posted on Jul 16, 2009, 8:47:20 PM PDT
J. Zavala says:
Hi. I bought a copy of Wanted on Blu-ray the week it came out and it played no problems on my PS3. I've watched it multiple times since then. But I haven't watched it in a few months. I tried to play it tonight (I do have the most up to date firmware) on July 16th, 2009 and as soon as I play the disc, the screen goes to black. like how it usually does before a disc is about to start. but the disc doesn't start playing. The PS3 itself doesn't play. Is anyone else having this problem currently? And I play blu-rays almost every day and Wanted is the only movie I'm currently having problems with.
‹ Previous 1 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


 

This discussion

Participants:  8
Total posts:  9
Initial post:  Dec 10, 2008
Latest post:  Jul 16, 2009

New! Receive e-mail when new posts are made.
Tracked by 3 customers