
<!doctype html><html class="a-no-js" data-19ax5a9jf="dingo"><head><script>var aPageStart = (new Date()).getTime();</script><meta charset="utf-8"/><!--  emit CSM JS -->
    <style>
[class*=scx-line-clamp-]{overflow:hidden}.scx-offscreen-truncate{position:relative;left:-1000000px}.scx-line-clamp-1{max-height:16.75px}.scx-truncate-medium.scx-line-clamp-1{max-height:20.34px}.scx-truncate-small.scx-line-clamp-1{max-height:13px}.scx-line-clamp-2{max-height:35.5px}.scx-truncate-medium.scx-line-clamp-2{max-height:41.67px}.scx-truncate-small.scx-line-clamp-2{max-height:28px}.scx-line-clamp-3{max-height:54.25px}.scx-truncate-medium.scx-line-clamp-3{max-height:63.01px}.scx-truncate-small.scx-line-clamp-3{max-height:43px}.scx-line-clamp-4{max-height:73px}.scx-truncate-medium.scx-line-clamp-4{max-height:84.34px}.scx-truncate-small.scx-line-clamp-4{max-height:58px}.scx-line-clamp-5{max-height:91.75px}.scx-truncate-medium.scx-line-clamp-5{max-height:105.68px}.scx-truncate-small.scx-line-clamp-5{max-height:73px}.scx-line-clamp-6{max-height:110.5px}.scx-truncate-medium.scx-line-clamp-6{max-height:127.01px}.scx-truncate-small.scx-line-clamp-6{max-height:88px}.sx-line-clamp-1{overflow:hidden;white-space:nowrap;text-overflow:ellipsis}.sx-line-clamp-2{overflow:hidden;max-height:37.5px}.scx-truncate-medium.sx-line-clamp-2{max-height:42.67px}.sx-line-clamp-3{overflow:hidden;max-height:56.25px}.scx-truncate-medium.sx-line-clamp-3{max-height:64.01px}.sx-line-clamp-4{overflow:hidden;max-height:75px}.scx-truncate-medium.sx-line-clamp-4{max-height:85.34px}.sx-line-clamp-5{overflow:hidden;max-height:93.75px}.scx-truncate-medium.sx-line-clamp-5{max-height:106.68px}@supports (-webkit-line-clamp:2){.sx-line-clamp-2,.sx-line-clamp-3,.sx-line-clamp-4,.sx-line-clamp-5,.sx-line-clamp-base-webkit{display:-webkit-box;-webkit-box-orient:vertical}.sx-line-clamp-2{-webkit-line-clamp:2}.s-featured-asin-carousel .sx-line-clamp-2{max-height:37.5px}.sx-line-clamp-3{-webkit-line-clamp:3}.s-featured-asin-carousel .sx-line-clamp-3{max-height:56.25px}.sx-line-clamp-4{-webkit-line-clamp:4}.s-featured-asin-carousel .sx-line-clamp-4{max-height:75px}.sx-line-clamp-5{-webkit-line-clamp:5}.s-featured-asin-carousel .sx-line-clamp-5{max-height:93.75px}}
</style>
<link rel="stylesheet" href="https://images-na.ssl-images-amazon.com/images/I/51tax7M48-L._RC|516fcOUE-HL.css,01evdoiemkL.css,01K+Ps1DeEL.css,31pdJv9iSzL.css,01VszOUTO6L.css,11UGC+GXOPL.css,21LK7jaicML.css,11L58Qpo0GL.css,21kyTi1FabL.css,01ruG+gDPFL.css,01YhS3Cs-hL.css,21GwE3cR-yL.css,019SHZnt8RL.css,01wAWQRgXzL.css,21bWcRJYNIL.css,11WgRxUdJRL.css,01dU8+SPlFL.css,11ocrgKoE-L.css,01SHjPML6tL.css,111-D2qRjiL.css,01QrWuRrZ-L.css,310Imb6LqFL.css,01piEq-AdwL.css,11Z1a0FxSIL.css,01cbS3UK11L.css,21mOLw+nYYL.css,01L8Y-JFEhL.css_.css?AUIClients/AmazonUI#us.not-trident.185427-T1" />
<link rel="stylesheet" href="https://images-na.ssl-images-amazon.com/images/I/51MFn+HAbnL._RC|212hS9k0-iL.css,01lO3awdqlL.css,01TQCVEAmxL.css,61dkFqBFZAL.css_.css?AUIClients/RetailSearchAssets#us.renderskin-pc.search-results-aui.89167-T1" />
<style>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</style>
<link rel="stylesheet" href="https://images-na.ssl-images-amazon.com/images/I/21DKiuKAnTL.css?AUIClients/AmazonPopoversAUIShim" />
<script>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</script>
<title>Amazon.com: Save Big on Samsung SSD Drives.: Electronics</title>
<meta property="og:title" content="Amazon.com: Save Big on Samsung SSD Drives.: Electronics" />
<meta name="twitter:title" content="Amazon.com: Save Big on Samsung SSD Drives.: Electronics" />

<meta name="description" content="Online shopping for Save Big on Samsung SSD Drives. from a great selection at Electronics Store." />
<meta property="og:description" content="Online shopping for Save Big on Samsung SSD Drives. from a great selection at Electronics Store." />
<meta name="twitter:description" content="Online shopping for Save Big on Samsung SSD Drives. from a great selection at Electronics Store." />

<meta name="keywords" content="Save Big on Samsung SSD Drives., Electronics, Amazon.com" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="canonical" href="https://www.amazon.com/b?ie=UTF8&amp;node=21103058011" />
<script type="text/javascript">
var search_t0 = window.ue_t0 || + new Date();
</script>
<style type="text/css">
.s-icon, .currencyINR, .srSprite {
    background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/searchSprite._CB457630852_.png);
    background-repeat: no-repeat;
}

#leftNav div.buttonsprite div {
    background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/searchSprite._CB457630852_.png);
}
 
#leftNav li.subgroup a span.expand {
    background: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/searchSprite._CB457630852_.png) no-repeat scroll -143px -821px;
}
 
#leftNav li.subgroup a span.collapse {
    background: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/searchSprite._CB457630852_.png) no-repeat scroll -132px -821px;
}

.s-icon-badging-sticker-sash {
    background-image: url();
}

.s-icon-us-selection-ags {
  background-image: url();
}

.s-icon-uk-selection-ags {
  background-image: url();
}

.s-icon-jp-selection-ags {
  background-image: url();
}

.s-icon-de-selection-ags {
  background-image: url();
}

.s-icon-uk-ags {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/global-store/badge._CB485936030_.png);
  background-repeat: no-repeat;
  display: inline-block;
  height: 19px;
  width: 80px;
}

.s-icon-holiday-toy-list {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/badging._CB485947578_.png);
}

.s-badges-background-tl {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/sticker/sx-badges-pc._CB485943020_.png);
}

.desktop-sx-top-slot_slds-amazon-fashion-fed-stripe-sprite,
.s-softlines-sprite {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/amazon-fashion-sprite-2._CB485917210_.png);
}

.desktop-sx-top-slot_slds-fed-stripe-sprite,
.s-federated-stripe-sprite {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/gui/top-brands-sprite-2._CB485917078_.png);
}


.s-prime-music-badge {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/prime-music-badge-1x._CB485945421_.png);
}

@media{ 
  .s-prime-music-badge {
    background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/nav2/images/prime-music-badge-2x._CB485941976_.png);
  }
}
</style>





<!--  -->
<link rel="stylesheet" href="https://images-na.ssl-images-amazon.com/images/I/21taIyvn9cL._RC|71Tq7EVt6oL.css,21TJB5pc5TL.css,31vGzsqCErL.css,21lRUdwotiL.css,41tc24mJIGL.css,11G4HxMtMSL.css,31OvHRW+XiL.css,01XHMOHpK1L.css_.css?AUIClients/NavDesktopMetaAsset#desktop" />
</head><body class="a-m-us a-aui_157141-c a-aui_72554-c a-aui_dropdown_187959-c a-aui_pci_risk_banner_210084-c a-aui_perf_130093-c a-aui_tnr_v2_180836-c a-aui_ux_145937-c"><div id="a-page"><script type="a-state" data-a-state="{&quot;key&quot;:&quot;a-wlab-states&quot;}">{"AUI_157141":null,"AUI_72554":null,"AUI_DROPDOWN_187959":null,"AUI_PCI_RISK_BANNER_210084":"C","AUI_PERF_130093":null,"AUI_TNR_V2_180836":null,"AUI_UX_145937":null}</script><script type="text/javascript">var nav_t_begin_nav = + new Date();</script>
<style type="text/css"><!--
.nav-sprite-v1 .nav-sprite, .nav-sprite-v1 .nav-icon {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-1x_optimized_layout1._CB468670774_.png);
  background-position: 0 1000px;
  background-repeat: repeat-x;
}
.nav-spinner {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/javascripts/lib/popover/images/snake._CB485935611_.gif);
  background-position: center center;
  background-repeat: no-repeat;
}
.nav-timeline-icon, .nav-access-image, .nav-timeline-prime-icon {
  background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/timeline_sprite_1x._CB485945973_.png);
  background-repeat: no-repeat;
}

--></style>
<script type="text/javascript">var nav_t_after_inline_CSS = + new Date();</script>

<!-- From remote config v3-->
<script type="text/javascript">
(function(d){document.createElement("header");function b(e){return[].slice.call(e)}function c(f,e){return{m:f,a:b(e)}}var a=function(f){var g={};g._sourceName=f;g._replay=[];g.getNow=function(i,h){return h};function e(i,h,j){i[j]=function(){g._replay.push(h.concat(c(j,arguments)))}}g.when=function(){var i=[c("when",arguments)];var h={};e(h,i,"run");e(h,i,"declare");e(h,i,"publish");e(h,i,"build");return h};e(g,[],"declare");e(g,[],"build");e(g,[],"publish");e(g,[],"importEvent");a._shims.push(g);return g};a._shims=[];if(!d.$Nav){d.$Nav=a("rcx-nav")}if(!d.$Nav.make){d.$Nav.make=a}}(window));
$Nav.importEvent('navbarJS-beaconbelt');
$Nav.declare('img.sprite', {
  'png8': 'https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/global-sprite_bluebeacon-v1._CB485918456_.png',
  'png32': 'https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-1x_optimized_layout1._CB468670774_.png',
  'png32-2x': 'https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-2x_optimized_layout1._CB468670774_.png'
});
$Nav.declare('img.timeline', {
  'timeline-icon-2x': 'https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/timeline_sprite_2x._CB443581191_.png'
});
window._navbarSpriteUrl = 'https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-1x_optimized_layout1._CB468670774_.png';
$Nav.declare('img.pixel', 'https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/transparent-pixel._CB485935036_.gif');
</script>
<img src="https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-1x_optimized_layout1._CB468670774_.png" style="display:none" alt=""/>
<!--[if IE 6]>
<style type="text/css"><!--
  #navbar.nav-sprite-v3 .nav-sprite {
    background-image: url(https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/global-sprite_bluebeacon-v1._CB485918456_.png);
  }
--></style>
<![endif]-->

<!-- nav-config-asset-injection no-aui-p -->
<!--  -->
<script>
(window.AmazonUIPageJS ? AmazonUIPageJS : P).when('navCF').execute(function(){
  (window.AmazonUIPageJS ? AmazonUIPageJS : P).load.js('https://images-na.ssl-images-amazon.com/images/I/417L6LIsU6L._RC|71ukVsVobVL.js,61nu+N-SMyL.js,41W9ohA0e+L.js,11vrNkbdcvL.js,21qaguVEGfL.js,41QN7vBTpzL.js,51MzEF-M1PL.js,313jWehHlpL.js_.js?AUIClients/NavDesktopMetaAsset#desktop');
});
</script>











  <!-- NAVYAAN -->








<!--Pilu -->

<!-- navmet initial definition -->


<script type='text/javascript'>
    if(window.navmet===undefined) {
      window.navmet=[];
      if (window.performance && window.performance.timing && window.ue_t0) {
        var t = window.performance.timing;
        var now = + new Date();
        window.navmet.basic = {
          'networkLatency': (t.responseStart - t.fetchStart),
          'navFirstPaint': (now - t.responseStart),
          'NavStart': (now - window.ue_t0)
        };
      }
    }
</script>




<script type='text/javascript'>window.navmet.tmp=+new Date();</script>
  <script type='text/javascript'>
    window.uet && uet('ns');
    window._navbar = (function (o) {
      o.componentLoaded = o.loading = function(){};
      o.browsepromos = {};
      o.issPromos = [];
      return o;
    }(window._navbar || {}));
    window._navbar.declareOnLoad = function () { window.$Nav && $Nav.declare('page.load'); };
    if (window.addEventListener) {
      window.addEventListener("load", window._navbar.declareOnLoad, false);
    } else if (window.attachEvent) {
      window.attachEvent("onload", window._navbar.declareOnLoad);
    } else if (window.$Nav) {
      $Nav.when('page.domReady').run("OnloadFallbackSetup", function () {
        window._navbar.declareOnLoad();
      });
    }
    window.$Nav && $Nav.declare('logEvent.enabled',
      'false');

    window.$Nav && $Nav.declare('config.lightningDeals', {});
  </script>

    <style mark="aboveNavInjectionCSS" type="text/css">
      div#navSwmHoliday.nav-focus {border: none;margin: 0;}
    </style>
    <script mark="aboveNavInjectionJS" type="text/javascript">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</script>

  <noscript>
    <style type="text/css"><!--
      #navbar #nav-shop .nav-a:hover {
        color: #ff9900;
        text-decoration: underline;
      }
      #navbar #nav-search .nav-search-facade,
      #navbar #nav-tools .nav-icon,
      #navbar #nav-shop .nav-icon,
      #navbar #nav-subnav .nav-hasArrow .nav-arrow {
        display: none;
      }
      #navbar #nav-search .nav-search-submit,
      #navbar #nav-search .nav-search-scope {
        display: block;
      }
      #nav-search .nav-search-scope {
        padding: 0 5px;
      }
      #navbar #nav-search .nav-search-dropdown {
        position: relative;
        top: 5px;
        height: 23px;
        font-size: 14px;
        opacity: 1;
        filter: alpha(opacity = 100);
      }
    --></style>
 </noscript>
<script type='text/javascript'>window.navmet.push({key:'PreNav',end:+new Date(),begin:window.navmet.tmp});</script>

<a id='nav-top'></a>




<a id="skiplink" tabindex="3" class="skip-link">Skip to main content</a>




<script type='text/javascript'>window.navmet.main=+new Date();</script>

<header class = "nav-opt-sprite nav-locale-us nav-lang-en nav-ssl nav-unrec">
    
  <div id='navbar' cel_widget_id='Navigation-desktop-navbar' data-template="layoutSwapToolBar"
  role='navigation' class="nav-sprite-v1 celwidget nav-bluebeacon nav-a11y-t1 layout2 nav-packard-glow hamburger bold-focus-hover">
    
    
    
    <div id='nav-belt'>
      
      
      
      <div class='nav-left'>
        <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
  <a href="/gp/site-directory?ref_=nav_em_js_disabled" id="nav-hamburger-menu" role="button" tabindex=5 aria-label="Open Menu">
    <i class="hm-icon nav-sprite"></i>
  </a>
  
<script type="text/javascript">
  var hmenu = document.getElementById("nav-hamburger-menu");
  hmenu.setAttribute("href", "javascript: void(0)");
  window.navHamburgerMetricLogger = function() {
    if (window.ue && window.ue.count) {
      var metricName = "Nav:Hmenu:IconClickActionPending";
      window.ue.count(metricName, (ue.count(metricName) || 0) + 1);
    }
    window.$Nav && $Nav.declare("navHMenuIconClicked",!0);
  };
  hmenu.addEventListener("click", window.navHamburgerMetricLogger);
  window.$Nav && $Nav.declare('hamburgerMenuIconAvailableOnLoad', false);
  window.$Nav && $Nav.declare('hamburgerMenuWeblabTreatment', 'T1');
</script>  
<script type='text/javascript'>window.navmet.push({key:'HamburgerMenuIcon',end:+new Date(),begin:window.navmet.tmp});</script>
        <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
  <div id="nav-logo" >
    <a href="/ref=nav_logo" class="nav-logo-link" aria-label="Amazon" tabindex="6">
      <span class="nav-sprite nav-logo-base"></span>
      <span class="nav-sprite nav-logo-ext"></span>
      <span class="nav-logo-locale"></span>
    </a>
  <a href="/prime?ref_=nav_logo_prime_join" aria-label="" class="nav-sprite nav-logo-tagline nav-prime-try" tabindex="7">
    Try Prime
  </a>
  </div>
<script type='text/javascript'>window.navmet.push({key:'Logo',end:+new Date(),begin:window.navmet.tmp});</script>
      </div>
      
      <div class='nav-right'>
          <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
          <div id='nav-tools' class="layoutToolbarPadding">
              
              
              
              
  <a href="/gp/customer-preferences/select-language/ref=topnav_lang_c?preferencesReturnUrl=%2F" id="icp-nav-flyout" class="nav-a nav-a-2 icp-link-style-2">
    <span class="icp-nav-link-inner">
      <span class="nav-line-1">
        <span class="icp-nav-globe-img-2"></span>
        <span class="icp-nav-language">EN</span>
      </span>
      <span class="nav-line-2">&nbsp;
        <span class="nav-icon nav-arrow"></span>
      </span>
    </span>
  </a>

              
<a href="https://www.amazon.com/ap/signin?openid.pape.max_auth_age=0&openid.return_to=https%3A%2F%2Fwww.amazon.com%2Fmn%2Flanding%2F21103058011%2F%3F_encoding%3DUTF8%26ref_%3Dnav_ya_signin&openid.identity=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&openid.assoc_handle=usflex&openid.mode=checkid_setup&openid.claimed_id=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&" class="nav-a nav-a-2  " data-nav-ref="nav_ya_signin"  data-nav-role="signin" data-ux-jq-mouseenter="true" id="nav-link-accountList" tabindex="22">
  <span class="nav-line-1">Hello, Sign in</span>
  <span class="nav-line-2 ">Account & Lists<span class="nav-icon nav-arrow"></span>
  </span>
  <span class="nav-line-3">Sign in</span>
  <span class="nav-line-4">Account & Lists</span>
</a>

              
<a href="/gp/css/order-history?ref_=nav_orders_first" class="nav-a nav-a-2  " id="nav-orders" tabindex="24">
  <span class="nav-line-1">Returns</span>
  <span class="nav-line-2">& Orders</span>
</a>

              
<a href="/prime?ref_=nav_prime_try_btn" class="nav-a nav-a-2 nav-single-row-link  " data-ux-jq-mouseenter="true" id="nav-link-prime" tabindex="25">
  <span class="nav-line-1"></span>
  <span class="nav-line-2 ">Try Prime<span class="nav-icon nav-arrow"></span>
  </span>
</a>

              
              
  <a href="/gp/cart/view.html?ref_=nav_cart" aria-label=" items in cart" class="nav-a nav-a-2" id="nav-cart" tabindex="26">
    <span aria-hidden="true" class="nav-line-1"></span>
    <span aria-hidden="true" class="nav-line-2">Cart<span class="nav-icon nav-arrow"></span>
    </span>
    <span class="nav-cart-icon nav-sprite"></span>
    <span id="nav-cart-count" aria-hidden="true" class="nav-cart-count nav-cart-0"></span>
  </a>

          </div>
          <script type='text/javascript'>window.navmet.push({key:'Tools',end:+new Date(),begin:window.navmet.tmp});</script>

      </div>
      
          <div class='nav-fill'>
            <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
<div id="nav-search">
  <div id="nav-bar-left"></div>
  <form
    accept-charset="utf-8"
    action="/s/ref=nb_sb_noss"
    class="nav-searchbar"
    method="GET"
    name="site-search"
    role="search"
  >
    <div class="nav-left">
      <div id="nav-search-dropdown-card">
        
  <div class="nav-search-scope nav-sprite">
    <div class="nav-search-facade" data-value="search-alias=aps">
      <span class="nav-search-label">Electronics</span>
      <i class="nav-icon"></i>
    </div>
    <span id="searchDropdownDescription" style="display:none">Select the department you want to search in</span>
    <select
      aria-describedby="searchDropdownDescription"
      class="nav-search-dropdown searchSelect"
      data-nav-digest="wpZgItVF/z8hvYkQ/JJXnOq/S38="
      data-nav-selected="28"
      id="searchDropdownBox"
      name="url"
      style="display: block;"
      tabindex="18"
      title="Search in"
    >
        <option value="search-alias=aps">All Departments</option>
        <option value="search-alias=audible">Audible Books & Originals</option>
        <option value="search-alias=alexa-skills">Alexa Skills</option>
        <option value="search-alias=amazon-devices">Amazon Devices</option>
        <option value="search-alias=warehouse-deals">Amazon Warehouse</option>
        <option value="search-alias=appliances">Appliances</option>
        <option value="search-alias=mobile-apps">Apps & Games</option>
        <option value="search-alias=arts-crafts">Arts, Crafts & Sewing</option>
        <option value="search-alias=automotive">Automotive Parts & Accessories</option>
        <option value="search-alias=baby-products">Baby</option>
        <option value="search-alias=beauty">Beauty & Personal Care</option>
        <option value="search-alias=stripbooks">Books</option>
        <option value="search-alias=popular">CDs & Vinyl</option>
        <option value="search-alias=mobile">Cell Phones & Accessories</option>
        <option value="search-alias=fashion">Clothing, Shoes & Jewelry</option>
        <option value="search-alias=fashion-womens">&#160;&#160;&#160;Women</option>
        <option value="search-alias=fashion-mens">&#160;&#160;&#160;Men</option>
        <option value="search-alias=fashion-girls">&#160;&#160;&#160;Girls</option>
        <option value="search-alias=fashion-boys">&#160;&#160;&#160;Boys</option>
        <option value="search-alias=fashion-baby">&#160;&#160;&#160;Baby</option>
        <option value="search-alias=under-ten-dollars">	
Under $10</option>
        <option value="search-alias=pantry">Amazon Pantry</option>
        <option value="search-alias=collectibles">Collectibles & Fine Art</option>
        <option value="search-alias=computers">Computers</option>
        <option value="search-alias=courses">Courses</option>
        <option value="search-alias=financial">Credit and Payment Cards</option>
        <option value="search-alias=edu-alt-content">Digital Educational Resources</option>
        <option value="search-alias=digital-music">Digital Music</option>
        <option selected="selected" current="parent" value="search-alias=electronics">Electronics</option>
        <option value="search-alias=lawngarden">Garden & Outdoor</option>
        <option value="search-alias=gift-cards">Gift Cards</option>
        <option value="search-alias=grocery">Grocery & Gourmet Food</option>
        <option value="search-alias=handmade">Handmade</option>
        <option value="search-alias=hpc">Health, Household & Baby Care</option>
        <option value="search-alias=local-services">Home & Business Services</option>
        <option value="search-alias=garden">Home & Kitchen</option>
        <option value="search-alias=industrial">Industrial & Scientific</option>
        <option value="search-alias=prime-exclusive">Just for Prime</option>
        <option value="search-alias=digital-text">Kindle Store</option>
        <option value="search-alias=fashion-luggage">Luggage & Travel Gear</option>
        <option value="search-alias=magazines">Magazine Subscriptions</option>
        <option value="search-alias=movies-tv">Movies & TV</option>
        <option value="search-alias=mi">Musical Instruments</option>
        <option value="search-alias=office-products">Office Products</option>
        <option value="search-alias=pets">Pet Supplies</option>
        <option value="search-alias=luxury-beauty">Premium Beauty</option>
        <option value="search-alias=instant-video">Prime Video</option>
        <option value="search-alias=smart-home">Smart Home</option>
        <option value="search-alias=software">Software</option>
        <option value="search-alias=sporting">Sports & Outdoors</option>
        <option value="search-alias=subscribe-with-amazon">Subscription Boxes</option>
        <option value="search-alias=tools">Tools & Home Improvement</option>
        <option value="search-alias=toys-and-games">Toys & Games</option>
        <option value="search-alias=vehicles">Vehicles</option>
        <option value="search-alias=videogames">Video Games</option>
    </select>
  </div>

      </div>
    </div>
    <div class="nav-right">
      <div class="nav-search-submit nav-sprite">
        <span id="nav-search-submit-text" class="nav-search-submit-text nav-sprite">
          Go
        </span>
        <input type="submit" class="nav-input" value="Go" tabindex="20">
      </div>
    </div>
    <div class="nav-fill">
      <div class="nav-search-field ">
        <label id="nav-search-label" for="twotabsearchtextbox" class="aok-offscreen">
          Search
        </label>
        <input
          type="text"
          id="twotabsearchtextbox"
          value=""
          name="field-keywords"
          autocomplete="off"
          placeholder=""
          class="nav-input"
          dir="auto"
          tabindex="19"
        >
      </div>
      <div id="nav-iss-attach"></div>
    </div>
  </form>
</div>
<script type='text/javascript'>window.navmet.push({key:'Search',end:+new Date(),begin:window.navmet.tmp});</script>
          </div>
      
    </div>
    <div id='nav-main' class='nav-sprite'>
      
      
      
      
      
      <div class='nav-left'>
        
<!-- NAVYAAN-GLOW-NAV -->
<div id="nav-global-location-slot">
    <span class="a-declarative" data-a-modal='{&quot;width&quot;:375, &quot;closeButton&quot;:&quot;false&quot;,&quot;popoverLabel&quot;:&quot;Choose your location&quot;, &quot;name&quot;:&quot;glow-modal&quot;, &quot;url&quot;:&quot;/gp/glow/get-address-selections.html?deviceType&#x3D;desktop&amp;pageType&#x3D;Landing&amp;storeContext&#x3D;pc&quot;, &quot;footer&quot;:&quot;&lt;span class&#x3D;\&quot;a-declarative\&quot; data-action&#x3D;\&quot;a-popover-close\&quot; data-a-popover-close&#x3D;\&quot;{}\&quot;&gt;&lt;span class&#x3D;\&quot;a-button a-button-primary\&quot;&gt;&lt;span class&#x3D;\&quot;a-button-inner\&quot;&gt;&lt;button name&#x3D;\&quot;glowDoneButton\&quot; class&#x3D;\&quot;a-button-text\&quot; type&#x3D;\&quot;button\&quot;&gt;Done&lt;/button&gt;&lt;/span&gt;&lt;/span&gt;&lt;/span&gt;&quot;,&quot;header&quot;:&quot;Choose your location&quot;}' data-action="a-modal">
        <a class="nav-a nav-a-2 a-popover-trigger a-declarative" tabindex="35">
            <div class="nav-sprite" id="nav-packard-glow-loc-icon"></div>
            <div id="glow-ingress-block">
                <span class="nav-line-1" id="glow-ingress-line1">
                   Hello
                </span>
                <span class="nav-line-2" id="glow-ingress-line2">
                   Select your address
                </span>
            </div>
        </a>
        </span>
        <input data-addnewaddress="add-new" id="unifiedLocation1ClickAddress" name="dropdown-selection" type="hidden" value="add-new" />
        <input data-addnewaddress="add-new" id="ubbShipTo" name="dropdown-selection-ubb" type="hidden" value="add-new" />
</div>


        
        
        
        
      </div>
      
      <div class='nav-right'>
          <script type='text/javascript'>window.navmet.tmp=+new Date();</script><!-- Navyaan SWM -->
<div id="nav-swmslot" class="nav-swm-text-widget">
  <a href="/dp/B0858ZPY17/ref=dvm_us_or_cs_swm_all_20upl/?_encoding=UTF8&ref_=nav_swm_dvm_us_or_cs_swm_all_20upl&pf_rd_p=2044dd2c-4060-47e1-a3e7-b6dfc87ccde7&pf_rd_s=nav-sitewide-msg-text&pf_rd_t=4201&pf_rd_i=navbar-4201&pf_rd_m=ATVPDKIKX0DER&pf_rd_r=YE6JG88QGZ36FVRYCRK2" class="nav_a nav-swm-text"><i>Upload</i> a new sci-fi comedy</a>
</div><script type='text/javascript'>window.navmet.push({key:'SWM',end:+new Date(),begin:window.navmet.tmp});</script>
      </div>
      
      <div class='nav-fill'>
        
        
        
          
 <div id="nav-shop">
 </div>
          <div id='nav-xshop-container' >
            
            <div id='nav-xshop'>
              <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
<a href="/gp/bestsellers/?ref_=nav_cs_bestsellers" class="nav-a  " tabindex="47">Best Sellers</a>

<a href="/gp/help/customer/display.html?nodeId=508510&ref_=nav_cs_customerservice" class="nav-a  " tabindex="48">Customer Service</a>

<a href="/gp/new-releases/?ref_=nav_cs_newreleases" class="nav-a  " tabindex="49">New Releases</a>

<a href="/gcx/Gifts-for-Everyone/gfhz/?ref_=nav_cs_giftfinder" class="nav-a  " tabindex="50">Find a Gift</a>

<a href="/gp/browse.html?node=17235386011&ref_=nav_cs_whole_foods" class="nav-a  " tabindex="51">Whole Foods</a>

<a href="/gp/goldbox?ref_=nav_cs_gb" class="nav-a  " tabindex="52">Today's Deals</a>

<a href="/gift-cards/b/?ie=UTF8&node=2238192011&ref_=nav_cs_gc" class="nav-a  " tabindex="53">Gift Cards</a>

<a href="/gp/browse.html?node=16115931011&ref_=nav_cs_registry" class="nav-a  " tabindex="54">Registry</a>

<a href="/stores/node/2528919011/?field-lbr_brands_browse-bin=AmazonBasics&ref_=nav_cs_amazonbasics" class="nav-a  " tabindex="55">AmazonBasics</a>

<a href="/b/?_encoding=UTF8&ld=AZUSSOA-sell&node=12766669011&ref_=nav_cs_sell" class="nav-a  " tabindex="56">Sell</a>

<a href="/finds?ref_=nav_cs_foundit" class="nav-a  " tabindex="57">#FoundItOnAmazon</a>

<a href="/Coupons/b/?_encoding=UTF8&node=2231352011&ref_=nav_cs_coupons" class="nav-a  " tabindex="58">Coupons</a>

<a href="/b/?node=16548547011&ref_=nav_cs_freeshipping" class="nav-a  " tabindex="59">Free Shipping</a>

<a href="/b/?node=17867753011&ref_=nav_cs_shoppertoolkit" class="nav-a  " tabindex="60">Shopper Toolkit</a>

<a href="/gp/help/customer/accessibility" aria-label="Click to call our Disability Customer Support line, or reach us directly at 1-888-283-1678" class="nav-hidden-aria  " tabindex="61" >Disability Customer Support</a>
<script type='text/javascript'>window.navmet.push({key:'CrossShop',end:+new Date(),begin:window.navmet.tmp});</script>
            </div>
            
            
            
              
            
          </div>
        
      </div>
      
    </div>

    <div id='nav-subnav-toaster'></div>

    
    <script type='text/javascript'>window.navmet.tmp=+new Date();</script>
<div id='nav-subnav' class="spacious" data-category="pc">
  <a href="/computer-pc-hardware-accessories-add-ons/b/?ie=UTF8&node=541966&ref_=topnav_storetab_pc" class="nav-a nav-b" >
    <span class="nav-a-content">
      Computers
      
    </span>
  </a>
  <a href="/Notebooks-Laptop-Computers/b/?ie=UTF8&node=565108&ref_=sv_pc_1" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-1,pc-subnav-flyout-promo-1:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-1,pc-subnav-flyout-promo-1">
    <span class="nav-a-content">
      Laptops
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/Desktops-Computers-Add-Ons/b/?ie=UTF8&node=565098&ref_=sv_pc_2" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-3,pc-subnav-flyout-promo-3:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-3,pc-subnav-flyout-promo-3">
    <span class="nav-a-content">
      Desktops
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/Monitors-Computers-Accessories/b/?ie=UTF8&node=1292115011&ref_=sv_pc_3" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-4,pc-subnav-flyout-promo-4:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-4,pc-subnav-flyout-promo-4">
    <span class="nav-a-content">
      Monitors
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/Tablets/b/?ie=UTF8&node=1232597011&ref_=sv_pc_4" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-2,pc-subnav-flyout-promo-2:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-2,pc-subnav-flyout-promo-2">
    <span class="nav-a-content">
      Tablets
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/Computer-Accessories-Supplies/b/?ie=UTF8&node=172456&ref_=sv_pc_5" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-5,pc-subnav-flyout-promo-5:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-5,pc-subnav-flyout-promo-5">
    <span class="nav-a-content">
      Computer Accessories
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/PC-Parts-Components/b/?ie=UTF8&node=193870011&ref_=sv_pc_6" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-6,pc-subnav-flyout-promo-6:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-6,pc-subnav-flyout-promo-6">
    <span class="nav-a-content">
      PC Components
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/PC-Gaming/b/?ie=UTF8&node=8588809011&ref_=sv_pc_7" class="nav-a nav-hasArrow" data-nav-flyout-full-width="1" data-nav-key="ab:pc-subnav-flyout-content-7,pc-subnav-flyout-promo-7:verticalstores-subnav-flyout" data-handler="verticalstores-subnav-flyout" data-slots="pc-subnav-flyout-content-7,pc-subnav-flyout-promo-7">
    <span class="nav-a-content">
      PC Gaming
      
    </span>
    <span class="nav-arrow"></span>
  </a>
  <a href="/b/?ie=UTF8&node=14777268011&ref_=sv_pc_8" class="nav-a" >
    <span class="nav-a-content">
      Deals
      
    </span>
  </a>
<!-- nav-linktree-subnav - 'pc' -->
</div>

<script type='text/javascript'>window.navmet.push({key:'Subnav',end:+new Date(),begin:window.navmet.tmp});</script>

    
    
    
  </div>

  
  

</header>
<script type='text/javascript'>window.navmet.push({key:'NavBar',end:+new Date(),begin:window.navmet.main});</script>

<script type='text/javascript'>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</script>


<a id="skippedLink" tabindex="-1"></a>

<script type='text/javascript'>window.navmet.MainEnd = new Date();</script>



<div id="top-static" class="a-section a-spacing-none s-padding-left-small s-padding-right-small s-span-page" role="banner"></div><div id="top" class="a-section a-spacing-none s-padding-left-small s-padding-right-small s-span-page" role="banner"></div><script>P.register('af');</script><script>P.register('cf');</script><div class="a-fixed-left-flipped-grid s-padding-left-small s-padding-right-small s-span-page a-spacing-top-small"><div class="a-fixed-left-grid-inner" style="padding-left:200px"><div class="a-fixed-left-grid-col a-col-right" style="padding-left:0%;width:100%;float:right;"><div id="container" class="lp s-padding-left-small twoColumn" data-app="lp" data-page="hybrid" data-page-construction="sx" documentRole="main">

                    <div id="merchandised-content" class="a-section"><img onload="if (typeof uet == 'function') { uet('af'); }" src="https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/transparent-pixel._CB485935036_.gif" width="1" alt="" height="1" border="0" /><img onload="if (typeof uet == 'function') { uet('fn'); }" src="https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/transparent-pixel._CB485935036_.gif" width="1" alt="" height="1" border="0" /><div id="search-js-btf">

  <script type="text/javascript">
      
      amzn.sx.utils.jsDepMgr.when('jQuery search-js-general breadcrumb', 'searchJsBtf', function($, searchComponents, breadcrumb) {
          
          SPUtils.triggerEvent("spFold");

          
          breadcrumb.breadcrumbSearch();

          
          breadcrumb.editableBreadcrumb();

          
          $(function () {searchComponents.hoverOverImageTriggersTitleHover();});

          SPUtils.afterEvent("spATFEvent", function () {
            
            registerAivHandler("atf");

              
              setFinancialValidation();
          });

          
          if (typeof processBundlesFlyouts == 'function') {
              processBundlesFlyouts('atf');
          }

          
                      amzn.sx.utils.jsDepMgr.when('popover', 'promotionPopover', function() {
                          processPromotionsPopover();
                      });
          

      });

      </script>

</div>
</div><div id="search-results" aria-label="Search results" class="a-section" role="contentinfo"><script type="text/javascript">

    !function() {
      ue.count('sx.cf.bounds-support', document.documentElement.getBoundingClientRect ? 1 : 0);

      var $, docElem = document.documentElement, body = document.body, imageLoadElems = [], imageLoadRecs = [], curResCount = -1,
          domReady, measurementOpen = true;

      function makeViewportContext() {
        var docElem = document.documentElement,
            body = document.body;
        return {
          scrollTop: window.scrollY || window.pageYOffset || docElem.scrollTop || body.scrollTop,
          scrollLeft: window.scrollX || window.pageXOffset || docElem.scrollLeft || body.scrollLeft,
          clientHeight: docElem.clientHeight,
          clientWidth: docElem.clientWidth,
          clientTop: docElem.clientTop || body.clientTop || 0,
          clientLeft: docElem.clientLeft || body.clientLeft || 0
        };
      }

      
      function inInitialViewport(viewportCtx, elem) {
        if (!elem.getBoundingClientRect) {
	  return true;
	}

        var box = elem.getBoundingClientRect(),
            
            bottom = Math.round(box.bottom + viewportCtx.scrollTop - viewportCtx.clientTop),
            right = Math.round(box.right + viewportCtx.scrollLeft - viewportCtx.clientLeft);
        return ((bottom <= viewportCtx.clientHeight) && (right <= viewportCtx.clientWidth));
      }

      
      function viewCompleteImageLoaded(image, time, resCount, isAjax) {
        var i, imageLoad, cfTime = -1, cfImageCnt = 0, cfImagePixels = 0, w, h, viewportCtx,
            ueScope, ueScopeRec;

        
        if (!measurementOpen) {
            return;
        }

        
        if (image) {
          if (imageLoadElems.indexOf(image) !== -1) {
            return; 
          }
          
          imageLoadRecs.push({"image": image, "time": time});
          imageLoadElems.push(image);

          
          if (curResCount !== -1 && curResCount !== resCount) {
            ue.count('sx.cf.res-count-misalignment', resCount);
          }
          curResCount = resCount;
        } else {
          resCount = curResCount; 
        }

        
        if (!domReady || imageLoadRecs.length < resCount) {return;}

        
        viewportCtx = makeViewportContext();
        for (i = 0; i < resCount; i++) {
          imageLoad = imageLoadRecs[i];
          if (inInitialViewport(viewportCtx, imageLoad.image)) {
            cfImageCnt++;
            if (imageLoad.time > cfTime) {cfTime = imageLoad.time;}
            imageLoad.inViewport = true;
          }
        }

        
        if (cfTime <= 0) {cfTime = +new Date;}

        
        if (cfImageCnt === 0) {
            ue.tag('ZeroInViewport');
        }

        
        ueScope = ($ && $.searchUE && $.searchUE.getScope()) || undefined;
        if (ueScope) {
            ueScopeRec = {scope: ueScope};
        }

        
        uet('cf', ueScope, undefined, cfTime);

        
        ueScope && $.searchUE.manageLoad();

                
        ue.count('cfImageCount', cfImageCnt, ueScopeRec);

        
        for (i = 0; i < resCount; i++) {
          imageLoad = imageLoadRecs[i];
          if (imageLoad.inViewport) {
              w = imageLoad.image.naturalWidth;
              h = imageLoad.image.naturalHeight;
              if (w && h) {
                cfImagePixels += w * h;
              }
          }
        }
        ue.count('sx.cf.image-thousand-pixels', parseInt(cfImagePixels / 1000), ueScopeRec);

        
        imageLoadRecs = [];
        imageLoadElems = [];
        curResCount = -1;

        
        measurementOpen = false;
      }

      
      function afterJQueryAvailable(jQuery) {
        $ = jQuery || window.jQuery;
        $ && $(document).bind('before-searchajax', function() {
          if (imageLoadRecs.length) {
            
            ue.count('sx.cf.images-loads-missed', curResCount - imageLoadRecs.length);

            
            imageLoadRecs = [];
            imageLoadElems = [];
            curResCount = -1;
          }

          if (window.document.addEventListener) {
            domReady = false;
          }

          
          measurementOpen = true;
        });
      }
      window.P && window.P.when('jQuery').execute(afterJQueryAvailable);

      
      if (window.document.addEventListener) {
        function domReadyHandler() {
            domReady = true;
            viewCompleteImageLoaded();
        }
        window.document.addEventListener('DOMContentLoaded', domReadyHandler, false);
        window.P && window.P.when('A').execute(
          function(A) {
            A.on('searchAjaxTransitionDone', domReadyHandler);
          }
        );
      } else {
        
        domReady = true;
      }

      
      window.viewCompleteImageLoaded = viewCompleteImageLoaded;
    }();
    </script>
<div id="s-result-info-bar" class="a-row a-spacing-base searchUndoAUIHacks"><div id="s-result-info-bar-content" class="a-row"><div class="a-column a-span8 a-spacing-none"><div class="s-first-column">
                <div class="a-section a-spacing-small a-spacing-top-small"><span id="s-result-count">4 results for <span><a class="a-link-normal a-color-base a-text-bold a-text-normal" href="https://www.amazon.com/electronics-store/b?ie=UTF8&amp;node=172282">Electronics</a> : <span class="a-color-state a-text-bold">Save Big on Samsung SSD Drives.</span></span></span></div></div>
        </div><div class="a-column a-span4 a-text-right a-spacing-none a-span-last"><div class="a-row a-spacing-micro a-spacing-top-micro"><div class="s-last-column">
                    </div>
            </div></div></div></div><div id="mainResults" class="a-row s-result-list-parent-container"><ul class="s-result-list s-col-3 s-col-ws-4 s-result-list-hgrid s-height-equalized s-grid-view s-text-condensed" data-columns="{&quot;0&quot;:1,&quot;522&quot;:3,&quot;348&quot;:2}"><li id="result_0" data-result-rank="0" data-asin="B0781Z7Y3S" class="s-result-item  celwidget  "><div class="s-item-container"><div class="a-row a-spacing-top-micro a-spacing-micro"><div class="a-row sx-badge-region"><div class="a-row a-spacing-large"></div></div></div><div class="a-row a-spacing-base"><div aria-hidden="true" class="a-column a-span12 a-text-left"><div class="a-section a-spacing-none a-inline-block s-position-relative"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-500GB-Internal-MZ-76E500B-AM/dp/B0781Z7Y3S"><img src="https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US160_.jpg" srcset="https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US160_.jpg 1x, https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US240_QL65_.jpg 1.5x, https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US320_QL65_.jpg 2x, https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US400_QL65_.jpg 2.5x, https://images-na.ssl-images-amazon.com/images/I/31-hn6s1QYL._AC_US480_QL65_.jpg 3x" width="160" height="160" alt="Samsung 860 EVO 500GB 2.5 Inch SATA III Internal SSD (MZ-76E500B/AM)" class="s-access-image cfMarker" data-search-image-load></a><div class="a-section a-spacing-none a-text-center"></div></div></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal s-access-detail-page s-color-twister-title-link a-text-normal" title="Samsung 860 EVO 500GB 2.5 Inch SATA III Internal SSD (MZ-76E500B/AM)" href="https://www.amazon.com/Samsung-500GB-Internal-MZ-76E500B-AM/dp/B0781Z7Y3S"><h2 data-attribute="Samsung 860 EVO 500GB 2.5 Inch SATA III Internal SSD (MZ-76E500B/AM)" data-max-rows="0" class="a-size-base s-inline s-access-title a-text-normal">Samsung 860 EVO 500GB 2.5 Inch SATA III Internal SSD (MZ-76E500B/AM)</h2></a></div><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">by </span><span class="a-size-small a-color-secondary">Samsung</span></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-500GB-Internal-MZ-76E500B-AM/dp/B0781Z7Y3S"><span class="a-price" data-a-size="l" data-a-color="base"><span class="a-offscreen">$94.99</span><span aria-hidden="true"><span class="a-price-symbol">$</span><span class="a-price-whole">94<span class="a-price-decimal">.</span></span><span class="a-price-fraction">99</span></span></span></a><span class="a-letter-space"></span><span aria-label="Suggested Retail Price: $109.99" class="a-size-base-plus a-color-secondary a-text-strike">$109.99</span><span class="a-letter-space"></span><i class="a-icon a-icon-prime a-icon-small s-align-text-bottom" role="img" aria-label="Prime"></i></div><div class="a-row a-spacing-none"><div class="a-row a-spacing-mini"></div><span class="a-size-small a-color-secondary">More Buying Choices</span></div><div class="a-row a-spacing-none"><a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/gp/offer-listing/B0781Z7Y3S"><span class="a-color-secondary a-text-strike"></span><span class="a-size-base a-color-base">$82.67</span><span class="a-letter-space"></span>(28 used &amp new offers)</a></div></div><div class="a-row a-spacing-top-mini a-spacing-mini"><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">FREE Shipping on eligible orders</span></div></div><div class="a-row a-spacing-none"><span name="B0781Z7Y3S">
    <span class="a-declarative" data-action="a-popover" data-a-popover="{&quot;max-width&quot;:&quot;700&quot;,&quot;closeButton&quot;:&quot;false&quot;,&quot;position&quot;:&quot;triggerBottom&quot;,&quot;url&quot;:&quot;/review/widgets/average-customer-review/popover/ref=acr_search__popover?ie=UTF8&amp;asin=B0781Z7Y3S&amp;contextId=search&amp;ref=acr_search__popover&quot;}"><a href="javascript:void(0)" class="a-popover-trigger a-declarative"><i class="a-icon a-icon-star a-star-5"><span class="a-icon-alt">4.8 out of 5 stars</span></i><i class="a-icon a-icon-popover"></i></a></span></span>

<a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-500GB-Internal-MZ-76E500B-AM/dp/B0781Z7Y3S#customerReviews">16,341</a></div></div></li><li id="result_1" data-result-rank="1" data-asin="B07MFZY2F2" class="s-result-item  celwidget  "><div class="s-item-container"><div class="a-row a-spacing-top-micro a-spacing-micro"><div class="a-row sx-badge-region"><div class="a-row a-spacing-large"></div></div></div><div class="a-row a-spacing-base"><div aria-hidden="true" class="a-column a-span12 a-text-left"><div class="a-section a-spacing-none a-inline-block s-position-relative"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-970-EVO-Plus-MZ-V7S1T0B/dp/B07MFZY2F2"><img src="https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US160_.jpg" srcset="https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US160_.jpg 1x, https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US240_QL65_.jpg 1.5x, https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US320_QL65_.jpg 2x, https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US400_QL65_.jpg 2.5x, https://images-na.ssl-images-amazon.com/images/I/31+rkXdQL8L._AC_US480_QL65_.jpg 3x" width="160" height="160" alt="Samsung  (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology" class="s-access-image cfMarker" data-search-image-load></a><div class="a-section a-spacing-none a-text-center"></div></div></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none sx-line-clamp-4"><a class="a-link-normal s-access-detail-page s-color-twister-title-link a-text-normal" title="Samsung  (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology" href="https://www.amazon.com/Samsung-970-EVO-Plus-MZ-V7S1T0B/dp/B07MFZY2F2"><h2 data-attribute="Samsung  (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology" data-max-rows="4" class="a-size-base s-inline s-access-title a-text-normal">Samsung  (MZ-V7S1T0B/AM) 970 EVO Plus SSD 1TB - M.2 NVMe Interface Internal Solid State Drive with V-NAND Technology</h2></a></div><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">by </span><span class="a-size-small a-color-secondary">Samsung</span></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-970-EVO-Plus-MZ-V7S1T0B/dp/B07MFZY2F2"><span class="a-price" data-a-size="l" data-a-color="base"><span class="a-offscreen">$229.99</span><span aria-hidden="true"><span class="a-price-symbol">$</span><span class="a-price-whole">229<span class="a-price-decimal">.</span></span><span class="a-price-fraction">99</span></span></span></a><span class="a-letter-space"></span><span aria-label="Suggested Retail Price: $249.99" class="a-size-base-plus a-color-secondary a-text-strike">$249.99</span><span class="a-letter-space"></span><i class="a-icon a-icon-prime a-icon-small s-align-text-bottom" role="img" aria-label="Prime"></i></div><div class="a-row a-spacing-none"><div class="a-row a-spacing-mini"></div><span class="a-size-small a-color-secondary">More Buying Choices</span></div><div class="a-row a-spacing-none"><a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/gp/offer-listing/B07MFZY2F2"><span class="a-color-secondary a-text-strike"></span><span class="a-size-base a-color-base">$211.59</span><span class="a-letter-space"></span>(14 used &amp new offers)</a></div></div><div class="a-row a-spacing-top-mini a-spacing-mini"><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">FREE Shipping on eligible orders</span></div></div><div class="a-row a-spacing-none"><span name="B07MFZY2F2">
    <span class="a-declarative" data-action="a-popover" data-a-popover="{&quot;max-width&quot;:&quot;700&quot;,&quot;closeButton&quot;:&quot;false&quot;,&quot;position&quot;:&quot;triggerBottom&quot;,&quot;url&quot;:&quot;/review/widgets/average-customer-review/popover/ref=acr_search__popover?ie=UTF8&amp;asin=B07MFZY2F2&amp;contextId=search&amp;ref=acr_search__popover&quot;}"><a href="javascript:void(0)" class="a-popover-trigger a-declarative"><i class="a-icon a-icon-star a-star-5"><span class="a-icon-alt">4.8 out of 5 stars</span></i><i class="a-icon a-icon-popover"></i></a></span></span>

<a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-970-EVO-Plus-MZ-V7S1T0B/dp/B07MFZY2F2#customerReviews">2,792</a></div></div></li><li id="result_2" data-result-rank="2" data-asin="B073H552FJ" class="s-result-item  celwidget  "><div class="s-item-container"><div class="a-row a-spacing-top-micro a-spacing-micro"><div class="a-row sx-badge-region"><div class="a-row a-spacing-large"></div></div></div><div class="a-row a-spacing-base"><div aria-hidden="true" class="a-column a-span12 a-text-left"><div class="a-section a-spacing-none a-inline-block s-position-relative"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-T5-Portable-SSD-MU-PA1T0B/dp/B073H552FJ"><img src="https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US160_.jpg" srcset="https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US160_.jpg 1x, https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US240_QL65_.jpg 1.5x, https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US320_QL65_.jpg 2x, https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US400_QL65_.jpg 2.5x, https://images-na.ssl-images-amazon.com/images/I/31H5YJRG1AL._AC_US480_QL65_.jpg 3x" width="160" height="160" alt="Samsung (MU-PA1T0B/AM) T5 Portable SSD - 1TB - USB 3.1 External SSD , Black" class="s-access-image cfMarker" data-search-image-load></a><div class="a-section a-spacing-none a-text-center"></div></div></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal s-access-detail-page s-color-twister-title-link a-text-normal" title="Samsung (MU-PA1T0B/AM) T5 Portable SSD - 1TB - USB 3.1 External SSD , Black" href="https://www.amazon.com/Samsung-T5-Portable-SSD-MU-PA1T0B/dp/B073H552FJ"><h2 data-attribute="Samsung (MU-PA1T0B/AM) T5 Portable SSD - 1TB - USB 3.1 External SSD , Black" data-max-rows="0" class="a-size-base s-inline s-access-title a-text-normal">Samsung (MU-PA1T0B/AM) T5 Portable SSD - 1TB - USB 3.1 External SSD , Black</h2></a></div><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">by </span><span class="a-size-small a-color-secondary">Samsung</span></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-T5-Portable-SSD-MU-PA1T0B/dp/B073H552FJ"><span class="a-price" data-a-size="l" data-a-color="base"><span class="a-offscreen">$179.99</span><span aria-hidden="true"><span class="a-price-symbol">$</span><span class="a-price-whole">179<span class="a-price-decimal">.</span></span><span class="a-price-fraction">99</span></span></span></a><span class="a-letter-space"></span><span aria-label="Suggested Retail Price: $249.99" class="a-size-base-plus a-color-secondary a-text-strike">$249.99</span><span class="a-letter-space"></span><i class="a-icon a-icon-prime a-icon-small s-align-text-bottom" role="img" aria-label="Prime"></i></div><div class="a-row a-spacing-none"><div class="a-row a-spacing-mini"></div><span class="a-size-small a-color-secondary">More Buying Choices</span></div><div class="a-row a-spacing-none"><a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/gp/offer-listing/B073H552FJ"><span class="a-color-secondary a-text-strike"></span><span class="a-size-base a-color-base">$150.07</span><span class="a-letter-space"></span>(19 used &amp new offers)</a></div></div><div class="a-row a-spacing-top-mini a-spacing-mini"><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">FREE Shipping on eligible orders</span></div></div><div class="a-row a-spacing-none"><span name="B073H552FJ">
    <span class="a-declarative" data-action="a-popover" data-a-popover="{&quot;max-width&quot;:&quot;700&quot;,&quot;closeButton&quot;:&quot;false&quot;,&quot;position&quot;:&quot;triggerBottom&quot;,&quot;url&quot;:&quot;/review/widgets/average-customer-review/popover/ref=acr_search__popover?ie=UTF8&amp;asin=B073H552FJ&amp;contextId=search&amp;ref=acr_search__popover&quot;}"><a href="javascript:void(0)" class="a-popover-trigger a-declarative"><i class="a-icon a-icon-star a-star-4-5"><span class="a-icon-alt">4.7 out of 5 stars</span></i><i class="a-icon a-icon-popover"></i></a></span></span>

<a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-T5-Portable-SSD-MU-PA1T0B/dp/B073H552FJ#customerReviews">5,507</a></div></div></li><li id="result_3" data-result-rank="3" data-asin="B07GBGG68L" class="s-result-item  celwidget  "><div class="s-item-container"><div class="a-row a-spacing-top-micro a-spacing-micro"><div class="a-row sx-badge-region"><div class="a-row a-spacing-large"></div></div></div><div class="a-row a-spacing-base"><div aria-hidden="true" class="a-column a-span12 a-text-left"><div class="a-section a-spacing-none a-inline-block s-position-relative"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-Portable-SSD-Thunderbolt-MU-PB500B/dp/B07GBGG68L"><img src="https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US160_.jpg" srcset="https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US160_.jpg 1x, https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US240_QL65_.jpg 1.5x, https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US320_QL65_.jpg 2x, https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US400_QL65_.jpg 2.5x, https://images-na.ssl-images-amazon.com/images/I/31AGggzGKBL._AC_US480_QL65_.jpg 3x" width="160" height="160" alt="Samsung X5 Portable SSD 500GB - Thunderbolt 3 External Solid State Drive with NVMe Interface (MU-PB500B/AM) - Gray/Red" class="s-access-image cfMarker" data-search-image-load></a><div class="a-section a-spacing-none a-text-center"></div></div></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none sx-line-clamp-4"><a class="a-link-normal s-access-detail-page s-color-twister-title-link a-text-normal" title="Samsung X5 Portable SSD 500GB - Thunderbolt 3 External Solid State Drive with NVMe Interface (MU-PB500B/AM) - Gray/Red" href="https://www.amazon.com/Samsung-Portable-SSD-Thunderbolt-MU-PB500B/dp/B07GBGG68L"><h2 data-attribute="Samsung X5 Portable SSD 500GB - Thunderbolt 3 External Solid State Drive with NVMe Interface (MU-PB500B/AM) - Gray/Red" data-max-rows="4" class="a-size-base s-inline s-access-title a-text-normal">Samsung X5 Portable SSD 500GB - Thunderbolt 3 External Solid State Drive with NVMe Interface (MU-PB500B/AM) - Gray/Red</h2></a></div><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">by </span><span class="a-size-small a-color-secondary">Samsung</span></div></div><div class="a-row a-spacing-mini"><div class="a-row a-spacing-none"><a class="a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-Portable-SSD-Thunderbolt-MU-PB500B/dp/B07GBGG68L"><span class="a-price" data-a-size="l" data-a-color="base"><span class="a-offscreen">$199.99</span><span aria-hidden="true"><span class="a-price-symbol">$</span><span class="a-price-whole">199<span class="a-price-decimal">.</span></span><span class="a-price-fraction">99</span></span></span></a><span class="a-letter-space"></span><i class="a-icon a-icon-prime a-icon-small s-align-text-bottom" role="img" aria-label="Prime"></i></div><div class="a-row a-spacing-none"><div class="a-row a-spacing-mini"></div><span class="a-size-small a-color-secondary">More Buying Choices</span></div><div class="a-row a-spacing-none"><a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/gp/offer-listing/B07GBGG68L"><span class="a-color-secondary a-text-strike"></span><span class="a-size-base a-color-base">$183.99</span><span class="a-letter-space"></span>(6 used &amp new offers)</a></div></div><div class="a-row a-spacing-top-mini a-spacing-mini"><div class="a-row a-spacing-none"><span class="a-size-small a-color-secondary">FREE Shipping on eligible orders</span></div></div><div class="a-row a-spacing-none"><span name="B07GBGG68L">
    <span class="a-declarative" data-action="a-popover" data-a-popover="{&quot;max-width&quot;:&quot;700&quot;,&quot;closeButton&quot;:&quot;false&quot;,&quot;position&quot;:&quot;triggerBottom&quot;,&quot;url&quot;:&quot;/review/widgets/average-customer-review/popover/ref=acr_search__popover?ie=UTF8&amp;asin=B07GBGG68L&amp;contextId=search&amp;ref=acr_search__popover&quot;}"><a href="javascript:void(0)" class="a-popover-trigger a-declarative"><i class="a-icon a-icon-star a-star-4-5"><span class="a-icon-alt">4.4 out of 5 stars</span></i><i class="a-icon a-icon-popover"></i></a></span></span>

<a class="a-size-small a-link-normal a-text-normal" href="https://www.amazon.com/Samsung-Portable-SSD-Thunderbolt-MU-PB500B/dp/B07GBGG68L#customerReviews">193</a></div></div></li></ul></div><li id="s-result-list-layout-placeholder" class="s-result-item aok-hidden "><div class="s-item-container"></div></li><div class="img_header hdr noborder" id="bottomBar">
    <div id="pagn" class="pagnHy" >
            <br clear="all" />
        </div>
    </div>


    














   
    












<div id="search-js-btf-external">




 


 
 

 
 



</div>



    













    












<div id="search-js-btr-external">
</div>




</div><div id="center-bottom" class="a-section" role="complementary"><div id="poweredByEmpty" style="width:24px; height:24px; background:white;"></div><script type="text/javascript">
  amzn.sx.utils.jsDepMgr.when('jQuery', 'search-trackingInfo-init', function($) {
    $.pageContext = {"isUnsupportedRequest":true,"isApplicationFailure":false,"redirectUrl":"\u002Fb?node=21103058011","rid":"YE6JG88QGZ36FVRYCRK2","qid":"1589306104","pageStructure":"results","pageApp":"gp\u002Fsearch","browseLadder":"n%3A172282%2Cn%3A%2113900871%2Cn%3A%212334091011%2Cn%3A%212334153011%2Cn%3A21103058011","node":"21103058011","searchAlias":"electronics","searchAliasDisplayName":"Electronics","csrfToken":"gE9PXJQxJMBH6Vz3vc3goL4XlxYrD5yQsbSO4CAAAAAMAAAAAF664vhyYXcAAAAA","searchSkeletonKey":"results--searchTemplate defaultLayout so_us_en--left-nav--shopping-engine","pageType":"Landing","subPageType":"Cat-Sr","store":"pc","programRegionId":"a6d85d259af204b58d2a7f317dcccd9888ed8ff0","pageTitle":"Amazon.com: Save Big on Samsung SSD Drives.: Electronics","metaKeywords":"Save Big on Samsung SSD Drives., Electronics, Amazon.com","metaDescription":"Online shopping for Save Big on Samsung SSD Drives. from a great selection at Electronics Store.","rhsSuppressed":"rhs"};
  });
</script>
</div><img onload="if (typeof uet == 'function') { uet('cf'); }" src="https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/transparent-pixel._CB485935036_.gif" width="1" alt="" height="1" border="0" /></div>
            </div><div class="a-fixed-left-grid-col a-col-left" style="width:200px;margin-left:-200px;float:none;"><div aria-label="Left Navigation" class="a-section s-padding-right-mini s-border-right" role="region"><div class="a-section a-spacing-none" role="directory"></div><div aria-label="Categories and Refinements" class="a-section a-spacing-none" role="navigation"><div id="leftNav" class="s-padding-right-mini s-border-right">
                                <h3 class="a-size-medium a-spacing-base a-spacing-top-small a-color-tertiary a-text-normal">Show results for</h3><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><li class="s-ref-indent-neg-micro"><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="https://www.amazon.com/electronics-store/b?ie=UTF8&amp;node=172282"><span class="a-size-small a-color-base"><span class="srSprite backArrow"></span>
                                Electronics</span></a></span></li><li class="s-ref-indent-one"><span class="a-list-item"><h4 class="a-size-small a-color-base a-text-bold">Save Big on Samsung SSD Drives.</h4></span></li><ul class="a-unordered-list a-nostyle a-vertical s-ref-indent-two"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="https://www.amazon.com/computer-pc-hardware-accessories-add-ons/b?ie=UTF8&amp;node=541966"><span class="a-size-small a-color-base">Computers &amp; Accessories</span></a></span></li></div></ul></ul><hr class="a-spacing-base a-spacing-top-base a-divider-normal s-left-rail-margin"/><h3 class="a-size-medium a-spacing-base a-spacing-top-base a-color-tertiary a-text-normal">Refine by</h3><h4 class="a-size-small a-spacing-micro a-color-base a-text-bold">Amazon Prime</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_85%3A2470955011&quot;}"><div data-a-input-name="s-ref-checkbox-2470955011" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-2470955011" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><i class="a-icon a-icon-prime a-icon-small s-ref-text-link" role="img"></i></span></label></div></span></span></li></div></ul><h4 class="a-size-small a-spacing-mini a-color-base a-text-bold">Eligible for Free Shipping</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_76%3A1249137011&quot;}"><div data-a-input-name="s-ref-checkbox-1249137011" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-1249137011" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Free Shipping by Amazon</span></span></label></div></span></span></li></div></ul><h4 class="a-size-small a-spacing-mini a-color-base a-text-bold">Featured Brands</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_89%3ASamsung&quot;}"><div data-a-input-name="s-ref-checkbox-Samsung" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-Samsung" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Samsung</span></span></label></div></span></span></li></div></ul><h4 class="a-size-small a-spacing-micro a-color-base a-text-bold">Avg. Customer Review</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_72%3A1248879011"><i class="a-icon a-icon-star-medium a-star-medium-4"><span class="a-icon-alt">4 Stars &amp; Up</span></i><span class="a-size-small a-color-base"> &amp; Up</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_72%3A1248880011"><i class="a-icon a-icon-star-medium a-star-medium-3"><span class="a-icon-alt">3 Stars &amp; Up</span></i><span class="a-size-small a-color-base"> &amp; Up</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_72%3A1248881011"><i class="a-icon a-icon-star-medium a-star-medium-2"><span class="a-icon-alt">2 Stars &amp; Up</span></i><span class="a-size-small a-color-base"> &amp; Up</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_72%3A1248882011"><i class="a-icon a-icon-star-medium a-star-medium-1"><span class="a-icon-alt">1 Star &amp; Up</span></i><span class="a-size-small a-color-base"> &amp; Up</span></a></span></li></div></ul><h4 class="a-size-small a-spacing-micro a-color-base a-text-bold">Condition<a class="s-ref-text-link" href="/gp/help/customer/display.html/ref=lp_21103058011_nr_p_n_condition-type_whatsthis/000-0000000-0000000?nodeId=202089470&amp;pop-up=1&amp;ie=UTF8&amp;qid=1589306104" target="WhatsThisHelp" onclick="return amz_js_PopWin(this.href,'WhatsThisHelp','width=800,height=600,resizable=1,scrollbars=1,toolbarr=1,status=1');">
    <span class="a-color-base s-text-size-micro">(What's this?)</span></a></h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-New/s?rh=n%3A21103058011%2Cp_n_condition-type%3A2224371011"><span class="a-size-small a-color-base">New</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Used/s?rh=n%3A21103058011%2Cp_n_condition-type%3A2224373011"><span class="a-size-small a-color-base">Used</span></a></span></li></div></ul><h4 class="a-size-small a-spacing-micro a-color-base a-text-bold">Price</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_36%3A1253505011"><span class="a-size-small a-color-base">$50 to $100</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_36%3A1253506011"><span class="a-size-small a-color-base">$100 to $200</span></a></span></li><li><span class="a-list-item"><a class="a-link-normal s-ref-text-link" href="/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_36%3A1253507011"><span class="a-size-small a-color-base">$200 &amp; Above</span></a></span></li><li><span class="a-list-item"><form method="get" action="/s"><input type="hidden" name="ie" value="UTF8"/><input type="hidden" name="page" value="1"/><input type="hidden" name="qid" value="1589306104"/><input type="hidden" name="rh" value="n:21103058011"/><input type="hidden" name="rnid" value="386442011"/><span class="a-color-base s-ref-small-padding-left s-ref-price-currency">$</span><input type="text" maxlength="9" id="low-price" placeholder="Min" name="low-price" class="a-input-text a-spacing-top-mini s-ref-price-range s-ref-price-padding" aria-label="Min"/><span class="a-color-base s-ref-small-padding-left s-ref-price-currency s-small-margin-left">$</span><input type="text" maxlength="9" id="high-price" placeholder="Max" name="high-price" class="a-input-text a-spacing-top-mini s-ref-price-range s-ref-price-padding s-small-margin-left" aria-label="Max"/><span class="a-button a-spacing-top-mini a-button-base s-small-margin-left"><span class="a-button-inner"><input class="a-button-input" type="submit" value="Go"/><span class="a-button-text" aria-hidden="true">Go</span></span></span></form></span></li></div></ul><h4 class="a-size-small a-spacing-mini a-color-base a-text-bold">Seller</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AA2L77EE7U53NWQ&quot;}"><div data-a-input-name="s-ref-checkbox-A2L77EE7U53NWQ" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A2L77EE7U53NWQ" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Amazon Warehouse</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AATVPDKIKX0DER&quot;}"><div data-a-input-name="s-ref-checkbox-ATVPDKIKX0DER" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-ATVPDKIKX0DER" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Amazon.com</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AA4UCFL9LU89NR&quot;}"><div data-a-input-name="s-ref-checkbox-A4UCFL9LU89NR" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A4UCFL9LU89NR" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">OneDealOutlet Online</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AAND9L8WSQXNWV&quot;}"><div data-a-input-name="s-ref-checkbox-AND9L8WSQXNWV" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-AND9L8WSQXNWV" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Memories Direct US</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AAN8LN2YPKS7DF&quot;}"><div data-a-input-name="s-ref-checkbox-AN8LN2YPKS7DF" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-AN8LN2YPKS7DF" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">DataVision Computer Video</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AAAZRLVTNON75Z&quot;}"><div data-a-input-name="s-ref-checkbox-AAZRLVTNON75Z" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-AAZRLVTNON75Z" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Triplenet Pricing INC</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AA318KZKAVS7VOQ&quot;}"><div data-a-input-name="s-ref-checkbox-A318KZKAVS7VOQ" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A318KZKAVS7VOQ" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Rover Mall</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-IPC-STORE%E2%9C%85/s?rh=n%3A21103058011%2Cp_6%3AA284PRV19Y1MTF&quot;}"><div data-a-input-name="s-ref-checkbox-A284PRV19Y1MTF" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A284PRV19Y1MTF" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">IPC-STORE✅</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AA2KTA1SDADMGAB&quot;}"><div data-a-input-name="s-ref-checkbox-A2KTA1SDADMGAB" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A2KTA1SDADMGAB" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Joe&#039;s Tech Shop</span></span></label></div></span></span></li><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_6%3AA2E7NH3SLWCOH4&quot;}"><div data-a-input-name="s-ref-checkbox-A2E7NH3SLWCOH4" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-A2E7NH3SLWCOH4" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Tech for Less</span></span></label></div></span></span></li></div></ul><h4 class="a-size-small a-spacing-micro a-color-base a-text-bold">Availability</h4><ul class="a-unordered-list a-nostyle a-vertical a-spacing-base"><div aria-live="polite" class="a-row a-expander-container a-expander-extend-container"><li><span class="a-list-item"><span class="a-declarative" data-action="s-ref-selected" data-s-ref-selected="{&quot;url&quot;:&quot;/Save-Big-Samsung-SSD-Drives-Electronics/s?rh=n%3A21103058011%2Cp_n_availability%3A1248801011&quot;}"><div data-a-input-name="s-ref-checkbox-1248801011" class="a-checkbox s-ref-link-cursor a-spacing-none"><label><input type="checkbox" name="s-ref-checkbox-1248801011" value="false"/><i class="a-icon a-icon-checkbox"></i><span class="a-label a-checkbox-label"><span class="a-size-small a-color-base s-ref-text-link s-ref-link-cursor">Include Out of Stock</span></span></label></div></span></span></li></div></ul></div>
                        </div><div class="a-section a-spacing-base"><div style="height: 1px;"></div>
                        <script type="text/javascript">
    amzn.sx.utils.jsDepMgr.when('search-js-general', "search-content-end", function() {
       
       SPUtils.triggerEvent("spSearchContentEnd");
    });
</script>
</div></div></div></div></div><div id="footer" class="a-section a-spacing-none s-span-page" role="directory">
















<!-- btf pilu -->







<style type="text/css">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</style>




<script type="text/javascript">
(function ($Nav) {
"use strict";

if (typeof $Nav === 'undefined' || $Nav === null || typeof $Nav.when !== 'function') {
    return;
}
$Nav.when('$', 'data', 'flyout.yourAccount', 'sidepanel.csYourAccount',
          'config')
    .run("BuyitAgain-YourAccount-SidePanel", 
    function ($, data, yaFlyout, csYourAccount, config) {
        if (config.disableBuyItAgain) {
          return;
        }
        var render = function (data) {
            if (data.status) {
                var widgetHtml = data.widgetBegin + 
                                 data.faceouts.join('') +
                                 data.widgetEnd;
                navbar.sidePanel({
                    flyoutName: 'yourAccount',
                    data: {html: widgetHtml}
                });
            }
        };

        var renderBuyItAgain = function (biaData) {
            if (csYourAccount) {
                csYourAccount.register(render, biaData);
            } else {
                render(biaData);
            }
        };

        yaFlyout.sidePanel.onData(function() {
            enableInlineAddToCart($); 
            enableImpressionLogging($);

            P.when('A','p13n-sc-static-list').execute(function(A, scList) {
                var navContainer = A.$("#bia-hcb-widget");
                var navList = navContainer.find('.p13n-sc-static-list');
                A.$(navList).bind('truncateList', function() {
                        scList(navList);
                });

                A.$(navList).trigger('truncateList');
            });

            if (window.P) {
                P.when('A', 'a-truncate').execute(function(A, truncate) {
                    var truncateElements = A.$('.a-truncate');
                    A.each(truncateElements, function(element) {
                        truncate.get(element).update();
                    });
                });
            }

        }); 
           
    yaFlyout.onRender(function() {
            $.ajax({
                url: '/gp/bia/external/bia-hcb-ajax-handler.html',
                data: 
   {"biaHcbRid":"YE6JG88QGZ36FVRYCRK2"},
                dataType: 'json',
                timeout: 4*1000,
                success: renderBuyItAgain,
                error: function (jqXHR, textStatus, errorThrown) {
                }
            });
        });


    var updateNavCartQty = function(qty) {
        if (typeof window.navbar === 'object' && typeof window.navbar.setCartCount === 'function') {
            window.navbar.setCartCount(qty);
        }
    };

    var addToCart = function(params, callback) {
        $.ajax({
           url: '/gp/bia/external/bia-cart-ajax-handler.html',
           data: params,
           dataType: 'json', 
           timeout: 2000,
           success: function(response) { callback(response); },
           error: function() { callback({ok:0}); }
        });
    };

    var enableInlineAddToCart = function ($) {
        if ($(".bia-inline-cart-form").length === 0) {
            return;
        }

        var inlineAddToCartHandler = function(e) {
            e.preventDefault();

            var $target = $(e.target);
            var $item = $target.parents(".bia-item");
            var $submit = $item.find(".bia-cart-submit");
            var params = $target.attr('data-order');

            $submit.attr("disabled", true);
            $item.find(".bia-action-button").addClass("bia-action-button-disabled");

            addToCart(params, 
                function(response) {
                    if(response && response.ok && response.ok === '1') {
                        $item.find(".bia-faceout").hide();
                        $item.find(".bia-cart-action").show();
                        updateNavCartQty(response.numActiveItemsInCart); 
                        //TODO: add metric
                    } else {
                        $target.unbind("submit", inlineAddToCartHandler);
                        $submit.attr("disabled", false);
                        $submit.click();
                        //TODO: add metric
                    }
                }
            );
        };

        $(".bia-inline-cart-form").bind("submit", inlineAddToCartHandler);
    };

    var enableImpressionLogging = function ($) {

        var registerToLog = function (p13nLogger, callOnVisible) {
            var featureEl = $("#bia-hcb-widget");
            callOnVisible.register(featureEl, function () {
                p13nLogger.logAction({
                                action: 'view', 
                                featureElement: featureEl, 
                                replicateAsinImpressions: true
                              });
            });
        };
        
        AmazonUIPageJS.when('p13n-sc-logger', 'p13n-sc-call-on-visible')
            .execute(function(p13nLogger, callOnVisible) {
                    registerToLog(p13nLogger, callOnVisible);});
    };

    });

})(window.$Nav);
//# sourceURL=bia-hcb-js.mi
</script>








<div style="display: none">
  <div id="nav-prime-menu" class="nav-empty nav-flyout-content nav-ajax-prime-menu">
    <div class="nav_dynamic"></div>
    <div class="nav-ajax-message"></div>
    <div class="nav-ajax-error-msg">
      <p class="nav_p nav-bold">There's a problem loading this menu right now.</p>
      <p class="nav_p"><a href="/gp/prime" class="nav_a">Learn more about Amazon Prime.</a></p>
    </div>
  </div>
</div>







<style>
  #nav-prime-tooltip{
    padding: 0 20px 2px 20px;
    background-color: white;
    font-family: arial,sans-serif;
  }
  .nav-npt-text-title{
    font-family: arial,sans-serif;
    font-size: 18px;
    font-weight: bold;
    line-height: 21px;
    color: #E47923;
  }
  .nav-npt-text-detail, a.nav-npt-a{
    font-family: arial,sans-serif;
    font-size: 12px;
    line-height: 14px;
    color: #333333;
    margin: 2px 0px;
  }
  a.nav-npt-a {
    text-decoration: underline;
  }
</style>


<div  style="display: none">
  <div id="nav-prime-tooltip">
    <div class="nav-npt-text-title"> Get free delivery with Amazon Prime </div>
    <div class="nav-npt-text-detail"> Prime members enjoy FREE Delivery and exclusive access to music, movies, TV shows, original audio series, and Kindle books. </div>
    <div class="nav-npt-text-detail">
      &gt;
      <a class="nav-npt-a" href="/prime">Get started</a>
    </div>
  </div>
</div>




  





<script type="text/javascript">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</script>

  <script type='text/javascript'>
      window.$Nav && $Nav.declare('config.prefetchUrls', ["https://images-na.ssl-images-amazon.com/images/G/01/authportal/common/images/amazon_logo_no-org_mid._CB485934470_.png","https://images-na.ssl-images-amazon.com/images/G/01/authportal/common/images/amznbtn-sprite03._CB485966112_.png","https://images-na.ssl-images-amazon.com/images/G/01/authportal/flex/reduced-nav/ap-flex-reduced-nav-2.0._CB485968702_.js","https://images-na.ssl-images-amazon.com/images/G/01/authportal/flex/reduced-nav/ap-flex-reduced-nav-2.1._CB485967487_.css","https://images-na.ssl-images-amazon.com/images/G/01/gno/sprites/nav-sprite-global_bluebeacon-1x_optimized_layout1._CB468670774_.png","https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/buttons/sign-in-secure._CB485941572_.gif","https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/login/fwcim._CB454428048_.js","https://images-na.ssl-images-amazon.com/images/G/01/x-locale/common/transparent-pixel._CB485935036_.gif"]);
window.$Nav && $Nav.declare('config.prefetch',function() {
    var pUrls = window.$Nav.getNow('config.prefetchUrls');
    (window.AmazonUIPageJS ? AmazonUIPageJS : P).when('A').execute(function (A) { A.preload(pUrls); });
});

  /*  */
  
(window.AmazonUIPageJS ? AmazonUIPageJS : P).when('A').execute(function(A){
  if(A.preload){
    A.preload('https://images-na.ssl-images-amazon.com/images/I/417L6LIsU6L._RC|71ukVsVobVL.js,61nu+N-SMyL.js,41W9ohA0e+L.js,11vrNkbdcvL.js,21qaguVEGfL.js,41QN7vBTpzL.js,51MzEF-M1PL.js,313jWehHlpL.js_.js?AUIClients/NavDesktopMetaAsset#desktop');
    A.preload('https://images-na.ssl-images-amazon.com/images/I/21taIyvn9cL._RC|71Tq7EVt6oL.css,21TJB5pc5TL.css,31vGzsqCErL.css,21lRUdwotiL.css,41tc24mJIGL.css,11G4HxMtMSL.css,31OvHRW+XiL.css,01XHMOHpK1L.css_.css?AUIClients/NavDesktopMetaAsset#desktop');
  }
});




    window.$Nav && $Nav.declare('config.flyoutURL', null);
    window.$Nav && $Nav.declare('btf.lite');
    window.$Nav && $Nav.declare('btf.full');
    window.$Nav && $Nav.declare('btf.exists');
    (window.AmazonUIPageJS ? AmazonUIPageJS : P).register('navCF');
  </script>

    
    
    
    
    
    
    









<script type="text/javascript">
  window.$Nav && window.$Nav.build('PldnLocalStorage', function() {
    var PldnLocalStorage = function() {};

    PldnLocalStorage.prototype.setItem = function(key, obj) {
      if (typeof obj !== 'string') {
        obj = window.JSON && window.JSON.stringify(obj);
      }

      try {
        window.localStorage && window.localStorage.setItem(key, obj);
        return true;
      } catch (exception) {
        return false;
      };
    };

    PldnLocalStorage.prototype.getItem = function(key) {
      try {
        return window.localStorage && window.localStorage.getItem(key);
      } catch(exception) {};
    };

    return new PldnLocalStorage();
  });

  window.$Nav && window.$Nav.when('PldnLocalStorage').run('PldnUcolCheck', function(storage) {
    if (!storage.getItem('amazonSmileCampaigns')) {
      storage.setItem('amazonSmileCampaigns', {
        "ucol": {
          "optOut": false,
          "hits": [
            {
              "date": new Date(),
              "redirect": false,
              "optOut": false
            }
          ]
        }
      });
    }
  });
</script>
<!-- btf tilu -->


<!-- footer pilu -->
<div class='navLeftFooter nav-sprite-v1' id='navFooter'><a href="#nav-top" id="navBackToTop"><div class="navFooterBackToTop"><span class="navFooterBackToTopText">Back to top</span></div></a>

<div class="navFooterVerticalColumn navAccessibility" role="presentation"><div class="navFooterVerticalRow navAccessibility" style="display: table-row;"><div class="navFooterLinkCol navAccessibility"><div class="navFooterColHead">Get to Know Us</div><ul><li class='nav_first'><a href='https://www.amazon.jobs' class='nav_a'>Careers</a></li><li><a href='https://blog.aboutamazon.com/?utm_source=gateway&amp;utm_medium=footer' class='nav_a'>Blog</a></li><li><a href='https://www.aboutamazon.com/?utm_source=gateway&amp;utm_medium=footer' class='nav_a'>About Amazon</a></li><li><a href='https://www.amazon.com/pr' class='nav_a'>Press Center</a></li><li><a href='https://www.amazon.com/ir' class='nav_a'>Investor Relations</a></li><li><a href='/amazon-devices/b?ie=UTF8&amp;node=2102313011&amp;ref_=footer_devices' class='nav_a'>Amazon Devices</a></li><li class='nav_last'><a href='https://www.aboutamazon.com/amazon-fulfillment-center-tours?utm_source=gateway&amp;utm_medium=footer&amp;utm_campaign=fctours' class='nav_a'>Amazon Tours</a></li></ul></div><div class="navFooterColSpacerInner navAccessibility"></div><div class="navFooterLinkCol navAccessibility"><div class="navFooterColHead">Make Money with Us</div><ul><li class='nav_first'><a href='https://www.amazon.com:443/gp/redirect.html?_encoding=UTF8&amp;location=https%3A%2F%2Fsell.amazon.com%2F%3Fld%3DAZFSSOA%26ref_%3Dfooter_soa&amp;source=standards&amp;token=F8DC1C821506E40D2CFF1864EE5EC23698540D23' class='nav_a'>Sell on Amazon</a></li><li><a href='/l/ref=map_1_b2b_GW_FT?_encoding=UTF8&amp;node=17882322011' class='nav_a'>Sell Under Amazon Accelerator</a></li><li><a href='https://www.amazon.com:443/gp/redirect.html?_encoding=UTF8&amp;location=https%3A%2F%2Fsell.amazon.com%2Fprograms%2Fhandmade.html%3Fld%3DAZUSHNDFooter%26ref_%3Dfooter_hnd&amp;source=standards&amp;token=FEFB671915AC52DA2A63BE2AB9FF1766AE617E9C' class='nav_a'>Sell on Amazon Handmade</a></li><li><a href='https://www.amazon.com:443/gp/redirect.html?_encoding=UTF8&amp;location=https%3A%2F%2Fsell.amazon.com%2Fprograms%2Fprofessional-services.html%3Fld%3DAZUSVAS-globalfooter%26ref_%3Dfooter_sell_svcs&amp;source=standards&amp;token=3F3E837D604928F43970DDF8BD769D68785D5977' class='nav_a'>Sell Your Services on Amazon</a></li><li><a href='https://sell.amazon.com/programs/amazon-business.html?ld=usb2bunifooter&amp;ref_=footer_b2b' class='nav_a'>Sell on Amazon Business</a></li><li><a href='https://developer.amazon.com' class='nav_a'>Sell Your Apps on Amazon</a></li><li><a href='https://affiliate-program.amazon.com/' class='nav_a'>Become an Affiliate</a></li><li><a href='https://advertising.amazon.com/?ref=ext_amzn_ftr' class='nav_a'>Advertise Your Products</a></li><li><a href='/gp/seller-account/mm-summary-page.html?ie=UTF8&amp;ld=AZFooterSelfPublish&amp;ref_=footer_publishing&amp;topic=200260520' class='nav_a'>Self-Publish with Us</a></li><li class='nav_last nav_a_carat'><span class="nav_a_carat">&rsaquo;</span><a href='/b/?_encoding=UTF8&amp;ld=AZUSSOA-seemore&amp;node=18190131011&amp;ref_=footer_seemore' class='nav_a'>See More</a></li></ul></div><div class="navFooterColSpacerInner navAccessibility"></div><div class="navFooterLinkCol navAccessibility"><div class="navFooterColHead">Amazon Payment Products</div><ul><li class='nav_first'><a href='/iss/credit/rewardscardmember?_encoding=UTF8&amp;plattr=CBFOOT&amp;ref_=footer_cbcc' class='nav_a'>Amazon Rewards Visa Signature Cards</a></li><li><a href='/credit/storecard/member?_encoding=UTF8&amp;plattr=PLCCFOOT&amp;ref_=footer_plcc' class='nav_a'>Amazon.com Store Card</a></li><li><a href='/dp/B07984JN3L?_encoding=UTF8&amp;ie=UTF-8&amp;plattr=ACOMFO' class='nav_a'>Amazon Business Card</a></li><li><a href='/dp/B07CBJQS16?_encoding=UTF8&amp;ie=UTF-8&amp;place=camp&amp;plattr=CCLFOOT&amp;pr=ibprox&amp;ref_=footer_ccl' class='nav_a'>Amazon.com Corporate Credit Line</a></li><li><a href='/b?ie=UTF8&amp;node=16218619011&amp;ref_=footer_swp' class='nav_a'>Shop with Points</a></li><li><a href='/compare-credit-card-offers/b?ie=UTF8&amp;node=3561432011&amp;ref_=footer_ccmp' class='nav_a'>Credit Card Marketplace</a></li><li><a href='/Reload-Your-Gift-Card-Balance/b?ie=UTF8&amp;node=10232440011&amp;ref_=footer_reload_us' class='nav_a'>Reload Your Balance</a></li><li class='nav_last'><a href='/Currency-Converter/b?ie=UTF8&amp;node=388305011&amp;ref_=footer_tfx' class='nav_a'>Amazon Currency Converter</a></li></ul></div><div class="navFooterColSpacerInner navAccessibility"></div><div class="navFooterLinkCol navAccessibility"><div class="navFooterColHead">Let Us Help You</div><ul><li class='nav_first'><a href='/gp/help/customer/display.html?ie=UTF8&amp;nodeId=GDFU3JS5AL6SYHRD&amp;ref_=footer_covid' class='nav_a'>Amazon and COVID-19</a></li><li><a href='/gp/css/homepage.html?ie=UTF8&amp;ref_=footer_ya' class='nav_a'>Your Account</a></li><li><a href='/gp/css/order-history?ie=UTF8&amp;ref_=footer_yo' class='nav_a'>Your Orders</a></li><li><a href='/gp/help/customer/display.html?ie=UTF8&amp;nodeId=468520&amp;ref_=footer_shiprates' class='nav_a'>Shipping Rates & Policies</a></li><li><a href='/gp/prime?ie=UTF8&amp;ref_=footer_prime' class='nav_a'>Amazon Prime</a></li><li><a href='/gp/css/returns/homepage.html?ie=UTF8&amp;ref_=footer_hy_f_4' class='nav_a'>Returns & Replacements</a></li><li><a href='/hz/mycd/myx?_encoding=UTF8&amp;ref_=footer_myk' class='nav_a'>Manage Your Content and Devices</a></li><li><a href='/gp/BIT/ref=footer_bit_v2_us_A0029?bitCampaignCode=A0029' class='nav_a'>Amazon Assistant</a></li><li class='nav_last'><a href='/gp/help/customer/display.html?ie=UTF8&amp;nodeId=508510&amp;ref_=footer_gw_m_b_he' class='nav_a'>Help</a></li></ul></div></div></div><div class="nav-footer-line"></div>
   
<div class="navFooterLine navFooterLinkLine navFooterPadItemLine"><span><div class="navFooterLine navFooterLogoLine"><a href="/ref=footer_logo"><div class="nav-logo-base nav-sprite"></div></a></div>
</span><ul></ul><span class="icp-container-desktop"><div class="navFooterLine">












  





<style type="text/css">
  #icp-touch-link-language { display: none; }
</style>

<a href="/gp/customer-preferences/select-language?ie=UTF8&preferencesReturnUrl=%2F" class="icp-button" id="icp-touch-link-language">
  <div class="icp-nav-globe-img-2 icp-button-globe-2"></div
  ><span class="icp-color-base">English</span
  ><span class="nav-arrow icp-up-down-arrow"></span
  ><span class="aok-hidden" style="display:none">Choose a language for shopping.</span>
</a>












<style type="text/css">
#icp-touch-link-country { display: none; }
</style>

  



<a href="/gp/navigation-country/select-country?ie=UTF8&preferencesReturnUrl=%2F" class="icp-button" id="icp-touch-link-country">
  <span class="icp-flag-3 icp-flag-3-us"></span
  ><span class="icp-color-base">United States</span
  ><span class="aok-hidden" style="display:none">Choose a country/region for shopping.</span>
</a>


</div>
</span><ul></ul></div>

<div class="navFooterLine navFooterLinkLine navFooterDescLine"role="navigation" aria-label="More on Amazon.com"><table class="navFooterMoreOnAmazon" cellspacing="0"><tr>
<td class="navFooterDescItem"><a href='https://music.amazon.com?ref=dm_aff_amz_com' class='nav_a'>Amazon Music<br/> <span class="navFooterDescText">Stream millions<br/> of songs</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://advertising.amazon.com/?ref=footer_advtsing_amzn_com' class='nav_a'>Amazon Advertising<br/> <span class="navFooterDescText">Find, attract, and<br/> engage customers</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/STRING-subnav_primephotos_amazondrive/b?ie=UTF8&amp;node=15547130011&amp;ref_=us_footer_drive' class='nav_a'>Amazon Drive<br/> <span class="navFooterDescText">Cloud storage<br/> from Amazon</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.6pm.com' class='nav_a'>6pm<br/> <span class="navFooterDescText">Score deals<br/> on fashion brands</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.abebooks.com' class='nav_a'>AbeBooks<br/> <span class="navFooterDescText">Books, art<br/> & collectibles</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.acx.com/' class='nav_a'>ACX <br/> <span class="navFooterDescText">Audiobook Publishing<br/> Made Easy</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.alexa.com' class='nav_a'>Alexa<br/> <span class="navFooterDescText">Actionable Analytics<br/> for the Web</span></a></td>
</tr>
<tr><td>&nbsp;</td></tr>
<tr>
<td class="navFooterDescItem"><a href='https://www.amazon.com:443/gp/redirect.html?_encoding=UTF8&amp;location=https%3A%2F%2Fsell.amazon.com%2F%3Fld%3DAZUSSOA-footer-aff%26ref_%3Dfooter_sell&amp;source=standards&amp;token=5C1C6935C910A355A9EFF638456512B3EE3E32AC' class='nav_a'>Sell on Amazon<br/> <span class="navFooterDescText">Start a Selling Account</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/business?_encoding=UTF8&amp;ref_=footer_retail_b2b' class='nav_a'>Amazon Business<br/> <span class="navFooterDescText">Everything For<br/> Your Business</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/alm/storefront?_encoding=UTF8&amp;almBrandId=QW1hem9uIEZyZXNo&amp;ref_=footer_aff_fresh' class='nav_a'>Amazon Fresh<br/> <span class="navFooterDescText">Groceries & More<br/> Right To Your Door</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/International-Shipping-Direct/b?ie=UTF8&amp;node=230659011&amp;ref_=footer_amazonglobal' class='nav_a'>AmazonGlobal<br/> <span class="navFooterDescText">Ship Orders<br/> Internationally</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/services?_encoding=UTF8&amp;ref_=footer_services' class='nav_a'>Home Services<br/> <span class="navFooterDescText">Handpicked Pros<br/> Happiness Guarantee</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://ignite.amazon.com/?ref=amazon_footer_ignite' class='nav_a'>Amazon Ignite<br/> <span class="navFooterDescText">Sell your original<br/> Digital Educational<br/> Resources</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://rapids.amazon.com/?ref=rapids_acq_gatewayfooter' class='nav_a'>Amazon Rapids<br/> <span class="navFooterDescText">Fun stories for<br/>  kids on the go</span></a></td>
</tr>
<tr><td>&nbsp;</td></tr>
<tr>
<td class="navFooterDescItem"><a href='https://aws.amazon.com/what-is-cloud-computing/?sc_channel=EL&amp;sc_campaign=amazonfooter' class='nav_a'>Amazon Web Services<br/> <span class="navFooterDescText">Scalable Cloud<br/> Computing Services</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.audible.com' class='nav_a'>Audible<br/> <span class="navFooterDescText">Listen to Books & Original<br/> Audio Performances</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.bookdepository.com' class='nav_a'>Book Depository<br/> <span class="navFooterDescText">Books With Free<br/> Delivery Worldwide</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.boxofficemojo.com/?ref_=amzn_nav_ftr' class='nav_a'>Box Office Mojo<br/> <span class="navFooterDescText">Find Movie<br/> Box Office Data</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.comixology.com' class='nav_a'>ComiXology<br/> <span class="navFooterDescText">Thousands of<br/> Digital Comics</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.createspace.com' class='nav_a'>CreateSpace<br/> <span class="navFooterDescText">Indie Print Publishing<br/> Made Easy</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.dpreview.com' class='nav_a'>DPReview<br/> <span class="navFooterDescText">Digital<br/> Photography</span></a></td>
</tr>
<tr><td>&nbsp;</td></tr>
<tr>
<td class="navFooterDescItem"><a href='https://www.eastdane.com/welcome' class='nav_a'>East Dane<br/> <span class="navFooterDescText">Designer Men's<br/> Fashion</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.fabric.com' class='nav_a'>Fabric<br/> <span class="navFooterDescText">Sewing, Quilting<br/> & Knitting</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.goodreads.com' class='nav_a'>Goodreads<br/> <span class="navFooterDescText">Book reviews<br/> & recommendations</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.imdb.com' class='nav_a'>IMDb<br/> <span class="navFooterDescText">Movies, TV<br/> & Celebrities</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://pro.imdb.com?ref_=amzn_nav_ftr' class='nav_a'>IMDbPro<br/> <span class="navFooterDescText">Get Info Entertainment<br/> Professionals Need</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://kdp.amazon.com' class='nav_a'>Kindle Direct Publishing<br/> <span class="navFooterDescText">Indie Digital Publishing<br/> Made Easy
</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://primenow.amazon.com/?ref=HOUD12C322_0_GlobalFooter' class='nav_a'>	
Prime Now<br/> <span class="navFooterDescText">FREE 2-hour Delivery<br/> on Everyday Items</span></a></td>
</tr>
<tr><td>&nbsp;</td></tr>
<tr>
<td class="navFooterDescItem"><a href='/STRING-subnav-prime-photos/b?ie=UTF8&amp;node=13234696011&amp;ref_=gno_p_foot' class='nav_a'>Amazon Photos<br/> <span class="navFooterDescText">Unlimited Photo Storage<br/> Free With Prime</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://videodirect.amazon.com/home/landing' class='nav_a'>Prime Video Direct<br/> <span class="navFooterDescText">Video Distribution<br/> Made Easy</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.shopbop.com/welcome' class='nav_a'>Shopbop<br/> <span class="navFooterDescText">Designer<br/> Fashion Brands</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/Warehouse-Deals/b?ie=UTF8&amp;node=10158976011&amp;ref_=footer_wrhsdls' class='nav_a'>Amazon Warehouse<br/> <span class="navFooterDescText">Great Deals on<br/> Quality Used Products </span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.wholefoodsmarket.com' class='nav_a'>Whole Foods Market<br/> <span class="navFooterDescText">America’s Healthiest<br/> Grocery Store</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.woot.com/' class='nav_a'>Woot!<br/> <span class="navFooterDescText">Deals and <br/> Shenanigans</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.zappos.com' class='nav_a'>Zappos<br/> <span class="navFooterDescText">Shoes &<br/> Clothing</span></a></td>
</tr>
<tr><td>&nbsp;</td></tr>
<tr>
<td class="navFooterDescItem"><a href='https://ring.com' class='nav_a'>Ring<br/> <span class="navFooterDescText">Smart Home<br/> Security Systems
</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://eero.com/' class='nav_a'>eero WiFi<br/> <span class="navFooterDescText">Stream 4K Video<br/> in Every Room</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://shop.ring.com/pages/neighbors-app' class='nav_a'>Neighbors App <br/> <span class="navFooterDescText"> Real-Time Crime<br/> & Safety Alerts
</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/b?ie=UTF8&amp;node=14498690011&amp;ref_=amzn_nav_ftr_swa' class='nav_a'>Amazon Subscription Boxes<br/> <span class="navFooterDescText">Top subscription boxes – right to your door</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='https://www.pillpack.com' class='nav_a'>PillPack<br/> <span class="navFooterDescText">Pharmacy Simplified</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/Certified-Refurbished/b?ie=UTF8&amp;node=12653393011&amp;ref_=footer_usrenew' class='nav_a'>Amazon Renewed<br/> <span class="navFooterDescText">Like-new products<br/> you can trust</span></a></td>
<td class="navFooterDescSpacer" style="width: 4%"></td>
<td class="navFooterDescItem"><a href='/amazonsecondchance?_encoding=UTF8&amp;ref_=footer_asc' class='nav_a'>Amazon Second Chance<br/> <span class="navFooterDescText">Pass it on, trade it in,<br/> give it a second life</span></a></td>
</tr>
</table></div>
   
<div class="navFooterLine navFooterLinkLine navFooterPadItemLine navFooterCopyright"><ul><li class='nav_first'><a href='/gp/help/customer/display.html?ie=UTF8&amp;nodeId=508088&amp;ref_=footer_cou' class='nav_a'>Conditions of Use</a></li><li><a href='/gp/help/customer/display.html?ie=UTF8&amp;nodeId=468496&amp;ref_=footer_privacy' class='nav_a'>Privacy Notice</a></li><li><a href='/interestbasedads/ref=footer_iba' class='nav_a'>Interest-Based Ads</a></li><li class='nav_last'>© 1996-2020, Amazon.com, Inc. or its affiliates</li></ul></div>
</div><!-- whfh-JMFutHaF5NbYdDDnKSqZpKSlI0kvqYj1tXy0QRhZxH6ZgklUCU62j9WDMHM06hEXE5ckpY2AoBE= rid-YE6JG88QGZ36FVRYCRK2 -->
<div id="sis_pixel_r2" aria-hidden="true" style="height:1px; position: absolute; left: -1000000px; top: -1000000px;"></div><!-- footer tilu -->


</div></div></body></html>