YED MagazinestoInspire Amazon Fashion nav_sap_plcc_ascpsc Starting at $39.99 STEM Valentines Day STEM Book House Cleaning animestrike animestrike animestrike  All-New Echo Dot Starting at $49.99 Kindle Oasis Trade in and get paid instantly Shop Now STEM
Customer Discussions > Amazon Instant Video forum

Instant Video Player update breaks rights


Sort: Oldest first | Newest first
Showing 26-50 of 365 posts in this discussion
Posted on Jan 16, 2012 2:36:52 PM PST
It's too bad the support representatives don't understand the question. I am STILL able to watch videos on this Ubuntu system; Each day after I see activity in this thread I go back and watch a few minutes of the first episode of "Lost." I'm about halfway through the episode and it still plays fine.

In reply to an earlier post on Jan 16, 2012 3:43:27 PM PST
Right. That is my issue too. I have been using it for the past year on various machines running various versions of Linux. The only issues I have run into had to deal with Adobe Flash and those issues were normally resolved by an update or other various workarounds to the Adobe Flash installation.

This is the first issue I have had which seems to be directly related to what Amazon is calling the Instant Video Player. I am not very happy with the unresponsiveness of Amazon and their complete dismissal of users using something foreign to them.

Furthermore, why did one of my machines experience this issue and then suddenly start working; one of my machines not experience any issues at all; and one of my machines continues to experience the issue. All running Linux.

Posted on Jan 16, 2012 4:18:55 PM PST
Okay, I have another machine which is now working... The problem is, what I did, did not work for another machine which is not working.

For one of my Fedora 14 machines, I set SELinux to permissive and the update worked and videos started playing without an issue.

However, I attempted the same thing on a Fedora 16 machine that was having the same issue and it didn't fix it. So perhaps the issue is related to how Adobe Flash and how xulrunner plugin-container are being packaged in the Linux distro.

Posted on Jan 16, 2012 4:50:58 PM PST
B. Wilson says:
This is quite upsetting for me to hear as well. I just purchased Amazon prime yesterday with the assumption that I'd be able to watch video on demand on my Ubuntu running computer. It is unacceptable that Amazon quietly dropped the ability for their service to run on Linux without any warning to their customers. Why would they change their perfectly working system for no apparent reason? Security is probably the answer, but why make the jump before they are prepared to support all their existing customers? I hope Amazon realizes that this is a serious issue and addresses it as soon as possible.

In reply to an earlier post on Jan 16, 2012 5:00:50 PM PST
Doug Roberts says:
It's probably going to turn out to be something pretty simple, actually. Amazon screwed up. They will fix it.

Amazon's customer support is really quite a bit better than other provider's I've used. Amazon has nothing to gain by excluding Linux users, and a lot to lose. If I were to guess at what caused this disruption of service for Linux users, it would be that some Windows-centric software guy overseeing Instant Video at Amazon stepped on his crank. Ouch. Let's track this and see how well the company recovers.

--Doug

In reply to an earlier post on Jan 16, 2012 5:04:19 PM PST
I have no further input from my last post. I made the changes I described, but had no luck until it suddenly started working again, not even a browser refresh needed. Both my Ubuntu systems are now currently able to play AIV without trouble. Only one had the problem, which is strange since both OS's were loaded about the same time, around a month ago.

I am not convinced this has anything to do with configuration or installed packages, this seems more to me like an AIV tweak that was performed on the server side, possibly some cookies or similar that reacted badly at times on the client side.

In reply to an earlier post on Jan 17, 2012 8:35:28 AM PST
[Deleted by the author on Jan 17, 2012 8:36:04 AM PST]

Posted on Jan 20, 2012 9:49:03 AM PST
John Repass says:
I believe that this is an adobe access drm bug and not necessarily an amazon issue.

After a week of frustration I have resolved the issue on my 64bit linuxmint11 system by re-installing adobe flash i.e. "sudo apt-get --reinstall install adobe-flashplugin" and everything plays perfectly.

I also tried tweaking flash access settings http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager08.html but just clearing the license files did not have any effect.

In reply to an earlier post on Jan 20, 2012 9:57:14 AM PST
Doug Roberts says:
"sudo apt-get --reinstall install adobe-flashplugin" did not work with my 64-bit Linux Mint 12 system.

Posted on Jan 20, 2012 3:47:35 PM PST
Dale R. Olds says:
I am seeing this issue as well. I only have access to video via a Linux (32-bit ubuntu 11.10) installation on an old thinkpad connected to the tv. It's actually been a great setup until about a week ago.

I've tried different flashplayers, reinstalling the plugin etc. Nothing has helped.

Old videos from amazon prime that I've tested still work. Newer videos that I've purchased such as "Moneyball" or "New Low" fail as described in this discussion. What I find as upsetting as the lack of Linux support is that I paid to rent videos since the amazon prime videos worked. For the second one I tried watching the trailer to make sure I could watch the video. The trailer played fine. I have since gone back and tried it with Moneyball as well. The trailers play fine, it's just the movies that require a player update, which fails.

Quite the bait and switch.

In reply to an earlier post on Jan 20, 2012 3:57:21 PM PST
Doug Roberts says:
I have been emailing Amazon support every day for about a week since I first experienced this problem. All I get in return is the promise that the technical team responsible for instant video has been made aware of the problem, and that they have verified that the problem exists for Linux. It would probably be a good idea if all of who are seeing this problem also contacted Amazon support.

Up the pressure a bit.

Posted on Jan 20, 2012 6:14:33 PM PST
Last edited by the author on Jan 20, 2012 6:27:37 PM PST
A. D. Lim says:
I had this problem for a couple of hours. I've looked into several possibilities and decided that it is not my flash installation issue. My wife and I have a separate Amazon account, and when I log in with her account everything works fine but with mine, I get the error everyone receives. I googled a bit about Flash content licensing known issues (Flash Access) and arrived at Flash Access SDK. There is a section that discusses client Access issue for Ubunto 10.10 and higher (at least I think that was the version...). Basically it's telling you to make sure you have libhal1 and hal installed on your system. I don't run Ubuntu but Debian Squeeze. I had libhal1 but no hal. Just installed it, restarted the browser and everything is working again.

apt-get install libhal1
apt-get install hal

They are the same for Ubuntu and Debian. I hope this helps.

Posted on Jan 20, 2012 7:44:21 PM PST
H. Patel says:
I got the same problem, upgraded to newest version of flash like everyone here, and it still tries to upgrade, I have no idea what it is trying to upgrade as the Adobe site reports I have the newest version of Flash.

Someone at Amazon dropped the ball on this. They don't realize the number of Linux customers they have and I got the standard reply, "We don't support Linux, try Windows". I'd rather try another vendor at this point, I haven't used windows in 5 years, nor do I have a computer with Windows on it.

Posted on Jan 20, 2012 7:49:48 PM PST
Last edited by the author on Jan 20, 2012 7:59:12 PM PST
H. Patel says:
Andy was right, I just tried his fix of install libhal1 and hal and restarted firefox and it now works.

However, all videos including the ones I have purchased now only play at 348kbit/s, aka, Lowest Quality setting regardless of what I try to set it to.

Man I hate DRM and how much it doesn't work even for PAID content. And now they want to pass SOPA and PIPA, just imagine how much better things will be for us paying customers then. HAH!

Posted on Jan 20, 2012 10:34:52 PM PST
Dale R. Olds says:
Andy's reply above worked for me -- installed hal, which installed libhal1 as well. Very cool. I'd still like to get my money back for the 2 movies I paid for but didn't get to watch, but I am certainly pleased with the community tech support.

Posted on Jan 21, 2012 9:20:10 AM PST
Doug Roberts says:
Installing hal and libhal1 did not work for me with my Linux Mint 12 64-bit system, I still get the failed attempt to update my player. Can you please try

Encounter At Farpoint (Part 1 & 2)

to see if you can play it?

Thanks,

--Doug

In reply to an earlier post on Jan 21, 2012 11:13:29 AM PST
H. Patel says:
It works for me. Have you verified you have the latest version installed through the browser? I actually had two versions of flash installed in the plugins directory for Firefox. As long as you verify on Adobe's site the active version is newest, it should work.

I am also using Ubuntu and not Mint so I am not sure if this solution works on Mint but one would think it should.

Posted on Jan 21, 2012 12:03:26 PM PST
A. D. Lim says:
Doug, I believe on Lisa, hald has to be started manually after install. You can check by issuing command

ps aux | grep hald

If you don't see hald running you can type:

sudo hald --daemon=yes

That should start the daemon process. Also, Mint doesn't necessary create the hal init script in /etc/init.d so you may have to either create this file or issue the command every time.

In reply to an earlier post on Jan 21, 2012 12:13:20 PM PST
Doug Roberts says:
Thanks Andy, You're right, hald was not running. I started it, but still get the "Updating player..." message for the video below. the update fails and the video doesn't play. Are you able to play

Encounter At Farpoint (Part 1 & 2) ?

If so, then the player issue must be specific to newer Linux distros. I'm running Mint 12 which is running the

3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

kernel.

Thanks,

--Doug

Posted on Jan 21, 2012 1:22:36 PM PST
A. D. Lim says:
Doug, it runs fine on my Mint 12 after HAL is installed. My OpenSuSe box never had the problem, and I just simply can't do anything on my BSD box (understandably). My guess is that Amazon changed the streaming player to probe something in your hardware like MAC address for DRM, but Flash Access uses HAL to accomplish this task although HAL has been obsolete for Debian-derived distros for some time now.

I think your player update is failing before it completes, correct? You don't see the error message everyone sees here ("your player could not be updated"). You can follow the steps below but since I don't know how your system is configured, please perform them at your own risk.

1. Remove/rename .adobe and .macromedia from your home directory
cd
mv .adobe adobe.old
mv .macromedia macromedia.old

2. Remove Flash
sudo apt-get --purge remove adobe-flashplugin

3. Install Flash
sudo apt-get install adobe-flashplugin

4. Verify you have the latest Flash by going to:
http://www.adobe.com/software/flash/about

5. Test with your Firefox (not Epiphany)

Please make sure your hald is running.

Posted on Jan 21, 2012 2:07:28 PM PST
I was having this same problem, but after following Andy's advice, I was able to fix it. Thank you, linux community, for helping to solve this problem!

Posted on Jan 21, 2012 7:08:17 PM PST
Kevin Vance says:
I ran into this tonight while trying to rent "Captain America: The First Avenger". I've been a happy user of Amazon Prime Instant Video since it was introduced, and I have been able to rent a movie using Instant Video in the past.

I'm running Gentoo which doesn't even package HAL anymore since "HAL is deprecated and interferes with newer mechanisms for hardware access" (http://www.gentoo.org/proj/en/desktop/kde/kde44-46-upgrade.xml#doc_chap3). Assuming HAL is the problem, it sounds like this won't be fixable on my system.

I've contacted support for a refund for the rental. If this is a permanent change, I doubt I'll renew my Prime subscription.

In reply to an earlier post on Jan 22, 2012 10:15:43 AM PST
Last edited by the author on Jan 22, 2012 10:16:30 AM PST
Doug Roberts says:
Progress! Thanks for all the suggestions, Andy. Purging the existing flash plugin, removing the .adobe and .macromedia directories, and sudo apt-get install adobe-flashplugin allowed the Amazon player to update, and I can now play the media that requires the new drm player.

However, this is either the 32-bit version of the player, or one that does not properly do hardware acceleration, because the videos are very jerky/stop-motion. In order to acceptably play flash video on my 64-bit/Nvidia graphics chipset system, I need to use the flash player for 64-bit hardware that gets installed by

sudo apt-get install flashplugin-installer This is the recommend installation process for 64-bit systems.

When this version of the Adobe player plugin is installed the Amazon player update fails. I conclude, therefore, that the Amazon player update is the 32-bit version which, again, performs miserably on my system.

I will send this thread to the Amazon support people and try to get them to respond. Thanks for all your help, and please offer any other suggestions you might think of.

--Doug

BTW: I am running the Google Chrome browser, latest version.

In reply to an earlier post on Jan 22, 2012 4:31:40 PM PST
A. D. Lim says:
Doug, I don't want to make things worse by suggesting something unfounded but try removing adobe-flashplugin (as described previously) and, instead, install mint-flashplugin.

sudo apt-get install mint-flashplugin

flashplugin-installer is just a wrapper package. If your Flash worked before you have nspluginwrapper installed correctly.

Also, you can check to make sure you don't have two versions of flashplugin loaded by typing 'about:plugins' in the address bar of Chrome.

Posted on Jan 22, 2012 5:22:37 PM PST
Doug Roberts says:
Hey Andy,

I had also tried mint-flashplugin, which behaves pretty much the same as adobe-flashplugin, in that it does allow the Amazon DRM-enabled player to be installed. However, it also has the same performance problem, in that when I run it full-screen the performance is unacceptable, with very jerky stop-action unaccelerated video.

Also, I'm not convinced that the flashplugin-installer is a wrapper, if you watch the update you see that this package downloads the current flash plugin directly from Adobe. When I use flashplugin-installer, I get a version of the player which does not have the full-screen performance problem that I see when either mint-flashplugin or adobe-flashplugin is used. It is for this reason that I believe that mint-flashplugin and adobe-flashplugin install a 32-bit flash version. It runs, but as I said, the performance is terrible.

Re: NSPluginWrapper -- as I'm sure you know, the whole point of NSPluginWrapper is that it enables the use of plugins on platforms they were not built for. For example, you can use the Adobe Flash Player 11 (Linux/i386) plugin on Linux/x86_64, NetBSD, and FreeBSD platforms along with a native Java Virtual Machine (JVM) in the same browser. NSPluginWrapper is also useful to confine native plugins into a specific execution domain for reliability and security purposes.

The problem with this is that the 32-bit packages do not perform as well as the native 64-bit packages. When I use flashplugin-installer, Chrome about:plugins shows

Flash (2 files) - Version: 11.1 r102
Shockwave Flash 11.1 r102

When I use mint-flashplugin, about:plugins shows

Flash - Version: 11.0 r1
Shockwave Flash 11.0 r1

so it's pretty clear that flashplugin-installer installs a different, more recent version of the flash plugin. Unfortunately, only the version number is shown, and not the architecture of the package.

BTW, I just got off the phone with Amazon instant video support people, and they basically told me "You're on your own, check the forums."

As an aside, I write for "Linux Journal", and also occasionally for "Linux Today" and Slashdot. I guess I'll write an article detailing this experience. It is a bit surprising to me that Amazon would decide to release this new DRM-enabled player that (oh, by the way) requires HAL, a deprecated package, without having first tested it thoroughly.

Thanks for all your input!

--Doug
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in
 


Recent discussions in the Amazon Instant Video forum

 

This discussion

Participants:  188
Total posts:  365
Initial post:  Dec 17, 2011
Latest post:  Aug 16, 2016

New! Receive e-mail when new posts are made.
Tracked by 55 customers