Amazon Vehicles Buy 2 kids' books and save Amazon Fashion Learn more nav_sap_plcc_ascpsc Benjamin Leftwich Fire TV Stick Health, Household and Grocery Back to School Totes Summer-Event-Garden Amazon Cash Back Offer power_s3 power_s3 power_s3  Amazon Echo  Echo Dot  Amazon Tap  Echo Dot  Amazon Tap  Amazon Echo Introducing new colors All-New Kindle Oasis Shop Now
Customer Discussions > Kindle forum

kindle for pc won't open

Sort: Oldest first | Newest first
Showing 1-25 of 158 posts in this discussion
Initial post: Jul 24, 2012 12:59:01 PM PDT
RhapsodyinDs says:
My kindle for pc (windows 7) won't open. What are some troubleshooting ideas. The troubleshooter already tried however it doesn't list windows 7, only upto vista.

In reply to an earlier post on Jul 24, 2012 1:00:26 PM PDT
Do you have the latest version of Kindle for PC? I understand some older versions were scheduled to stop working on July 22, 2012

In reply to an earlier post on Jul 24, 2012 1:04:22 PM PDT
Download the latest version and install it.

Do not de-register or uninstall the old version and all of your books/settings will not change.

In reply to an earlier post on Jul 25, 2012 1:47:02 PM PDT
Francesca says:
You saved me hours of searching for a solution. Thank you so much!

Posted on Jul 25, 2012 3:30:24 PM PDT
RhapsodyinDs says:
Thank you, I wasn't aware of the need to redownload again. That did the trick and all books are accounted for. Much appreciated!

Posted on Jul 25, 2012 5:49:38 PM PDT
Razzy says:
I got a message that said KindleForPC-installer.exe couldn't be downloaded. Now what?

In reply to an earlier post on Jul 25, 2012 6:13:07 PM PDT
Try it again.

Where are you getting that message?

In reply to an earlier post on Jul 26, 2012 8:03:19 AM PDT
Thanks for your help, saved me lots of time troubleshooting!

In reply to an earlier post on Jul 26, 2012 4:14:20 PM PDT
Bichon Mom says:
Thank you. I noticed that both my laptop and desktop would not open so figured there had to be a problem with the app. I'm so used to an old app automatically updating and was hoping that I wouldn't have to uninstall the old app. Your advice saved me from a bad decision and now the apps are working perfectly with all my collections in place :)

Posted on Jul 26, 2012 4:37:13 PM PDT
Kindle for PC stopped working on my Asus Eee PC. Windows XP. Tried uninstalling and reinstalling via download several times. Tried deleting old Kindle stuff before reinstalling. Tried repairing registry after uninstalling. Turned off Norton Internet Security. Still will not start: pointer goes to hourglass for a few seconds, then nothing.

In reply to an earlier post on Jul 26, 2012 5:53:40 PM PDT
Same thing for me. The old version said it was out of date and couldn't open. I downloaded and installed the new version and it won't open. Never gets to the main screen of Kindle for PC. What happens if I delete everything including the registry entries. Would that lose my library? Does Amazon have record of what I have purchased so I don't have to pay again? This is a mess. I am on Windows XP SP3.

Posted on Jul 26, 2012 6:30:50 PM PDT
Last edited by the author on Jul 26, 2012 6:31:53 PM PDT
@ James C and William C.

That's odd. I do know that on another program Kindle is building for ebook creators, they have a known issue that is somewhat similar.

So, since it seems that both of you have XP, probably both have SP3, I thought I'd install my remaining yet-to-be-installed updated Kindle4PC on my XP, SP3.

It also won't open, although the latest K4PC downloaded and installed on top of the old ones in Windows 7 and Vista did open and function just fine.

I hadn't noticed on the XP because I like reading in the Calibre reader. While Calibre's reader is a bit clunkier, Calibre itself is more reliable, and I have more options to move things around the way I want.

In reply to an earlier post on Jul 26, 2012 8:18:52 PM PDT
I have another laptop with Windows XP, also SP3, on which Kindle is running just fine. That one was updated a couple of weeks ago when they first warned about the July 22 discontinuity. I wonder if the latest version has a serious bug.

Deleting everything except registry entries will remove all downloaded books, but your library at Amazon will remain intact. I've often had to re-download books after installing a new version anyway-- something to do with rights management. If you try this and it works, I'd like to hear about it, although I expect it won't help.

In reply to an earlier post on Jul 27, 2012 12:07:17 AM PDT
M. Coombs says:
Thanks so much for the tip, like others I had no idea that the old version stopped working a few days ago. Appreciate it! -Mark

In reply to an earlier post on Jul 27, 2012 12:08:29 AM PDT
I imagine it's a serious bug, and the only workaround at this time is to use an alternate .mobi or .azw reader on the XP, SP3.

And this would not be announced anywhere, for obvious reasons. FWIW, unannounced glitches like this don't even get shared with their own CS reps, so calling Amazon, Kindle department may very well not do any good. I ran into the above-mentioned known issue, and decided just to use another e-book creator that didn't depend on KindleGen.

Since it also would be important for the K4PC to work on XP,SP3, I'm guessing that they would quietly have it at top priority to fix, so perhaps us, just trying the download from time to time, will get us our K4PC back, on our XP machines.

In reply to an earlier post on Jul 27, 2012 12:11:47 AM PDT
@Wasatch: I've installed the new version over the top of the old one on all 5 of my laptops (I use them for work) - 2 with W7 and 2 with XPPro SP3 and 1 with XPHome, with no problems at all. All opened the new version, so I can't generalise that the new version has a serious bug in all cases.

Posted on Jul 27, 2012 12:20:06 AM PDT
Last edited by the author on Jul 27, 2012 12:27:47 AM PDT
When did you successfully install the one for XPPro SP3? The guess was based on *recent* downloads and attempts to install. I tried 5 hours ago, and replicated the error in installation that the other two owners of XP SP3 reported. William C. Mead, who made the first guess on the matter, said that his successful install was considerably before that.

In reply to an earlier post on Jul 27, 2012 12:22:39 AM PDT
@Wasatch: A couple of days ago. I think that it was the day after the update came out.

In reply to an earlier post on Jul 27, 2012 12:30:48 AM PDT
Last edited by the author on Jul 27, 2012 12:36:15 AM PDT
And in three days their product fails. Hm.

(I wondered why the co-creator of the ebook software that depended on the KindleGen software had even bothered to sell a product whose system requirement was a Kindle-provided software that didn't work.)

I wonder if they have a glitch that comes AFTER QA has qualified the product for release. That's an uncomfortable thought.

Edit: Also very difficult for them to find the problem and make an estimate on when a fix might be available, prolly.

2nd edit: FWIW, when I called for help on the other Kindle-provided software, thinking that the problem was in my computer, the Kindle specialist replicated the problem on HIS Windows computer after contacting the programmers reported to me that it was a known issue and that they had no estimated fix date.

In reply to an earlier post on Jul 27, 2012 12:35:00 AM PDT
@Wasatch: "And in three days their product fails." Are you saying that no one can now install it successfully on XP SP3?

In reply to an earlier post on Jul 27, 2012 12:36:52 AM PDT
I'm sorry, I'm a bit slow ... please read the edit to my previous post, above.

Posted on Jul 27, 2012 12:39:41 AM PDT
I hope it's not a known issue with no estimated fix date.

However, I don't want to spend the time waiting through all the train of customer service agents who haven't been told about the glitch, and insist on telling me that the problem is in my computer and that I am an unfortunate, unintelligent user..... to finally get to a polite cs rep who will oblige me and get a response from the actual programmers.

Anybody else up for that enquiry of Amazon - kindle specialists?

Posted on Jul 27, 2012 12:54:11 AM PDT
Dragi Raos says:
For people who continue to have problems with K4PC *after* the upgrade to 1.10.1, there is a lively discussion in announcement thread over on Kindle Help Forum, with some potential solutions on pages 3 and 4 (at the moment):

In reply to an earlier post on Jul 27, 2012 2:30:44 AM PDT
Last edited by the author on Jul 27, 2012 2:35:26 AM PDT
Thank you very much. It was very interesting reading, and I tried the two suggestions, one from a person who posted about the network settings, and the other who reported a fix received from Amazon customer service. No joy. Exactly the same result. The new icon placed on my desktop after a rather complete uninstallation would not launch Kindle for PC when clicked.
I also tried to uninstall the CmTray.exe, which one person found to delete, and which worked for her. I don't have a CmTray.exe to uninstall.
Thanks, though.

Posted on Jul 27, 2012 7:20:01 AM PDT
I tried the suggestion of James C Clifford. Removing all the Kindle references in the registry did not help in my case.

One other thing that might be important: I uninstalled the old Kindle for PC before installing the new version (this is the way the previous updates worked). Would things have gone ok if I had installed the new over the old? Anybody with XP-SP3 try this? Of course, it's too late for me, now, but knowing might help some others.

This might be an installation bug that shows up under XP, rather than a bug in the program itself. I get no acknowledgement from the installer that it has succeeded.

Anyone who is willing to invest in calling Amazon: I'd like to hear what they say!
‹ Previous 1 2 3 4 5 6 7 Next ›
[Add comment]
Add your own message to the discussion
To insert a product link use the format: [[ASIN:ASIN product-title]] (What's this?)
Prompts for sign-in

Recent discussions in the Kindle forum

  Discussion Replies Latest Post
Critical Software Update for Kindle E-Readers
0 Mar 23, 2016
Welcome to the Kindle Discussion Forum - A Congregation of Kindle Enthusiasts
0 Mar 20, 2015
Fire OS 5 - No full device encryption. 256 1 minute ago
Amazon Echo (no invite questions) 7311 1 minute ago
Can't get magazine delivered to laptop 10 2 minutes ago
Page Numbers vs. Locations = Decision to Buy Kindle or Not 1925 2 minutes ago
Hiding books from other family Kindle devices possible?? 157 2 minutes ago
customer support 20 2 minutes ago
August 2016--Informal Poll--What are you reading? 146 4 minutes ago
how do I get my tablet back on. 3 4 minutes ago
We're Quirky And We Know It! Come Witness The Howling Dink, Hussy Turkey Hens, And A Veritable Plethora Of Other Beasts! So Geese! 5669 5 minutes ago
I want to MOVE a book to a collection 6 6 minutes ago

This discussion

Discussion in:  Kindle forum
Participants:  102
Total posts:  158
Initial post:  Jul 24, 2012
Latest post:  27 days ago

New! Receive e-mail when new posts are made.
Tracked by 31 customers

Search Customer Discussions